[Server] Fragen zum Tutorial "Linux FTP-Server mit Glftpd"

O

olddoggy

Gast
----------------------------------------------------------
In diesem Thread werden Fragen zu dem Toutorial
Linux FTP-Server mit Glftpd
behandelt.

Für allgemeine Fragen zum Thema FTP - Server eröffnet bitte einen eigenen Thread im Forum Netzwerke & Server, nachdem ihr die dortige FAQ von Supernature gelesen habt ;)

Für Linux - bezogene Fragen erstellt bitte einen Thread im Linux - Forum

MfG, Bio-logisch

-----------------------------------------------------------
Thx für die Info/Beschreibung @Killerkuno :bier

werde es die Tage mal Testen.

greetz olddoggy
 
Zuletzt bearbeitet von einem Moderator:

FormA

gehört zum Inventar
Ohne einen C Compiler (der bei der Minimal Installation nicht dabei ist) kommt man aber hier nicht weit ....
 
P

Photon

Gast
Erstmal ein fettes Lob an das Tutorial! Bin selbst ein Linux Neuling und alles hat gut geklappt! Danke :)

Naja, leider fehlt wie man weiter vorgeht. Und wieso gehen Befehle wie z.b. 'site kill xy' nicht, bekomm immer folgende Meldung: You do not have access to this command.
Was für mich soviel bedeutet wie das ich die entsprechenden rechte nicht habe ... wie bekomme ich die also?
 

Skytrix

kennt sich schon aus
jo..super danke hat alles gut funktioniert!?

Nur wo kann ich dem ftp die url zuweisen unter der dann der ftp verfügbar sein soll!?

danke...
 
Zuletzt bearbeitet:

Einsamer Wolf

Herzlich willkommen!
Morsche!!!

So, direkt nach der Registrierung will ich nu auch ma mein erstes posting hier setzen.

Ich hab da eine kleines Prob mit glftp. Ich denke, das Grundproblem is, dass ich statt inetd den xinetd am laufen haben. Ist bei meinen anderen Servern eigentlich kein Prob, da ich diese alle stand-alone laufen lasse. Aufgrund der Tatsache, dass ich inet net benutze, kann ich das mit dem Kopieren der ftp tcpd...-Zeile net direkt übertragen. Nu meine Frage: Was genau bedeutet der String, den man kopieren soll, killerkuno? Vielleicht kann ich die Einträge in der entsprechenden Datei beim xinetd dann ja ändern.

Kurz zur Config:
OS: Mandrake 9.1 Bamboo
Xinetd (statt inetd)
tcpd läuft nicht (braucht man eigentlich in der neuen glftpd-Version 1.29)
Glftpd V1.29

Ganz konkret bekomme ich nach dem Durchlaufen der Installationsroutine (install.sh) der 1.29er Version und dem Neustart des xinetd die Fehlermeldung, wenn ich mich auf dem glftpd per ftp anmelden will, dass er die Verbindung sofort abbricht (connection refused), was für mich soviel heißt, dass der demon schon lüppt, halt nur keine Connections annimmt. Dabei spielt es auch keine Rolle, ob ich lokal versuche zu connecten oder per remote.

Das Installieren der Version, die in dem hier vorgeführt wurde, 1.26 brachte auch keine Verbesserung.

Ich steh im mom echt aufm Schlauch. Waere nett, wenn mir jemand helfen könnte.

CU Einsamer Wolf
 

Killerkuno

Senior Member
Original geschrieben von Skytrix
jo..super danke hat alles gut funktioniert!?

Nur wo kann ich dem ftp die url zuweisen unter der dann der ftp verfügbar sein soll!?

danke...

Sobald der Glftpd läuft kannst du mal testen, entweder in der Konsole:
ftp
open localhost
username
PW
oder von ausserhalb über deine IP Adresse, oder du richtest dir einen Namen ein bei:
z.b. www.dyndns.org
wie das geht steht hier: https://www.supernature-forum.de/showthread.php?s=&threadid=6334&highlight=dyndns
 

Skytrix

kennt sich schon aus
ja...open localhost geht usw!

Nur wo sag ich glftpd, dass es unter der angegebenen dyndns adresse verfügbar sein soll!?

dyndns account habe ich bereits! ;)
 

Killerkuno

Senior Member
Original geschrieben von Skytrix
ja...open localhost geht usw!

Nur wo sag ich glftpd, dass es unter der angegebenen dyndns adresse verfügbar sein soll!?

dyndns account habe ich bereits! ;)


Der glftpd ist unter deiner IP-Adresse die du vom Provider bekommst erreichbar.
Nun brauchst du nur noch einen Client der die IP-Adresse zu Dyndns schickt, den bekommst du bei Dyndns, dort gibts ein paar links.

hm..wie bau ich den mit dem glftpd monitor eine verbindung zu glftpd auf!?

einfach den Rechnernamen deines Servers wo der Glftpd läuft eingeben, Benutzernamen und Kennwort auch noch. Dann Connect.
 

Skytrix

kennt sich schon aus
ok...connecten kann ich mich jetzt schonmal mit dem glftpd monitor nur ich komme mit den daten nicht auf den server...auch nicht mit den standart daten user: glftpd pass: glftpd

>connecting to local.net
220 ProFTPD 1.2.2 Server (ProFTPD) [cw003021.local.net]
>USER Skytrix
331 Password required for Skytrix.
>PASS **********
530 Login incorrect.

kannst du helfen!?
 

Killerkuno

Senior Member
Tja da läuft wohl auch der Proftpd, den musst du abschalten in der inetd.conf.
Also dort wo was mit Proftpd staht machst du in der Zeile ein # davor.
Dann bootest du entweder neu oder mit dem Befehl:
rcinetd restart
startest du inetd neu.
 

Skytrix

kennt sich schon aus
argh...stimmt dass ich das nicht gesehen habe! *g*

nur in der inetd ist proftpd gar nicht eingetragen...wie kann der dann on sein!?

"ftp stream tcp nowait root /usr/sbin/tcpd /glftpd/bin/glftpd -l -o -i -n 1 -r /etc/glftpd.conf"

das hab ich eingetragen...

und glftpd lädt er auch

ftp> open localhost
Trying ::1...
ftp: connect to address ::1: Connection refused
Trying 127.0.0.1...
Connected to localhost.
220 MY SITE NAME (glftpd 1.26_Linux) ready.
 

Killerkuno

Senior Member
Schau mal mit:
ps -e
welche Prozesse laufen dort müsste proftpd auch dabei sein
kill den mal mit
kill -9 ****

deinstalliere dann am besten den proftpd.
 

Skytrix

kennt sich schon aus
da läuft kein proftpd....und im yast kann ich den auch nicht deinstallieren! :(

wie kann ich das noch deinstallieren!?
 
M

Mana

Gast
Hi,

vorab, bin leider noch ein ziemlich Linux N00b, da ich aber jetzt nen Server bekommen hab, versuche ich mich am einrichten von diversen Sachen.
Darunter eben Glftpd.
OS is Red Hat 8.0.
Habs mit Glftp 1.26 und 1.30 probiert und leider keinen Erfolg gehabt.
Hab wie laut Doc die installgl.sh ausgeführt.

Enter the port you woud like glftpd to listen on [21]: 21
Setting permissions . . . Done.
Adding glftpd service to /etc/services . . . Done.

Configuring xinetd for glftpd . . . Done.

Restarting xinetd . . . Success.

Adding crontab entry to tabulate site stats nightly . . . Done.

so sieht das Ende der Meldung aus.

Aver irgendwie tut sich da Null, es läuft kein Server.
So langsam verzweifel ich an dem Ding. Liegt das an Red Hat wie ich jetzt schon ein paar Mal lesen konnte, oder muss ich was anderes noch beachten als das installgl.sh?

Wäre nett, wenn mir einer weiterhelfen könnte, und vielleicht auch ein paar gute Links dazu hat.

Greetz
Mana
 

Supernature

Und jetzt?
Teammitglied
Die Meldungen sehen ja allesamt nach Erfolg aus. Wie hast Du versucht, mit dem Server zu connecten? Versuch einfach mal
ftp localhost
auf der Konsole - was kommt da für eine Meldung?
 
M

Mana

Gast
Hi!
Es kommt Connection refused.

Laut Prozessliste seh ich auch keinen Prozess mit GLFTP.
Auf dem System ist ProFTP noch installiert, aber gestoppt. Kanns daran noch liegen?

Ich verzweifel langsam echt. Das Blöde ist halt, dass ich wenig peil hab und wenn ich nach Doc vorgehe, dann sieht die Meldung richtig aus, aber funktionieren tut nix.


Greetz
Mana
 
Oben