Wie MPlayer installieren unter Suse 10.1

PsychoDad

Herzlich willkommen!
Hallo

Kann mir einer sagen wie ich den MPlayer installiere ?
Mein Kumpel hat mit einem Handyvertag ein Notebook mit installiertem Suse 10.1 gekriegt und kann keine DVD's anschauen.

Ich hab gleich danach gegoogelt und erfahren das man 2 libsoundso Dateien installieren muß.

Die hab ich jetzt in rpm Format aber keine Ahnung wie ich die installieren muß und dazu den Mplayer oder VLC oder irgendwas damit er die Kastelruther Spatzen:ROFLMAO: DVD am Notebook schauen kann.

Wäre nett wenn mir einer helfen könnte.

Gruß
PD
 
Zuletzt bearbeitet von einem Moderator:

Bio-logisch

Moderator
Teammitglied
Erst mal herzlich willkomen auf dem Wohlfühlboard.

Ganz allgemein:
RPM-Dateien werden mit dem Befehl rpm -Uhv datei.rpm installiert, oder du klickst einfach mal drauf, da sollte bei Suse irgend ein Automatismus starten.

Sehr gute Mplayer oder VLC - Paket für SuSE gibt es bei PackMan :: Startseite, entsprechende Codec-Packs sind dort auch erhältlich.

PS: Tipps zur Installation findest Du auch in der Tutorialsektion
https://www.supernature-forum.de/to...suse-linux-online-nachinstallieren-ueber.html
https://www.supernature-forum.de/to...48321-programme-installieren-unter-linux.html
 

PsychoDad

Herzlich willkommen!
Danke für den Willkommensgruß:)

Das mit dem Befehl ist so eine Sache.
Ich hab mit Linux nix am Hut und wenn ich irgendwo ein Befehl eingeben muß
komm ich schon in Not.

Ich hab auf Mplayer.rpm drauf geklickt dann steht da
"Paket mit Yast installieren"
da klicke ich drauf und nach einer Weile kommt

Fehlermeldungschild

Fehler
"Folgende Pakete wurden auf dem Medium nicht gefunden
MPlayer"

Die Installationsdateien befinden sich in einem persönlichen Ordner falls das von Wichtigkeit ist.


Die Dateien hab ich übrigens von der Packman-Seite




Gruß
PD
 

PsychoDad

Herzlich willkommen!
Ich probier es mal wie oben beschrieben.

Das Notebook ist aber nicht ans Inet angeschlosssen.
Werde es dann wohl aber anschliessen müssen wenn es mit der Methode nicht geht.
 

PsychoDad

Herzlich willkommen!
Wohin sollte ich die Installationsdateien(.rpm's) hintun damit ich nur das Nötigste in die Konsole eingeben muß ?
 

PsychoDad

Herzlich willkommen!
Ich hab jetzt die libxine installieren wollen, da kommt
speex is needed,
libcaca is needed
libcucul is needed

Ich glaube bis das läuft bin ich alt :cry:
 

PsychoDad

Herzlich willkommen!
Nachdem ich jetzt nicht mal eine Verbindung mit meinem Router zustande bringe um mich mit einem Packman-Server zu verbinden, geb ich es auf.

Linux rühr ich nicht mehr an :(
 

Bio-logisch

Moderator
Teammitglied
Sorry, aber wenn Du ein neues Betriebssystem anfangen willst, und nach 3 Stunden die Segel streichst, dann solltest es wirklich besser gleich bleiben lassen.

PS:
Verbindung mit dem Router? Schätzungsweise ein W-Lan Problem. Liegt idR. daran, dass erst ein mal eine Firmware installiert werden muss, dafür sollte man dann den Rechner ein mal über Kabel an den Router anschließen.

Zu den fehlenden Abhängigkeiten: Das ist der Grund weswegen ich empfohlen habe, die automatische Installationsvariante zu wählen. Wenn Du Dir den zweiten Link durchgelesen hättest, dann wüsstest Du auch warum und wie Du das lösen kannst ;)
 

Stephan1965

nicht mehr wegzudenken
Nur nicht aufgeben

Hallo PsychoDad,
gib nicht einfach auf. Sogar ich habe inzwischen mein Linux hingekriegt. Natürlich gibt es mal Probleme, aber das gibt es mit dem anderen OS auch.

Versuch mal, die Verbindung mit einem Kabel an den Router. Und wenn das klappt, kannst Du Dich mal an die WLAN-Probleme wagen. Aber erstmal solltest Du Dein System zum Laufen bringen.

Und für Programminstallationen kannst Du (später) auch apt (bzw. die GUI davon: synaptics) oder smart benutzen. Es geht aber natürlich auch Yast. Das ist aber nicht so komfortabel. Denn wenn apt oder smart erstmal eingerichtet ist, geht alles wie von selbst. Diese Programme schauen dann nach den Abhängigkeiten und lösen diese auf. Wenn Du das selber machen willst, wirst Du scheitern. Aber es wird eine Verbindung zum Internet gebraucht. Und bei regelmäßigen Updates ist eine DSL-Flatrate nicht von Übel...

So, jetzt mal zu den Verbindungsproblemen:
Kannst Du den Router anpingen? (ping 192.168.1.0 bzw. die Adresse Deines Routers). Gibt es damit eine Verbindung? (Anpingen und dann nach kurzer Zeit Strg+C => dann wird gezeigt, ob die Packete verloren wurden oder nicht).

Ach ja, da Du Neuling bist: mach eine Konsole auf: Unter System => Terminals => Konsole. Oder Alt + F2. Und dann konsole eingeben. und hier kannst Du dann die Befehle eingeben.
Hier kannst Du auch mal ifconfig (als root) eingeben. Um root zu werden: su eingeben => dann das root-Paßwort. Und dann bist du root (in der Konsole).
Aber Vorsicht: Root darf alles. Z. B. auch geschützte wichtige Dateien öffnen oder löschen. Und damit kann root auch das System zerstören. Also nur Sachen machen, von denen Du weißt, wie es geht.

Damit kannst Du schon mal sehen, ob Du an dem Rechner auch ein Adresse hast. Und Du kannst schon mal ein paar Info hier posten.

Viele Grüße,
Stephan

P.S.: Du must auch Bio verstehen. Du installierst ein anderes OS und wenn es nicht sofort klappt... Ein bißchen Einsatz muß schon kommen. Es gibt im Internet aber auch sehr viele Infos zu Linux.
 

PsychoDad

Herzlich willkommen!
Hallo :)

Linux ist bestimmt toll wenn man sich länger damit beschäftigt und sich damit auskennt.
Aber ich bin mit meinem WinXP voll zufrieden.

Mir ging es nur darum für einen Kumpel eine DVD zum laufen zu bringen.
Der hat von Notebooks und PC keine Ahnung und hat das Linux-Notebook
so nebenher bekommen.

Zu der Routerverbindung
Ich hab es mit Kabel probiert.
Von WLAN war nie die Rede.

Es kam keine Verbindung zustande.
Vielleicht irgendeine Sicherheitseinstellung(Firewall oder was anderes) unter Suse 10.1.
Vielleicht muß man sich ja irgendwo Erlaubnis einholen um unter Linux mit dem Internet verbunden zu werden.

Zu der Playerinstallation
Vielleicht lag es auch an der Xine-lib.
Ich hab irgednwo gelesen das man die vorhandene erst löschen muß bevor man die DVD-fähige Libxine installiert.
Aber wo man die löschen kann hab ich nicht gefunden.

Macht ja auch nichts ;)


Gruß
PD
 

Bio-logisch

Moderator
Teammitglied
Vielleicht irgendeine Sicherheitseinstellung(Firewall oder was anderes) unter Suse 10.1.
Vielleicht muß man sich ja irgendwo Erlaubnis einholen um unter Linux mit dem Internet verbunden zu werden.

Normalerweise nein.
Verschiedene Ansatzpunkte:
1.) Habt ihr DHCP?
Dann kontrollier mal im Yast - Kontrollzentrum unter Netzwerk, ob die betreffende Netzwerkkarte richtig auf DHCP eingestellt ist. Im Zweifelsfall ist sie es nicht, weil dann das Booten relativ lange dauert, wenn man mal nicht im Netzwerk ist.

2.) Der DHCP-Server war zu langsam
rcnetwork restart (also root ausgeführt) startet alle Netzwerkkarten neu. Oft hilfreich, wenn der Rechner keine IP mehr abbekommen hat.

Löschen tut man mit dem Befehl
rpm -e libxine.

Wie dem auch sei, die Fehlermeldung sagt ja ganz genau, was gefehlt hat.
Wenn Du mit den Dateinamen in die Suchmaske auf RPM Search. Vorher am besten auf "Advance Search" (erweiterte Suche gehen), dann kannst Du da spezifisch für Deine Distribution suchen.
Dann legst Du alle rpm-Pakete in ein Verzeichnis, wechselst mit dem Befehl cd dort hin (cd /home/nutzer/neues_verzeichnis) und installierst mit dem Befehl rpm -Uhv *.rpm alle Pakete auf einen Schlag.

Die Sache mit der Netzwerkkarte liegt wohl einfach daran, dass das Linux schon vorinstalliert war, normaler Weise geht das bei einer Neuinstallation sofort.

Die Softwareinstallation funktioniert unter Linux eben komplett anders als unter Windows. Da darf man nicht erwarten, dass alles sofort funktioniert. Deswegen schreibt man ja auch die ganzen Tutorials, nur lesen sollte man die als Einsteiger dann schon (in dem Fall ist es der 3. Link, Softwareinstallation unter Linux beschreibt das ganze Dilemma ;))
 
Oben