[Server] Netzwerkprobleme

Stephan1965

nicht mehr wegzudenken
Netzwerkprobleme

Hallo,
ich habe mir zuhause ein kleines Netzwerk eingerichtet mit einem alten Rechner, auf den ich den eisfair-Server aufgesetzt habe. Diesen benutze ich als (Imap-)Mailserver und Faxserver. Das funktioniert auch sehr gut. Kann ich nur empfehlen.
Jetzt wollte ich ihn auch noch als NFS-Server benutzen. Einrichtung kein Problem, aber der Zugriff von den SuSe-Linux-Clients klappt nicht, da der NFS-Server-Hostname nicht gefunden wird.
Wenn ich den Server anpinge mit "ping hostname", wird er nicht gefunden. Mit "ping IP-Adresse" kein Problem. Wenn ich nslookup, host oder dig benutze, bekomme ich die Auflösung (in beide Richtungen: entweder mit dem Hostnamen oder mit der IP-Adresse).
DHCP habe ich in meinem Netzwerk abgeschaltet, alle Clients und der Server haben feste IP-Adressen und Hostnamen. Auf dem Eisfair läuft auch ein Bind9-Server.

Wie kriege ich es hin, das die Auflösung ping hostname funktioniert?

Gruß,
Stephan
 

Supernature

Und jetzt?
Teammitglied
Ich hab keinen konkreten Lösungsvorschlag, aber immerhin einen Workaround: Trag doch den Server mit Namen und IP in die hosts-Datei ein, dann sollte es auf jeden Fall klappen.
 

Stephan1965

nicht mehr wegzudenken
Gefunden!

Hallo Supernature,
in die hosts-Datei geht natürlich auch. Dann muß ich aber diese Dateien von allen clients bearbeiten.
Aber ich habe den Fehler gefunden:
Meine lokale domain hatte den Namen "xxxx.local" . Und "local" wird seit Umstellung von Suse 9.0 auf 9.1 anders behandelt...
Also: Benennt Eure Domain im lokalen Netzwerk nicht mit "local". Sondern mit heim oder sonst irgendwie (nur keine echte Internet top level domain nehmen)


Gruß,
Stephan
 
Oben