Hilfe ! Krieg meinen Cesar FTP nicht zum laufen

Cliffhanger17

fühlt sich hier wohl
Hallo,

ich benötige Eure Hilfe. Und zwar wollte ich mir einen FTP-Server für zuhause einrichten aber ich hab Probleme damit ihn zum laufen zu bekomen. Hab schon vieles hier durchgelesen aber manches habe ich einfach nicht genau verstanden. Deshalb versuche ich es auf diesem Weg in der Hoffnung das mir jemand weiterhilft.

Fakten: Ich wollte den Cesar FTP Server (Version 0.99g) unter Win XP Home installieren.Ich habe DSL 2000.

Die Installation ging ganz einfach, konnte soweit alles einrichten (Benutzer, Verzeichnisfreigabe usw..). Damit ich für die Zukunft eine feste IP habe, habe ich mich bei DYNDNS.org angemeldet. Hierzu nachfolgend ein paar Screenshots.




Ich denke der Fehler liegt auch hier bei DYNDNS nicht, aber ausschliessen will ich das natürlich auch nicht. Als nächstes habe ich meinen Router konfiguriert. Es handelt sich dabei um das Modell T-Sinus 154 DSL. Auch hierzu habe ich ein paar Screenshots gemacht.








Ich denke, dass ich bei der Router-Konfig. etwas nicht richtig gecheckt habe, aber sorry, ich weiss echt nicht mehr was ich wo einstellen soll.

Wenn ich nun z.B. in meinem Firefox-Browser "FTp://meine ip eingebe erscheint zwar ein Fenster mit Username und PW-Abfrage (siehe Bild)

aber wenn ich dann das PW eintippe kommt folgende Fehlermeldung:



So, nun hab ich euch mit Bildern versorgt, vielleicht kann mir einer von Euch Experten den entscheidenden Tipp geben was ich noch machen muss !!??

Für Eure Bemühungen und Ratschläge sag ich schon mal herzlichen Dank !

Gruss
Cliffhanger17

P.S. Ach ja, was die Router-Firewall betrifft die ist eingeschaltet. Dazu habe ich auch noch einen Screenshot gemacht.
Die Windwos Firewall ist aus.....Hoffe ich hab nix vergessen...
 

Supernature

Und jetzt?
Teammitglied
Hallo und herzlich willkommen :)

Versuche es mal statt mit der Internet-IP mit "localhost" - das ist dann eine lokale Anmeldung und so können wir sicherstellen, dass der Server überhaupt läuft und eine Anmeldung möglich ist. Wenn das klar ist, machen wir uns an die "Umgebung".
 

Cliffhanger17

fühlt sich hier wohl
Supernature schrieb:
Hallo und herzlich willkommen :)

Versuche es mal statt mit der Internet-IP mit "localhost" - das ist dann eine lokale Anmeldung und so können wir sicherstellen, dass der Server überhaupt läuft und eine Anmeldung möglich ist. Wenn das klar ist, machen wir uns an die "Umgebung".


Hallo Supernature,

also ich habs jetz mal mit localhost probiert und es kommt folgendes:

 

Supernature

Und jetzt?
Teammitglied
Gut - nun solltest Du da noch Namen und Passwort des Benutzers eingeben, den Du auf Deinem Server angelegt hast.
 

Cliffhanger17

fühlt sich hier wohl
Supernature schrieb:
Gut - nun solltest Du da noch Namen und Passwort des Benutzers eingeben, den Du auf Deinem Server angelegt hast.

Okay, ich habe also als Benutzer "hib" angelegt und ihm das PW "Kaleuni" zugeteilt. Um es nochmal zu verdeutlichen hab ich es bildlich dargestellt aber leider kommt immer noch diese Fehlermeldung: 530 Identification failed....

Shit !!!!



 

Supernature

Und jetzt?
Teammitglied
Username und Login sind zweierlei - schau mal auf den ersten Screenshot, in das Feld "Login" musst Du dann auch "hib" eintragen.
 

Cliffhanger17

fühlt sich hier wohl
Supernature schrieb:
Username und Login sind zweierlei - schau mal auf den ersten Screenshot, in das Feld "Login" musst Du dann auch "hib" eintragen.

Man, bin ich erst ein Vollidiot :eek: Ich dachte das Feld gehört zu einem "Anonymous"-Eintrag. Jetzt gehts, und das wegen so´ner Lapalie....

Supernature, du hast was gut bei mir :) Vielen Vielen dank !!!
Bis bald mal wieder ;)
 

Supernature

Und jetzt?
Teammitglied
Erst dachte ich "der übertreibt ein wenig mit den vielen Screenshots" - aber ohne die hätten wir wahrscheinlich noch Stunden und Tage zugebracht. Freut mich, wenn nun alles funktioniert :).
 

Cliffhanger17

fühlt sich hier wohl
Supernature schrieb:
Erst dachte ich "der übertreibt ein wenig mit den vielen Screenshots" - aber ohne die hätten wir wahrscheinlich noch Stunden und Tage zugebracht. Freut mich, wenn nun alles funktioniert :).

Ja, normal mach ich net so viele Screenshots, aber ich dachte ich muss ja alle Fehlerquellen irgendwie ausschliessen :) Und umso mehr die Leute hier sehen um so einfacher ist die Fehlersuche.

Ciao !!! :)
 

Cliffhanger17

fühlt sich hier wohl
Hallo,

jetzt hab ich nochmal eine Frage zu dem Cesar-FTP. Naja wird wahrscheinlich eh keiner wissen weil die meisten hier einen anderen FTP-Server installiert haben.

Ich wollte im Cesar-FTP unter "Events" einen bestimmten Sound abspielen wenn sich jemand ohne Passwort einloggt bzw. dieser jemand versucht sich mit einem falschen Passwort einzuloggen.

Jetzt hab ich mit Verwunderung festgestellt das es nicht mal so ein Event gibt !!? (n) :cry:

Hab nur folgende Events zur Auswahl :

- a file has been downloaded
- a file has been uploaded
- a file has been deleted
- a file has been renamed
- a directory has been created
- a directory has been removed
- max user limit is reached
- a banned ip tries to connect
- the server is closed and does not accept more connects

Schon irgendwie blöd finde ich. :eek:
 

Supernature

Und jetzt?
Teammitglied
Du hast Recht, ich nutze einen anderen Server - aber ich hätte eine plausible Erklärung dafür, warum es den Event nicht gibt:
Die Ausführung dieses Events erzeugt eine, wenn auch geringe Last - wenn jetzt bei einem Hack-Versuch massenhaft versucht wird, sich mit falschen Daten einzuloggen, kann man damit das System lahm legen.
 

Cliffhanger17

fühlt sich hier wohl
Supernature schrieb:
Du hast Recht, ich nutze einen anderen Server - aber ich hätte eine plausible Erklärung dafür, warum es den Event nicht gibt:
Die Ausführung dieses Events erzeugt eine, wenn auch geringe Last - wenn jetzt bei einem Hack-Versuch massenhaft versucht wird, sich mit falschen Daten einzuloggen, kann man damit das System lahm legen.

Bei deinem FTP-Server gibts dieses Event dann auch nicht ???
 

Supernature

Und jetzt?
Teammitglied
Doch, beim Gene6 gibt es einen Event "LoginFailed" - nutzen würde ich ihn aber aus oben genannten Gründen nicht.
 

Cliffhanger17

fühlt sich hier wohl
Bio-logisch schrieb:
CesarFTP in Deiner Version ist leider von außen angreifbar:
heise online - CesarFTP führt eingeschleusten Code aus

Daher solltest vielleicht ein anderes Programm einsetzen, bis ein Patch verfügbar ist.


Upps, das war mir so nicht klar. Sollte vielleicht auch zu Gene 6 wie Supernature wechseln....Hat da jemand einen Link zur aktuellen Version für mich ??

Hoffe der Server ist net zu kompliziert für einen Laien wie mich :eek:
 

Cliffhanger17

fühlt sich hier wohl
Hallo, hatte jetzt mal den G6Server installiert komm ich nicht so gut klar damit. Aber der größte Scheiss ist das jetzt mein Cesar FTP nicht mehr funktioniert. Ich brech echt langsam zusammen.......

Wenn ich ftp://localhost eingebe erscheint das Fenster mit dem Benutzernamen und PW. Sobald ich´s aber mit ftp://ip versuche bringt er mir einen Seitenladefehler mit Verbindung unterbrochen !!?? Menno was issn da schon wieder los ????

Supernature du musst da nochmal ran, biiiiittteeeee;)

edit: Den anderen Server hab ich natürlich wieder deinstalliert !!

Kanns vielleicht an dieser Einstellung liegen ??? Weiss gar nimmer was ich da das letzte mal reingeschrieben hatte....
 

Cliffhanger17

fühlt sich hier wohl
Freakazoid.one schrieb:
hast du schon mal im router log geguckt ob es sich in deinen account eingelogt hat

vergleich ma die ip im dynds account

mit der hier

heise online - My-IP-Service

dein srennshot ist nur fernwartung


also bei DYNDNS ist alles okay. Die IP´s stimmen überein. Im Router weiss ich jetzt nicht so genau was ich da machen sollte. Hab da ja auch nichts verändert......Hm, echt komisch !

edit: Also irgendwie spinnt das Teil jetzt. Plötzlich kann ich mich auch mit ftp://genannter ip einloggen.

Aber ich hatte ja vorher die Adresse: ftp://@hannibal99.homeftp.net und das geht eben nicht..!!!????????????
 
Oben