Events starten nicht?!

whiteF

Herzlich willkommen!
hallo, habe miich mal an die events bei gene6 gemacht.
leider klappt das nicht so wie ich das will...

also: ich habe mir ein programm erstellt, welches aufpopt und mir anzeigt, dass ein user online gekommen ist (mit sound unterlegung). dieses habe ich dan mittels Domain Settings > Events eingestellt und zwar habe ich das mit folgenden Events versucht:

OnClientAuth...
OnClientConnected
OnClientLoggedIn
OnDirList
OnDomainOpened
OnFileDownloaded

Nichts!

Als nächstes habe ich mir eine VBS-Datei erstellt, in der mein Programm (*.exe) geöffnet werden soll.

ebenfalls nichts... es passiert rein gar nichts...

weiß jemand woran das liegt??

mfg
 

Supernature

Und jetzt?
Teammitglied
Hallo und herzlich willkommen, wenn auch mit Verspätung ;).
Schau mal bitte in die Protokolldatei, da sollte sich ein Hinweis finden, warum der Event nicht ausgeführt wird.
 

whiteF

Herzlich willkommen!
hi... hab mal ne logdatei erstellt die alles aufzeichnet... ja du hattest teilweise recht...

da stand:

Code:
08/11/07 19:08:52, 13, 192.168.178.22, , Event OnClientConnected: Executing 'C:\Programme\Gene6 FTP Server\ftp1.exe' --> Failed: 'Das System kann die angegebene Datei nicht finden'.

nur das problem, wenn ich meine eigene exe nur auf C:\ mache, kommt das:

Code:
08/11/07 19:09:44, 14, 192.168.178.22, , Event OnClientConnected: Executing 'C:\ftp1.exe' --> Ok.

Also sollte eigentlich ausgeführt werden... WIRD ES ABER NICHT!!! *ARGH*
 

MaXg

assimiliert
Das System kann die angegebene Datei nicht finden

Liegt an einer falschen Syntax. Windows kommt mit (DOS) Leerzeichen nicht klar.

Richtig wäre im Execute Feld:

Code:
"C:\Programme\Gene6 FTP Server\ftp1.exe"

WIRD ES ABER NICHT

Schau mal in deinen Taskmanager, da lungern bestimmt einige der ftp1.exe Tasks herum. Alles was sie machen ist deinen Speicher aufzufressen.

Entweder die Syntax ist unvollständig (fehlende Parameter) oder das Programm ist fehlerhaft.
______________


Ungetestete Miniversion, die gehen müsste, ist der Beep Sound aus diesem thread und drei Zeilen Batch, wobei die login.cmd & bell.bat in C:\Programme\Gene6 FTP Server\ liegen müssen.

Event: OnClientLoggedIn

Execute:
Code:
"C:\Programme\Gene6 FTP Server\login.cmd" $USR_NAME ($USR_PEERIP)

Die login.cmd
Code:
@echo off
@for /f "Tokens=1,2,3,4 delims=/. " %%a in ('time/t') do set zeit=%%a
call "C:\Programme\Gene6 FTP Server\bell.bat"
cls
echo. >c:\ftp.txt
echo. >>c:\ftp.txt
echo. >>c:\ftp.txt
echo. >>c:\ftp.txt
echo. >>c:\ftp.txt
echo.________________________________________________________________________________ >>c:\ftp.txt
echo. >>c:\ftp.txt
echo. >>c:\ftp.txt
echo. >>c:\ftp.txt
echo.  Am %Date% um %zeit% : Erfolgreicher Login von User %1 via %2. >>c:\ftp.txt
echo. >>c:\ftp.txt
echo. >>c:\ftp.txt
echo.________________________________________________________________________________ >>c:\ftp.txt
notepad  c:\ftp.txt
del c:\ftp.txt
exit
 

whiteF

Herzlich willkommen!
aja mit der cmd erstellt mir diese txt datei auf C: das klappt... aber selbst wenn ich selber ne cmd schreibe: start C:\ftp1.exe
dann ruft der nicht die exe auf. ich könnt kotzen! wenn ich per mausklick meine cmd aufrufe klappt es... also ich glaube irgendwie kommt gene damit net zurecht... der greift wohl nicht ganz normal per ShellExecute drauf zu ;)
 

whiteF

Herzlich willkommen!
Will irgendjemand mal das für mich testen ob das bei euch geht?

hab meine selbstgeschriebene billige exe mal hochgeladen... ich komm echt net weiter...

Code:
http://rapidshare.com/files/161896894/ftp1.exe

mfg
 
Oben