Bilder werden nicht mehr angezeigt!

demonwomb

treuer Stammgast
Nachtrag:

Hey Leute ich habe das Problem behoben!
war ein Server Fehler!
Ich nutze jetzt das Verzeichniss meines MYSQL Servers....das geht alles jetzt 100% auf beim nachladen

Ich Danke Euch jedenfalls sehr!

Dieser Beitrag kann eigentlich `zum Platz sparen´gelöscht werden!!!









Bilder werden nicht mehr angezeigt

--------------------------------------------------------------------------------

Mein Gott es klappt einfach nicht mehr!

Gestern mit 2 Bildern im Ordner war noch alles perfekt!


Ich habe jetzt insgesamt 6 Bilder in meinem Zufallsbild Ordner.

Er zeigt mir aber Teilweise gar kein Bild an!

Ich sehe nach jedem aktualisieren der Seite fast immer ein rotes X da wo das Bild sein sollte!

woran könnte es liegen?

nur das problem ist wenn ich als Besucher in den Rubriken wechsel erscheint irgenwann die Header grafik nicht mehr!

Ich habe das php script extra ausgesucht weil die bild namen egal sind. Ich habe die namen auch schon in 1.jpg 2.jp usw... geändert! Daran scheint es also nicht zu liegen!

Kann jemand helfen?

Danke schon mal vorab
mfg
demon

P.s.

Hier das php file:
__________________________________________________ _________________________
<?php
/*
AUTOMATIC IMAGE ROTATOR
Version 2.2 - December 4, 2003
Copyright (c) 2002-2003 Dan P. Benjamin, Automatic, Ltd.
All Rights Reserved.
Automatic : 404

Automatic : Welcome



// --------------------- END CONFIGURATION -----------------------
$img = null;
if (substr($folder,-1) != '/') {
$folder = $folder.'/';
}
if (isset($_GET['img'])) {
$imageInfo = pathinfo($_GET['img']);
if (
isset( $extList[ strtolower( $imageInfo['extension'] ) ] ) &&
file_exists( $folder.$imageInfo['basename'] )
) {
$img = $folder.$imageInfo['basename'];
}
} else {
$fileList = array();
$handle = opendir($folder);
while ( false !== ( $file = readdir($handle) ) ) {
$file_info = pathinfo($file);
if (
isset( $extList[ strtolower( $file_info['extension'] ) ] )
) {
$fileList[] = $file;
}
}
closedir($handle);
if (count($fileList) > 0) {
$imageNumber = time() % count($fileList);
$img = $folder.$fileList[$imageNumber];
}
}
if ($img!=null) {
$imageInfo = pathinfo($img);
$contentType = 'Content-type: '.$extList[ $imageInfo['extension'] ];
header ($contentType);
readfile($img);
} else {
if ( function_exists('imagecreate') ) {
header ("Content-type: image/png");
$im = @imagecreate (100, 100)
or die ("Cannot initialize new GD image stream");
$background_color = imagecolorallocate ($im, 255, 255, 255);
$text_color = imagecolorallocate ($im, 0,0,0);
imagestring ($im, 2, 5, 5, "IMAGE ERROR", $text_color);
imagepng ($im);
imagedestroy($im);
}
}
?>
 
Zuletzt bearbeitet:

Supernature

Und jetzt?
Teammitglied
Ich habe die Seite jetzt bestimmt 50mal aktualisiert und hatte immer ein Bild, insofern kann ich das Problem nicht nachvollziehen.
 
Oben