[WinXP] Schreibschutz aufheben

gechse

fühlt sich hier wohl
Schreibschutz aufheben

Hallo,

ich habe auf meinem Rechner u.a. StarOffice installiert.
Die eigenen Makros werden unter
D:\Dokumente und Einstellungen\MEINANME\Anwendungsdaten\staroffice\basic
gespeichert.

Leider ist der Ordner schreibgeschützt, d.h. nach jedem booten sind meine Makros weg.
Ich kenne die Methode:
Rechte Maustaste -> Eigenschaften -> Schreibgeschützt (Haken weg)
funktioniert leider nicht.

Kann mir jemand sagen, wie ich den Schreibschutz da wegbekomme? Eintrag in Regstry oder so?

Vielen Dank
 

little tyrolean

Elder Statesman
gechse schrieb:
Kann mir jemand sagen, wie ich den Schreibschutz da wegbekomme? Eintrag in Regstry oder so?
Ich kenne StarOffice nicht,
aber das scheint wohl eher an den Makro-Sicherheits-Einstellungen in StarOffice zu liegen als an Windows.

Schreibgeschützte Ordner sind unter Windows häufig zu finden,
der Schreibschutz hat aber keinen Einfluß auf die Lesbarkeit der Ordner.
Es kann auch sein, daß der Ordner das System-Attribut hat,
welches Windows überhaupt nicht anzeigt,
sondern einfach "Schreibgeschützt" meldet, was an sich ja auch stimmt,
aber doch irreführend ist.
 

gechse

fühlt sich hier wohl
Es geht ja nicht um die Lesbarkeit.
Die original mit StarOffice mitgelieferten Makros befinden sich im scheibgeschützten Ordner \basic. Ich kann nur meine eigenen Makros dort nicht speichern. Und in \basic nicht gespeicherte Makros lassen sich nicht aufführen.
Die Makros sind übrigens mit StarOffice selbst erstellt.

So einen ähnlichen Fall hatte ich schon einmal, damals konnte ich den Schreibschutz von \Anwendungsdaten\staroffice einfach mit dem Kontextmenü aufheben: Problem erledigt.
Nur nach einer kompletten Neuinstallation von XP funktioniert das eben seltsamerweise nicht mehr.

Es kann auch sein, daß der Ordner das System-Attribut hat,
welches Windows überhaupt nicht anzeigt,
sondern einfach "Schreibgeschützt" meldet,
Einer der Gründe, warum ich eigentlich Linux bevorzuge. Das ist ehrlich mit seinen Aussagen.

Mein XP ist so eingestellt, daß Systemordner und -daten sowei versteckte Ordner und Dateien angezeigt werden.
 

little tyrolean

Elder Statesman
Nur nach einer kompletten Neuinstallation von XP funktioniert das eben seltsamerweise nicht mehr.
Das ist nicht seltsam -
selbst wenn du denselben Usernamen bei der Neu-Installation verwendet hast,
so bist du für das neue XP NICHT derselbe User -
und du hast eben deshalb keinen Schreibzugriff auf den Ordner mehr.

Wenn du XP Home hast, mußt du einen anderen Ordner einrichten.

Bei XP Pro gehst du als eingeloggter Administrator in Systemsteuerung => Ordneroptionen => Ansicht
und entfernst den Haken bei "Einfache Dateifreigabe....".
Danach erscheint beim Rechtsklick auf den Ordner => Eigenschaften ein Reiter "Sicherheit",
wo du dir selber den Besitz des Ordners zuweisen kannst.
 

gechse

fühlt sich hier wohl
Ich hatte den Rechner komplett platt gemacht.
und auf eine saubere Festplatte installiert, formatiert ntfs.

[quore]so bist du für das neue XP NICHT derselbe User -
und du hast eben deshalb keinen Schreibzugriff auf den Ordner mehr.[/quote]
Da komplett formatiert, alle Daten nur per CD übertragen bin ich wirklich ein neuer User.
Ich habe in D:\Dokumente und Einstellungen\MEINNAME insoweit in anderen Ordnern Schreibrecht, nur eben nicht in D:\Dokumente und Einstellungen\MEINNAME\Anwendungsdaten.


Nach Deinem Tip
Eigenschaften =>Reiter "Sicherheit
bin ich Eigentümer mit allen Rechten des Ornders \basic
nur bekomme ich keine Schreibrechte. I
ch entferne das Häkchen bei Schreibgeschützt.
Es kommt die Anfrage für alle Unterordner und Dateien,
ich bestätige,
Irgendso ein Windowsflatterer segelt über den Bildschirm,
Ich prüfe die Eigneschaften: Schreibgeschützt!

Meine Güte, geht das bei Linux einfach
Code:
chmod u+w DATEI/ORDNER
Und Eigentümer wird man mit
Code:
chown NEUER_EIGENTÜMER DATEI/ORDNER
 

little tyrolean

Elder Statesman
bin ich Eigentümer mit allen Rechten des Ornders \basic
nur bekomme ich keine Schreibrechte. I
Mag sein, daß du Ersteller / Besitzer bist - aber hast du auch "Vollzugriff"?
Schau noch einmal nach, auch unter "System"....
 

Anhänge

  • rechte1.gif
    rechte1.gif
    11,1 KB · Aufrufe: 610

gechse

fühlt sich hier wohl
sieht bei mir so aus:

Ich habe:
  • Vollzugriff
  • Ändern
  • Lesen, Ausführen
  • Ordnerinhalt ausführen
  • Lesen
  • Schreiben
 

Anhänge

  • basic_1.jpg
    basic_1.jpg
    37,1 KB · Aufrufe: 455

little tyrolean

Elder Statesman
Jetzt wird's langsam mysteriös...

Bei mir ist der Ordner schreibgeschützt und versteckt (Attribut RH),

Vollzugriff haben nur
Administratoren
System (bitte nochmal überprüfen)

Benutzer :
nur Lesen, Ausführen sowie Ordnerinhalt auflisten und Lesen,

Ersteller / Besitzer (diese Gruppe fehlt in deinem Screenshot):
keine Rechte.

Kann es sein, daß OpenOffice Administratoren-Rechte zum Installieren / Ausführen braucht?
 

gechse

fühlt sich hier wohl
Administrator, thbi023 und System habe dieselben Rechte.

Die Gruppe
"Ersteller / Besitzer"
existiert nicht auf meinem Rechner

StarOffice läuft bis auf das Problem mit den eigenen Makros vollkommen problemlos, egal als wer ich mich anmelde.

SO benötigt keine AdminRechte. Bei anderen Installtionen hatte ich dieses Problem nie.
 

little tyrolean

Elder Statesman
Ehrlich gesagt weiß ich nicht mehr weiter...
Vielleicht bringt das Erstellen der Gruppe "Ersteller-Besitzer" etwas.

Ohne OpenOffice-Kenntnisse muß ich jetzt passen... :mad
 
Oben