Vista hat nach Neustart keinen Standard-Gateway

Lektro

assimiliert
Nachdem ich heute einige Windowsupdates installiert habe, war ein Neustart fällig. So weit, so gut.

Als der Rechner (Laptop) wieder verfügbar ist, sehe ich schon eine altbekannte Meldung "Eingeschränkte oder keine Konnektivität". Der kleine Globus beim Systray-Symbol der Netzwerkverbindung fehlt.

Bedeutet, dass Verbindung zum lokalen Netz besteht, aber nicht über den Router (Gateway) ins Internet. Ich muss dazu sagen, dass ich mit festen IP-Einstellungen arbeite.
Bei Verwendung von automatischer Zuweisung (DHCP) sollte das Phänomen nicht auftreten.

Schaut man sich die TCP/IPv4-Einstellungen an, fällt auf, dass kein Standard-Gateway mehr eingetragen ist (Screenshot 1). Selbst wenn man den jetzt wieder einträgt; nach dem nächsten Neustart fehlt der Eintrag wieder. Ich hatte das Problem damals schon einmal nach der Servicepack 2-Installation und wusste daher wo der Haken ist: Ein vermurkster Eintrag in der Registry, der durch eins der Updates verbogen wurde. Wie nach der SP2-Installation. Siehe Screenshot 2.

Zur Fehlerbehebung ist nun folgendes zu unternehmen:
  1. Registry-Editor starten (Start "Ausführen..." > "regedit"
  2. Zum Zweig "HKLM/System/CurrentControlSet/Services/Tcpip/Parameters/Interfaces/" durchhangeln und die betroffene Netzwerkverbindung suchen (am besten nach der vergebenen IP suchen)
  3. Doppelklick auf den Wert "DefaultGateway" und man sieht, dass die erste Zeile leer ist
  4. Die leere Zeile vor der Standard-Gateway-IP löschen (Screenshot 3) und mit OK bestätigen
  5. Registryeditor beenden und Rechner neustarten, damit der Standard-GW wieder da ist

P.S.: Wer sich den Neustart sparen will, kann den Standard-GW auch bei den Netzwerkeinstellungen vornehmen.
 

Anhänge

  • stgw_weg_1.jpg
    stgw_weg_1.jpg
    83,7 KB · Aufrufe: 2.450
  • stgw_weg_2.jpg
    stgw_weg_2.jpg
    155,4 KB · Aufrufe: 1.564
  • stgw_weg_3.jpg
    stgw_weg_3.jpg
    23,1 KB · Aufrufe: 1.293

JJ.

Herzlich willkommen!
Hallo,
Ich habe das gleiche Problem und bin deinen Anweisungen genau gefolgt, leider speichert er den Standartgateway immer noch nicht!- Hast du noch einen weiteren Rat?
Lg
 

Supernature

Und jetzt?
Teammitglied
Hallo und herzlich willkommen :)
Ist Dein Vista updatemäßig auf dem neuesten Stand?
Es gab mal einen Patch gegen dieses Problem, ich kann es nur zeitlich nicht mehr genau einordnen.
 

JJ.

Herzlich willkommen!
Ja ist er. Ich hab auch schon den Treiber neu installiert...Wenn ich mir dessen Eigenschaften angucke, läuft der einwandtfrei.
Es ist der Standartgateway, den er einfach nicht speichern will und ich und ich verzwiefel hier langsam:cry:
 

Lektro

assimiliert
Hast du auch den richtigen Netzwerkadapter erwischt? Welcher CLSID (ClassIDentifier) zu welchem Adapter gehört, findest du in der Registry hier: HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion\NetworkCards
 

Lektro

assimiliert
Hast du auf dem Rechner eventuell Software, die Netzwerkprofile verwaltet und dazwischenfunkt?

Kannst ja auch mal die komplette Registry nach dem Wert "DefaultGateway" durchsuchen. Vielleicht kommt irgendwo noch so ein Eintrag mit dieser Leerzeile vor.
 

JJ.

Herzlich willkommen!
ok,ich schau mal ob ich was finde...
aber schon malvielen Dank:)

mmmh. also ich hab nur zwei interfaces und davon hat der der eine gar keine Defaultgateway-(zumindest wird in der liste nichts aufgeführt). Den anderen hab ich ja bereits nach deiner anweisung geändert.
 
Zuletzt bearbeitet von einem Moderator:
Oben