[Tips für Anwender] Dateien verlinken, aber richtig!

Supernature

Und jetzt?
Teammitglied
Erstmal hallo und willkommen :)
Auch wenn sich das jetzt böse anhört (ist aber nicht so gement): Wenn es nicht funktioniert, dann hast Du es auch nicht so gemacht, wie es in der Anleitung steht, denn so funktioniert es zu 100% - also geh sie nochmal haarklein durch, ob Du nicht eine Kleinigkeit übersehen hast. Der häufigste Fehler ist, dass die links.txt an einem Ort abgelegt wird, auf den derUser nicht zugreifen kann. Von der Methode mit den Windows-Verknüpfungen halte ich nicht sehr viel - deren Auflösung muss nämlich auch der FTP-Client auf der anderen Seite beherrschen, sonst geht es so aus wie nun bei Dir und Deinem User.
Wenn Du noch Hilfe brauchst, dann poste bitte mal die genaue Konfiguration. Wo ist der Server installiert, welches Verzeichnis ist "home", welche sollen verknüpft werden...die ganze Umgebung halt.
 

Angelus

treuer Stammgast
Also, ich habe es nicht so gemacht wie in der Anleitung hier beschrieben und es funktioniert bestens. ;)

Ich habe
  • einen Ordner unter "c:\programme\bpftp\" angelegt der "stammverzeichnis" heisst. (Rechte: alle)
  • Wenn ich einen Acc anlege wird der für einen User als erstes freigegben
  • in diesen Ordner auf der Festplatte lege ich eine Windows Verknüfung zu den Ordnern die ich eigentlich freigeben will, also zB "UPLOAD", "DATEN" oder so,
  • diesen Ordner gebe ich in BPFTP natürlich auch noch frei (Rechte: je nach Bedarf).
Gruppenacc benutze ich nicht, da ich neue Acc für Personen derselben "Gruppe" einfach erzeuge indem ich einen bereits bestehenden kopiere und mit einem neuen Namen + PW versehe.

Klappt prima!
 
O

oreissig

Gast
Hi!

Also bei mir funzte das mit der link.txt von anfang in gut, aber bei mir liegen die dateien alle in einem verzeichnis, auf das meine user keinen zugriff haben und es geht trotzdem...

naja, ich hab mal ne frage: kann man es irgendwie machen, dass solche links NICHT im home-dir, sondern in einem bestimmten ordner erscheinen?

und dann nochwas: ich hab ne ganze menge user, die (fast) alle in ein und die selbe gruppe gehören...
die timeout-einstellung für die gruppe ist 120s, aber bei jedem user ist als default auf 600s, da muss ich das immer bei jedem user ändern, obwohl es ja schon in der gruppe geregelt is und der user auch zur gruppe gehört...
 

Supernature

Und jetzt?
Teammitglied
Die Links funktionieren leider nur direkt im Home-Verzeichnis.

Was den Timeout angeht - die Rechte der User sind halt immer höher als die Gruppe.
Ich hab höchstens einen Tipp, wie Du alle User auf einmal ändern kannst: Öffne die users.ini mit einem Texteditor und ersetzte "TimeOut=600" durch "TimeOut=120". Oder lösche die entsprechenden Zeilen komplett, dann sollte auch das Limit der Gruppe greifen.
 

Maxymalny

Erster Beitrag
Ich habe eine Frage...
Ich habe FTP mit virtual system file und z.B. Ich mochte diese linken machen:

Filmz | E:\Filmz1
Filmz | D:\Filmz2

Ist das moglisch??? Wie kann ich das machen??? Wie solt file link.txt aussehen?

P.S.: Sorry for my deutsh, but i known it very weak... ;)
 

Aldan

nicht mehr wegzudenken
also, ich habe meine Platten so verlinkt, wobei die Text-Datei im Home-Verzeichnis ist ( d:\home\pup\ ) und die Daten Verzeichnisse alle in \pup\ und g:\dateien\ sind.

+ Dateien | g:\dateien\
+ zurück zum Hauptverzeichniss | ~
+ Upload | H:\Upload
+ CD Laufwerk | F:\

wobei das + bewirkt das die Ordner /Dateien / Upload / immer am Anfang der Ordnerauflistung stehen.

Allerdings hängt sich der Client immer auf wenn keine CD im Laufwerk ist.

:bier
 
F

Fatdag

Gast
Hallo Leute

Habe des mit der Link-Liste hingekriecht. Die Anderen sehen alle meine Verzeichnisse.

Aber jetzt kommt die Die FRage, wenn derjenige in eine Verzeichnis geht kommt er nicht wieder in das Home verzeichnis. Bullet meint no Permission. obwohl ich Read und list, +subdirs angeklickt habt.

Hilfe, wer kann mir helfen. Anscheint seh ich den Wald vor Bäumen nicht mehr.

Ciao
 
F

Fatdog

Gast
Vielleicht hilft das zur prob-lösung

asked to change directory : 'F:\Brenner 2\ -> H:\Programme\G6 FTP Server\' --> Access denied (No Access Right).
(000031) 25.04.2004 14:41:18 - ich (xxx.xx.xxx.xxx) > 550 CWD failed. No permission
 

Supernature

Und jetzt?
Teammitglied
Wenn es gewollt ist, dass der User auf das Programmverzeichnis Zugriff hat, und so sieht es ja dem Log nach aus, dann musst Du unter "Options" die Häkchen bei "Protect FTP Server Directory - and sub directories" rausmachen.
 

Joley

Herzlich willkommen!
Also so wie das hier beschrieben ist geht das gar nicht bei mir!

Ich habe einen neuen user eingerichtet dem habe ich dann ein home gegeben und recht dafür in das home habe ich die links.txt reingemacht.
wenn ich nun auf den ftp connecte dann geht das home auf und die .txt datei steht da.
mehr is da nicht.
in der .txt habe ich volgendes reingeschieben.

ace of base | E:\Musik\gruppen\Ace of Base

und da kommt nix von ace of base!

was soll ich machen?
 

Supernature

Und jetzt?
Teammitglied
So wie das beschrieben ist geht es auf jeden Fall, hat sich wirklich schon hundertfach bewährt. Geh doch noch mal alles Punkt für Punkt durch, vielleicht hast Du was übersehen.
 

rassmann

Erster Beitrag
Es reicht nicht aus, den freigegeben Ordner im txt-file dem User zuzuordnen (Setup User acc. Links& Mess. z.B. in links.txt: #Uploads | E:\#Uploads\ ). Immer daran denken, im Setup bei den Access Rights den Ordner reinzunehmen (z.B. #Uploads per drag and drop in das Fenster und anschließend Rechte vergeben) Zur Freischaltung ist immer BEIDES erforderlich.
 

KOENICH

der Monarch
Re: Tip: Dateien verlinken, aber richtig!

Original geschrieben von Supernature

Wichtig ist, dass der User auf alle Verzeichnisse auch entsprechende Zugriffe hat.
Auch die Textdatei muss an einem Ort liegen, auf den der User mindestens Lesezugriff hat!
Wer lesen kann... :rolleyes:


Steht doch bereits in Supis Anleitung :)

Herzlich Wilkommen nichtsdestotrotz - fühl dich wohl!
 

ArpO

Herzlich willkommen!
habe 2.30.
so das verlinken der Ordner klappt jetzt. über links.txt.
hatte es vorher mit verknüfungen auf die ordner probiert und die verknüfungen sollten im server "aufgelöst" werden. leider konnten die user dann auf den ordner nix ziehen, sie sahen den inhalt nur.

leider sehen jetzt alle user auch die datei links.txt, sie liegt im homeverzeichnis.
wenn ich das homeverzeichnis so einstelle, das es nicht gelistet wird, sieht man zwar die datei nicht, aber die ordner sind auch alle weg :(

gibt es eine möglichkeit den links.txt datei vor den user zu verstecken?
 

Supernature

Und jetzt?
Teammitglied
Mit einem kleinen Trick :).
Lege die txt-Datei in einen separaten Ordner und gib dem Benutzer Lesezugriff darauf, ohne allerdings auf dieses Verzeichnis zu verlinken.
 
Oben