[SuSE] smbldap-tools 0.9.2-1

rainer

kennt sich schon aus
smbldap-tools 0.9.2-1

Tach Leute!
Hab da so ein Problem mit der Installation der smbldap-tools 0.9.2-1 auf SuSe 10 als auch SLES 9: perl-openldap ist installiert aber die tools möchten unbeding t noch das perlmodul Unicode::MapUTF8. Lade ich mir dieses rpm runter, so meckert dies seinerseits über fehlende Abhängigkeiten: perl(Jcode) sowie Unicode::Map. Ersteres Modul scheint zur Umsetzung des japanischen Zeichensatzes zu sein (???????) , vom zweiten gibt es etliche Versionen, aber scheinbar keine für SuSE.
Ich habe diese tools vor einiger Zeit schon einmal installiert und keinen solchen Ärger gehabt. Kann mir da jemand weiterhelfen?

thx
Rainer
 

rainer

kennt sich schon aus
Danke für die schnelle Antwort, aber ich treibe mich schon den ganzen mittag auf diversen rpm-suchmaschienen rum - ohne erfolg, aber ich werds mal mit der 0.9.1.11 versuchen, vielleicht nicht so zickig
 

rainer

kennt sich schon aus
Manchmal ist das Neue doch nicht das Beste, die 0.9.1-11 lässt sich einwandfrei installieren. Danke.
 

Bio-logisch

Moderator
Teammitglied
Das Problem dürfte in diesem Fall nicht das Programm, sondern das Paket sein. Der große Nachteil von rpm und deb ist eben der, dass viele Abhängigkeiten als erforderlich ausgewiesen werden, die viele Nutzer gar nicht brauchen.

Besonders kompliziert wird das ganze, wenn Pakete von anderen Distributionen verwendet werden:
Da sind dann manchmal Pakete anders benannt, oder bestimmte Komponenten in andere Paketen aufgeteilt.

Anders herum geht es übrigens auch: Wenn man Programme selber kompiliert ist es oft zum verzweifeln, da eigentlich vorhandene Abhängigkeiten bei den Devel - Paketen nicht mit eingetragen wurden.

In diesem Fall ist es dann oft klüger, das Programm am Paketsystem vorbei zu installieren, also die tgz-Variante zu verwenden:
http://www.idealx.com/content/view/187/172/lang,en/ (Leider scheint die Homepage gerade nur auf französisch verfügbar zu sein).
 
Oben