[SuSE] Kein Zugriff auf Bilder-CD

Stephan1965

nicht mehr wegzudenken
Kein Zugriff auf Bilder-CD

Hallo,
ich habe eine CD mit Bildern von einem Freund bekommen. Leider kann ich darauf nicht zugreifen.
Auf dem Desktop habe ich nach Einlegen der CD in das Laufwerk ein Symbol "Nicht eingebundener CD-Brenner". Wenn ich darauf zugreifen will, habe ich dazu keine Berechtigung.

Kann mir jemand helfen?

Gruß,
Stephan
 

Stephan1965

nicht mehr wegzudenken
Bildschirmfoto

Hallo,
anbei das Bildschirmfoto.

Gruß,
Stephan
 

Anhänge

  • Bildschirmphoto.jpg
    Bildschirmphoto.jpg
    87,8 KB · Aufrufe: 446

Bio-logisch

Moderator
Teammitglied
Was ist denn das für ein Suse?
Ich kann mich da dunkel an was erinnern:
Schau mal in die /etc/fstab, ob da für /dev/hdb ein Eintrag ist.

Wenn ja, ergänze mal in dem Optionsteil ein guid=users (keine Leerzeichen einfügen oder so!)
 

Stephan1965

nicht mehr wegzudenken
Suse 10.1

Hallo Bio,
bei mir läuft SuSE 10.1.
Wenn ich die etc/fstab entsprechend ändere, kann ich jetzt zwar auf die CD zugreifen, aber es ist kein Inhalt da (als ob keine Dateien auf der CD wären).
Hier die entsprechende (geänderte) Zeile aus der fstab:
/dev/hdb /media/dvdrecorder subfs noauto,fs=cdfss,ro,procuid,nosuid,guid=users,nodev,exec,iocharset=utf8 0 0


Jetzt habe ich das Öffnen gerade nochmal versucht und jetzt bekomme ich wieder die gleiche Fehlermeldung wie am Anfang des Threads.

Gruß,
Stephan
 

Stephan1965

nicht mehr wegzudenken
Hallo Bio,
auf meinem zweiten Rechner habe ich SuSE 10.0 laufen. Dort kann ich die CD anstandslos öffnen und darauf zugreifen. Ich habe dort folgende Einstellung in der fstab stehen:
/dev/dvdrecorder /media/dvdrecorder subfs
noauto,fs=cdfss,ro,procuid,nosuid,nodev,exec,iocharset=utf8 0 0

Das ist so ziemlich das gleiche, was ich auch vorher auf meinem 10.1'er hatte.

Wieso kann ich auf dem 10.0'er auf die CD zugreifen und auf dem 10.1er nicht?

Gruß,
Stephan
 

Bio-logisch

Moderator
Teammitglied
Keine Ahnung.
Wenn Du Zeit und muße hast, kannst Du Dich mal in dem Bugzilla von Novell einlesen:

Dort werden Fehler in SuSE - Linux gesammelt. Normaler Weise kriegt man da sogar eine Antwort von den Entwicklern, kann aber 1 - 2 Monate dauern.

Ich habe dort zwei Bugs in SuSE 10.0 gemeldet, die wurden recht schnell repariert:
https://bugzilla.novell.com/index.cgi
 

Smuggler

schläft auf dem Boardsofa
Seltsam .....

Scheint aber irgendwie am Konqueror zu liegen - versuche doch mal die CD mit mount /dev/cdrom über die Konsole (als root) einzubinden und dann in der Adresszeile des Konqueror media:/hdc bzw. media:/cdrom einzugeben und schau mal, was passiert .... und berichte.
 

Stephan1965

nicht mehr wegzudenken
Hallo,
folgende Reaktion:

stephan@liwozi:~> su
Passwort:
liwozi:/home/stephan # mount /dev/cdrom
mount: unbekannter Dateisystemtyp „subfs“
liwozi:/home/stephan #

Gruß,
Stephan
 

Stephan1965

nicht mehr wegzudenken
Und nun:

liwozi:/home/stephan # mount -t iso9660 /dev/cdrom
Aufruf: mount -V : Version ausgeben
mount -h : Diese Hilfe ausgeben
mount : eingehängte Dateisysteme auflisten
mount -l : dito, inklusive Volume-Label
So weit mit dem informativen Part. Als nächstes das Einhängen.
Der Befehl lautet „mount [-t fstype] irgendwas irgendwo“.
Details, die in /etc/fstab stehen, können weggelassen werden.
mount -a [-t|-O] ... : alles aus der /etc/fstab einhängen
mount gerät : Gerät an bekanntem Ort einhängen
mount verzeichnis : hier bekanntes Gerät einhängen
mount -t typ ger verz : normaler Mount-Befehl
Beachten Sie, dass man nicht wirklich ein Gerät einhängt, sondern vielmehr
ein Dateisystem (vom gegebenen Typ), dass sich auf dem Gerät befindet.
Man kann auch einen schon sichtbaren Verzeichnisbaum woanders einhängen:
mount --bind altesVerz neuesVerz
oder einen Unterbaum verschieben:
mount --move altesVerz neuesVerz
Ein Gerät kann über seinen Namen, also /dev/hda1 oder /dev/cdrom, gegeben
werden, oder über sein Label, mittels -L Label, oder über die UUID, mit -U UUID.
Weitere Optionen: [-nfFrsvw] [-o optionen] [-p passwdfd].
Für viele weitere Details: man 8 mount.
liwozi:/home/stephan #


Gruß,
Stephan
 

Stephan1965

nicht mehr wegzudenken
mount

Hallo Bio,
ich bekomme folgende Ausgabe:

stephan@liwozi:~> su
Passwort:
liwozi:/home/stephan # mount
/dev/sda2 on / type reiserfs (rw,acl,user_xattr)
proc on /proc type proc (rw)
sysfs on /sys type sysfs (rw)
debugfs on /sys/kernel/debug type debugfs (rw)
udev on /dev type tmpfs (rw)
devpts on /dev/pts type devpts (rw,mode=0620,gid=5)
/dev/sda3 on /home type reiserfs (rw,acl,user_xattr)
securityfs on /sys/kernel/security type securityfs (rw)
mailserver.scheve.heim:/home/bigdisk on /home/Netzplatte type nfs (rw,addr=192.168.1.100)
mailserver.scheve.heim:/home/Musik on /home/Netzmusik type nfs (rw,addr=192.168.1.100)
/dev/sdb1 on /media/USB_DISK type vfat (rw,nosuid,nodev,noatime,flush,uid=2002,utf8,shortname=lower)
liwozi:/home/stephan #


Gruß,
Stephan
 

Bio-logisch

Moderator
Teammitglied
Hast Du das nach dem Mountversuch der CD (zwei Beiträge weiter oben) gemacht?
Da steht absolut nichts von einer CD.

Versuch es mal so:
mount -tiso9660 /dev/cdrom (ohne Leerzeichen vor dem Iso) und dann noch mal ein "mount" ohne alles hinterher.
 

Stephan1965

nicht mehr wegzudenken
blöde CD wird nicht angezeigt :(

Hallo Bio,
anbei die gewünschte Ausgabe:

liwozi:/home/stephan # mount -tiso9660 /dev/cdrom
Aufruf: mount -V : Version ausgeben
mount -h : Diese Hilfe ausgeben
mount : eingehängte Dateisysteme auflisten
mount -l : dito, inklusive Volume-Label
So weit mit dem informativen Part. Als nächstes das Einhängen.
Der Befehl lautet „mount [-t fstype] irgendwas irgendwo“.
Details, die in /etc/fstab stehen, können weggelassen werden.
mount -a [-t|-O] ... : alles aus der /etc/fstab einhängen
mount gerät : Gerät an bekanntem Ort einhängen
mount verzeichnis : hier bekanntes Gerät einhängen
mount -t typ ger verz : normaler Mount-Befehl
Beachten Sie, dass man nicht wirklich ein Gerät einhängt, sondern vielmehr
ein Dateisystem (vom gegebenen Typ), dass sich auf dem Gerät befindet.
Man kann auch einen schon sichtbaren Verzeichnisbaum woanders einhängen:
mount --bind altesVerz neuesVerz
oder einen Unterbaum verschieben:
mount --move altesVerz neuesVerz
Ein Gerät kann über seinen Namen, also /dev/hda1 oder /dev/cdrom, gegeben
werden, oder über sein Label, mittels -L Label, oder über die UUID, mit -U UUID.
Weitere Optionen: [-nfFrsvw] [-o optionen] [-p passwdfd].
Für viele weitere Details: man 8 mount.
liwozi:/home/stephan # mount
/dev/sda2 on / type reiserfs (rw,acl,user_xattr)
proc on /proc type proc (rw)
sysfs on /sys type sysfs (rw)
debugfs on /sys/kernel/debug type debugfs (rw)
udev on /dev type tmpfs (rw)
devpts on /dev/pts type devpts (rw,mode=0620,gid=5)
/dev/sda3 on /home type reiserfs (rw,acl,user_xattr)
securityfs on /sys/kernel/security type securityfs (rw)
mailserver.scheve.heim:/home/bigdisk on /home/Netzplatte type nfs (rw,addr=192.168.1.100)
mailserver.scheve.heim:/home/Musik on /home/Netzmusik type nfs (rw,addr=192.168.1.100)
/dev/sdb1 on /media/USB_DISK type vfat (rw,nosuid,nodev,noatime,flush,uid=2002,utf8,shortname=lower)
liwozi:/home/stephan #


Die CD wird nicht angezeigt. Das finde ich auch seltsam. Ich habe sie aber eingelegt und auf dem Desktop wird sie auch angezeigt ( wie am Anfang des threads) als nicht eingebundener CD-Brenner.

Gruß,
Stephan
 

Bio-logisch

Moderator
Teammitglied
Na ja, kannst ja noch mal selber etwas rumexperimentieren, aber wenn es nicht geht, dann ist da wohl ein Bug in der SuSE...
 

Stephan1965

nicht mehr wegzudenken
Hallo Bio,
danke für Deine Hilfe. Ich experimentiere noch ein bißchen herum. Und wenn 10.2 kommt, spiele ich das auf. Es kann nur besser werden.
Und wenn ich wirklich mal an eine CD muß, benutze ich meinen anderen Rechner. Und den ändere ich nicht. Never change...
Trotzdem komisch, wie sich das verstellt. Denn es hat mal funktioniert....

Gruß,
Stephan
 

Stephan1965

nicht mehr wegzudenken
mit 10.2 kein Problem mehr

Hallo,
nur zur Info: mit der Version 10.2 (Neuinstallation) kann ich wieder richtig auf die CD zugreifen. War wohl irgendwie ein Bug in 10.1. Jedenfalls auf meinem Rechner.

Gruß,
Stephan
 
Oben