[Server] Fragen zum Tutorial "Linux FTP-Server mit Glftpd"

purene

kennt sich schon aus
Hallo zusammen,

ist es möglich einen Ordner im glftpd zu verstecken? es liegen alle Ordner im Ordner Site,
da ist auch ein Ordner "private" den möchte ich so haben das den nur eine Benutzergruppe öffnen kann. Ist das möglich ?


Thx schonmal
 

Berni01

Herzlich willkommen!
Das machst du ganz einfach indem du den Usern dann rechte vergibst.

SITE CHANGE =User1 homedir private

dann sollte es laufen
 

purene

kennt sich schon aus
jip aber dann sehen die anderen auch noch den inhalt ich will das nur eine gruppe den inhalt sehen kann geht das auch ?
 

purene

kennt sich schon aus
das problem habe ich gelösst, (privatdir Staff ) jetzt hätte ich noch ne andere frage wie sage ich dem Glftpd das er keine Ip´s loggen soll ?


Thx schonmal
 

Bio-logisch

Moderator
Teammitglied
Tagchen und willkommen auf dem Wohlfühlbord!

2.01 ist die aktuelle Version. Die Anleitung bezieht sich zwar auf eine ältere, ist aber übertragbar und funktioniert nach wie vor. Wenn es konkrete Probleme gibt, können wir versuchen Dir zu helfen.

MfG, Bio
 
Zuletzt bearbeitet:

alt

Herzlich willkommen!
Hallo Bio-logisch und thx

also ich weis nicht ob es daran liehgt
ich bin jetzt nach /etc/xinetd.d/glftpd.txt dort habe ich die server_args geändert so wie es in der beschreibung steht

vorher
server_args = /glftpd/bin/glftpd -l -i -o -e

nachher
server_args = /glftpd/bin/glftpd -l -i -o -e -z cert=/glftpd/ftpd-dsa.pem

danacht habe ich die glftpd.conf abgeändert
so und nu sollte man diesen befehl eingeben

./etc/rc.d/init.d/xinentd restart or killall -USR2 xinetd

nur geht dieser befehl nicht bekomme diese meldung das er es nicht findet

-bash: ./etc/rc.d/init.d/xinentd: Datei oder Verzeichnis nicht gefunden

ich hoffe das ihr mir da weiter helfen könnt

MFG
Alt
 

alt

Herzlich willkommen!
huhu also das ging bit den befehlt thx :)
/etc/init.d/xinetd restart or killall -USR2 xinetd

aber ich kann mich immer noch nicht connecten mit den FTP prog das kommt dann

Connecting to : test
Connected to : test ( ip : port )
USER glftpd
Connection Lost.
ERROR: Faild sending list command: CWD /

und laufen tut er laut ps -e

glftpd-LNX_2.01 # ps -e
PID TTY TIME CMD
1 ? 00:00:01 init
16254 ? 00:00:00 dbus-daemon
17659 ? 00:00:00 syslogd
17665 ? 00:00:00 saslauthd
17666 ? 00:00:00 saslauthd
17704 ? 00:00:00 couriertcpd
17706 ? 00:00:00 courierlogger
17719 ? 00:00:00 couriertcpd
17722 ? 00:00:00 courierlogger
17736 ? 00:00:00 couriertcpd
17738 ? 00:00:00 courierlogger
17748 ? 00:00:00 couriertcpd
17750 ? 00:00:00 courierlogger
17758 ? 00:00:00 sshd
17830 ? 00:00:00 named
17851 ? 00:00:00 mysqld_safe
17897 ? 00:00:00 mysqld
17914 ? 00:00:00 qmail-send
17916 ? 00:00:00 splogger
17917 ? 00:00:00 qmail-lspawn
17918 ? 00:00:00 qmail-rspawn
17919 ? 00:00:00 qmail-clean
17952 ? 00:00:03 httpd2-prefork
17953 ? 00:00:00 httpd2-prefork
17964 ? 00:00:04 httpsd
17968 ? 00:00:00 httpsd
17969 ? 00:00:00 httpsd
17970 ? 00:00:00 httpsd
17971 ? 00:00:00 httpsd
17972 ? 00:00:00 httpsd
18035 ? 00:00:00 cron
26298 ? 00:00:04 ircd
26359 ? 00:00:00 services
1854 ? 00:00:00 sshd
1858 pts/0 00:00:00 bash
9219 ? 00:00:00 xinetd
9423 pts/0 00:00:00 ps

was könnte das noch sein ?

MFG
alt
 

alt

Herzlich willkommen!
da bin ich nochmal

also ich habe nochwas geändert in der glftpd.conf

#if you have rsa cert file
RSA_CERT_FILE /glftpd/ftpd-rsa.pem
#if you have dsa cert file
DSA_CERT_FILE /glftpd/ftpd-dsa.pem
#ciphers for control connection
#CIPHERS_FOR_CTRL HIGH:MEDIUM
#ciphers for dirlists
#CIPHERS_FOR_DIR MEDIUM:HIGH:LOW
#ciphers for other data transfers
#CIPHERS_FOR_DATA MEDIUM:HIGH:LOW
#TLS_FTPS 0


weis nicht ob es richtig ist aber jetzt bekomme ich vom ftp eine nachricht die
so aussieht

[R] 530 TLS subsystem failed. Check ftp-data/logs/error.log for details...


so nun habe ich in den error.log mal reingeschaut und volgenes steht dort

Sat Aug 26 17:15:04 2006 [9944 ] unknown option -z ignored
Sat Aug 26 17:15:05 2006 [9944 ] No certificate files found!


also so wie ich es verstehe kommt er mit den server_args nicht klar

server_args = /glftpd/bin/glftpd -l -i -o -e -z cert=/glftpd/ftpd-dsa.pem


was habe ich falsch gemacht ? bitte um HILFE :)

MFG
alt
 

alt

Herzlich willkommen!
huhu ich bins nochmal

also ich hatte voll kacke gebaut ich dachte man muß sich mit einen FTP prog connecten aber das muß man ja mit den putty machen *grrr*

Example:
ftp
open localhost 5130
Name=glftpd
Passwort=glftpd

nur habe ich dabei nen prob
wenn ich das so eingebe kommt volgenes

v30188:~ # ftp
-bash: ftp: command not found
v30188:~ # ftp open localhost 33433
-bash: ftp: command not found
v30188:~ #

weis vll einer warum er es nicht macht ?
 

Bio-logisch

Moderator
Teammitglied
ftp: command not found bedeutet, dass kein Komandozeilentool für das ftp Protokoll installiert ist.
Musst Du mit yast2 nachinstallieren (Das Paket heißt "lukemftp").
 

alt

Herzlich willkommen!
macht er leider nicht

v30188:~/downloads # rpm -U lukemftp*rpm
warning: lukemftp.rpm: V3 DSA signature: NOKEY, key ID 9c800aca
error: Failed dependencies:
libncurses.so.5 is needed by lukemftp-1.5-582
v30188:~/downloads #
 

Bio-logisch

Moderator
Teammitglied
Dann musst Du libncurses vorher installieren.
Such bei rpm.pbone.net nach der Datei und installier das passende Paket. Geh vorher auf advance Search (fortgeschrittene Suche), dann kannst Du speziell für Suse 10.0 und OpenSuse Pakete suchen.
 

Night_Crow

bekommt Übersicht
GLFTPD und SSL

Hallo Leute ,

habe da mal eine frage und zwar habe ich den glftpd auf mein Server und würde gerne wissen wie man und ob man im glftpd irgendwo einstellen kann das man nur mit SSL drauf kommt.
Oder muss ich da noch ein Zusatz Programm installieren.
Ich habe :

Fedora Core 5
GLFTPD 2.01

Würde mich freuen wenn mir einer weiter helfen kann.

MFG Night_Crow
 

comA

Herzlich willkommen!
530 Error reading config file

Hi,

ich habe soweit alles installiert, wenn ich allerdings auf den ftp connecten will, bekomme ich die Meldung:

Code:
Connected to localhost.
530 Error reading config file

Der xinetd ist erfolgreich gestartet und hat auch den Dienst glftpd erfolgreich ausgeführt:

Code:
06/11/8@19:06:35: DEBUG: 7551 {cnf_start_services} Started service: glftpd
06/11/8@19:06:35: DEBUG: 7551 {cnf_start_services} mask_max = 6, services_started = 1
06/11/8@19:06:35: NOTICE: 7551 {main} xinetd Version 2.3.14 started with libwrap loadavg options compiled in.
06/11/8@19:06:35: NOTICE: 7551 {main} Started working: 1 available service
06/11/8@19:06:35: DEBUG: 7551 {main_loop} active_services = 1

Ich vermute das es entweder etwas mit nem falschen Eintrag in der xinetd.conf zu tun hat, welche wie folgt aussieht:

Code:
# Simple configuration file for xinetd
#
# Some defaults, and include /etc/xinetd.d/

service glftpd
{       
        disable = no
        flags                   = REUSE
        socket_type             = stream
        protocol                = tcp
        wait                    = no
        user                    = root
        server                  = /jail/glftpd/bin/glftpd
        server_args             = glftpd -l -o -i
}

defaults
{

# Please note that you need a log_type line to be able to use log_on_success
# and log_on_failure. The default is the following :
# log_type = SYSLOG daemon info

}

includedir /etc/xinetd.d

oder das evtl. die glftpd.config Zugriffsrechte mit chmod modifiziert werden muß, bin aber nen absoluter Linux Neuling und deswegen noch ein wenig zaghaft was Selbsinitiative betrifft.

Kann mir jemand helfen, google konnte es leider nicht!?

Gruß comA

P.S. Ich hab nen aktuelles Ubuntu System am laufen.
P.P.S. Ist es normal das in der xinetd.conf der user root angegeben ist? Ubuntu hat ja da sein eigenes System (mit sudo) und so, kann das nicht zu Problemen führen?
 

pmfire

Erster Beitrag
Hallo,

ich habe torrentflux installiert,
und per mount -o bind in den glftpd ordner gemounted.
ich habe die nötigen rechte vergeben und kann problemlos per ftp auf glftpd zugreifen und dateien verschieben ABER nicht herunterladen:

[R] 426 Timeout while writing data
[R] Übertragung fehlgeschlagen!
Übertragung von Warteschlange komplett
1 Datei(en) nicht übertragen

ich habe keine idee wo das problem liegt.
hoffe ihr könnt mir weiterhelfen...
 

Wonder1

Erster Beitrag
Hi bin neu bei euch hatte euch bei goggle gefunden da ich nen tut für glftd suchte, das tut ist recht einleuchtend.
Nun habe ich nen root server mit suse linux 9.3 und plesk 8.0 wenn ich hier nen modul add mache mit der installgl.sh bekomme ich eien fehler meldung : (Error: Unable to install the module package file: modulemng failed: Please run php35EUde from the glftpd installation dir.
modulemng: error: Installing failed), der fett geschriebene wert ändert sich.
Wahrscheinlich ist es ziemlich simples aber ich bin leider nen linux noob.
 
Oben