[Router] Kein Zugriff auf NAS Laufwerk

janoshaza

treuer Stammgast
Kein Zugriff auf NAS Laufwerk

Hallo liebe Gemeinde

Lange, lange ist es her, das ich hier war, aber gute Adressen merkt man sich.
Hier fand ich immer Hilfe und konnte welche auch bieten.

Heute habe ich ein Problem und hoffe auf Eure Unterstützung.

Folgendes:

Ich habe ein ModemRouter SBG900E mit 3 normal Rechnern und ein Laptop.
Alles läuft über WLAN. Komme auch mit jeden ins Netz und auch untereinander kann ich mich connecten.

Zusätzlich habe ich mir nun eine NAS Platte gekauft, damit ich von unterwegs
auf meine Daten zugreifen kann.
Hier habe ich zwischen Router noch einen Switch gehängt.
Ist notwendig, da ich auch mein Telefon über den Router nutze.
Diese funktioniert.
( Anbieter: Cablesurf.de )

Genau hier liegt das Problem.
Ich bringe es nicht fertig von Aussen auf meine NAS Platte zu kommen.
Hier muss ich anmerken, ich habe eine "Quasi feste IP". ( 85.233.58.60 )
Die Netzwerkkarte ist aktiv, und ich sehe auch in den Einstellungen die IP die der DHCP vergeben hat. Sowie die interne IP.
Intern komme ich ohne Probleme drauf.

In der Einstellung der NAS habe ich ein FTP.
Habe zwei User mit derren Berechtigungen hinterlegt.


Meine Frage:
Wie komme ich auf die Platte?
Wie würde die Syntax lauten wenn ich vom Internet auf meine IP zugreifen will?
Ich habe keinen eigene Domäne, also xxxx.de oder so.
Deshalb ist mir nicht klar, wie die Syntax lautet.

Wenn ich intern über ein FTP Programm auf die NAS Platte gehe, sind die Berechtigten und die Verzeichnisse vorhanden.

Hoffe,jemand kann mir helfen,
vielen Dank vorab.

:sleep
 

Lektro

assimiliert
Im Router muß du außerdem Port 21 auf die IP deines NAS weiterleiten/forwarden. Deswegen besser feste IP für den NAS vergeben.

MfG
Lektro
 

janoshaza

treuer Stammgast
Hi

"Quasi IP" heisst soviel, das mein ISP keine Zwangstrennug hat.
Ich bin am TV Cabel angeschlossen und fahre mit der IP dauernd.
Diese IP wird mir laufend zugewiesen und so wirbt die Firma auch.
Funktioniert perfekt.

Ok. Port 21 ist frei.
Werde mal die Syntax testen die ich von Euch bekommen habe.

Werde Euch informieren.
 

Lektro

assimiliert
So sollte es aussehen: ftp://xxxxx@85.233.58.60

Port 80 brauchst du nicht für deine Anforderungen. Also lieber zumachen.

MfG
Lektro
 

janoshaza

treuer Stammgast
Hi

Danke für die korrekte Schreibweise um Zugriff auf meinen FTP zu kommen.
O.K nun bin ich auf das Anmeldefenster gekommen.
Aber ich scheine Probleme mit dem Router zu haben.
Immer wenn ich versuche mich anzumelden, per ftp>>reseten sich dieses Misstück von Router.

Ich mach nun erst einmal eine Pause, sonst raste ich noch irgendwann aus.
Momentan weiss ich echt nicht mehr weiter.
 

Franz

assimiliert
Portforwarding ist am Router aktiviert?
In der evtl. vorhandenen Software Firewall sind ebenfalls die Ports für den FTP geöffnet?
Kann der FTP ins INetz?
Für den FTP sollten immer Port 20 und 21 offen sein.
 

stkottmann

nicht mehr wegzudenken
@arcanoa:

Also... vielleicht bin ich zu simpel struktiert aber ich würde es wie folgt machen(solange dein Router DynDNs unterstützt):

1.) Die NAS an den Router anschließen und ne feste IP vergeben.
2.) account bei Dynamic Network Services, Inc. -- DynDNS -- Welcome aufmachen und dem Router dementsprechend
konfigurieren, dass er a.) permanent online ist und dann noch regelmäßig an DynDNS ein update der IP-Adresse schickt.
3.) Im Router den Port 21 auf die IP des NAS weiterleiten.
4.) dann per FTP-Client oder per Browser auf die URL , die Du Dir bei DynDNS.org ausgesucht hast, zugreifen und alles ist bene.

per Browser kann man dann per ftp://deinusername:deinpasswort@deine.url.wasauchimmer zugreifen..

Klappt bei mir klasse.

Wenn Du Fragen zu DynDNS hast, such mal im Forum danach. Ist dort sehr gut beschrieben, wie das geht.

Gruss
Stephan
 

Franz

assimiliert
ot:
Sorry stkottmann,

ich bin es nicht, der Schwierigkeiten mit einem NAS Server hat.
Eine Anmeldung bei dyndns dürfte überflüssig sein, da janoshaza schon eine feste IP hat.
Ansonsten beschreibst alles, was deine Vorposter schon gepostet hatten. ;)
 
Zuletzt bearbeitet:

Lektro

assimiliert
@janoshaza: In dieser Anleitung
wird beschrieben, wie du bei deinem Router die Firewall/NAT konfigurieren mußt.
  • Port-ID "FTP-Zugriff (als Beispiel)"
  • Enable "Ja (Haken setzen)"
  • Allowed Protocol "UDP/TCP"
  • Port Range "21:21"
  • Protocol Number "0"
  • Allow Outbound "Ja (Haken setzen)"
  • Allow Inbound "Ja (Haken setzen)"

Damit sollte es funktionieren.

MfG
Lektro
 

janoshaza

treuer Stammgast
Guten morgen liebe Helfer

Habe als Test ein FTP Client installiert und mich auf einen mir bekannten Zugang connectet.
Kein Problem. Konnte downloden und uplod machen.
Das bedeutet: Ich kann auf FTP´s zugreifen.

Habe auch wie mir Lektro geraten, die Einstellungen kontrolliert.
Die Einstellungen sind wie mir freundlicherweise nieder geschrieben worden sind identisch.

Hier weitere Auszüge des Konfigurationsmenü des Routers.

DHCP SERVER Einstellungen

LAN IP Address>>>192.168.0.1
LAN IP Subnet Mask>>>255.255.255.0
Starting IP Address>>>192.168.0.2
# of DHCP Users >>253
DHCP Server Lease Time>>>3600
Domain Name>>>>cablesurf.de
Time to Live>>>64
Interface Maximum Transmission Unit>>>0

WAN Status

WAN IP Address 194.105.100.238
DNS Address 1 85.233.58.60
DNS Address 2 195.46.47.2
DNS Address 3 0.0.0.0
TCP Session Wait Timeout 86400 seconds
UDP Session Wait Timeout 300 seconds
ICMP Session Wait Timeout 300 seconds

CONFIGURED PORT FORWARDING

Name PortStart PortEnd LAN IP Address Enable
FTP 21 21 192.168.0.2 Yes
 
Zuletzt bearbeitet:

Lektro

assimiliert
janoshaza schrieb:
...
WAN Status

WAN IP Address 194.105.100.238
DNS Address 1 85.233.58.60
DNS Address 2 195.46.47.2
DNS Address 3 0.0.0.0
TCP Session Wait Timeout 86400 seconds
UDP Session Wait Timeout 300 seconds
ICMP Session Wait Timeout 300 seconds

CONFIGURED PORT FORWARDING

Name PortStart PortEnd LAN IP Address Enable
FTP 21 21 192.168.0.2 Yes

194.105.100.238 ist die IP, auf die du connecten mußt. Und nicht wie im ersten Beitrag geschrieben 85.233.58.60. Die gehört nämlich zu einem DNS-Server im I-Net (auf dem anscheinend auch ein FTP-Server läuft).
Also "ftp://benutzername@194.105.100.238" wäre korrekt. Damit solltest du auf deinem FTP-Server/NAS landen.

MfG
Lektro
 

janoshaza

treuer Stammgast
Danke füe die gute und nette Unterstützung.

Zum Teil ist das Problem gelöst.
Man kann nun den Wald wieder erkennen.
Folgendes funktioniert nun.
Ich kann mich per FTP Client auf die Platte connecten.
Aber nicht zum Beispiel mit dem FlashXP.
Habe FTP pro genommen.

Zu Testzwecker hat sich mein Bruder auf die Platte geschalten und sich Daten gezogen sowie mir gegeben.
Klappte perfekt.
Sobald ich mich mit FlashXP oder per Web es versuchte, schaltet sich der Router ab und startet neu.

Nun weiss ich hier nicht mehr weiter, hat noch jemand eine Idee?
Würde mich freuen.
 

janoshaza

treuer Stammgast
Hallo liebe Helfer

Habe es soeben selber herraus gefunden, dank eines Super Forum wie hier.
Ein wenig suchen und man hat die Lösung erhalten.
Auf die einfachsten Dinge kommt der Mensch nie.
Der Hinweis: Hinter einen Router benötigt man keinen Passiv Modus, das wuste ich allerdings nicht.
Aber das man diesen ausschalten kann >>irgendwo, das hatte ich noch im Hinterkopf.

Somit habe ich 3 Tage mein komplettes Netz umgesetzt, die NAS Platte mit grossen, aber lehrreichen Schwierigkeiten nun gefixt.

Danke an alle hier im Forum.
Selbstverständlich werde ich, wenn möglich gerne auch behilflich sein, wo es nötig ist.

:) :ROFLMAO: :) :ROFLMAO: :)
 
Oben