Server Remote CP Login funktioniert nicht

Sommerzeit

Running Gag
Hallo Community!

Ich habe heute den Entschluss gefasst mir einen TMF-Server zu erstellen. ;)
Schritt für Schritt bin ich diesem Tutorial gefolgt, und alles hat bis jetzt auch super hingehauen.

Jetz als einer der letzten Schritte in diesem Tutorial muss ich mich im Remote CP einloggen.
Auf die Loginseite (mit http://127.0.0.1/rcp/) komme ich noch ohne Probleme.
Wenn ich mich allerdings mit Username: admin und Password: admin einloggen will, lädt es erst mal ein paar Minuten und dann bleibt nur noch eine weiße Seite. (http://127.0.0.1/rcp/index.php)

Weiß jemand, woran das liegen kann?
 

Fowst

gehört zum Inventar
ich würde einen anderen Usernamen wählen. Ich weiss nicht wie das bei rcp ist, aber ich meine sowas in Erinnerung zu haben, dass man sich eben nicht mit "admin" einloggen kann. Probier ma die logindaten in den Serversettings (die datei wo unter anderem ip und son kram drinsteht) zu ändern.
 

Sommerzeit

Running Gag
ich würde einen anderen Usernamen wählen. Ich weiss nicht wie das bei rcp ist, aber ich meine sowas in Erinnerung zu haben, dass man sich eben nicht mit "admin" einloggen kann. Probier ma die logindaten in den Serversettings (die datei wo unter anderem ip und son kram drinsteht) zu ändern.
Laut dem Tutorial ist das beim ersten Mal einloggen ins RCP standard!
Das kann ich meines Wissens, ohne mich einzuloggen, gar nicht ändern.
 

Fowst

gehört zum Inventar
also wenn du das deepsilver turtorial meinst, was ich meine, könnte es höchstens an Tippfehlern in der Portfreigabe liegen. Dass dein Server nicht denselben Port wie das Spiel benutzen darf weisst du hoffentlich auch.
Ansonsten fällt mir auf die schnelle auch nichts ein, aber ich würde das Tut noch mal überfliegen oder mit mit dem Notepad++ nochmal die Serverconfig anschauen. Sollte das Problem bestehen bleiben lad ich mir auch mal wieder den dedicated runter und versuch ihn zum Laufen zu kriegen, dann fällt mir vielleicht was ein^^

EDIT: Bei mir war der login "rcplive" (ohne Gänsefüßchen)
 

Sommerzeit

Running Gag
Ich bin jetzt das Tutorial noch einmal durchgegangen und habe alles überprüft - es sollte alles passen!

Das wäre toll, wenn du dir das mal ansehen könntest. :)
Anbei auch noch ein paar Screenshots - vielleicht helfen die dir weiter, mir zu helfen. ;)
 

Anhänge

  • TrackmaniaServer.jpg
    TrackmaniaServer.jpg
    70,6 KB · Aufrufe: 461
  • Netgear.jpg
    Netgear.jpg
    344,6 KB · Aufrufe: 530
  • Sommerserve.jpg
    Sommerserve.jpg
    61,5 KB · Aufrufe: 664

benton007

dem Board verfallen
Vielleicht hat es gar nichts zu bedeuten, aber wenn ich mich ins Remote-CP eingeloggt habe, stand da nie was von "register new account".

Hast auch versucht, dort direkt einen neuen account zu registrieren? Vielleicht existiert "admin" noch gar nicht ...
 

Sommerzeit

Running Gag
Ich habe jetzt mal den User "sommer" angelegt (sollte ja egal sein, wie der heißt, oder?)

Danach ist folgendes gekommen:
RCP.jpg

Jetzt ist die Frage - Wo/Wann/Wie kann ich den Account aktivieren?


Edit: Wenn ich mich mit dem Einloggen will, kommt:

[2010-02-21T16:39:07+01:00] [remoteCP Notice] Error, user not found
 

benton007

dem Board verfallen
Da ist dann irgendwo ein Fehler mit dem Passwort passiert.

Dazu jetzt generell mal ein paar Fragen:


1) Hast du die live.bat geändert? Wenn ja, das darf man keinesfalls (dort darf kein Passwort drinnen stehen).

2) Hast du den User von Live in der admins.xml verändert? Wenn ja, das darf man nicht und auch nicht den alten von einer älteren Datei übernehmen.

3) Das Passwort, dass du für den SuperAdmin gesetzt hast und den accountname "SuperAdmin" musst du in der Config des RCP angeben (RCP-Verzeichnis/xml/servers.xml):

<connection>
<ip>localhost</ip>
<port>5004</port>
<account>SuperAdmin</account>
<password>deinpasswort</password>
</connection>

Das müsste dann so aussehen, ist das der Fall?

4) Hast du in der XML-Datei das localhost auch in 127.0.0.1 geändert?
 
Zuletzt bearbeitet:

Sommerzeit

Running Gag
Die live.bat habe ich so geändert, wie das Tutorial es mir gesagt hat.

PHP:
@echo off

rem ****** Set here your php path *******
set INSTPHP=D:\tmforeverserver\xampp\php
rem *************************************

PATH=%PATH%;%INSTPHP%;%INSTPHP%\extensions
"%INSTPHP%\php.exe" live.php -- 1 http://127.0.0.1/rcp

pause

Von der Datei admins.xml habe ich noch nichts gehört - in folge dessen denke ich, dass ich da nichts geändert habe. ;)
 

benton007

dem Board verfallen
Also mir hat ein Freund gesagt, dass man die live.bat nicht ändern darf...

Und selbst wenn, du hast jedenfalls den Schrägstrich nach D: vergessen, was mal sicher nicht funktionieren kann und nach Server, müsste also so aussehen: D:\tmforeverserver\xampp\php

Ausserdem müsste es auch PATH=%PATH%;%INSTPHP%;%INSTPHP%\extensions heissen, also auch hier fehlt der Schrägstrich.
 

Sommerzeit

Running Gag
benton007 schrieb:
Und selbst wenn, du hast jedenfalls den Schrägstrich nach D: ...
Das liegt nur an dem PHP-Code hier im Forum - in der live.bat sind die Schrägstriche vorhanden. ;)

3) Das Passwort, dass du für den SuperAdmin gesetzt hast und den accountname "SuperAdmin" musst du in der Config des RCP angeben (RCP-Verzeichnis/xml/servers.xml):
Unter dem Passwort ist bei mir noch folgende Zeile:
<communitycode>***_</communitycode> (Buchstaben statt Sternchen)

Ansonsten sieht es so aus, ja.

benton007 schrieb:
4) Hast du in der XML-Datei das localhost auch in 127.0.0.1 geändert?
Wenn du die Zeile unter connection <host>localhost</host> meinst, dann nein.
 

benton007

dem Board verfallen
Unter dem Passwort ist bei mir noch folgende Zeile:
<communitycode>***_</communitycode> (Buchstaben statt Sternchen)

Ansonsten sieht es so aus, ja.

Diese Zeile brauchst du nicht (übrigens ein Freund, der schon lange einen Server betreibt und grad neben mir sitzt, sagt mir an, was ich schreiben soll, ich selber bin da nicht so der Experte).

Und nur zur Sicherheit, "deinpasswort" steht dort nicht, sondern stattdessen ist dein Passwort dort zu lesen?


Wenn du die Zeile unter connection <host>localhost</host> meinst, dann nein.

Dann solltest du das mal probieren, denn du möchtest ja mit http://127.0.0.1/rcp starten, das Programm muss schon wissen, was unter 127.0.0.1 zu finden ist ...
 

Sommerzeit

Running Gag
ot:
(übrigens ein Freund, der schon lange einen Server betreibt und grad neben mir sitzt, sagt mir an, was ich schreiben soll, ich selber bin da nicht so der Experte).
Ein großes DANKE auch an ihn. :)

benton007 schrieb:
Und nur zur Sicherheit, "deinpasswort" steht dort nicht, sondern stattdessen ist dein Passwort dort zu lesen?
Hehe, ja. Da steht mein Passwort.

benton007 schrieb:
Dann solltest du das mal probieren, denn du möchtest ja mit http://127.0.0.1/rcp starten, das Programm muss schon wissen, was unter 127.0.0.1 zu finden ist ...
Sollte doch eigentlich egal sein, oder?
Unter http://localhost/rcp komme ich ja auch dort hin.

Habe das localhost in der servers.xml mal in 127.0.0.1 geändert - aber jetzt komme ich irgendwie nur noch auf eine weiße Seite... verhält sich genau so wie vorher wenn ich mich im rcp anmelden wollte.
 

benton007

dem Board verfallen
Dann liegt der Fehler scheinbar direkt bei der Konfiguration von Remote-CP.

Jetzt wirds detailierter:

Geh in den Ordner

„\tmforeverserver\xampp\htdocs\rcp\xml\“

und öffnet dort die Datei „servers.xml“ mit Notepad++.

Dort kontrolliere, ob alles so drin steht:

Code:
<?xml version='1.0' standalone='yes'?>
<servers>
<server>
<serverid>1</serverid>
<name>My Server</name> <!-- Der name deines Servers -->
<settingset></settingset>
<filepath></filepath> <!-- Pathname without slashes, leave empty for old remoteCP3 style -->
<connection>
<ip>127.0.0.1</ip> <!-- Das soll man auf 127.0.0.1 ändern -->
<port>5004</port> <!-- Das ist der RPC-Port, den du in der dedicated_cfg.txt angegeben habt-->
<account>SuperAdmin</account>
<password>however</password> <!-- Das Passwort für den SuperAdmin -->
</connection>
<ftp enabled='false'>
<host>localhost</host>
<username>webmaster</username>
<password>password</password>
<path>/GameData/Tracks/</path>
</ftp>
<sql enabled='true'> <!-- Wenn du [live] und die volle Funktionalität von remoteCP nutzen wollt, musst du hier true einsetzen -->
<host>127.0.0.1</host> <!-- Das soll man auf 127.0.0.1 ändern -->
<username>root</username> <!-- Der Name des SQL-Nutzers -->
<password>"hier dein passwort"</password> <!-- Das Passwort von root !!!! -->
<dbname>live</dbname> <!-- Der Name der SQL-Datenbank -->
</sql>
</server>
</servers>
 

Sommerzeit

Running Gag
Das wenn etwas dick markiert ist, steht dort etwas anderes als bei dir.


1. Zeile: <?xml version="1.0" encoding="utf-8"?>

Vor dem Servernamen:
<id>1</id>
<login></login>

Nach dem Passwort für den Superadmin:
<communitycode>***_</communitycode>

Unter der Zeile <ftp enabled='false'> und nach <host>localhost</host> steht noch:
<port></port>
<username>username</username> ("username" statt "webmaster")

Unter </ftp> stehen folgende Zeilen:
</ftp>
<sql enabled='true'>
<dsn>mysql:dbname=live;host=localhost</dsn>
<username>root</username> (Darüber fehlt die Zeile <host>)
<password>*********</password> (Darunter fehlt die Zeile <dbname>
</sql>
<lists>
<guestlist>guestlist.txt</guestlist>
<blacklist>blacklist.txt</blacklist>
 

Anhänge

  • Notepad.jpg
    Notepad.jpg
    211,5 KB · Aufrufe: 429
Zuletzt bearbeitet:

benton007

dem Board verfallen
<username>username</username> ("username" statt "webmaster")

Hier soll mal sicher nicht username stehen dürfen.

Das mit der Gäste- und Blackliste ist eine optionale Geschichte.

<port></port> ist scheinbar sinnlos, ist ja kein Wert definiert.


Aber mir wurde gesagt, dass du es mal mit genau dem versuchen sollst, wie ich es geschrieben habe. Natürlich mit Neustart und so, denn das hat er exakt so in seiner Datei stehen.
 

Sommerzeit

Running Gag
Aber mir wurde gesagt, dass du es mal mit genau dem versuchen sollst, wie ich es geschrieben habe. Natürlich mit Neustart und so, denn das hat er exakt so in seiner Datei stehen.
Habe die servers.xml mal genau so umgeschrieben wie du es geschrieben hast.

Wenn ich mich nun mit User: admin Passwort: admin einloggen will, schreibt er mir wieder folgendes:
[2010-02-21T18:47:26+01:00] [remoteCP Notice] Error, user not found

Auch mit dem vorher erstellten User "sommer" kommt diese Meldung.

:unsure:
 

Fowst

gehört zum Inventar
nimm mal rcplive als login namen...
ansonsten kann benton oder zumindest sein kollege dir warscheinlic besser helfen
 

benton007

dem Board verfallen
Tja, das letzte was wir noch vorschlagen könnten:

1. Lösche mal den User rcplive aus deiner alten admins.xml
2. Dann füge den User rcplive aus der admins.xml des RCP Downloads in deine admins.xml ein.
3. Cache leeren und Neustart ist klar, schreibs aber dennoch.
4. Jetzt versuch dich mit deinem Adminaccount in RCP einzuloggen.

Sollte es klappen, dann noch folgendes:
5. Öfffne die __live.sh / __live.bat und lösche jeweils die Daten rcplive und das Passwort das du bisher verwendet hast raus. Somit sollte nach dem -- direkt die ID des Servers kommen.
5. Nun RemoteCP-[Live] neu starten.

Wenn das auch nicht hilft, wissen wir nicht mehr weiter...
 

Sommerzeit

Running Gag
nimm mal rcplive als login namen...
ansonsten kann benton oder zumindest sein kollege dir warscheinlic besser helfen
Habe jetzt mal probiert mich mit rcplive einzuloggen - dann erhalte ich folgende Meldung:

[2010-02-22T19:08:57+01:00] [remoteCP Warning] Login error, account rcplive is blocked for webinterface login on line 58 in file D:\tmforeverserver\xampp\htdocs\rcp\includes\core\rcp_session.class.php

Also so weit ich das verstehe, müsste ich doch nur theoretisch in der .php-Datei etwas umschreiben, oder?
 
Oben