[RedHat] Keine grafische Oberfläche

HO!

assimiliert
Keine grafische Oberfläche

Brauche kurz Hilfe:
Habe jetzt Red Hat 5 installiert, aber wen ich es starte, komme ich in den Text-Modus. Wie kann ich umschalten?
 

Bio-logisch

Moderator
Teammitglied
Redhat 5?
Von wann ist das denn? Meine älteste Redhat Box ist 6.1, und die ist von Anfang 2000...

Wenn Du Redhat Enterprise Linux meinst, macht das mehr Sinn ;)
Wie dem auch sei:
Keine grafische Oberfläche = Kein X-Server gestartet.
Also entweder, der wurde nicht installiert, oder er kann aus anderen Gründen nicht starten.

/var/log/messages sollte ein Protokoll enthalten, mit entsprechender Fehlermeldung.

Wenn da nichts steht:
Als root einloggen,

init 5

oder

startx

Könnten abhilfe schaffen.
 

HO!

assimiliert
Moin,
habe soeben Opera installiert, nur, wie starte ich es? Anwendungen->Internet gibt es kein Opera zur Auswahl, es ist aber installiert, wie unter "installierte Software" steht.
Wie starte ich Opera?
Klaus
 

HO!

assimiliert
Und dann bräuchte ich noch einen Grafikkartentreiber für Nvidia Geforce MX 4000. Habe auf deren Hausseite schon geguckt, wenn ich aber einen Runterladen will, öffnet sich ein sehr langer Text (nach den Lizenzbedingungen ;)). Was soll ich da machen?

Opera läuft :)
 

Bio-logisch

Moderator
Teammitglied
Du müßtest auf dieser Seite landen:
Linux Display Driver - IA32

Dort gibt es unter Punkt 2 einen Downloadlink.

Viel Vergnügen bei der Installation, das ist unter Linux etwas aufwändiger ;)

---

Noch mal zum ersten Punkt:
Hast Du es jetzt hinbekommen, dass der X-Server gleich beim Start des Systems mitgeladen wird?

Irgend wo muß es einen Runleveleditor geben (benutze seit Jahren kein Fedora...), da muss der Runlevel 5 als default eingestellt werden.
 

HO!

assimiliert
Bio-logisch schrieb:
Du müßtest auf dieser Seite landen:
Linux Display Driver - IA32

Dort gibt es unter Punkt 2 einen Downloadlink.

Viel Vergnügen bei der Installation, das ist unter Linux etwas aufwändiger ;)

---

Noch mal zum ersten Punkt:
Hast Du es jetzt hinbekommen, dass der X-Server gleich beim Start des Systems mitgeladen wird?

Irgend wo muß es einen Runleveleditor geben (benutze seit Jahren kein Fedora...), da muss der Runlevel 5 als default eingestellt werden.

Womit soll ich die .run-Datei öffnen? Der will sie mit einem Texteditor öffnen.

Zum 2. Punkt von dir:
Habe Fedora neu installiert :D, dann mit X-Server.
 

Bio-logisch

Moderator
Teammitglied
Gar nicht:
Du öffnest eine Konsole (z. B. Alt + F2 xterm) und dann folgende Befehle

su (root Passwort wird abgefragt, es gibt keine Sterne oder so!)
chmod +x Dateiname.run (es gibt eine Vervollständigungsfunktion: Die ersten Buchstaben schreiben und dann einfach die "Tab - Taste" drücken. Achtung: Groß und Kleinschreibung beachten!)

./Dateiname.run

Diese Datei ist selber ein ausführbares Script, ähnlich den Zip - Archiven mit der Endung .exe bei Windows.
 

Bio-logisch

Moderator
Teammitglied
PS:
Mach vorher ein Backup der X-Server Konfiguration.

Die Befindet sich normalerweise in der Datei /etc/X11/xorg.conf oder ähnlich. Einfach mit cp die ganze Datei kopieren:

cd /etc/X11/
cp xorg.conf xorg.conf.20.10.2006.bak
 

HO!

assimiliert
Bio-logisch schrieb:
Gar nicht:
Du öffnest eine Konsole (z. B. Alt + F2 xterm) und dann folgende Befehle

su (root Passwort wird abgefragt, es gibt keine Sterne oder so!)
chmod +x Dateiname.run (es gibt eine Vervollständigungsfunktion: Die ersten Buchstaben schreiben und dann einfach die "Tab - Taste" drücken. Achtung: Groß und Kleinschreibung beachten!)

./Dateiname.run

Diese Datei ist selber ein ausführbares Script, ähnlich den Zip - Archiven mit der Endung .exe bei Windows.
Moin,
bekomme das nicht hin. Habe die Datei erst mal in "Treiber.run" umbenannt, weil der Name sonst so lang und kompliziert war. Dann "Alt+F2" gedrückt, "xterm" eingegeben und mich als root angemeldet. Dann chmod +x Treiber.run eingegeben. Dann steht da, dass entweder ein fehlender Operant nach Treiber.run fehlt oder dass das Verzeichnis nicht gefunden wurde. Die Vervollständigungsfunktion geht schon mal nicht. Muss die Datei in einem bestimmten Ordner liegen?
Klaus
 

HO!

assimiliert
Habe eine Option gefunden: "ausführbare Dateien bei Klick ausführen". Habe sie angeklickt, seitdem steht unten in der Taskleiste, wenn ich Treiber.run anklicke, "Treiber.run wird ausgeführt", es öffnet sich aber kein Fenster und unten verschwindet das auch wieder, ohne das weitere Dinge passieren.
 

Bio-logisch

Moderator
Teammitglied
Du musst vorher schon in den Ordner wechseln, in dem Du die Datei gespeichert hast.
Der Befehl heißt cd.

Darauf achten, dass der Bezug stimmt:

cd /home/benutzername/wo/auch/immer

oder

cd ~/wo/auch/immer

Das mit dem Ausführen ist, Käse, Du musst ja sehen, was passiert. Also schön aus der Konsole öffnen!
 

HO!

assimiliert
Fast...

Moin,
klappt, es kommt aber eine Fehlermeldung: ERROR: You appear to be running an X server; please exit X before installing.
Wie mache ich das?
 

Bio-logisch

Moderator
Teammitglied
Ich glaub, init 1 bei Redhat.

Um ihn wieder zu starten init 5. Kann sein, dass die Befehle ohne Leerzeichen geschrieben werden.
 

HO!

assimiliert
Les mir gerade das hier durch:
Wenn ich init 3 eingebe, dan bleibt der irgend wo hängen.
Ich schalte dann um auf meinetwegen Konsole 4 (STRG-ALT-F4) und dann gebe ich init 5 ein, so komme ich zum grafischen Anmeldefenster.
Aber bei init 3 bleibt er hängen. bei telinit 3 auch.

kilall -9 X geht auch nicht.
 

Bio-logisch

Moderator
Teammitglied
Dann geh mal in den Modus init 1

Wenn das auch nicht geht:
Beim booten den Parameter init=/bin/sh übergeben (direkt im Bootloader)

Zum Runterfahren dann den Befehl "halt" verwenden.

PS: Ich merk gerade, wie lang sich selber so was schon nicht mehr gemacht hab - komm gerade ganz schön ins grübeln ;)
 

HO!

assimiliert
init 1 hat geklappt, aber irgend etwas stimmt mit der Datei nicht.
Habe den Log mal kopiert, ich deute es so, dass die Datei nicht mit dem Betriebssystem stimmt. Oder sehe ich das falsch?
nvidia-installer log file '/var/log/nvidia-installer.log'
creation time: Sat Oct 21 22:13:45 2006

option status:
license pre-accepted : false
update : false
force update : false
expert : false
uninstall : false
driver info : false
precompiled interfaces : true
no ncurses color : false
query latest version : false
OpenGL header files : true
no questions : false
silent : false
no recursion : false
no backup : false
kernel module only : false
sanity : false
add this kernel : false
no runlevel check : false
no network : false
no ABI note : false
no RPMs : false
no kernel module : false
force SELinux : default
force tls : (not specified)
X install prefix : (not specified)
X library install path : (not specified)
X module install path : (not specified)
OpenGL install prefix : (not specified)
OpenGL install libdir : (not specified)
utility install prefix : (not specified)
utility install libdir : (not specified)
doc install prefix : (not specified)
kernel name : (not specified)
kernel include path : (not specified)
kernel source path : (not specified)
kernel output path : (not specified)
kernel install path : (not specified)
proc mount point : /proc
ui : (not specified)
tmpdir : /tmp
ftp mirror : ftp://download.nvidia.com
RPM file list : (not specified)

Using: nvidia-installer ncurses user interface
-> You appear to be running in runlevel 1; this may cause problems. For exampl
e: some distributions that use devfs do not run the devfs daemon in runlevel
1, making it difficult for `nvidia-installer` to correctly setup the kernel
module configuration files. It is recommended that you quit installation no
w and switch to runlevel 3 (`telinit 3`) before installing.

Quit installation now? (select 'No' to continue installation) (Answer: No)
-> License accepted.
-> No precompiled kernel interface was found to match your kernel; would you li
ke the installer to attempt to download a kernel interface for your kernel f
rom the NVIDIA ftp site (ftp://download.nvidia.com)? (Answer: No)
-> No precompiled kernel interface was found to match your kernel; this means
that the installer will need to compile a new kernel interface.
-> Performing CC sanity check with CC="cc".
-> Performing CC version check with CC="cc".
ERROR: Unable to find the kernel source tree for the currently running kernel.
Please make sure you have installed the kernel source files for your
kernel and that they are properly configured; on Red Hat Linux systems,
for example, be sure you have the 'kernel-source' RPM installed. If you
know the correct kernel source files are installed, you may specify the
kernel source path with the '--kernel-source-path' command line option.
ERROR: Installation has failed. Please see the file
'/var/log/nvidia-installer.log' for details. You may find suggestions
on fixing installation problems in the README available on the Linux
driver download page at NVIDIA Home.
Klaus
 

Bio-logisch

Moderator
Teammitglied
Steht da doch:
Die wollen runlevel 3.
also: Erst in 1 gehen, dann in 3 gehen, dann noch mal versuchen. Und dann sollte der Treiber auch nach einem vorkompilierten Modul suchen, in Runlevel 1 geht das nicht, da kein Netzwerk an ist.

Wenn da nichts ist, heißt das eben selber kompilieren.
Die benötigten Pakete stehen in der Meldung: 1.) Kernelsourcen (sind mit auf der CD), 2.) den gcc Compiler. Und dann noch mal versuchen!
 

HO!

assimiliert
Öhm...

Ist mit runlevel init gemeint? Oder was meinst du?


Habe es soeben das ganze nochmal mit init 3 probiert, diesmal ging es, aber wieder selber Fehler wie eben.
 
Oben