WindowsXP Problem mit Silicon Image SiI 3512 Controller

NotANerd

kennt sich schon aus
Hallo,

ich habe ein Problem mit dem Silicon Image SiI 3512 Controller. Nachdem ich ihn in den Rechner verbaut und den Treiber installiert habe, dachte ich ich könnte einfach 2 werksneue S-ATA-Platten dran hängen und sie als Daten-Platten nutzen. Der Treiber scheint auch korrekt installiert zu sein. Das System läuft auf einer (älteren) IDE-Platte und das würde ich auch gern so lassen. Das BIOS des Controllers zeigt die Platten zwar an, aber das BIOS des Rechners nicht. Wenn die S-ATA-Platten angeschlossen sind, startet der Rechner erst und bleibt in einem Black-Screen stehen, wenn er eigentlich Windows booten sollte. Sobald ich die Platten abklemme, fährt der Rechner regulär hoch.

Wer kann mir helfen?
Was muss ich noch beachten und einstellen?

Rechner: AMD Duron 1200 MHz
Board: ECS K7SEM
System: Win XP Prof SP III
S-ATA-Platten: Samsung HD154UI
(ist nur ein Zweit-Rechner, der als Ablage dienen soll)

Danke im Voraus für Hilfe. :)



P.S.: Das kleine Manual und die Suche im Netz konnten mir nicht weiter helfen. :(
 
Zuletzt bearbeitet:

little tyrolean

Elder Statesman
Friert der Rechner auch dann ein, wenn du die S-ATA-Platten nachträglich einschaltest?
Ich verwende denselben Controller, bei mir ist es so,
daß bis zum Erkennen der Platten die Maus einfriert, danach ist alles wieder normal.

Korrektur:
Microsoft bietet über das Windows-Update einen zertifizierten Treiber an, der keine Probleme macht.
Anscheinend gilt das nur für Vista / W7.
/Korrektur

Der Controller sollte nach dem Abschluß der Startvorgänge im BIOS als selbständiges Gerät angezeigt werden,
auch die Platten sollten darin zu sehen sein, aber nicht im BIOS selbst.
Wenn nicht,
ist entweder der Controller schlecht montiert / defekt / oder nicht kompatibel zum Motherboard.

Schau einmal im BIOS nach, von welcher Platte zu booten versucht wird,
es kann durchaus sein, daß die Boot-Priority verstellt worden ist.
 
Zuletzt bearbeitet:

NotANerd

kennt sich schon aus
Hallo,

im Bootvorgang wird der Controller angezeigt. Auch die beiden 1,5TB-Platten (Samsung HD154UI) werden als "0" und "1" aufgelistet. Danach bleibt der Rechner im Black-Screen stehen.

Ich habe mal im Rechner-BIOS die Boot-Priorität gecheckt und versucht einzustellen dass er von der normalen System-IDE-Platte startet. Dort wird ja auch nur diese eine angezeigt, aber als IDE Secondary Master. Ich bekomme nicht eingestellt, dass die HD als IDE Primary Master eingetragen ist.

Kann es daran liegen?

Und wenn ja - wie kann ich die eingebaute IDE-Platte als IDE Primary Master setzen? Einfach einstellen geht nämlich nicht. :(
 

little tyrolean

Elder Statesman
Ich habe mal im Rechner-BIOS die Boot-Priorität gecheckt und versucht einzustellen dass er von der normalen System-IDE-Platte startet. Dort wird ja auch nur diese eine angezeigt, aber als IDE Secondary Master. Ich bekomme nicht eingestellt, dass die HD als IDE Primary Master eingetragen ist.

Kann es daran liegen?
Möglich,
aber nur mehr bei älteren Boards.
Und wenn ja - wie kann ich die eingebaute IDE-Platte als IDE Primary Master setzen? Einfach einstellen geht nämlich nicht. :(
Bist du sicher, daß die Festplatte als Master gejumpert ist und NICHT als Cable Select?
Falls das der Fall ist, die Platte als Master jumpern und wenn nötig,
das Festplattenkabel am Motherboard umstecken,
meistens ist der primäre IDE-Controller rot, der sekundäre blau gefärbt.

Ich weiß nicht, ob das BIOS eine Möglichkeit hat, auch die Bootreihenfolge festzulegen, hier sollte

1.) Diskettenlaufwerk (wenn vorhanden)
2.) CD-ROM
3.) IDE/ATA (oder die IDE-Plattenbezeichnung des BIOS )
4.) der SIL-Controller (wenn überhaupt sichtbar)

eingetragen sein.
 
Zuletzt bearbeitet:

NotANerd

kennt sich schon aus
Ich habe nochmals die IDE-System-Platte gecheckt, diese ist auf Master gejumpert. Durch Umstecken der Kabel wird sie auch wieder als IDE Primary Master erkannt.

Das BIOS hat die Möglichkeit, auch die Bootreihenfolge festzulegen. Dort wird aber nirgends der SiI 3512 Controller aufgeführt.

Nach erneutem Versuch ist es der gleiche Stand: Das System fährt hoch, wenn die Festplatten nicht angesteckt sind. Das System bleibt nach dem Screen "SiI 3512A SATARaid BIOS Version 4.3.79" mit Anzeige der 2 Festplatten im Blackscreen stehen.

Was mache ich nun nun? :(
 

little tyrolean

Elder Statesman
So wie das nun aussieht, rumpelt das BIOS beim Booten an der IDE-Platte vorbei oder kommt erst gar nicht dorthin.

Bootreihenfoge und Boot-Priority sind zwei Paar Schuhe:
Die Boot-Priority legt fest, ob von IDE, S-ATA, USB oder SCSI (in deinem Fall der SIL-Controller) gebootet wird.
Die Bootreihenfolge bestimmt, von welchem Gerät aus (Festplatte, USB-Stick, was auch immer) der Rechner hochgefahren wird.

Ich vermute,
daß da im BIOS noch nachjustiert werden muß, kenne aber dein Board so gut wie gar nicht.

Der SIL-Controller versucht zu booten, kann das natürlich nicht und bleibt hängen.
Das Gerät ist aber nicht imstande, eine entsprechende Meldung abzusetzen, deshalb auch der schwarze Bildschirm.
 

NotANerd

kennt sich schon aus
Dass es einen Unterschied zwischen Bootreihenfoge und Boot-Priority gibt, wusste ich nicht.

Ich kann im BIOS in den "Advanced BIOS Features" First Boot Device, Second Boot Device und Third Boot Device einstellen. Dazu die Einstellung Boot Other Device.

Eingetragen ist:
First Boot Device -> HDD-0 (dächte es wäre die IDE-System-Platte)
Second Boot Device -> CDROM
Third Boot Device -> Disabled
Boot Other Device -> Disabled

Bei First Boot Device habe ich die mir angebotenen HDD-1, HDD-2 und HDD-3 ausprobiert, es kam zu keiner Veränderung. :(

Unter "Integrated Peripherals" habe ich auch geschaut. Muss dort der SiI 3512A-Controller aufgeführt sein unter "SIS 730 OnChip PCI Device"?

Dann habe ich noch "PnP/PCI Configurations", aber als Leihe gurke ich da nur sinnlos rum. :(
 

little tyrolean

Elder Statesman
Kann es sein, daß das ein (modifiziertes) Award Modular BIOS ist?
Deine Bechreibung läßt diesen Schluß zu.
Eingetragen ist:
First Boot Device -> HDD-0 (dächte es wäre die IDE-System-Platte)
Second Boot Device -> CDROM
Third Boot Device -> Disabled
Boot Other Device -> Disabled
[...]
Bei First Boot Device habe ich die mir angebotenen HDD-1, HDD-2 und HDD-3 ausprobiert
Da stimmt was nicht, stehen die Plattenbezeichnungen auch dabei?
 

redskin

kennt sich schon aus
moin, hab mal ein wenig gelesen... vielleicht solltest du das bios des 3512 mal updaten... zitat: If the computer hangs (no display) during booting after installing the controller card only when a drive is attached, it is usually a sign of incompatability between the controller BIOS and the drive firmware. You can often fix this by installing new BIOS for the controller or updating the firmware on the drive...
 

redskin

kennt sich schon aus
damit wir uns richtig verstehen, es handelt sich um eine pci-controllerkarte, oder?
wie war denn der dateiname des bios, das du flashen wolltest?
lg
redskin
 
Zuletzt bearbeitet:

NotANerd

kennt sich schon aus
Problem gelöst!

Das Problem ist gelöst.

BIOS-Update des Mainboards und BIOS-Update des Controllers brachten nun alles zum Laufen. Beides mit Boot-CD ausgeführt und ich kann den Controller und die Festplatten nutzen.

Danke an alle Poster und Helfer. :D
 
Oben