SuSE Problem mit MBR nach Installation von W7

rovaton

bekommt Übersicht
Hallo,
Vor Kurzem habe ich habe ich ein Upgrade von Vista nach W7 gemacht.
Windows ist aber so habgierig, dass er den MBR (Grub) mit Suse 11.2 ´rausgeschmissen hat.
Wie bekomme ich eine bootrecord von Linux wieder hin?
- ich bin ein aboluter ahnungsloser Anwender :) -
ronald
 

Bio-logisch

Moderator
Teammitglied
Wobei Du vorher nachsehen solltest, welche Grub - Version du verwendest:
Grub legacy oder Grub2 (ich vermute letzteres).
 

Smuggler

schläft auf dem Boardsofa
Am einfachsten geht es wenn man sich die opensuse-Installations-DVD nochmal brennt und so tut, als möchte man das System neu installieren - irgendwann am Anfang kommt der Punkt, an dem man entscheiden kann, ob man das System reparieren möchte oder doch neu installieren möchte ...

Natürlich möchte man jetzt reparieren - lässt das meiste automatisch durchlaufen, bestätigt mit OK die vorgeschlagenen GRUB-Optionen und hat nach ca. 30 Minuten sein System wieder ... und man braucht keine Ahnung von Linux oder GRUB oder so zu haben oder sich anzueignen ....
 

MaXg

assimiliert
Tipp:
Als Fan von Stabilen Systemen gibt es Linux und Windows nur auf Physikalisch verschiedenen Systemen.

Wenn es auf einem Einzelrechner sein MUSS, dann als Virtuelle Maschine.
Rest ist absolutes no go.

Lösungen für no go Systeme stehen weiter oben.
 

Bio-logisch

Moderator
Teammitglied
Na ja, wer einen Wechselrahmen hat, für den ist das schon möglich. Aber imho nicht notwendig, ich hab z. B. meine Bootsektoren immer noch auf einer Diskette gesichert - damit kann ich dann im Notfall meist immer noch starten...
 

rovaton

bekommt Übersicht
Vielen Dank an Alle. Es hat leider ein paar Tage gedauert. Ich hatte andere (für mich) wichtige Aufgaben zu erfüllen.
Ich habe mit der Reparaturfunktion von Suse wieder die Möglichkeit gefunden, wenigstens OpenSuse 11.2 wieder aufzurufen. Jetzt ist aber windows verschwunden.Auch meine Versuche, Windows auf sda1 (da ist das Programm installiert) in Yast zu beschreiben, funktionierte leider nicht. Irgendwo steckt noch ein kleiner Fehlerteufel. würde hier jemand mir nochmal behilflich sein?
Vielen Dank
Ronald
 

Bio-logisch

Moderator
Teammitglied
In dem Fall würde ich den Linuxbootloader in eine Datei sichern, mit der Win 7 Reperaturkonsole den Windows Bootloader wieder herstellen und anschließend den gesicherten Bootsektor in den Win 7 Bootloader einbinden:

Bootsektor sichern:
Master Boot Record und Bootsektoren sichern (I) - - PC-WELT

Linux in den Win7 loader einbinden:
Windows 7: Linux starten / Bootloader bearbeiten

Das setzt aber in jedem Fall voraus, dass Du Dich in die Materie "bootloader" auseinandersetzt:
Das ist nicht unbedingt "klick und geht".
 

Smuggler

schläft auf dem Boardsofa
Grmbl ...

Wenn die Kiste mit openSuSE ja wieder läuft, kannst du mit YaST unter "System" den Menüpunkt "Bootloader" aufrufen und nach dem anklicken die Einstellungen bearbeiten. Rechts unten über dem "OK-Button" ist ein "Weiter-Button" der die Möglichkeit gibt die "Konfiguration neu von Festplatte" einzulesen. YaST sollte hiermit die Windows-Partition finden und entsprechend zum booten anbieten - die emtsprechenden Änderungen mit "OK" speichern - und es sollte wieder beides funktionieren ....
 

rovaton

bekommt Übersicht
Danke Smuggler,
nach einigem hin und her hat es geklappt!
Leider gibt es so ein paar Programme, die nur unter Windows laufen. Ärgerlich, aber nicht zu ändern. :)
Ronald
 
Oben