Problem Dateiübertragung

Daniel2000

Herzlich willkommen!
Hallo ich teste gerade auf unserem Win2003 Server G6FTP 3.9.0. Der Login funktioniert, kleinere Dateiübertragung funktioniernen auch.
Dateien größer als 2 MB werden übertragen, die Übertragung bleibt jedoch bei 100% stehen.
Bricht man dann die Übertragung ab, ist die Datei trotzdem OK, nur wenn man mehrere übertragen möchte, klappt es natürlich nicht, weil man immer erst auf abbrechen klicken muss beim Client.
Woran kann es liegen?
 

KOENICH

der Monarch
Wie immer wären Log-Auszüge von Client und Server hilfreich :)

ot:
Herzlich Willkommen :) Fühl dich wohl
 

Daniel2000

Herzlich willkommen!
Ich hoffe, dass genügt, der Client ist Pyrobatch

Logfile-Server:
Code:
USER User1
331 Password required for User1.
PASS ****
logged in as "User1".
230 User User1 logged in.
CWD folder\
change directory '/folder' -> 'E:\FTP\folder' --> Access allowed.
250 CWD command successful. "/folder" is current directory.
PWD
257 "/folder" is current directory.
TYPE A
200 Type set to A.
PORT ip-adresse,11,243
200 Port command successful.
LIST
150 Opening data connection for directory list.
226 Transfer ok.
TYPE A
200 Type set to A.
PORT ip-adresse,11,244
200 Port command successful.
LIST datei__2007-07-25.mdb
150 Opening data connection for directory list.
226 Transfer ok.
TYPE I
200 Type set to I.
PORT ip-adresse,11,245
200 Port command successful.
SIZE datei__2007-07-25.mdb
213 3704832
RETR datei__2007-07-25.mdb
User1, asked to download '/folder/datei__2007-07-25.mdb' -> 'E:\FTP\folder\datei__2007-07-25.mdb' from 0 --> Access allowed.
150 Opening data connection for datei__2007-07-25.mdb (3704832 bytes)
finished downloading '/folder/datei__2007-07-25.mdb' -> 'E:\FTP\folder\datei__2007-07-25.mdb' from 0 to 3704832 (00:02:36 - 23,191 KBytes/s).
226 File sent ok.
disconnected. (00d00:02:57)

Logfile-Client

Code:
0000.04  -  $ Connect
0000.04  -  #200 OK
0000.05  -  $ RemoteChDir "Folder\"
0000.05  -  #200 OK (now in '/Folder)
0000.05  -  $ getdir -M
0459.07  -  % Get "Datei_2007-07-25.mdb"
0459.07  -  % #200 OK (3.53 MB, time= 2:36.8, 23.1 KB/sec.)
0459.08  -  % RemoteDelete "Datei_2007-07-25.mdb"
0459.08  -  % #500 internet connection reset (12031)
 

Supernature

Und jetzt?
Teammitglied
Der Server sagt "finished downloading", für ihn ist der Transfer also erledigt.
Was mich irritiert, ist die Anzeige im Client
0459.08 - % RemoteDelete "Datei_2007-07-25.mdb"
Versucht er die Datei zu löschen?
 

Daniel2000

Herzlich willkommen!
Ja richtig er versucht zu löschen, habe mal einen anderen Client genommen (TotalCommander)

Dort steht am Ende der Übertragung wenn er bei 100% hängen bleibt: Warten auf Antwort des Servers

Code:
----------
Connect to: (31.07.2007 19:50:53)
hostname=XXXXXXXXX
username=XXXX
startdir=
220 Gene6 FTP Server v3.9.0 (Build 2) ready...
USER XXXX
331 Password required for XXXXXX.
PASS ***********
230 User XXXX logged in.
SYST
215 UNIX Type: L8
FEAT
211-Extensions supported:
 AUTH TLS
 CCC
 CLNT
 CPSV
 EPRT
 EPSV
 MDTM
 MFCT
 MFMT
 MLST type*;size*;create;modify*;
 MODE Z
 PASV
 PBSZ
 PROT
 REST STREAM
 SIZE
 SSCN
 TVFS
 UTF8
 XCRC "filename" SP EP
 XMD5 "filename" SP EP
 XSHA1 "filename" SP EP
211 End.
Connect ok!
PWD
257 "/" is current directory.
Verzeichnis einlesen
TYPE A
200 Type set to A.
PASV
227 Entering Passive Mode (IP-ADRESSE,251,199)
PORT 192,168,2,12,8,131
200 Port command successful.
LIST
150 Opening data connection for directory list.
Herunterladen
Warte auf Antwort des Servers...
226 Transfer ok.
CWD backup
250 CWD command successful. "/backup" is current directory.
Verzeichnis einlesen
PORT 192,168,2,12,8,134
200 Port command successful.
LIST
150 Opening data connection for directory list.
Herunterladen
Warte auf Antwort des Servers...
226 Transfer ok.
TYPE I
200 Type set to I.
PORT 192,168,2,12,8,140
200 Port command successful.
RETR XXXXXXX_2007-07-26.mdb
150 Opening data connection for XXXXXXXXX_2007-07-26.mdb (3772416 bytes)
Herunterladen: 3.771.036 bytes, 23.4 kbytes/s
Warte auf Antwort des Servers...
Taste 'Abbrechen' betätigt! - DAS WAR ICH DANN :-)

Vielleicht hilft das noch ein wenig!
 

Supernature

Und jetzt?
Teammitglied
Und im Server-Log sieht es wieder gleich aus?
Das würde bedeuten, dass die Quittung vom Server nicht beim Client ankommt - warum auch immer...
 

Daniel2000

Herzlich willkommen!
ja genau server log wie vorher auch! Sorry, hatte ich nicht dabei geschrieben! Das ist von allen Rechnern so. Egal von wo ich connecte....
 

MaXg

assimiliert
Sieht aus wie eine Fehlkonfiguration oder Bug des Clients.

Funktioniert es denn mit anderen Clients? Zur Not machts auch der IE/FF.
 

Thorsten-Bln

Erster Beitrag
Hallo,

habe eine Idee dazu. Bei mir tritt das Problem auch auf.
Ich denke es handelt sich um das selbe Phänomen.

Ich betreibe den Gene6 FTP-Server auf einem Windows 2003 Server, der bei einem Provider läuft. Es ist eine virtueller Server, also nicht besonders viel Performance dahinter.

Wenn ich kleinere Dateien übertreibe, tritt das Problem nicht auf. Wenn ich jedoch größere Dateien übertrage, läuft die Übertragung bis 100% und danach kommt praktisch "Warte auf Serverantwort.."

Dann dauert es einige Zeit, entweder es kommt dann die Antwort vom Server oder aber mein FTP-Client bricht ab mit Timeout.

Wenn ich das Logfile lesen richtig verstanden habe, dann macht G6FTP-Server mit dem FTP-Client eine XSHA1 Prüfung. Also eine Hash-Prüfung, ob das File auch einwandfrei übertragen worden ist.
Da der Server natürlich nicht viel Performance hat, braucht er einige Zeit bis er den Hashwert errechnet hat bei großen Files. In der Zeit wartet der Client natürlich.


Ich denke, daran könnte es liegen ? Was meinen die anderen ?

Meine Frage wäre nun, kann man diese XSHA1 Prüfung ausschalten ?

Liebe Grüße
Thorsten
 
Oben