PASV Port mit Router

bytestar

kennt sich schon aus
Und nein überbleibsel können es nit sein am router liegt es auch nit mein Freund hat das selbe Problem mit G6 !

Serv-u habe ich immer angehalten Dienst deaktiviert rechner neugestartet usw...
 

Supernature

Und jetzt?
Teammitglied
OK, ich werde das zu Hause auch nochmal ausführlich durchtesten.
Was ich nach wie vor nicht verstehe ist, warum sich die Ports an Server und Client unterscheiden. Man müsste mit einem externen Programm mal den Netzverkehr aufzeichnen, dann sieht man, welches Kommando der Server wirklich abschickt.
 

bytestar

kennt sich schon aus
;) So jetzt wird es richtig verrückt

das ist der log der Test seite mit G6 2.21

Trying to connect to bytestar.homeip.net (81.173.130.226):21 ...
220 BulletProof FTP Server ready ...

Connected to remote host "bytestar.homeip.net (81.173.130.226):21"
USER anonymous
331 Password required for anonymous.

PASS test@test.com
230 User anonymous logged in.

Authentication OK
CLNT Testing from http://www.g6ftpserver.com/?page=ftptest via 81.173.130.226
500 Unknown command.

PWD
257 "/" is current directory.

Current directory is : /
PASV
227 Entering Passive Mode (81,173,130,226,5,122)

LIST
Trying to connect datasocket to 81.173.130.226:1402 ...
150 Data connection accepted from 213.215.47.130:3001; transfer starting.

Datasocket connected to remote host
Directory listing :
drwxr-xr-x 1 ftp ftp 0 Apr 29 14:14 appz
drwxr-xr-x 1 ftp ftp 0 Apr 29 20:11 files
drwxr-xr-x 1 ftp ftp 0 Apr 29 20:11 mukke
drwxr-xr-x 1 ftp ftp 0 Apr 29 13:39 updates
drwxr-xr-x 1 ftp ftp 0 Apr 29 18:22 uppload
drwxr-xr-x 1 ftp ftp 0 Apr 29 18:22 users
Datasocket disconnected from remote host
226 Transfer ok

QUIT
Disconnected from remote host

Alles ok wie mann sieht !
 
Zuletzt bearbeitet:

bytestar

kennt sich schon aus
Jetzt erklären Sie mir das , das ist defininitiv Ein dicker Bug in G6 V.3
 

Anhänge

  • g6_bp_215.jpg
    g6_bp_215.jpg
    37,8 KB · Aufrufe: 690

bytestar

kennt sich schon aus
hier noch das log des alten G6





---------- Session created on 03.05.2004 15:48:04 on port 21 ----------

(000003) 03.05.2004 15:48:11 - (not logged in) (213.215.47.130) > connected to ip : 192.168.2.100
(000003) 03.05.2004 15:48:11 - (not logged in) (213.215.47.130) > sending welcome message.
(000003) 03.05.2004 15:48:11 - (not logged in) (213.215.47.130) > 220 BulletProof FTP Server ready ...
(000003) 03.05.2004 15:48:11 - (not logged in) (213.215.47.130) > USER anonymous
(000003) 03.05.2004 15:48:11 - (not logged in) (213.215.47.130) > 331 Password required for anonymous.
(000003) 03.05.2004 15:48:11 - (not logged in) (213.215.47.130) > PASS ********
(000003) 03.05.2004 15:48:11 - anonymous (213.215.47.130) > logged in.
(000003) 03.05.2004 15:48:11 - anonymous (213.215.47.130) > 230 User anonymous logged in.
(000003) 03.05.2004 15:48:11 - anonymous (213.215.47.130) > CLNT Testing from http://www.g6ftpserver.com/?page=ftptest via 81.173.130.226
(000003) 03.05.2004 15:48:11 - anonymous (213.215.47.130) > 500 Unknown command.
(000003) 03.05.2004 15:48:12 - anonymous (213.215.47.130) > PWD
(000003) 03.05.2004 15:48:12 - anonymous (213.215.47.130) > 257 "/" is current directory.
(000003) 03.05.2004 15:48:12 - anonymous (213.215.47.130) > PASV
(000003) 03.05.2004 15:48:12 - anonymous (213.215.47.130) > 227 Entering Passive Mode (192,168,2,100,5,122).
(000003) 03.05.2004 15:48:12 - anonymous (213.215.47.130) > LIST
(000003) 03.05.2004 15:48:12 - anonymous (213.215.47.130) > 150 Data connection accepted from 213.215.47.130:3001; transfer starting.
(000003) 03.05.2004 15:48:12 - anonymous (213.215.47.130) > 226 Transfer ok
(000003) 03.05.2004 15:48:12 - anonymous (213.215.47.130) > QUIT
(000003) 03.05.2004 15:48:12 - anonymous (213.215.47.130) > 221 Bye bye ...
(000003) 03.05.2004 15:48:12 - anonymous (213.215.47.130) > disconnected. (00:00:00)
 

Supernature

Und jetzt?
Teammitglied
Besonders interessant daran ist, dass auch hier wieder die Ports zwischen Server und Client nicht übereinstimmen. Wahrscheinlich wird das durch den Router ausgelöst und auch wieder zurückübersetzt, hat also mit dem eigentlichen Problem nichts zu tun.

Original geschrieben von Supernature
Dann müsste man fast annehmen, dass der Server laut seinem eigenen LOG zwar den richtigen Range benutzt, tatsächlich aber andere Kommandos abschickt. Kann ich mir kaum vorstellen, aber man soll ja nie nie sagen :D

Jetzt kann ich mir kaum noch eine andere Ursache vorstellen :crazy
Ich benutze als PASV-Range die Ports 30000 - 30050 und mit diesen funktioniert es. Möglicherweise gibt es tatsächlich Probleme mit bestimmten Ranges.
 

bytestar

kennt sich schon aus
ok ich habe jetzt den 2.15 getestet dann den 2.21 alles ok
also jetzt werde ich den port berreich mal wechseln.
 

bytestar

kennt sich schon aus
also das hier kapier ich auch nit G6 soll jetzt 30000 - 300005 nutzen was für 2 user auf einem ftp vollkommen ausreichen sollte.
Aber da steht was von Port 60038

Trying to connect to bytestar.homeip.net (81.173.130.226):21 ...
220 Gene6 FTP Server v3.0.0 (Build 34) ready...

Connected to remote host "bytestar.homeip.net (81.173.130.226):21"
USER anonymous
331 Password required for anonymous.

PASS test@test.com
230 User anonymous logged in.

Authentication OK
CLNT Testing from http://www.g6ftpserver.com/?page=ftptest via 81.173.130.226
200 Noted.

PWD
257 "/" is current directory.

Current directory is : /
PASV
227 Entering Passive Mode (81,173,130,226,234,134)

LIST
Trying to connect datasocket to 81.173.130.226:60038 ...
Error : Cannot open data connection to 81.173.130.226:60038
Error : Cannot connect to remote host
Error : LIST command failed
 
Zuletzt bearbeitet:

bytestar

kennt sich schon aus
hier der g6 Log so jetzt habe ich keine nerven mehr ich möchte wirklich gern den den g6 nutzen und erwerben aber so kann ich ihn nicht brauchen

04/05/03 16:07:44, starting ...
04/05/03 16:07:44, listens on 192.168.2.100:21
04/05/03 16:07:59, 0, 213.215.47.130, , connected to ip : 213.215.47.130
04/05/03 16:07:59, 0, 213.215.47.130, , sending welcome message.
04/05/03 16:07:59, 0, 213.215.47.130, , 220 Gene6 FTP Server v3.0.0 (Build 34) ready...
04/05/03 16:07:59, 0, 213.215.47.130, , USER anonymous
04/05/03 16:07:59, 0, 213.215.47.130, anonymous, 331 Password required for anonymous.
04/05/03 16:07:59, 0, 213.215.47.130, anonymous, PASS ****
04/05/03 16:07:59, 0, 213.215.47.130, anonymous, logged in.
04/05/03 16:07:59, 0, 213.215.47.130, anonymous, 230 User anonymous logged in.
04/05/03 16:07:59, 0, 213.215.47.130, anonymous, CLNT Testing from http://www.g6ftpserver.com/?page=ftptest via 81.173.130.226
04/05/03 16:07:59, 0, 213.215.47.130, anonymous, 200 Noted.
04/05/03 16:07:59, 0, 213.215.47.130, anonymous, PWD
04/05/03 16:07:59, 0, 213.215.47.130, anonymous, 257 "/" is current directory.
04/05/03 16:07:59, 0, 213.215.47.130, anonymous, PASV
04/05/03 16:07:59, 0, 213.215.47.130, anonymous, 227 Entering Passive Mode (81,173,130,226,117,52)
04/05/03 16:07:59, 0, 213.215.47.130, anonymous, LIST
04/05/03 16:08:29, 0, 213.215.47.130, anonymous, 425 Cannot open data connection.
 

Supernature

Und jetzt?
Teammitglied
Auch wenn's Dir erstmal nicht hilft, sage ich vielen Dank für Deine ausführlichen Tests und Deine Geduld (y)
Und vor allem nochmal Entschuldigung für meine schnippische Bemerkung :friede!

Ich werde das Thema mal an den Entwickler weitertragen und es außerdem nochmals bei mir zu Hause nachvollziehen.
 

bytestar

kennt sich schon aus
Einstellung wie in PM besprochen gemacht leider keine besserung

FTP test seite

Trying to connect to bytestar.homeip.net (81.173.130.226):21 ...
220 Gene6 FTP Server v3.0.0 (Build 34) ready...

Connected to remote host "bytestar.homeip.net (81.173.130.226):21"
USER anonymous
331 Password required for anonymous.

PASS test@test.com
230 User anonymous logged in.

Authentication OK
CLNT Testing from http://www.g6ftpserver.com/?page=ftptest via 81.173.130.226
200 Noted.

PWD
257 "/" is current directory.

Current directory is : /
PASV
227 Entering Passive Mode (81,173,130,226,234,138)

LIST
Trying to connect datasocket to 81.173.130.226:60042 ...
Error : Cannot open data connection to 81.173.130.226:60042
Error : Cannot connect to remote host
Error : LIST command failed

-----------------------------------------------------

G6 V3 Log

04/05/03 17:03:10, starting ...
04/05/03 17:03:10, listens on 192.168.2.100:21
04/05/03 17:03:26, 0, 213.215.47.130, , connected to ip : 213.215.47.130
04/05/03 17:03:26, 0, 213.215.47.130, , Hostname resolved : g6ftpserver.com
04/05/03 17:03:26, 0, 213.215.47.130, , sending welcome message.
04/05/03 17:03:26, 0, 213.215.47.130, , 220 Gene6 FTP Server v3.0.0 (Build 34) ready...
04/05/03 17:03:26, 0, 213.215.47.130, , USER anonymous
04/05/03 17:03:26, 0, 213.215.47.130, anonymous, 331 Password required for anonymous.
04/05/03 17:03:26, 0, 213.215.47.130, anonymous, PASS ****
04/05/03 17:03:26, 0, 213.215.47.130, anonymous, logged in.
04/05/03 17:03:26, 0, 213.215.47.130, anonymous, 230 User anonymous logged in.
04/05/03 17:03:26, 0, 213.215.47.130, anonymous, CLNT Testing from http://www.g6ftpserver.com/?page=ftptest via 81.173.130.226
04/05/03 17:03:26, 0, 213.215.47.130, anonymous, 200 Noted.
04/05/03 17:03:26, 0, 213.215.47.130, anonymous, PWD
04/05/03 17:03:26, 0, 213.215.47.130, anonymous, 257 "/" is current directory.
04/05/03 17:03:26, 0, 213.215.47.130, anonymous, PASV
04/05/03 17:03:26, 0, 213.215.47.130, anonymous, 227 Entering Passive Mode (81,173,130,226,117,49)
04/05/03 17:03:26, 0, 213.215.47.130, anonymous, LIST
04/05/03 17:03:56, 0, 213.215.47.130, anonymous, 425 Cannot open data connection.
04/05/03 17:04:26, 0, 213.215.47.130, anonymous, disconnected. (00d00:01:00)
 

Anhänge

  • g6_3_neue_settings.jpg
    g6_3_neue_settings.jpg
    40,8 KB · Aufrufe: 256

Supernature

Und jetzt?
Teammitglied
Ich habe nun mal lokal mit dem Port-Range 1400-1405 experimentiert - da kam das Kommando "unverfälscht" beim Client an, also scheint der Server es richtig zu machen und den vorgegebenen Range zu verwenden. Ein Tipp, der direkt vom Programmierer Matthieu Roger kommt:
Dein Router scheint das PASV-Kommando zu "übersetzen", das erklärt den abweichenden Port, der beim Client ankommt. Er tut das ja auch richtig, denn es funktioniert ja mit BPFTP 2.x und Serv-U. Der Eintrag unter "Redirect PASV IP" wäre demnach überflüssig. Mach den mal raus und versuche es so.
 
Zuletzt bearbeitet:

bytestar

kennt sich schon aus
So jetzt erstmal ne gute Nachricht die Einstellung ist überflüssig und führte den G6 wohl zur Verwirrung ;)

Aber nun die schlechte der Haupt server muss zwingend auf Port 21 laufen sonst klappt es wieder nit warum ?, bei serv-u und auch den alten 2.er lief es auch wenn der Server auf 2003 oder 2004 läuft.

Nun das Ergebniss des G6 mit der Einstellung Port 21

Trying to connect to bytestar.homeip.net (81.173.135.23):21 ...
220 Gene6 FTP Server v3.0.0 (Build 34) ready...

Connected to remote host "bytestar.homeip.net (81.173.135.23):21"
USER anonymous
331 Password required for anonymous.

PASS test@test.com
230 User anonymous logged in.

Authentication OK
CLNT Testing from http://www.g6ftpserver.com/?page=ftptest via 81.173.135.23
200 Noted.

PWD
257 "/" is current directory.

Current directory is : /
PASV
227 Entering Passive Mode (81,173,135,23,234,122)

LIST
Trying to connect datasocket to 81.173.135.23:60026 ...
150 Data connection accepted from 213.215.47.130:3428; transfer starting.

Datasocket connected to remote host
Directory listing :
-rw-rw-rw- 1 user group 1414080 May 03 15:55 50966.exe
drw-rw-rw- 1 user group 0 Apr 29 12:14 appz
drw-rw-rw- 1 user group 0 Apr 29 18:11 files
drw-rw-rw- 1 user group 0 Apr 29 18:11 mukke
drw-rw-rw- 1 user group 0 Apr 29 11:39 updates
drw-rw-rw- 1 user group 0 Apr 29 16:22 uppload
drw-rw-rw- 1 user group 0 Apr 29 16:22 users
Datasocket disconnected from remote host
226 Transfer ok.

QUIT
Disconnected from remote host

:p klar kann ich den server auf port 21 laufen lassen , aber das möchte ich eigentlich nicht.

Sprechen sie mal mit dem Programierer was das nun wieder sein kann, warum nur port 21 vernünftig geht.
Der Server läuft auf anonymous sie könnnen ihn also mal testen.
 

Supernature

Und jetzt?
Teammitglied
Ich hoffe es wird nicht als unhöflich angesehen, wenn ich einfach beim "Du" bleiben, so ist nun mal die Umgangssprache hier ;)
Es soll nicht wie eine Ausrede klingen, aber es zeigt sich, dass es wohl kein Server-Problem ist. Die Einstellung mit "Redirect PASV IP" wird bei den meisten Routern zwingend gebraucht, denn sie sind nicht so intelligent wie es Deiner offenbar ist. Er "merkt" sich, wo der Befehl aus dem internen Netz her kam und übersetzt die Antwort wieder zurück - das ist perfekt, so sollte es bei allen Routern sein. Wenn G6 nun eine Absender-IP schickt, die nicht aus dem internen Netz stammt, dann findet der Router den "Rückweg" nicht mehr, und es kommt zum Timeout. Ein solcher Fall war mir bisher nicht bekannt, wieder was gelernt :). Weder Server noch Router scheinen hier einen wirklichen Fehler zu haben, es kommt vielmehr darauf an, dass beide Partner richtig aufeinander abgestimmt werden.
Das mit dem "nicht-standard-Port" muss eine ähnliche Ursache haben, denn mein Homeserver läuft auf Port 2121 - mit PASV.
Ich weiß, blöde Frage, aber nur zur Sicherheit: Hast Du denn die Router-Regeln angepasst, bevor Du es nun auf einem anderen Port getestet hast? Denn die ganze Zeit über lief ja nun alles über Port 21.
Das finden wir jetzt bestimmt auch noch raus :)
 

bytestar

kennt sich schon aus
ok bleiben wir bei du ja ich habe soviele port im router offen weil ich sehr viel durchteste, aber ich werde jetzt mal port 2121 testen.

diese Ports sind im Router geöffnet jetzt bist du drann...

Private IP Port Type

192.168.2.100 990 TCP

192.168.2.100 1400 TCP

192.168.2.100 1401 TCP

192.168.2.100 1402 TCP

192.168.2.100 1403 TCP

192.168.2.100 1404 TCP

192.168.2.100 1405 TCP

192.168.2.100 2004 TCP

192.168.2.100 4661 TCP

192.168.2.100 4662 TCP

192.168.2.100 4665 UDP

192.168.2.100 4672 UDP

192.168.2.100 6891 TCP

192.168.2.100 49000 TCP

So jetzt was ganz seltsames also wenn ich den server auf Port 2004 lege
ohne die Einstellung Redirect Pasv IP dann kommt das bei der G6 testseite

Trying to connect to bytestar.homeip.net (81.173.135.23):2004 ...
220 Gene6 FTP Server v3.0.0 (Build 34) ready...

Connected to remote host "bytestar.homeip.net (81.173.135.23):2004"
USER anonymous
331 Password required for anonymous.

PASS test@test.com
230 User anonymous logged in.

Authentication OK
CLNT Testing from http://www.g6ftpserver.com/?page=ftptest via 81.173.135.23
200 Noted.

PWD
257 "/" is current directory.

Current directory is : /
PASV
227 Entering Passive Mode (192,168,2,100,5,121)

LIST
Error : Cannot open data connection to 192.168.2.100:
Error : 192.168.2.100 is a private ip which can not be connected over internet!
Error : check your server settings for passive mode ip!
Error : Cannot connect to remote host
Error : LIST command failed

--------------------------------------------------

So und nun nur Redirect Pasv IP wieder bytestar.homeip.net rein

Trying to connect to bytestar.homeip.net (81.173.135.23):2004 ...
220 Gene6 FTP Server v3.0.0 (Build 34) ready...

Connected to remote host "bytestar.homeip.net (81.173.135.23):2004"
USER anonymous
331 Password required for anonymous.

PASS test@test.com
230 User anonymous logged in.

Authentication OK
CLNT Testing from http://www.g6ftpserver.com/?page=ftptest via 81.173.135.23
200 Noted.

PWD
257 "/" is current directory.

Current directory is : /
PASV
227 Entering Passive Mode (81,173,135,23,5,125)

LIST
Trying to connect datasocket to 81.173.135.23:1405 ...
150 Data connection accepted from 213.215.47.130:4922; transfer starting.

Datasocket connected to remote host
Directory listing :
-rw-rw-rw- 1 user group 1414080 May 03 15:55 50966.exe
drw-rw-rw- 1 user group 0 Apr 29 12:14 appz
drw-rw-rw- 1 user group 0 Apr 29 18:11 files
drw-rw-rw- 1 user group 0 Apr 29 18:11 mukke
drw-rw-rw- 1 user group 0 Apr 29 11:39 updates
drw-rw-rw- 1 user group 0 Apr 29 16:22 uppload
drw-rw-rw- 1 user group 0 Apr 29 16:22 users
Datasocket disconnected from remote host
226 Transfer ok.

QUIT
Disconnected from remote host


So zu guter letzt wenn ich die Einstellung drinn habe kann ich auch den Port 20 und 21 im Router rausnehmen, aber umgekehrt funktioniert der Server auf Port 21 nur wenn in Redirect nix drinn steht Im Router sind 20 und 21 frei ist ja klar.

Nun bitte ich dich auch wenn es jetzt zu klappen scheint bitte mal etwas klarheit zu schaffen.

Gruss Bytestar
 
Zuletzt bearbeitet:

Supernature

Und jetzt?
Teammitglied
Nun wirst Du sicherlich denken, ich versuche mit aller Macht die "Schuld" auf den Router zu schieben, aber in der Tat liegt die Ursache dort.
Den Port 21 erkennt der Router als FTP-Service und übernimmt nun mit seiner einprogrammierten Logik alle Übersetungsfunktionen, daher funktioniert das ohne irgendwelche weiteren Einstellungen. Das ist wie schon erwähnt sehr clever gemacht, da kann man dem Hersteller nur gratulieren.
Es kommt eine Anfrage über Port 21 rein, der Router leitet sie weiter und "weiß", dass nun die Antwort eines FTP-Servers kommt, die er entsprechend behandeln muss. Wird ein anderer Port benutzt, dann hat der Router dafür keine bestimmte Regel, d.h. auch die "Übersetzung" des PASV-Kommandos funktioniert nicht mehr - das erkennst Du gut daran, dass nun auch auf der Client-Seite der selbe Port ankommt, d.h. der Router hat den Befehl einfach nur durchgeleitet - darum wird in diesem Fall auch der Eintrag unter "Redirekt PASV IP" benötigt.
Unabhängig davon, dass G6 mein Lieblings-FTP ist, gehe ich bei derartigen Problemen immer von Problemen mit der Netzwerkumgebung aus. Ein FTP-Server ist ein passives Stück Software, er nimmt Anfragen entgegen und beantwortet sie, da sind die Programme alle gleich.
 

bytestar

kennt sich schon aus
Ist doch alles super wenn mann nur weiss wie danke für deine Hilfe ich sags ja immer , gemeinsam schafft mann einfach mehr.

Danke nochmal ich werde dich weiterempfehlen.
 

Supernature

Und jetzt?
Teammitglied
Ich schau gerade nochmal über den Thread und denke "wow" :eek:
Ende gut, alles gut, hat mir persönlich auch was gebracht, von daher auch danke an Dich.
Auch ohne konkretes Problem darfst Du Dich gerne mal wieder sehen lassen :)
 
Oben