PASV Port mit Router

bytestar

kennt sich schon aus
Hallo an alle,
ich bin neuer Benutzer von G6 ich habe folgende Situation, ich hoffe ihr könnt mir helfen ?

Also ich möchte einen Ftp server hinter meinem Router Level One 1415tx betreiben, da ich Kabel Internet mit 2mbit down / 512kbit upp habe bietet es sich ja auch an.

So nun das Problem der Ftp läuft auf Port 2003 kann aber auch jeder ander sein über 1024 nur nicht Port 21 das will ich nicht.

So am Router sind im Virtual Server folgende Port forwardet.

Rechner Ip 192.168.2.100 - Port 2003 für den Server.

Rechner Ip 192.168.2.100 - Port 1400 - 1415 für PASV

Meine Frage ist nun wenn sich jemmand mit meinem Pc verbindet kommt manchmal auf den Ftp,
aber bekommt keine Dateien zu sehen es kommt Canot open DataConnection 425.
Was ich dann ab und zu sehe ist das der G6 die Router IP 192.168.2.100 an den Client sendet.

Ich habe vorher mit den selben Einstellungen Serv-U 4 und nacher 5 einwandfrei betreiben können,
am Anfang hatte ich das Problem auch mal mit Serv-U dann habe ich im Internet ein Plugin gefunden.
Was mit hilfe meines dydns homeip.net dann bei Pasv meine Internet IP an den Client gesendet hat von da an lief alles super.

Nur leider finde ich diese DLL (Plugin nicht für G6) die Datei bei Serv-U heisst

IPChangr.dll

Sie wird bei Serv-U in die Daemon.ini eingetragen

[EXTERNAL]
EventHookDLL1=IPChange.dll

Eintrag in der IPChange.ini

[GLOBAL]
Logging = on
Logfile = IPChangr_log.txt
DDNS = name.homeip.net
UseIP =

Meine Frage wie bekomme ich es hin das G6 auch mit Roeuter läuft und nicht dem Client ,mein Lan Ip sendet. ? ? ?

Natürlich habe ich die Pasv Ports bei G6 unter Domain \ Secure \ IP binding eingestellt ich habe auch schon probier meinen dyndns dort unter Redirect PASV IP einzutragen, leider keine Änderung festzustellen.

Gruss Bytestar
 

bytestar

kennt sich schon aus
Screenshot:
 

Anhänge

  • g6.jpg
    g6.jpg
    51,3 KB · Aufrufe: 774
Zuletzt bearbeitet von einem Moderator:

Supernature

Und jetzt?
Teammitglied
Ich hab den Screenshot mal hier rüber gezogen, damit es übersichtlich bleibt :)

Neue Version , alte Probleme könnte man da sagen.
Kannst Du mal aus dem Logfile eine Beispielzeile kopieren, in der "Entering passive Mode" vorkommt?

Von den Einstellungen her sieht eigentlich alles ok aus. Ich kann mir nur vorstellen, dass der Hostname aus irgendeinem Grund nicht aufgelöst werden kann und stattdessen die LAN-IP verwendet wird.
 

bytestar

kennt sich schon aus
04/04/30 20:22:09, 12, 84.128.182.18, , connected to ip : 84.128.182.18
04/04/30 20:22:09, 12, 84.128.182.18, , Hostname resolved : p5480B612.dip.t-dialin.net
04/04/30 20:22:09, 12, 84.128.182.18, , sending welcome message.
04/04/30 20:22:09, 12, 84.128.182.18, , 220 Gene6 FTP Server v3.0.0 (Build 34) ready...
04/04/30 20:22:09, 12, 84.128.182.18, , USER ieXglurak
04/04/30 20:22:09, 12, 84.128.182.18, ieXglurak, 331 Password required for ieXglurak.
04/04/30 20:22:09, 12, 84.128.182.18, ieXglurak, PASS ****
04/04/30 20:22:09, 12, 84.128.182.18, ieXglurak, logged in.
04/04/30 20:22:09, 12, 84.128.182.18, ieXglurak, 230 User ieXglurak logged in.
04/04/30 20:22:09, 12, 84.128.182.18, ieXglurak, SYST
04/04/30 20:22:09, 12, 84.128.182.18, ieXglurak, 200 Noted.
04/04/30 20:22:09, 12, 84.128.182.18, ieXglurak, PWD
04/04/30 20:22:09, 12, 84.128.182.18, ieXglurak, 257 "/" is current directory.
04/04/30 20:22:09, 12, 84.128.182.18, ieXglurak, TYPE A
04/04/30 20:22:09, 12, 84.128.182.18, ieXglurak, 200 Type set to A.
04/04/30 20:22:09, 12, 84.128.182.18, ieXglurak, PORT 192,168,0,2,9,83
04/04/30 20:22:09, 12, 84.128.182.18, ieXglurak, 200 Port command successful.
04/04/30 20:22:10, 12, 84.128.182.18, ieXglurak, LIST -al
04/04/30 20:22:31, 12, 84.128.182.18, ieXglurak, 425 Cannot open data connection.
04/04/30 20:22:31, 12, 84.128.182.18, ieXglurak, QUIT
04/04/30 20:22:31, 12, 84.128.182.18, ieXglurak, 221 Goodbye.
04/04/30 20:22:31, 12, 84.128.182.18, ieXglurak, disconnected. (00d00:00:23)
 
Zuletzt bearbeitet:

Supernature

Und jetzt?
Teammitglied
Wie man sieht, sendet der Client das PORT-Kommando
Die darin enthaltene IP stammt vom Client, nicht vom Server. Der Client muss im passive Mode arbeiten und das Kommando "PASV" senden, nur dann sieht man, ob es funktioniert.
Und Du darfst es nicht aus dem eigenen Netz heraus versuchen, sondern musst einen externen Tester haben.
Oder teste es über diese Seite:
http://g6ftpserver.com/?page=ftptest&lang=en
 

bytestar

kennt sich schon aus
Oder teste es über diese Seite:
http://g6ftpserver.com/?page=ftptest&lang=en [/B][/QUOTE]

ich hatte zwar mit einem freund aus der ferne getestet

aber hier das ergebnis von der G6 Test Seite

Trying to connect to 81.173.130.226 (81.173.130.226):21 ...
220 Gene6 FTP Server v3.0.0 (Build 34) ready...

Connected to remote host "81.173.130.226 (81.173.130.226):21"
USER anonymous
331 Password required for anonymous.

PASS test@test.com
230 User anonymous logged in.

Authentication OK
CLNT Testing from http://www.g6ftpserver.com/?page=ftptest via 81.173.130.226
200 Noted.

PWD
257 "/" is current directory.

Current directory is : /
PASV
501 Please try again later.

Error : PASV command failed
 

bytestar

kennt sich schon aus
bei dem klasse programm bleibe ich lieber bei serv-u

so sieht es aus wenn ein programm genau so arbeitet wie eingestellt ist

Saturday, May 01, 2004 - 19:19:00

Trying to connect to 81.173.130.226 (81.173.130.226):2003 ...
220-Serv-U FTP Server v5.0 für WinSock bereit...

Connected to remote host "81.173.130.226 (81.173.130.226):2003"
USER - - -
331 Benutzername okay, benötigt Passwort.

PASS - - -
230-.Û²----Û²-------[ ByteStar`s + Air`s FTP Server ]----Û²----Û²------.
230 Benutzer wird verbunden, fortsetzen.

Authentication OK
CLNT Testing from http://www.g6ftpserver.com/?page=ftptest via 81.173.130.226
200 Bekannt.

PWD
257 "/" ist aktuelles Verzeichnis.

Current directory is : /
PASV
227 Passive Modus einfügen (81,173,130,226,5,123)

LIST
Trying to connect datasocket to 81.173.130.226:1403 ...
150 Eröffnung ASCII Modus Datenverbindung für /bin/ls.

Datasocket connected to remote host
Directory listing :
dr--r--r-- 1 user group 0 Apr 30 12:47 .
dr--r--r-- 1 user group 0 Apr 30 12:47 ..
drw-rw-rw- 1 user group 0 Apr 30 12:47 custom
Datasocket disconnected from remote host
226 Übertragung komplett.

QUIT
Disconnected from remote host
 

Supernature

Und jetzt?
Teammitglied
Original geschrieben von bytestar
bei dem klasse programm bleibe ich lieber bei serv-u

Na dann weiterhin viel Spass damit :)
Das Programm kann aber nichts dafür, wenn dem Anwender die Zusammenhänge nicht klar sind.
 

bytestar

kennt sich schon aus
das kann ich so leider nicht stehen lassen, g6 scheint nicht die ports zu nutzen die mann ihm vorgibt warum auch immer warum läuft dann serv-u einwandfrei mit der selben konfiguration sogar mit ssl wenn es gewünscht ist... ? ? ?
Ich lasse mich nicht gern als Depp darstellen, das Problem mit der Router verbindung haben komischerweise jetzt schon einige nur das sie sich an anderer Stelle Rat suchen warum auch immer.
 

Supernature

Und jetzt?
Teammitglied
Sorry, natürlich wollte ich Dich nicht als Deppen hinstellen. Mir ist es persönlich völlig wurscht, ob Du Serv-U oder G6 verwendest. Wenn Du mit Serv-U besser zurecht kommst, dann ist es das bessere Programm für Dich.
Bei mir nutzt G6 die passive-Ports richtig, und ich helfe Dir auch gerne herauszufinden, woran es bei Dir liegt, aber bis jetzt hast Du dafür noch kein brauchbares Beispiel geliefert. Im ersten LOG-Auszug verwendet der Client "PORT" statt "PASV", und bei dem zweiten Testauszug fehlt die entscheidende Zeile "entering passive Mode....." aus dem Server-Log - denn nur mit dem kann man nachprüfen, ob die richtigen Ports genutzt werden.
 

bytestar

kennt sich schon aus
Ok also g6 installiert User eingerichtet

im Router die port eingestellt siehe hier ...
 

Anhänge

  • roeuter_ports_virtual_server.jpg
    roeuter_ports_virtual_server.jpg
    47,2 KB · Aufrufe: 1.034

bytestar

kennt sich schon aus
Was sollte ich den noch einstellen , oder sogar müssen ich wüsste nix !

So sieht der Log von der Testseite aus...

04/05/03 14:13:55, starting ...
04/05/03 14:13:55, listens on 192.168.2.100:21
04/05/03 14:14:13, 0, 213.215.47.130, , connected to ip : 213.215.47.130
04/05/03 14:14:13, 0, 213.215.47.130, , sending welcome message.
04/05/03 14:14:13, 0, 213.215.47.130, , 220 Gene6 FTP Server v3.0.0 (Build 34) ready...
04/05/03 14:14:13, 0, 213.215.47.130, , USER anonymous
04/05/03 14:14:13, 0, 213.215.47.130, anonymous, 331 Password required for anonymous.
04/05/03 14:14:14, 0, 213.215.47.130, anonymous, PASS ****
04/05/03 14:14:14, 0, 213.215.47.130, anonymous, logged in.
04/05/03 14:14:14, 0, 213.215.47.130, anonymous, 230 User anonymous logged in.
04/05/03 14:14:14, 0, 213.215.47.130, anonymous, CLNT Testing from http://www.g6ftpserver.com/?page=ftptest via 81.173.130.226
04/05/03 14:14:14, 0, 213.215.47.130, anonymous, 200 Noted.
04/05/03 14:14:14, 0, 213.215.47.130, anonymous, PWD
04/05/03 14:14:14, 0, 213.215.47.130, anonymous, 257 "/" is current directory.
04/05/03 14:14:14, 0, 213.215.47.130, anonymous, PASV
04/05/03 14:14:14, 0, 213.215.47.130, anonymous, 227 Entering Passive Mode (81,173,130,226,5,124)
04/05/03 14:14:14, 0, 213.215.47.130, anonymous, LIST
04/05/03 14:14:44, 0, 213.215.47.130, anonymous, 425 Cannot open data connection.
04/05/03 14:15:14, 0, 213.215.47.130, anonymous, disconnected. (00d00:01:01)
 

bytestar

kennt sich schon aus
Das log von G6 server

das log von G6 Testseite

Trying to connect to bytestar.homeip.net (81.173.130.226):21 ...
220 Gene6 FTP Server v3.0.0 (Build 34) ready...

Connected to remote host "bytestar.homeip.net (81.173.130.226):21"
USER anonymous
331 Password required for anonymous.

PASS test@test.com
230 User anonymous logged in.

Authentication OK
CLNT Testing from http://www.g6ftpserver.com/?page=ftptest via 81.173.130.226
200 Noted.

PWD
257 "/" is current directory.

Current directory is : /
PASV
227 Entering Passive Mode (81,173,130,226,234,108)

LIST
Trying to connect datasocket to 81.173.130.226:60012 ...
Error : Cannot open data connection to 81.173.130.226:60012
Error : Cannot connect to remote host
Error : LIST command failed
 

Supernature

Und jetzt?
Teammitglied
Aus dieser Zeile
04/05/03 14:14:14, 0, 213.215.47.130, anonymous, 227 Entering Passive Mode (81,173,130,226,5,124)
kann man den verwendeten Port errechnen, und zwar anhand der letzten beiden Zahlen in der Klammer:
vorletzte Zahl x 256 + letzte Zahl, in diesem Fall also 5 x 256 + 124 = 1404
So "verlässt" der Befehl den Server, bis hierhin stimmt es noch mit dem vorgegebenen Portrange überein.
Dann wird es interessant, denn beim Client kommt dann was ganz anderes an:
227 Entering Passive Mode (81,173,130,226,234,108)
Wir rechnen wieder den Port aus: 234 x 256 + 108 = 60012
Das passt nicht zusammen und kann somit auch nicht funktionieren.
Fest steht aber, dass der Server den Befehl korrekt absendet, mehr kann er nicht tun.
Wenn beim Client etwas Anderes ankommt, dann sieht das nach einem NAT-Fehler aus. Du hast die PASV-Ports im Router auf TCP gestellt, das müsste UDP sein. Das kann aber eigentlich nicht die Ursache sein.
Versuche mal eine lokale Verbindung mit PASV, ich bin sicher, dann wird es funktionieren. Benutzt Du mit Serv-U den selben Portrange?
Falls ja, dann ist es wirklich merkwürdig. Dann müsste man fast annehmen, dass der Server laut seinem eigenen LOG zwar den richtigen Range benutzt, tatsächlich aber andere Kommandos abschickt. Kann ich mir kaum vorstellen, aber man soll ja nie nie sagen :D
 

bytestar

kennt sich schon aus
So hier der test log von G6 test seite

ja die Port Range ist absolut gleich

Trying to connect to bytestar.homeip.net (81.173.130.226):21 ...
220-Serv-U FTP Server v5.0 für WinSock bereit...
220

Connected to remote host "bytestar.homeip.net (81.173.130.226):21"
USER anonymous
331 Benutzername okay, bitte sende komplette E-mail Adresse als Passwort.

PASS test@test.com
230 Benutzer wird verbunden, fortsetzen.

Authentication OK
CLNT Testing from http://www.g6ftpserver.com/?page=ftptest via 81.173.130.226
200 Bekannt.

PWD
257 "/" ist aktuelles Verzeichnis.

Current directory is : /
PASV
227 Passive Modus einfügen (81,173,130,226,5,120)

LIST
Trying to connect datasocket to 81.173.130.226:1400 ...
150 Eröffnung ASCII Modus Datenverbindung für /bin/ls.

Datasocket connected to remote host
Directory listing :
drw-rw-rw- 1 user group 0 Apr 29 14:14 .
drw-rw-rw- 1 user group 0 Apr 29 14:14 ..
drw-rw-rw- 1 user group 0 Apr 29 14:14 appz
drw-rw-rw- 1 user group 0 Apr 29 20:11 files
drw-rw-rw- 1 user group 0 Apr 29 20:11 mukke
drw-rw-rw- 1 user group 0 Apr 29 13:39 updates
drw-rw-rw- 1 user group 0 Apr 29 18:22 uppload
drw-rw-rw- 1 user group 0 Apr 29 18:22 users
Datasocket disconnected from remote host
226 Übertragung komplett.

QUIT
Disconnected from remote host
 

Supernature

Und jetzt?
Teammitglied
Und das Programm lief auch nicht zur selben Zeit, nehme ich mal an. Möglicherweise. Denkbar wären noch irgendwelche Socket-Errors, sozusagen "Überbleibsel" vorheriger Verbindungen - entweder auf Deinem PC oder im Router.
Falls Du noch Nerven hast ;), versuche mal einen anderen Range in G6.
 

bytestar

kennt sich schon aus
Also bei Serv-u ist es so egal wie oft ich den test wiederhole die Ports werden immer wie eingestellt von 1400 - 1405 genutzt
 
Oben