Nach Windows 10 Update, USB Ports kein Strom

canehoyer

treuer Stammgast
Hallo,

bin schon ne ganze Weile am suchen, aber die Lösung habe ich leider bisher nicht gefunden.

Mein Problem:

Nach dem Update von Win 8.1 auf Win 10, haben meine USB Ports teilweise keinen Strom mehr.
D.h. die Ports, an der Frontseite des Rechners (USB 2.0 und 3.0), funktionieren einwandfrei.
die USB Ports des Motherboards, an der Rückseite allerdings liefern keinen Strom.
D.h. USB Sticks und USB Festplatten mit externer Stromversorgung funktionieren an diesen Ports einwandfrei.
Aber wenn ich z.B. Tastatur oder Maus an diese USB Ports anschließen möchte, dann sind die tot. Also scheint kein Strom über diese Ports zu kommen.

Ich habe gerade mal die Chiptreiber des Mobos aktualisiert. Aber auch danach funktioniert es leider nicht.

Hat jemand eine Idee, woran das liegen mag? Kann das eine BIOS Einstellung sein?
Unter Win 8.1 liefen alle Ports ganz normal, erst nach dem Update funktionieren die Ports am Mobo nicht, die zusätzlichen Ports an der PC Frontseite funktionieren allerdings.


Meine Config:

I7 4770 K
ASUS Z87 - PLUS
RAM 32 GB
Windows 10 Pro
 

canehoyer

treuer Stammgast
Ist das nicht eher ein Windows 7 Handicap?
Bei Windows 10 sollten die USB 3.0 Controller Treiber doch vorhanden sein.
 

Bullabeisser

assimiliert
Dein Board hat ein UEFI-BIOS. Bei denen müssen schon ohne Betriebssystem alle USB-Ports versorgt werden - wie sonst soll ne USB-Maus bzw. Tastatur im UEFI funktionieren?? Haste da was "zerbügelt" ??Zumindest lohnt ein Blick ins UEFI. Dort lassen sich in der Regel die USB-Ports "schalten". Und denk dran, dass die "normalen" USB-Ports max. 500 mA liefern, was für HDD's oft nicht reicht. Tastatur und Maus reicht das aber aus.
 

canehoyer

treuer Stammgast
Ja da hast Du Recht, habe ich gar nicht bedacht.

Aber ich muss mal einen Nachtrag machen, denn mir ist etwas aufgefallen.

Es liegt nicht an der Stromversorgung, sondern es werden nur USB 3.0 Geräte unterstützt.
Der USB Stick, den ich getestet hat, ist USB 3.0 und funktioniert. Ein andrer Stick mit USB 2.0 wird nicht erkannt.

Es geht aber nur um die USB Ports an der Rückseite, die des Mobo also. Die USB Ports an der Front des Rechners
funktionieren für USB 2.0 und 3.0 einwandfrei.

Ist das denn nun eine Einstellung im UEFI? Windows kann doch damit eigentlich nichts zu tun haben.
Im UEFI hatte ich aber nie Änderungen vorgenommen. Kann auch aktuell keine Einstellungen finden, die irgendwie falsch aussehen.
Alles USB Ports sind aktiviert und der USB Legacy Support ist enabled.
 

canehoyer

treuer Stammgast
Also die dort beschriebene Lösung "USB Legacy Unterstützung" deaktivieren, habe ich auch schon probiert.
Dabei ist es egal, ob die auf aktiviert, auto oder deaktiviert steht.
 

Techy

Kulturbanause!
Teammitglied
Hier dasselbe Problem, leider auch ohne konkreten Lösungsansatz für uns.
3DCenter Forum - Win 7 x64 - nach Hardwareupgrade: Maus und Tastatur schalten sich ab! (Windows-Installationsmenü)

Interessant wäre aber noch der Punkt, wie ist bei dir im UEFI die Option für "Intel xHCI Mode" gesetzt?
SMART auto, Enabled oder auto?

Intel xHCI Mode [Smart Auto]
[Auto] Behält die letzte Ausführung des xHCI-Controllers während des Bootens im
Betriebssystem.
[Smart Auto] Aktiviert den Betrieb des xHCI-Controllers.
[Enabled] Aktiviert diese Funktion.
[Disabled] Deaktiviert diese Funktion.


Damit wird der USB3 Betriebsmodus geregelt, ggf mal zwischen Auto u. Smart Auto umschalten.
(Auch wenn du vor dem Upgrade nichts daran geändert hast, ggf. treten hier nun mit Windows 10 und den Treibern Probleme damit auf).
 

canehoyer

treuer Stammgast
Da ich nicht so recht wusste, was der xHCI regelt, habe ich da lieber nichts dran verändert.
Steht auf [Smart Auto].

Kann da was passieren, wenn ich daran etwas verändere?
 

Techy

Kulturbanause!
Teammitglied
Die Einstellung regelt den USB3 Betriebsmodus der USB Ports ((Auto) an,(smart auto) an, aus).

Wenn du dort etwas daran veränderst kann folgendes eintreten, während die Option gesetzt ist:
- USB3 funktioniert nicht mehr solange xhci auf disabled steht, dafür sollte USB2 auf jeden Fall funktionieren
- USB3 funktioniert problemlos solange xhci auf enabled, smart auto, auto steht
- USB2/3 funktioniert problemlos solange xhci auf smart auto, auto steht

In jedem Fall kannst du den Werkszustand wieder herstellen, wenn du die Option auf "smart auto" zurückstellst.

Die Einzige Einstellung die man hier probieren könnte, wäre Auto.
Alles Andere ist für unseren Einsatzzweck nicht zielführend, denn wir wollen ja USB3 UND USB2 verwenden...


Allerdings erwarte ich auch nicht zuviel von diesem Versuch, denn auch auf "Auto" schalten die USB3 Ports auf den reinen USB3 Betriebsmodus um, sobald das Betriebssystem die zugehörigen Treiber geladen hat.

Smart Auto bedeutet nur, dass die Ports die während des Betriebssystems auf USB3 liefen, auch während der Bootphase auf USB3 aktiv sind.
Auto bedeutet, dass die Ports während der Bootphase auf USB3 laufen und anschließend beim Laden des USB3 Treibers im Betriebssystem auf USB3 wechseln.
Enabled bedeutet, dass alle USB3 Ports immer auf USB3 laufen und im Betriebssystem die USB3 Treiber benötigen.

Um ehrlich zu sein, eine konkrete Idee habe ich nicht, stocher hier auch nur im Nebel.
 

canehoyer

treuer Stammgast
Problem gelöst!!! :)

Dachte mir, bevor ich weiter herum murkse, ruf ich einfach mal beim ASUS Support an.
Der hat mir dann gesagt, dass die betroffenen USB Ports einen ASMedia Controller haben, während die anderen Intels sind.
Okay, Problemlösung hatte er nicht, da fürs Board für Windows 10 keine separaten USB Treiber, sondern nur die Intel Chipset Treiber und die ASUS MEI Treiber verfügbar sind.
Die hatte ich ja bereits erfolglos installiert.

Also gab er mir den Tipp. mal die USB Treiber von Windows 8.1 zu versuchen, die gibts nämlich noch separat.
Und siehe da, es läuft!!!

Wer sagt denn, dass der Support nicht auch wirklich mal helfen kann.

Trotzdem vielen Dank für Eure Hilfe und Erläuterungen.
 

canehoyer

treuer Stammgast
Kleiner Nachtrag:

Positiver Sideeffekt des Ganzen ist, dass der Windows 10 Login nun nicht mehr 20 sek dauert, sondern nicht mal 1 Sekunde!
Gibt genügend Leute, die trotz Clean Install Probleme ahben mit der langen Login Zeit bei Windows 10. Vielleicht funzen da auch ein paar Treiber nicht richtig. ;)
 
Oben