[Multimedia] Kann der Linux-MPlayer auch DivX und wmv?

Supernature

Und jetzt?
Teammitglied
Kann der Linux-MPlayer auch DivX und wmv?

Der neue MPlayer gefällt mir ganz gut und funktioniert auch hervorragend. Kann ich dem auch "beibringen", DivX-Avi's und wmv-Dateien abzuspielen?
Oder gibt es dafür andere Lösungen ?
 

--RAVEN--

dem Board verfallen
Kann er normalerweise. Nur die komische Version von SuSE kann es nicht. Er spielt alles ab, wenn er richtig eingerichtet ist. Ich setze mich da heute Abend mal dran und schreibe was dazu...
 

--RAVEN--

dem Board verfallen
Wie versprochen: Eine Anleitung um den MPlayer zu "kurieren"

Nun geht es los:

Mit Yast:
GTK installieren (alles was nach GTK und Develop aussieht),
make installieren
gcc installieren
gcc-c++ installieren
binutils installieren

Auf http://www.mplayerhq.hu/homepage/dload.html folgendes runterladen:

MPlayer v0.90pre8 source
Win32 codecs
Default Skin
Fonts & symbols package for OSD (ISO 8859-1)

Die Win32-Codecs entpacken, ein Textfensterchen in dem Verzeichnis öffnen,
"su" (wie SuperUser) eingeben, Root-Passwort. Dann "mv * /usr/lib/win32"
um die Dateien in das Verzeichnis zu verschieben. Unter Suse existiert es
zwar, ist aber leer, warum auch immer...

Nun im Home-Verzeichnis den Inhalt des (unsichtbaren) Verzeichnisses ".mplayer" löschen. Einen Ordner "Skin" in ".mplayer" anlegen, das "Default Skin"-Packet da hinein entpacken. Dabei wird der Ordner "Skin/Default" angelegt.

Für den Zeichensatz: In ".mplayer" das Verzeichnis "Font" anlegen und die ZIP-Datei da rein entpacken (legt einige Unter-Ordner an). Den Inhalt eines dieser Unterordner zum einen nach /.mplayer/font/ kopieren und zum anderen nach /usr/local/share/mplayer/font kopieren. Z.B. wenn man sich im Fontverzeichnis /arial-18/ befindet mittels cp * /usr/local/share/mplayer/font Man muss sich im Superuser-Modus befinden, da man sonst keine Schreibrecht auf /usr/... hat.

Nun die Mplayer-Datei in ein temporäres Verzeichnis entpacken. Dort ein Konsolenfenster öffnen, wieder in der SuperUser-Modus wechseln (mit su) und "./configure --enable-gui" eingeben. Das geht relativ flott.

Wenn keine Fehlermeldung erscheint, "make" zum kompilieren eingeben, ein paar Minuten (mehr ;)) warten, und schließlich "make install" zum installieren.

Die Fehlermeldungen geben in der Regel einen guten Aufschluß darüber, welche Programme noch fehlen. Falls es eine Fehlermeldung gibt, auf jeden Fall hier posten, damit anderen das von vorneherein nicht passiert. Es kann natürlich sein das ich etwas installiert habe, was MPlayer benötigt, aber nicht mit der Standard-Installation kommt, da ich bei der Installation von Suse gleich alles ausgesucht habe was ich so benötige...

Nebenbei: Jetzt haben wir die aktuellste Version des MPlayers und den noch auf den jeweiligen Prozessor optimiert, also wesentlich perfomanter, da auch MMX, MMX2, 3Dnow, SSE usw... genutzt wird.

Edit: kleinen Fehler mit dem Font behoben. Wenn man ihn nicht nach /usr/local/share/mplayer/font/ kopiert kommt bei mir mit bei jedem Start von MPlayer eine Fehlermeldung.

Frohes Movies schauen :D Ich hoffe bei euch klappt es nun auch mit dem MPlayer unter SuSE 8.1.
 
Zuletzt bearbeitet:

Supernature

Und jetzt?
Teammitglied
Ich sag schon mal ein ganz fettes Danke - werde leider vor dem Wochenende nicht mehr dazu kommen, aber wenn Du sagst so geht es, dann glaube ich das :bier
 
K

knallzapzerap

Gast
Fehlermeldung

ich habe leider eine Fehlermeldung erhalten.

Error: PNG support required for GUI compilation, please install libpng or libpng-dev packages.

ich habe libpng-dev nachinstalliert, libpng war installiert.
Obwohl ich nachinstalliert habe erhalte ich die Fehlermeldung weiterhin :(
 

--RAVEN--

dem Board verfallen
Was noch benötigt wird wäre: libjpeg

Lösche mal dein temporäres Kompilierverzeichnis und entpacke MPlayer neu da hinein um es nochmal sauber von vorne anzufangen. Nicht vergessen als root einzulogen! ;)
 
K

knallzapzerap

Gast
libjpeg war installiert.
neu entpacken habe ich ebenfalls probiert.
Ich poste mal die Fehlermeldung png betreffend aus der log-Datei

============ Checking for PNG support ============

#include <png.h>
#include <string.h>
int main(void) {
printf("png.h : %s\n", PNG_LIBPNG_VER_STRING);
printf("libpng: %s\n", png_libpng_ver);
return (strcmp(PNG_LIBPNG_VER_STRING, png_libpng_ver));
}

gcc /tmp/mplayer-conf-19141-12071.c -o /tmp/mplayer-conf-29262-12071.o -lpng -lz -lm
In file included from /tmp/mplayer-conf-19141-12071.c:1:
/usr/include/png.h:324:18: zlib.h: Datei oder Verzeichnis nicht gefunden
In file included from /usr/include/png.h:327,
from /tmp/mplayer-conf-19141-12071.c:1:
/usr/include/pngconf.h:1103: parse error before '*' token
/usr/include/pngconf.h:1104: parse error before '*' token
/usr/include/pngconf.h:1105: parse error before '*' token
In file included from /tmp/mplayer-conf-19141-12071.c:1:
/usr/include/png.h:1040: parse error before "z_stream"
/usr/include/png.h:1278: parse error before '}' token

ldd /tmp/mplayer-conf-29262-12071.o
ldd: /tmp/mplayer-conf-29262-12071.o: Datei oder Verzeichnis nicht gefunden

Result is: no

/usr/include/png.h ist als Link auf libpng12/png.h vorhanden
genauso wie die pngconf.h auf /libpng12/pngconf.h verweisst
 

--RAVEN--

dem Board verfallen
Sorry, so spontan fällt mir dazu leider keine Patent-Lösung ein.
Was du aber noch ausprobieren könntest wäre die libpng und libpng-dev nochmal drüber zu installieren. Irgendetwas scheint mit den beiden Dateien nicht zu stimmen, vielleicht ist bei der vorigen Installation was schief gelaufen. Er hat wohl offensichtlich Probleme damit die Header-Dateien zu parsen.
 
K

knallzapzerap

Gast
Habe nach alter Windowsmanier das komplette System neu installiert, leider habe ich den gleichen Fehler weiterhin :(
 

--RAVEN--

dem Board verfallen
Das wäre wohl nicht nötig gewesen, die Pakete nochmal zu installieren hätte genügt.
In einem anderen Forum hat jemand auf meinen Beitrag gepostet, das es bei ihm genügt hat, die Win32-Codecs in /usr/lib/win32 zu kopieren. Vielleicht reicht das bei dir auch? Ist dann zwar nicht die aktuellste Version, die geben sich aber sowieso nicht soviel. Hauptsache es funktioniert.
 

Supernature

Und jetzt?
Teammitglied
Yeeeeeeeehaaaaaaa!!!!

Sorry, das musste raus - ich hab es tatsächich hinbekommen.
Als kleine Ergänzung: Das Problem "PNG support required for GUI compilation, please install libpng or libpng-dev packages" hatte ich auch, und nachdem ich nicht rausfinden konnte, welche Dev-Pakete mir fehlen, hab ich einfach mit Yast die ganze Rubrik "Entwicklung (erweitert)" installiert. Nun hab ich wohl viel auf der Platte, das ich niemals brauche, aber die ist erstens groß genug und zweitens war die Fehlermeldung dann weg.
Nun gibt der Mplayer auch DivX-Avi's, asf- und wmv-Dateien einwandfrei wieder, und ich hab unter Linux, was ich unter Windows nie geschafft habe: Einen tollen Player mit prima Funktionien für alle Formate.
 

Supernature

Und jetzt?
Teammitglied
Inzwischen hat übrigens auch SuSE gemerkt, dass der mitgelieferte MPlayer so nichts taugt. In der Supportdatenbank erklären sie sogar, warum das so ist und wie man das abstellt :)
http://sdb.suse.de/sdb/de/html/mplayer.html
Nachvollzogen habe ich die Anleitung nicht, diese hier von Raven finde ich ohnehin besser.
 

Hans- Peter

dem Board verfallen
Vieeel einfacher :)

Ich habe die Codecs nach /usr/lib/win32 kopiert und die im Verzeichnis bereits vorhandene md5sum* gelöscht, weil ich mir nicht erklären konnte, wozu die gut sein soll, seit dem spielt der mplayer alles ab. :D
 

MaFa

Herzlich willkommen!
Hallo Liste,

erst mal danke für die Anleitung zum Mplayer :)

Und da hab ich aber noch ein Problem ....
Mein SVCD rip wird mir zusammengestaucht angezeigt
ich kann keinen Einfluss über Aspect/Ratio auf das Bild nehmen,
nur das Fenster vergrössert oder verleinert sich.
Das eigentliche Bild wird nicht beeinflusst.

Hiiilfääää :cry:

Kann mir dazu bitte jemand von euch helfen ??

Vielen Dank schon im vorraus
und beste Grüße aus N-I bei FFM ;)
 
Zuletzt bearbeitet:

--RAVEN--

dem Board verfallen
Du kannst die Aspect Ratio die mplayer verwenden soll mit dem Parameter -aspect angeben, also beispielsweise:

gmplayer -aspect 16:9 IrgendeinFilm.avi
 

MaFa

Herzlich willkommen!
Hallo Raven,

also ich habe das mal versucht und da bekomme ich eine Fehlermeldung,

"file format is not recognized/supported" :rolleyes:

nun habe ich über die GUI play SVCD gewählt und da spielt er mir die CD,
aber wie gehabt (da erkennt er aber mein mpeg stream :confused )

Der video decoder [mpegpes] in der console wird mit 480x576 inizialiesiert
bricht aber ab ....

dann wird zum schluss codec [mpeg12] gestartet und der macht mir dieses Bild.

kurze System info:
Toshiba Tecra 8100 / Suse 8.2
Mplayer 0.91

Beste Grüße

MaFa
 

Judge_Cobba

Erster Beitrag
Hi,
danke schonmal für eure überaus gelungene Anleitung.
Ich hab das alles so gemacht wie es da steht und kann auch über die Console jeden Film ohne Probleme starten,
ich hätte aber gerne dieses Steuerungsmodul (weiss jetzt keine treffendere Bezeichnung dafür).
Kann mir jemand sagen wie ich das bekomme?
Ich kann den Mplayer auch nicht einfach so starten mit: mplayer...da bekomme ich dann folgende Fehlermeldung:
"mplayer: error while loading shared libraries: liblzo.so.1: cannot open shared object file: No such file or directory"

Fänd es sau cool, wenn ihr mir helfen könntet. Und sorry schonmal im Vorraus, falls es dazu schon einen Thread gibt.

Gruss Cobba
 

--RAVEN--

dem Board verfallen
Wenn du nach Anleitung vorgegangen bist, dann müsstest du die grafische Oberfläche bereits installiert haben. Gib einfach mal gmplayer in der Konsole ein.

Ich kann den Mplayer auch nicht einfach so starten mit: mplayer...
Wie meinst du das? Wie startest du ihn anderst?

@MaFa:
Hast du auch mal eine andere SVCD ausprobiert?
 
Oben