MP3-Player wird am USB nicht mehr erkannt

unsteady

gehört zum Inventar
Warum kann eigentlich nie was bleiben wie es ist ? :(

Wohlmeinende Leute haben mir einen MP3-Player geschenkt; meinen vormaligen hatte ich erdrückt.



Diesen Dingern gemeinsam ist, daß die Anzeige (Schrift) immer zu klein ist für meine großen Augen.

So habe ich dann auch nicht genau erkannt, was da (auf dessen Display) grad angezeigt wurde, als ich ihn das erste Mal an den USB-Anschluß am PC einstöpselte.
Es 'pingte', und er wurde mir auch gleich als Wechseldatenträger im Dateimanager angezeigt.
Danach installierten sich (dennoch) erst wieder einige Windows-Treiber; die mitgelieferte Treiber-CD sei nur erforderlich, wenn Win98 oder 2000 benützt würden.

Irgendwas stand da noch von: "Wenn sie USB 2.0 verwenden [i.S.v.: würden], wäre die Datenübertragungsgeschwindigkeit eine höhere ... "

Dann mußte sich dieses Ding aber erstmal aufladen. Bzw. wurde das von mir verlangt, daß ich es täte.
Mußte dazu erst noch bissel dran herumschalten, bis ich das gefunden hatte.

Nun ist er aufgeladen - und ich will was drauf überspielen -, und nun 'pingt' es aber nicht mehr, wenn ich ihn einstecke.
Egal, ob eingeschaltet (das Dingens) oder aus. (Beim ersten Einstecken war er wohl sogar aus gewesen und wurde dennoch angezeigt.)

Der Gerätemanager zeigt mir jetzt einen Wust von USB-Installationen; sämtlich mehrfach gelistet:

USB-Controller
- Standard erweiterte PCI-zu-USB universeller Hostcontroller
- Standard erweiteret PCI-zu-USB universeller Hostcontroller
- Standard OpenHCD USB- Hostcontroller
- Standard OpenHCD USB- Hostcontroller
- Standard OpenHCD USB- Hostcontroller
- Standard OpenHCD USB- Hostcontroller
- Standard OpenHCD USB- Hostcontroller
- USB-Massenspeichergerät
- USB-Root-Hub
- USB-Root-Hub
- USB-Root-Hub
- USB-Root-Hub
- USB-Root-Hub
- USB-Root-Hub
- USB-Root-Hub

Unter "Hardware sicher entfernen" (Systray), wenn man das anklickt, ist nun lediglich und völlig nichtssagend als einzige vorgebliche Option "Hardware sicher entfernen" angezeigt.
Natürlich ohne, daß irgendwas daraufhin passiert.

Dann wollte ich gerade "Vorher stand dort mindestens (u.a.) 'Massenspeichergerät entfernen' ... " wollte ich gerade schreiben, als ich es noch mal anklickte, um sicherzugehen ...
Steckte also noch mal wieder ein, es 'pingte' NICHTS, und plötzlich stand da nun doch jetzt wieder "Massenspeichergerät entfernen".
Dies tat ich dann ...
... und endlich ist nun auch die ganze Option (Ikon) aus dem Systray verschwunden ...
Ohne daß ich irgendwas sonst gemacht hätte!
Und im Gerätemanager ist dabei jetzt ein Ausrufzeichen angezeigt, das vorher nicht da war.

Entweder bin ich blöd, oder ich werd's gleich.

Meine Frage nun:
Könnte es sein, daß da mehr als nur diese Position jetzt irgendwie beschädigt ist, weil da ja auch so vieles angezeigt ist, was - meinem Gefühl nach - ... mir so jedenfalls früher noch nie aufgefallen ist ?
7 Hubs, wenn das dann die USB-Schnittstellen meint, stimmen z.B. schon mal nicht - davon habe ich nur 6.

Und was könnte ich da mal komplett deinstallieren, damit es beim nächsten Systemstart automatisch (hoffentlich) wieder eingerichtet würde?
Ich habe an USB noch den Drucker und den Trackball dran und will da nichts beschädigen, wo ich die beiden nachher auch noch mal neu installieren müßte.
Daher weiß ich jetzt nicht, womit anfangen.
Ob ich evtl. gleich den ganzen USB-Controller vielleicht mal deinstallieren sollte.

Ich habe nur die vorderen USB-Anschlüsse ausprobiert, wo ich bisher auch immer meinen alten MP3-Player angestöpselt hatte. Für hinten ist das Kabel zu kurz und ich werde nicht jedesmal erst unter den Schreibtisch krauchen mit dem Teil.

Wenn das nicht aufhört, hätte derjenige Glück, der grad unter meinem Fenster vorbeigeht, wenn ich das Dingens bei selbigem dann rausschmeiße.
Ich kann doch denen, die mir das geschenkt hatten, nicht zugeben, daß ich zu blöd bin, da nun irgendwas draufzuspielen ...
 

Techy

Kulturbanause!
Teammitglied
"[...]Und im Gerätemanager ist dabei jetzt ein Ausrufzeichen angezeigt, das vorher nicht da war.[...]"

Wenn du das Gerät einsteckst und das Gerät mit dem Ausrufezeichen erscheint, was steht denn bei den Gerätedetails für ein Fehlercode?
 

unsteady

gehört zum Inventar
Kann ich leider nicht beantworten, da ich hier einen sauberen Crash hatte und jetzt mein Reserve-OS verwende. (Ursache hatte sehr wahrscheinlich nichts mit dem USB-Problem zu tun, nachdem ich daran ja auch noch nichts umzustellen versucht hatte.)

Somit komme ich jetzt erstmal nicht mehr an das vermurkste USB-System herran.

In dem alten jetzt (Image vom Juli!) ist, wie ich grad sehe, genau die gleiche Latte an USB-Geräten gelistet.

Es ist allerdings nirgends ein Ausrufzeichen dabei ...

... dennoch funktioniert der MP3-Player dort genau auch wieder bloß NICHT.

(Wie waren die Zeiten noch schön, als es noch die verläßlichen Dampfradios gab. Da mußte man nur oben Wasser nachschütten ... Sollte ich hier jetzt vielleicht auch mal versuchen.)

An diesem System will ich jetzt aber auch nichts ausprobieren, sondern hoffe, daß ich das aktuell gewesene, jetzt gecrashte, wieder auf die Räder stellen kann.

Danach würde ich mich dann noch mal melden. Danke einstweilen.
 

AlterKnacker

Moderator
Teammitglied
Ich hatte mal einen Rechner, sobald ich bei dem einen USB-Stick anschloss, krallte sich der Stick den Laufwerksbuchstaben eines Netzlaufwerkes und war so natürlich nicht mehr zu sehen.

In der Festplattenverwaltung kann man jedoch die Laufwerksbuchstaben per Hand anpassen. Dort mal nachgeschaut?
 

unsteady

gehört zum Inventar
Nein, Laufwerksbuchstaben sind nur die "im Umlauf", die zu den Partitionen gehören. Sollte aber selbst in solchem Falle dann im Dateimanager angezeigt werden, wenn ich das jetzt richtig interpretiere.

Ich hab' das jetzt noch mal mim Photoapparat ausprobiert:

Sobald man den dann einschaltet, wird angezeigt: "Neue Hardware erkannt" und was es ist. Dann kurz, daß es jetzt (automatisch) installiert würde, und wenige Sekunden danach ist der "Wechseldatenträger" mit neuem (temporärem) Laufwerksbuchstaben dann im Dateimanager.
Halt so wie beim ersten Mal bei dem Player auch.

Sobald man das Gerät dann abschaltet, zeigt auch das "Sicher-entfernen"-Ikon, daß man es kann; selbst wenn da die Anwendung noch aktiv ist.

Es hat mich sowieso gewundert, daß das auf dem jetzt verwendeten System alles genauso ist. Ich werd' wohl mal schauen müssen, ob der Hersteller einen Support anbietet (AXDIA International GmbH in D-47877 Willich ... Importware aus China, versteht sich).
Aber die Verpackung ist schön: Pappkarton mit MAGNETVERSCHLUSS ! Mindestens dieses Teil werd' ich nicht wieder mit zurückgeben ... :ROFLMAO:
 

unsteady

gehört zum Inventar
Ich denke, der Support wird mir nicht weiterhelfen können, denn der Player wird über das Kabel ja verbunden - halt nur vom System nicht erkannt und er seinerseits zeigt auch eine Grafik mit nichteingestöpseltem Kabel, was wohl dasselbe meint. Aber aufgeladen wird er.

Habe dazu nun auch jetzt erst bemerkt - weil ich vorher nichts hatte brennen müssen -, daß zwar von meinem CD-ROM Laufwerk Lesen ohne Probleme möglich ist, aber kein Rohling (etliche versucht) mehr erkannt wird, und denke nunmehr, daß dies alles etwas mit den gemounteten Devices zu tun haben könnte.
Was ich da finde, sieht keineswegs mehr sehr original aus ...

HKEY_LOCAL_MACHINE\SYSTEM\MountedDevices\

\??\Volume{3f6b6cf3-1a59-11e0-930e-6cf0497d47d7}
\??\Volume{426febb5-7d5b-11df-bd2e-001bfc0fbfb2}
\??\Volume{4aeaa5f1-8216-11df-bd30-001bfc0fbfb2}
\??\Volume{5a58bccf-249e-11e0-9314-6cf0497d47d7}
\??\Volume{8a9ecc84-5ff9-11df-97a9-806d6172696f}*
\??\Volume{8a9ecc85-5ff9-11df-97a9-001bfc0fbfb2}*
\??\Volume{96f51084-5dd2-11df-9ea1-806d6172696f}*
\??\Volume{c62e3da6-84ee-11df-bd33-001bfc0fbfb2}
\??\Volume{c81d4ea0-4794-11df-bca9-806d6172696f} [mein (einziges) CD-ROM Laufwerk]
\??\Volume{c81d4ea1-4794-11df-bca9-806d6172696f} [ein längst schon nicht mehr vorhandenes CD-ROM Laufwerk; meint dasselbe wie unter FreeDev\00004]]
\??\Volume{c81d4ea2-4794-11df-bca9-806d6172696f}
\??\Volume{c81d4ea3-4794-11df-bca9-806d6172696f}
\??\Volume{c81d4ea4-4794-11df-bca9-806d6172696f}
\??\Volume{c81d4ea5-4794-11df-bca9-806d6172696f}
\??\Volume{c81d4ea6-4794-11df-bca9-806d6172696f}*
\??\Volume{c81d4ea7-4794-11df-bca9-806d6172696f}*
\??\Volume{c81d4ea8-4794-11df-bca9-806d6172696f}*
\??\Volume{c81d4ea9-4794-11df-bca9-806d6172696f}*
\??\Volume{eacc20e2-8937-11df-bd36-001bfc0fbfb2}
\??\Volume{eba60d04-6e0d-11df-bd0b-806d6172696f}*
\??\Volume{f22a2246-4aa4-11df-8161-806d6172696f} [mein (einziges) CD-ROM Laufwerk]
\??\Volume{f22a2247-4aa4-11df-8161-806d6172696f} [ein längst schon nicht mehr vorhandenes CD-ROM Laufwerk; meint dasselbe wie unter FreeDev\00004]]
\??\Volume{f22a2248-4aa4-11df-8161-806d6172696f}
\??\Volume{f22a2249-4aa4-11df-8161-806d6172696f}
\??\Volume{f22a224a-4aa4-11df-8161-806d6172696f}
\??\Volume{f22a224b-4aa4-11df-8161-806d6172696f}
\??\Volume{f22a224c-4aa4-11df-8161-806d6172696f}*
\??\Volume{f22a224d-4aa4-11df-8161-806d6172696f}*
\??\Volume{f22a224e-4aa4-11df-8161-806d6172696f}*
\??\Volume{f22a224f-4aa4-11df-8161-806d6172696f}*
\??\Volume{f4e671da-19a5-11e0-930b-806d6172696f}*
\??\Volume{f4e671db-19a5-11e0-930b-806d6172696f}*
\??\Volume{f4e671dc-19a5-11e0-930b-806d6172696f}*
\??\Volume{f4e671dd-19a5-11e0-930b-806d6172696f} [exakt dieselbe wie Laufwerk E: (CD-ROM Laufwerk)
\DosDevices\C:*
\DosDevices\D:*
\DosDevices\E: [mein (einziges) CD-ROM Laufwerk]
\DosDevices\F:*
\DosDevices\G: [dieser Lw-Buchstabe war bisher immer mein "Wechseldatenträger", unabhängig wo eingesöpselt war
\DosDevices\M:*
\DosDevices\P:*
\FreeDev\00000*
\FreeDev\00001*
\FreeDev\00004 [ein längst schon nicht mehr vorhandenes CD-ROM Laufwerk]
\FreeDev\00005
\FreeDev\00006
\FreeDev\00007 [mein (einziges) CD-ROM Laufwerk]
(Die Sterne haben nur für mich Bedeutung, da es in der gesicherten (exportierten) und nachher ggf. umzuschreibenden .reg-Datei anders sortiert war als im Reg-Editor angezeigt - so wie es hier jetzt auch gelistet ist. Und ziemlich sicher kann auch davon ausgegangen werden, daß diese jedenfalls KEINE Wechseldatenträger sind.)

Fett formatiert sind storage removable media.

Für den Fall, daß einer mitzählen möchte:

Ich habe - allerdings alle deaktiviert - noch so einen Mehrfach-Kartenleser, welcher im Gerätemanager als 4 USB-Laufwerke angezeigt wird:

- Generic USB CF Reader USB Device
- Generic USB MS Reader USB Device
- Generic USB SD Reader USB Device
- Generic USB SM Reader USB Device
Diese werden aber wohl über einen gemeinsamen Controler angesteuert, so daß sich - wie eingangs beschrieben ^^ - zusammen mit meinen 6 USB-Buchsen dann wohl die 7 USB-Hubs ergeben ( ... laienmäßig gedacht).

Eine weitere Festplatte wird schon vom BIOS nicht erkannt und dürfte daher hier auch nicht mit dabei sein.

Wer sowas vielleicht schon mal gemacht hat - was meint Ihr: Kann man diesen ganzen Kram (außer Festplatten) mal ganz brutal löschen und, was die USB Devices anlangt, auf automatisches Mounten hoffen?
 

unsteady

gehört zum Inventar
Falls obiges evtl. zu komplex sein sollte - und weil ich möglicherweise dann erstmal eine Zeitlang gehindert sein könnte, mögliche Antworten abzuwarten (denn mich juckt es in den Fingern, da jetzt selbst "Antworten zu finden", sprich: in der Registry 'rumzusauen' :D) -, könnte mir dann vielleicht bitte einer wenigstens erstmal die Frage beantworten, ob ich überhaupt richtigliege, wenn ich davon ausgehe, daß in meinem Falle, wo nebenher jetzt das eine System zerschossen wurde (und trotz helfender Hinweise noch nicht wiederhergestellt, nachdem ich auch keinen Dualboot ordentlich eingerichtet hatte und deswegen da jetzt erstmal neue Schwierigkeiten befürchte), nachdem der Fehler ja bereits vom alten System her schon bestanden hatte, daß also für beide Festplatten immer nur einunddieselbe Registry gilt, die demnach im alten (zerschossenen) System nachher genausso schon ausgesehen haben könnte wie der hier dargestellte Schlüssel?

(Mein jetzt verwendetes, sozusagen Reserve-OS, war ein Klon des vormaligen (mittels "XXClone" erstellt), welcher von selber aber nicht bootfähig war.)

Nur, damit ich mich besser hineindenken könnte, was ich zu tun jetzt vorhabe.

In einem Beitrag vor 6 Jahren hatte Koloth mal diesen Konflikt unter gemounteten Laufwerken erwähnt, was da jedoch auf allgemeines Aufhängen beim Bootvorgang bezogen war.

Das ist ja bei mir nun glücklicherweise noch nicht so.

Dadurch bin ich jetzt überhaupt auch nur auf diese Idee verfallen.
 

Grainger

Praktizierender Atheist
Am einfachsten ist es vermutlich, wenn Du Dir das Tool DriveCelanUp von Uwe Siebers Homepage herunter lädst und ausführst.

Vorher alle nicht benötigten USB-Geräte (USB-Sticks, externe Festplatten mit USB-Anschluss, usw.) entfernen. Das Tool macht nichts anderes, als alle verwaisten USB-Einträge (einschließlich aller Einträge von momentan nicht angeschlossenen USB-Geräten) zu entfernen.

Anschließend werden alle USB-Geräte, die man anschließt, so behandelt wie bei einer Erstinstallation.
 

unsteady

gehört zum Inventar
Danke, Grainger, für das jedenfalls sehr hilfreiche Programm. Ich hatte wirklich große Hoffnung da hinein gesetzt; es hörte sich sehr vielversprechend an. Indessen sind wohl doch noch einige sich überschneidende Zuweisungen verblieben.

Dies ist jetzt erstmal dabei herausgekommen:

\??\Volume{c81d4ea6-4794-11df-bca9-806d6172696f}*
\??\Volume{eba60d04-6e0d-11df-bd0b-806d6172696f}*
\??\Volume{f4e671da-19a5-11e0-930b-806d6172696f}*
\??\Volume{f4e671db-19a5-11e0-930b-806d6172696f}*
\??\Volume{f4e671dc-19a5-11e0-930b-806d6172696f}*
\??\Volume{f4e671dd-19a5-11e0-930b-806d6172696f} [von mir später entfernt, da Übereinstimmung mit E:]
\DosDevices\C:*
\DosDevices\D:*
\DosDevices\E:
\DosDevices\F:*
\DosDevices\M:*
\DosDevices\P:*
\FreeDev\00000*
\FreeDev\00001*
\FreeDev\00004
\FreeDev\00005
\FreeDev\00006
\FreeDev\00007
Eine konkrete Übereinstimmung konnte ich schon mal für E: feststellen, woraufhin ich den \??\-Eintrag dann auch UNSCHÄDLICH löschen konnte.
(Nun muß ich allerdings auch gestehen, daß ich mir gar nicht klar war, mit welcher genauen Fehlermeldung noch mal ein CD-ROM-Laufwerk angezeigt (bzw. eben nicht angezeigt) wird, wenn da nur ein leerer CD-Rohling drinnen liegt. Ich hatte schon lange nichts mehr gebrannt und jetzt gar kein Brennprogramm am Laufen, welches da sicher eine andere Meldung ausgegeben hätte als mein Dateimanager; bzw. auch Explorer behauptete ja immerfort, er fände kein Laufwerk E: )

Dieses DriveCleanup bereinigt ja noch andere Einträge als nur im Registry-Pfad \MountedDevices:

Removed 7 USB devices
Removed 0 USB hubs
Removed 6 Disk devices
Removed 0 CDROM devices
Removed 0 Floppy devices
Removed 20 Storage volumes
Removed 36 Keys from registry
Der MP3-Player wurde jedenfalls danach weiterhin 'zuverlässig' nicht erkannt. Zu G: war zunächst - weil ja "weisungsgemäß" ;) vorher ausgestöpselt - kein Eintrag mehr vorhanden. Nach Einrichten (per Photoapparat) war wieder einer angelegt. Übereinstimmungen fanden sich erwartungsgemäß (weil eben gänzlich neu erstellt) dort allerdings keine. Obwohl damit gleichzeitig auch noch ein \??\-Eintrag erstellt worden war (also anderer Wert).

Damit ist mir jetzt mein Zutrauen in die eigene Chuzpe verlorengegangen ... Warum tut er das mit mir? Warum schreibt er da Dinge hinein, die ich nicht verstehen kann? Und woher holt er sich da noch eine zweite Information?

Geht man der ... wie nenn' ich's ? ... geschweiften Klammer nach, findet man etliche Bezüge zu Explorer. Nur, warum muß das dann auch noch mal unter MountedDevices stehen, wenn es doch an jenen Stellen schon steht, daß zu entsprechenden Operationen auf das entsprechende Laufwerk zugegriffen wird?

Ich werde das Teil jetzt erstmal an einem anderen Computer testen.
 
Zuletzt bearbeitet:

unsteady

gehört zum Inventar
ot:
Was ich erstmal noch hinzufügen wollte ... Sicher weniger wichtig, aber zeigt, daß das Tool schon mal grundsätzlich was taugt / bewirkt.

Gerade bemerkt: Durch diese Bereinigung bleibt mir jetzt auch wieder erspart, daß zuletzt bei jedem Neustart dieses nervige automatische CheckDisk die Startpartition prüfen wollte - und natürlich nie was finden konnte.
 
Oben