Laufwerksbuchstaben A: und B: unter XP vertauscht

Norbert

Moderator
Teammitglied
Nach dem Motto "Eine Lösung habe ich schon, doch wer hat das Problem?":D stelle ich mal diesen Tipp hier hinein.

In meinem alten PC ist ein normales Diskettenlaufwerk (A:) und ein LS120-Floppylaufwerk (B:, Anschluss am IDE-Port) installiert. Unter Win98 ist die Zuordnung der Buchstaben auch so, wie hier gezeigt. Nicht jedoch bei XP auf dem selben Rechner, da waren sie vertauscht. Nur den Treiber zu De- und wieder Neuinstallieren bringt in diesem Fall nichts.


Die Lösung ist aber trotzdem relativ einfach:

1.) Treiber im Gerätemanager deinstallieren.

2.) Mit dem Registry-Editor zum Schlüssel HKEY_LOCAL_MACHINE\SYSTEM\MountedDevices gehen.

3.) Dort die Einträge \DosDevices\A: und \DosDevices\B: löschen.

3a) Falls noch Schlüssel wie HKEY_LOCAL_MACHINE\SYSTEM\MountedDevice1 usw. existieren, Schritt 3 dort wiederholen.

4.) PC herunterfahren und das LS120-Laufwerk abklemmen.

5.) Einschalten und den Hardware-Assistenten den Treiber fertiginstallieren lassen.
Das normale Diskettenlaufwerk sollte jetzt als A: erscheinen.

6.) PC herunterfahren, LS120-Laufwerk anklemmen und Schritt 5 ausführen.
Das Laufwerk wird nun als B: eingebunden.
 
B

Brummelchen

Gast
Dann kannst du mir auch sicherlich sagen, warum bei 2* 3.5" Drehscheibenlaufwerken
das LW A richtig erkannt wird und das LW B als 5 1/4 (wird aber als 3.5 benutzt) :D :p
Die Macke habe ich an zwei Rechnern nicht rausbekommen.
 

Norbert

Moderator
Teammitglied
Interessanter Hinweis. Leider kann ich momentan nicht sagen, warum das so sein soll:unsure:.

Ich habe aber gerade zwei alte PCs da, die ich für jemanden nochmal auf Vordermann bringen soll. Da werde ich demnächst mal ein Floppylaufwerk aus- und bei meinem PC einbauen, um zu versuchen, das herauszubekommen.

Ich melde mich hier wieder, wenn ich was neues weis.:)
 

Norbert

Moderator
Teammitglied
@Brummelchen:
So, ich habe das mit einem zweiten normalen 3½" Wackelscheibenlaufwerk getestet. Es wurde von XP korrekt erkannt (Bild1). Möglicherweise wurde in Deinem Fall ein früher eingebautes 5¼" Laufwerk gegen ein neueres mit 3½" ausgetauscht und Windows hat die alte Bezeichnung beibehalten.

Die Bezeichnung ist weder in der Registry noch in einer INF-Datei als Klartext zu finden. Auch ein Index auf den Text in irgendeiner DLL war nicht auffindbar.

Es gibt aber zwei einfache Möglichkeiten, den Text zu korrigieren:


1.) Das oben beschriebene Vorgehen mit De- und Neuinstallation.


2.) Überschreiben der Voreinstellung mit beliebig wählbarem Text.

Dazu im Registry-Editor zu folgendem Schlüssel gehen:
(die grünen Unterschlüssel neu anlegen, wenn nicht vorhanden)
HKLM\SOFTWARE\Microsoft\Windows\CurrentVersion\Explorer\DriveIcons\B\DefaultLabel
Dort dem Standardwert den gewünschten Text zuweisen (Bild2).
Das Ergebnis ist in Bild3 zu sehen.

Nebenbei kann hier auch ein anderes Icon zugewiesen werden unter
HKLM\SOFTWARE\Microsoft\Windows\CurrentVersion\Explorer\DriveIcons\B\DefaultIcon
Dem Standardwert einfach den Pfad zur ICO-Datei zuordnen, bei DLL's usw. mit ,Nummer der Iconposition ergänzen.

Der hier genannte Buchstabe im Registry-Schlüssel (...\B\...) gilt natürlich für den entsprechenden Laufwerksbuchstaben (also auch C, D, usw.).

Dieser zweite Tipp kann für alle Laufwerke angewendet werden und ist ohne Neustart sofort wirksam.
 

Anhänge

  • Bild1.jpg
    Bild1.jpg
    5,6 KB · Aufrufe: 180
  • Bild2.jpg
    Bild2.jpg
    14,4 KB · Aufrufe: 238
  • Bild3.jpg
    Bild3.jpg
    5,9 KB · Aufrufe: 248
Zuletzt bearbeitet:

timtaya

schläft auf dem Boardsofa
Unabhängig von Windows, ist das doch eine Option im BIOS.
Wo man einstellen kann welche Diskettenformate a: bzw. b: haben.
 
B

Brummelchen

Gast
Das interessiert XP aber anscheinend nicht :D
Und ich hatte nie ein 5 1/4 hier. Das einzige klemmt an einem
C128 und das ist nicht sonderlich PC-kompatibel :ROFLMAO:
 
Oben