Kompatibilität zwischen Ftp-Clients, Browsern usw.

Finn17

kennt sich schon aus
hallo

hab meinen server auch zum laufen gebracht, nun hab
ich folgendes festgestellt:

mit smartftp können alle user ohne probleme connecten.
mit flashget hingegen nicht. mit dem ie kann ich ohne probleme
verbinden, aber andere hingegen nicht.

ich nehme an das kann 100 ursachen haben, aber
gibt es gewisse einstellungen beim g6 die das verhindern?
oder gibt es bekannte probleme zwischen den clients?

thx in advance
 

Supernature

Und jetzt?
Teammitglied
Und immer wieder die selbe Bitte ;): postet doch bei solchen Fehlern die LOG-Files dazu, die sind so auskunftsfreudig, dass man meist auf den ersten Blick erkennt, was Sache ist.
Grundsätzliche Probleme gibt es keine. FTP ist ein Standardprotokoll, und zudem kein besonders kompliziertes.
Bei Deinem Problem sieht mir das nach dem "Lieblingsthema" passive Mode aus. Aber wie schon geschrieben, ein LOG-sagt mehr als 1000 Worte :)
 

Finn17

kennt sich schon aus
der server funktioniert mit ftp-clients eigentlich ausgezeichnet,
aber mit den browsern tut er sich schwierig.
da nicht alle user nen ftp-client haben bzw. bedienen können möchte
ich es irgendwie hinbringen das es auch mit den standardbrowsern funktioniert.
(alles wurde im Lan mit der internen ip getestet)

Opera 7.23
Wenn man auf den server zugreifen möchte (ftp://192.168.1.55)
kommt die user-/passwortabfrage, jedoch scheint der opera
das passwort nicht zu senden. nach dem bestätigen steht
nur "sending request", aber der ftp-server empfängt keine daten!
log:
Code:
(000033) 27.02.2004 14:29:38 - (not logged in) (192.168.1.60) > connected to ip : 192.168.1.55
(000033) 27.02.2004 14:29:38 - (not logged in) (192.168.1.60) > sending welcome message.
(000033) 27.02.2004 14:29:38 - (not logged in) (192.168.1.60) > 220-dafinn.mine.nu
(000033) 27.02.2004 14:29:38 - (not logged in) (192.168.1.60) > 220-
(000033) 27.02.2004 14:29:38 - (not logged in) (192.168.1.60) > 220-Welcome to FTP-Server :-)
(000033) 27.02.2004 14:29:38 - (not logged in) (192.168.1.60) > 220-
(000033) 27.02.2004 14:29:39 - (not logged in) (192.168.1.60) > USER benutzer
(000033) 27.02.2004 14:29:39 - (not logged in) (192.168.1.60) > 331 Password required for benutzer.
mehr wird nicht geloggt. sieht mir nach einem opera-bug aus. hat jemand was ähnliches beobachtet?
-------------
wenn man über ftp://benutzer:passwort@192.168.1.55 auf den server zugreifen möchte bringt er einen
netzwerkfehler weil er die adresse in 'ftp://benutzer:pa/' ändert. kann ja nicht funktionieren, aber er macht es trotzdem. bug?

*************************************************

Mozilla FireFox 0.8
Wenn man auf den server zugreifen möchte (ftp://192.168.1.55) kommt ein fenster
mit "530 Login or Password incorrect". Das ist ja eingentlich richtig, da ich keine anonymen
verbindungen erlaube. aber wie soll ein benutzer sein usename bzw. passwort eingeben wenn
der browser nicht danach fragt?
-------------
wenn man über ftp://benutzer:passwort@192.168.1.55 auf den server zugreifen möchte klappt alles ganz normal, nur das er beim LIST-Kommando stehenbleibt. Im browser erscheint deshalb auch nicht der serverinhalt.
log:
Code:
(000042) 27.02.2004 14:50:21 - (not logged in) (192.168.1.60) > connected to ip : 192.168.1.55
(000042) 27.02.2004 14:50:21 - (not logged in) (192.168.1.60) > sending welcome message.
(000042) 27.02.2004 14:50:21 - (not logged in) (192.168.1.60) > 220-dafinn.mine.nu
(000042) 27.02.2004 14:50:21 - (not logged in) (192.168.1.60) > 220-
(000042) 27.02.2004 14:50:21 - (not logged in) (192.168.1.60) > 220-Welcome to
(000042) 27.02.2004 14:50:21 - (not logged in) (192.168.1.60) > 220-Blondi's FTP-Server :-)
(000042) 27.02.2004 14:50:21 - (not logged in) (192.168.1.60) > 220-
(000042) 27.02.2004 14:50:21 - (not logged in) (192.168.1.60) > USER benutzer
(000042) 27.02.2004 14:50:21 - (not logged in) (192.168.1.60) > 331 Password required for benutzer.
(000042) 27.02.2004 14:50:21 - (not logged in) (192.168.1.60) > PASS ********
(000042) 27.02.2004 14:50:21 - imsfotos (192.168.1.60) > logged in.
(000042) 27.02.2004 14:50:21 - imsfotos (192.168.1.60) > 230 User benutzer logged in.
(000042) 27.02.2004 14:50:21 - imsfotos (192.168.1.60) > SYST 
(000042) 27.02.2004 14:50:21 - imsfotos (192.168.1.60) > 215 UNIX Type: L8
(000042) 27.02.2004 14:50:21 - imsfotos (192.168.1.60) > PWD 
(000042) 27.02.2004 14:50:21 - imsfotos (192.168.1.60) > 257 "/" is current directory.
(000042) 27.02.2004 14:50:21 - imsfotos (192.168.1.60) > TYPE I
(000042) 27.02.2004 14:50:21 - imsfotos (192.168.1.60) > 200 Type set to I.
(000042) 27.02.2004 14:50:21 - imsfotos (192.168.1.60) > PASV 
(000042) 27.02.2004 14:50:21 - imsfotos (192.168.1.60) > 227 Entering Passive Mode (81,62,125,164,195,87).
(000042) 27.02.2004 14:50:21 - imsfotos (192.168.1.60) > SIZE /
(000042) 27.02.2004 14:50:21 - imsfotos (192.168.1.60) > 550 No such file or directory.
(000042) 27.02.2004 14:50:21 - imsfotos (192.168.1.60) > MDTM /
(000042) 27.02.2004 14:50:21 - imsfotos (192.168.1.60) > 213 18991230000000
(000042) 27.02.2004 14:50:21 - imsfotos (192.168.1.60) > RETR /
(000042) 27.02.2004 14:50:21 - imsfotos (192.168.1.60) > asked to download 'C:\FTP\Fotos\ims_fotos\' --> Access denied (No Such File).
(000042) 27.02.2004 14:50:21 - imsfotos (192.168.1.60) > 550 '/' : No Such File.
(000042) 27.02.2004 14:50:21 - imsfotos (192.168.1.60) > PASV 
(000042) 27.02.2004 14:50:21 - imsfotos (192.168.1.60) > 227 Entering Passive Mode (81,62,125,164,195,84).
(000042) 27.02.2004 14:50:21 - imsfotos (192.168.1.60) > CWD /
(000042) 27.02.2004 14:50:21 - imsfotos (192.168.1.60) > asked to change directory : 'C:\FTP\Fotos\ims_fotos\ -> C:\FTP\Fotos\ims_fotos\' --> Access allowed.
(000042) 27.02.2004 14:50:21 - imsfotos (192.168.1.60) > 250 CWD command successful. "/" is current directory.
(000042) 27.02.2004 14:50:21 - imsfotos (192.168.1.60) > LIST
mehr passiert nicht.

*************************************************

Internet Explorer 6.0.2800
Wenn man auf den server zugreifen möchte (ftp://192.168.1.55) kommt ein anmeldefenster.
korrekter ablauf also. der ie probiert sich standardmässig zuerst als anonymous anzumelden, tut hier aber nichts zur sache. meldet man sich korret an, loggt der server folgendes:
Code:
(000045) 27.02.2004 15:00:46 - (not logged in) (192.168.1.60) > connected to ip : 192.168.1.55
(000045) 27.02.2004 15:00:46 - (not logged in) (192.168.1.60) > sending welcome message.
(000045) 27.02.2004 15:00:46 - (not logged in) (192.168.1.60) > 220-dafinn.mine.nu
(000045) 27.02.2004 15:00:46 - (not logged in) (192.168.1.60) > 220-
(000045) 27.02.2004 15:00:46 - (not logged in) (192.168.1.60) > 220-Welcome to
(000045) 27.02.2004 15:00:46 - (not logged in) (192.168.1.60) > 220-Blondi's FTP-Server :-)
(000045) 27.02.2004 15:00:46 - (not logged in) (192.168.1.60) > 220-
(000045) 27.02.2004 15:00:46 - (not logged in) (192.168.1.60) > USER anonymous
(000045) 27.02.2004 15:00:46 - (not logged in) (192.168.1.60) > 331 Password required for anonymous.
(000045) 27.02.2004 15:00:46 - (not logged in) (192.168.1.60) > PASS ********
(000045) 27.02.2004 15:00:46 - (not logged in) (192.168.1.60) > 530 Login or Password incorrect.
(000045) 27.02.2004 15:00:46 - (not logged in) (192.168.1.60) > disconnected.
(000047) 27.02.2004 15:02:06 - (not logged in) (192.168.1.60) > connected to ip : 192.168.1.55
(000047) 27.02.2004 15:02:06 - (not logged in) (192.168.1.60) > sending welcome message.
(000047) 27.02.2004 15:02:06 - (not logged in) (192.168.1.60) > 220-dafinn.mine.nu
(000047) 27.02.2004 15:02:06 - (not logged in) (192.168.1.60) > 220-
(000047) 27.02.2004 15:02:06 - (not logged in) (192.168.1.60) > 220-Welcome to
(000047) 27.02.2004 15:02:06 - (not logged in) (192.168.1.60) > 220-Blondi's FTP-Server :-)
(000047) 27.02.2004 15:02:06 - (not logged in) (192.168.1.60) > 220-
(000047) 27.02.2004 15:02:06 - (not logged in) (192.168.1.60) > USER benutzer
(000047) 27.02.2004 15:02:06 - (not logged in) (192.168.1.60) > 331 Password required for benutzer.
(000047) 27.02.2004 15:02:06 - (not logged in) (192.168.1.60) > PASS ********
(000047) 27.02.2004 15:02:06 - buelachfotos (192.168.1.60) > logged in.
(000047) 27.02.2004 15:02:06 - buelachfotos (192.168.1.60) > 230 User benutzer logged in.
(000047) 27.02.2004 15:02:06 - buelachfotos (192.168.1.60) > OPTS utf8 on
(000047) 27.02.2004 15:02:06 - buelachfotos (192.168.1.60) > 500 Unknown command.
(000047) 27.02.2004 15:02:06 - buelachfotos (192.168.1.60) > SYST 
(000047) 27.02.2004 15:02:06 - buelachfotos (192.168.1.60) > 215 UNIX Type: L8
(000047) 27.02.2004 15:02:06 - buelachfotos (192.168.1.60) > SITE help
(000047) 27.02.2004 15:02:06 - buelachfotos (192.168.1.60) > 500 Unknown command.
(000047) 27.02.2004 15:02:06 - buelachfotos (192.168.1.60) > PWD 
(000047) 27.02.2004 15:02:06 - buelachfotos (192.168.1.60) > 257 "/" is current directory.
danach bleibt er stehen (bis zum timeout).
das komische dabei: laut server-log ist der benutzer richtig eingeloggt, aber beim internet explorer in der Statuszeile steht immer nocht "Benutzer: Anonym"!!! Warum das?
Hat jemand hierfür eine Erklärung?
-------------
wenn man über ftp://benutzer:passwort@192.168.1.55 auf den server zugreifen möchte kommt ein errorfenster "ftp://benutzer...blabl" wurde nicht gefunden..." kopiere ich die exakt gleiche addresse in den firefox findet er den server! beim ie wird auch gar nichts geloggt, er stellt also gar keine verbindung her.

*************************************************

Netscape werd ich bei zeiten auch mal testen.

generelle infos
geforwardete ports:
50001 - 50013
userrechte (login+pw benötigt):
R---LS-
router:
Netopia Cayman 3351


ich hoffe es kann mir jemand zumindest teilweise ein paar dieser ungereimtheiten erklären oder
sogar einen workaround geben! das ganze ist so mysteriös weil es teilweise funktioniert. zumindest mit dem internet explorer (ohne das etwas dazwischen geändert oder umgestellt wurde!).
falls noch mehr infos benötigt werden nur sagen, dann werde die auch noch posten

thx in advance!
 

Supernature

Und jetzt?
Teammitglied
Grundsätzlich ist der FTP-Zugriff mit Browsern immer eine Krücke und sollte wo es nur geht vermieden werden.
Meist sind es Probleme mit dem passive Mode, das sieht man dann daran, dass keine Verzeichnisse angezeigt werden.
Oder die Browser leiten die Login-Informationen nicht richtig durch, wie man an Deinen Beispielen gut sehen kann.
 

Supernature

Und jetzt?
Teammitglied
Du kannst auf der Server-Seite dafür sorgen, dass der passive Mode einwandfrei funktioniert, mehr kannst Du nicht tun. Für inkompatible Clients kann doch kein Server was.
 

Finn17

kennt sich schon aus
schon klar, aber ich kann mir kaum vorstellen das alle geschilderten probleme
ausschliesslich auf die passiven ports zurückzuführen sind.

ausserdem was ausser ports forwarden muss man noch tun
damit der pasv-mode einwandfrei funktioniert?
 

Supernature

Und jetzt?
Teammitglied
Alle geschilderten Probleme sicher nicht.
Wenn aber wie im ersten Beispiel der Browser die Login-Daten nicht korrekt überträgt, was soll man da machen?
Damit PASV mit dynamischer IP richtig funktioniert, musst Du mindestens Version 2.21 einsetzen und Deinen Hostnamen unter Dynamic IP eintragen.
 

Finn17

kennt sich schon aus
Original geschrieben von Supernature
Damit PASV mit dynamischer IP richtig funktioniert, musst Du mindestens Version 2.21 einsetzen und Deinen Hostnamen unter Dynamic IP eintragen.
version ist 2.21 und den host ist auch schon eingetragen.
 

Finn17

kennt sich schon aus
ja, mit richtigen clients ist es kein problem.
getestet habe ich es mit smartftp, ftpzilla und noch einem.
 
Oben