[Kommandozeile] Ubuntu - Eigentümer einer Partition ändern

Blackthorne

assimiliert
Ubuntu - Eigentümer einer Partition ändern

Hallo,

ich bin heute den Schritt gegangen, mich von Windoes zu verabschieden und nur noch Linux (Ubuntu 6.06) als einziges Betriebssystem auf dem PC zu haben.

Ich habe deswegen die Partition C, die als einzige Partition eine Primärpartition ist, mit ext3 formatiert und auch GRUB entsprechend angepasst. Es hat soweit auch alles gut geklappt.

Ich habe jetzt allerdings eine Partition sda1, die mit ext3 formatiert wurde und deren Eigentümer root ist.

Wie kann ich den Eigentümer in blackthorne ändern. Ich habe gelernt, dass der dazu gehörende Befehl "chown" ist, was ich allerdings konkret zu tun habe, weiss ich nicht.

:)
 

Tequilla

assimiliert
Moin,

wenn ich das noch richtig im Kopf habe ist das ein Grundprinzip von Linux, daß alles bis auf entsprechende/spezielle Verzeichnisse (home/webs auf einem Webserver) root gehört. Ändern sollte man das nicht, ich glaub auch das geht gar nicht.

Eigentümer sollte blackthorne nur von /home/blackthorne sein und dazu evtl. angepassten Ordner.
 

ZuluDC

assimiliert
Man kann Verzeichnisse beim tuxi x-beliebig irgendwo hin mounten - also z.B Partitionen in die Homeverzeichnisse. Daher kann man logischerweise auch die Rechte resp.den Eigentümer ändern.

1.) Zuerst einen Ordner erstellen, an dem Ort wo man möchte, dass /dev/sda1 den Mountpunkt bekommt.

Als root in der konsole an den Platz im Verzeichnisbaum hingehen wo das sein soll - dann 'mkdir Name_des_Ordners' z.B 'mkdir blackthorne_daten'

2.) blackthorne zum Besitzer des erstellten Ordners machen

Da man sich in der konsole schon da befindet wo der erstellte Ordner ist reicht ein:

'chown Besitzer Name_des_Ordners' das wäre dann z.B 'chown blackthorne blackthorne_daten'

3.) In der /etc/fstab muss der Mountpunkt und entsprechende Optionen angegeben werden

# <file system> <mount point> <type> <options> <dump> <pass>
/dev/sda1 /media/blackthorne_daten ext3 defaults 0 0

Das sollte eigentlich so funktionieren - wenn es das bei mir nicht tut nehm ich unter <options> meist rw,auto,users,exec

4.) Jetzt noch den vorher erstellten Mountpunkt mounten.

'mount /dev/sda1' oder 'mount /media/blackthorne_daten' je nachdem wo der Mountpunkt erstellt wurde oder wie er bezeichnet wurde.




Mit diesen Angaben sollte es klappen ohne die Gruppenzugehörigkeit oder die <options> in der /etc/fstab ändern zu müssen. Ich selber hier am Rechner bin als Benutzer in der Gruppe adm drin und kann mich eigentlich auch nicht entsinnen das mal selber eingetragen zu haben.

Wenn es so nicht klappt hat es nur mit den Rechten zu tun - sei es wegen chown (Besitzer), chmod (die eigentlichen Rechte wie schreiben, lesen, ausführen) oder der /etc/fstab. Ist dort als <options> z.B umask=777 hat man ziemlich sicher keine Rechte mehr, den umask in der /etc/fstab subtrahiert die Rechte des chmod.

Bevor ich es vergesse: Mein Kompliment!
Ich bin noch nicht soweit mich ganz von Windows zu verabschieden, aber genaugenommen brauche ich es schon extrem selten.
 

Blackthorne

assimiliert
Irgendwie verstehe ich das Ganze nicht. Ich habe jetzt in der fstab folgenden Eintrag gemacht:

/dev/sda1 /home/blackthorne/sonstiges ext3 defaults 0 2

und mit mkdir einen Ordner "sonstiges" erzeugt. Anscheinend hängt die Partition sda1 jetzt an diesem Ordner "sonstiges", ich habe also im home-Verzeichnis zusätzlichen Speicherplatz gewonnen. Eigentümer des Ordners "sonstiges" ist root, der Ordner hat einen Unterordner "lost+found". Beide sind schreibgeschützt.

sda1 wird nicht mehr angezeigt, wenn ich etwas in den Ordner einfügen will, geht das nicht.

Die Frage ist nach wie vor die gleiche - wie werde ich Eigentümer des Verzeichnisses, so dass ich die Zugriffsrechte verändern kann?


:)
 

Bio-logisch

Moderator
Teammitglied
Du wirst unter Linux nie Eigentümer einer Partition, nur eines Verzeichnisses (das ist ein wichtiger unterschied!).

Dafür der Befehl chown (Benutzer ändern) notwendig.
Als root:

chwon blackthrone /home/blackthrone/sonstiges
 

ZuluDC

assimiliert
Jo versuch es doch mal so wie Bio-logisch schrieb (nur ohne Schreibfehler :D )

chown blackthorne /home/blackthorne/sonstiges

Wenn es immer noch nicht klappt sag Bescheid - dann kann es nur noch an der /etc/fstab liegen oder an den Zugriffsrechten (kann man mit chmod ändern - lesen, schreiben und ausführen)
 
Oben