Knoppix Start Problem

snischi

fühlt sich hier wohl
Hallo ihr weisen Leutz. Bräuchte mal eine kleine hilfe. Und zwar habe ich mir die Knoppix 5.0 Live DVD runtergeladen und auf DVD gebrannt. Soweit alles ohne Probleme. Aber wenn ich jetzt mit der DVD boote. und er meine Hardware checkt beim booten. hängt er sich beim USB auf. habe schon mehrere sachen getestet. unteranderem failsafe. Habt ihr nen tip wie ich knoppix starten kann? hatte auch schon die Live CD gehabt in der version 3.0 und die lief ohne Probleme.

Danke und MFG
 

ZuluDC

assimiliert
Öehmm...kommt doch ganz am Anfang ein Prompt wo man durchentern kann und über F2/F3 Optionen angeben zum booten...in der Art wie
linux26 noscsi ...
linux24 screen=1280x1024
etc.

Ich weiss jetzt ned genau, aber USB Massenspeicher werden als SCSI eingebunden...ich würd einfach mal eine Option suchen, die der entspricht und deaktivieren oder den 2.4er Kernel nehmen zum booten.
 

Juliet

fühlt sich hier wohl
Ich glaube nicht das es was nutzt wenn du die 2.4 kernel nimmst, weil ich glaube du weist garnicht wie man die tauscht ;)

zudem sagst du doch, du hast es schon probiert, usb abgenommen.
vielleicht leigt es ja an der Gragga, nur so ein Gedanke von mir.
 

Soong

nicht mehr wegzudenken
Ich würde mal mit den Knoppix Cheatcodes etwas rumspielen. Da kannst du Knoppix schon eine Menge über deine Hardware verraten oder Teile der Hardwareerkennung deaktivieren.
Bastel doch mal ein wenig und melde dich dann nochmal und sag uns was (nicht) zum Erfolg geführt hat.
Ich hab dir die Cheatcodes mal als PDF angehängt, dann kannst du sie gut ausdrucken. Ansonsten findest du sie im txt-Format (Unix) auch auf den Knoppix-Servern und auf der DVD müssten sie auch drauf sein, aber das weiß ich grad nicht sicher.
 

Anhänge

  • knoppix-cheatcodes.pdf
    38,3 KB · Aufrufe: 917

snischi

fühlt sich hier wohl
also die cheatcodes sind auch mit auf der dvd. also habe knoppix jetzt mal mit der funktion nousb gestartet und er iss schon mal in stück weiter aber dann hängt er sich bei hot plug irgendwas auf. weil ich denke mal nicht das das länger als 10 min dauert oder irre ich mich da?
 

tlx

treuer Stammgast
hotplug hängt wahrscheinlich daher, weil er usb hotpluggen möchte, jedoch keine usb-Unterstützung aktiv hat.

Schon mal mit "noacpi nolapic" als optionen versucht? Hilft oftmals Wunder, besonders bei Laptops *anmerk*
 

snischi

fühlt sich hier wohl
so habe mein problem lösen können. das prob war gewesen hatte im bios die funktion usb support auf keyboard + mouse zu stehen gehabt. habe es auf disable gestellt. und schon startet knoppix
 
G

Gast5065

Gast
Sodele, hab im Linuxforum ja noch gar nichts geschrieben.

Kurze Schilderung des Problems:
Beim booten von der Knoppix-CD 5.0.1 findert er die Festplatte(hda) an IDE und das CD-ROM(hdb) sowie Brenner(hdc).
Dann wird nach der CD in hda gesucht!?!
Das kann ja auch nix werden, aber warum sucht er denn in hda und nicht in hdb?
 

Bio-logisch

Moderator
Teammitglied
Komische Sache...

Eine echte Lösung habe ich zwar nicht, aber vielleicht kannst Du bei dem Expert-Setup das CDrom - Device von Hand vergegeben?

Bei meinem Knoppix hier (gerade eigens gebootet, Version 5.0) ist das Device auch hda, nur stimmt das hier auch...
 
G

Gast5065

Gast
Beim Rechner meiner Schwester funktioniert es.
Dort ist das CD-ROM hdb und es wird auch in hdb gesucht.
Immerhin etwas :)

Muß das CD-ROM an IDE0 angeschlossen sein?
Sollte doch egal sein.
 

Soong

nicht mehr wegzudenken
Was ich sicherheitshalber noch überprüfen würde, wäre ob die Jumper an den Geräten richtig gesetzt sind, also passend zur Verkabelung. Glaube zwar eigentlich nicht, dass es daran liegt, aber man kann nie wissen. Nicht dass Knoppix durcheinander kommt wenn die Verkabelung das eine sagt, die Laufwerke aber was anderes.
 
G

Gast5065

Gast
Ich habs grade nochmal ausprobiert.
Die Festplatte ist hda
DVD ist hdc
und Brenner ist hdd

Hatte vorher geschrieben, das es mit hdb weiterging.

Er versucht aber immer auf hda den CD-Inhalt zu suchen.

In den Expertmodus hab ich mich als absoluten Linuxanfänger nicht getraut.

Die Jumper sind schon richtig ;)
 
Oben