SuSE keine 3D Programme funktionieren

Chom

gehört zum Inventar
Wie im Titel schon gesagt: Es funktionieren bei mir keine Programme die mit 3D Simulation (?) laufen, also Beispiel Spiele, sogar aus den Opensuse Repositorys, auch Blender geht nicht (auch aus den Repositorys).
Ich verwende OpenSuse 11.2 mit KDE 4.3.1

An der hardware kann das nicht liegen: Club HD4670
Wird auch richtig erkannt, also 1080p sogar...
 

Bio-logisch

Moderator
Teammitglied
Welchen Treiber hast Du installiert?
Es gibt ATI, RadeonHD, oder fglrx (der von ATI selber).

Nachzulesen in der Datei /etc/X11/xorg.conf
 

Chom

gehört zum Inventar
eine xorg.con habe ich nicht nur die die im Anhang ist, nur ohne die endung .txt ....
 

Anhänge

  • xorg.conf.install.txt
    849 Bytes · Aufrufe: 224

Amon

assimiliert
Da steht was von "vboxvideo" in der Datei. Läuft Suse denn in einer virtuellen Maschine? Bei der Virtualbox gibt es 3D Unterstützung für den (Windows) Gast nur experimentell, ich denke nicht das es bei Linux viel besser ist.
 
Zuletzt bearbeitet:

ZuluDC

assimiliert
Xorg verwendet standardmässig schon ein Weilchen keine xorg.conf mehr. Es wird automatisch der "bestmögliche" Kernel-Treiber ausgewählt, welcher vermutlich je nach Distribution meist kein proprietäres 3D Treibermodul beinhaltet.

Will man aber eine eigene Konfiguration muss man eine xorg.conf erstellen, sofern einem der 3D Treiber es nicht macht oder man eine einigermassen schlaue 2 Bildschirmkonfiguration mit einer älteren Grafikkarte (GeForce 6600gt) haben will wie ich.

Diese Textdatei ist wahrscheinlich nur eine Vorlage für einige mögliche Einträge in der xorg.conf für den Fall, dass man nicht über die bash hinauskommt (keine schlaue GUI kriegt), und dann kann man vesa oder sowas verwenden. Ich denke der vmware-Eintrag ist genau auch dazu da um wenigsten eine einigermassen brauchbare Oberfläche in einer vmware-Umgebung zu ermöglichen um von da aus weiterzukonfigurieren.

Wenn also Suse nativ bei Dir läuft fehlt Dir der richtige Treiber, der 3D ermöglicht.
 

Chom

gehört zum Inventar
Nein es Läuft nicht in einer Virtuellen Machine, aber ich hatte letztes Probleme mit dem Kernel, hatte einen anderen wegen Virtualbox installiert, beim deinstallieren, habe ich leider den falschen gelöscht, aber direkt wieder drauf gespielt, musste aber die Installations DVD zur Bootlader Konfiguration nehmen weil die Einträge Suse wegwaren.
Seit dem bootet Suse auch komisch: es kommt nach Grub immer normal ein Schwarzer Bildschirm mit Text (ne ist klar) aber neuerding kommt da immer was von Fatal Error, aber er bootet dann trotzdem und im Betrieb habe ich außer dem 3D Problem nichts zu beanstanden.

Edit:
Also brauch ich einen anderen Treiber?
 

ZuluDC

assimiliert
Kann gut sein was Bio sagt. Ich poste trotzdem was mir so in den Sinn gekommen ist, obwohl ich in Suse nicht der "Checker" bin.

Ich kenne mich auch mit ATI-Grakas nicht aus, aber der Ruf der 3D Treiber von ATI ist.......äehm......knapp bemessen. Die Webseite, von welcher man vermutlich die aktuellsten Stable-Treiber bekommt, dürfte von ATI selber sein und wäre hier. Ob das dann aber mit dem entsprechenden Kernel harmoniert ist wieder eine andere Frage. Jedenfalls gibt es auch Stimmen, die sagen die ATI-Treiber seien gar nicht mehr so schlecht wie auch schon. Und es gibt anscheinend verschiedene Treiber - Bio's Aufzählung suggeriert es. Vielleicht muss man bei Suse in Yast nur irgendwelche Paketquellen aktivieren und kann dann per Hand den 3D Treiber auswählen, vielleicht ist es auch nur ein Befehl auf der Konsole - ich weiss es ehrlich gesagt nicht.

Wenn ich Ubuntu hier frisch installiere (Geforce 6600gt) und das erste Mal reboote, dreht xorg bei meiner DualMonitor-Konfiguration gleich komplett durch. Beide Monitor blinken wie Ampeln in allen möglichen RGB-Farben. Man kann nichts anderes machen als die GUI abzuschiessen und auf der Konsole die proprietären 3D Treiber installieren (oder sowas "Knappes" wie vesa). Dann bekomme ich zwar erst ein einigermassen schlaues Bild, aber es ist meilenweit von einer vernünftigen Konfiguration weg. Ergo muss ich noch Hand an der xorg.conf anlegen. Jedesmal wenn ich Ubuntu neu installiere werde ich richtig zur bockigen Zicke; und zuerst würde ich die Kiste am liebsten gleich aus dem Fenster schmeissen; habe ich aber das mit xorg.xonf und 3D mal einigermassen sauber, komme ich recht schnell zum Ziel und es endet eigentlich immer wieder damit, dass ich Windows gar nicht mehr boote.

Wenn ich Virtualbox aus den Quellen von Ubuntu verwende spielt es keine Rolle wenn automatisch ein Kernelupdate nachgeschoben wird, denn Ubuntu hat da was an Board, dass alle diese speziellen Module dann automatisch nachkonfiguriert; nennt sich dkms
  • Description-de: Unterstützungsrahmen für dynamische Kernelmodule DKMS ist ein Rahmen (Framework), der dazu dient, einzelne Kernelmodule zu aktualisieren ohne den kompletten Kernel auszutauschen. Er macht es auch einfach, die Kernelmodule beim Aktualisieren des Kernels neu zu kompilieren.
Verwende ich aber eine neuere Version von Virtualbox, weil Diese noch nicht in den Quellen ist, muss ich mir nach der Installation mit einem Konsolenbefehl helfen. Wenn ich mich nicht täusche heisst der bei Ubuntu in etwa so:

sudo /etc/init.d/vboxdrv setup
 

Chom

gehört zum Inventar
Danke,
mein Kernel ist der normale default 2.6.31.12

Zu der Anleitung:
Hat zu gut geklappt mit dem Repository, wenn ich es installieren will kommt immer die Meldung:
Intigritäts Fehler die Datei wurde bei dem Download beschädigt.

Vorher kommt aber die Meldung unerwartete Prüfsumme, anscheinend wurde das Paket verändert.
Es geht um das Paket ati-fglrxG01-kmp-default
 

Smuggler

schläft auf dem Boardsofa
Da dies eine "Radeon"-Karte ist ... hast du mal den freien Radeon-Treiber ausprobiert? Findest du in den ATI-Community-Repos.

Ansonsten schau mal, dass du dir die passenden Kernel-Sourcen nochmal nachinstallierst und dir dieses kleine Installationsprogramm von AMD direkt herunter lädst: ATI Catalyst? Proprietary Display Driver

Danach in Runlevel 3 wechseln und als root den Installer ausführen - passende Module werden durch das Programm herunter geladen und installiert.

Reboot - und per SAX die GraKa einrichten ... soweit die Theorie ...
 

Bio-logisch

Moderator
Teammitglied
Danke,
mein Kernel ist der normale default 2.6.31.12

Zu der Anleitung:
Hat zu gut geklappt mit dem Repository, wenn ich es installieren will kommt immer die Meldung:
Intigritäts Fehler die Datei wurde bei dem Download beschädigt.

Vorher kommt aber die Meldung unerwartete Prüfsumme, anscheinend wurde das Paket verändert.
Es geht um das Paket ati-fglrxG01-kmp-default

Dann würde ich mal das Paket von Hand herunterladen und installieren. In die Repositories von SuSE kann man auch mit einem normalen Webbrowser surfen.
 

Chom

gehört zum Inventar
Dank,
ich habe das gerade getestet:
Paket geladen für Opensuse 11.2 paket erstellt (also das was im wiki stand) so das am Ende ein RPM File da war.
Dann im Runlevel 3 insterliert: Kernel-source fehlt
gut also noch im runlevel 3-> YaST2 -> Kernel-source nachinsterliert
Wie das ATI Paket gesagt hatte: kernel konfigurations Teil ausgeführt immer noch Kernel-Source fehlt.
diesmal einfach ignoriert weil ich es ja insterliert habe, und auch das ATI Paket als installiert angezeigt wird.
Also Konfiguration:
hat auch geklapt, aber dann Sax2: Absturz.
Reboot (automatisch) -> Suse: KWin ist abgestürzt, außerdem kein Mauszeiger.
Wieder Reboot: Totaler Fehler nichts geht mehr kein Blue Screen sondern ein Black Screen, zuerst dachte ich ach das läd nur aber nach 10min immer noch schwarz.
Seit dem komme ich in Suse nicht mehr rein.
Außerdem habe ich meine Installations DVD einem Freund gegeben, ich werde jetzt erst mal mir noch mal Opensuse runterladen und drüber Neuinstallieren.
Mal sehen ob es dann geht...
 

Chom

gehört zum Inventar
naja, jetzt muss ich halt Suse Neuistallieren, besonders weil jetzt nicht mal mehr Grub geladen wird.
 

ZuluDC

assimiliert
jetzt muss ich halt Suse Neuistallieren
...ausser Du bist in der Lage ab einer Linux-LiveCD zu booten, das Wurzelverzeichnis samt /boot zu mounten, nun in das Suse-System per chroot "einzusteigen" und dann auf der konsole grub, die dev-Pakete und den 3D-Treiber neu zu installieren.
 

Chom

gehört zum Inventar
Danke, aber das geht leider nicht....
Außerdem werde ich nicht ganz Neuinstallieren, sondern nur das / Verzeichnis überschreiben, da ich sowie so nur wenige Programme hatte ich ich nach installieren muss( Thunderbird, Skype, Recordmydesktop...) dauert nur 10 Minuten.
Ich werde dann noch mal das ganze versuchen, aber dies mal vorher kernel-source installieren ;).
 

Chom

gehört zum Inventar
Da nimm ich lieber ReactOS ;)

Ne, habe es Neu installiert, jetzt gehen die Programme entweder gar nicht oder mein Bildschirm wird schwarz und zeigt an: Frequenzen werden nicht unterstützt.
Ich versuche noch mal das mit dem ATI Treiber...

Edit:
habe es noch mal probiert, Ergebnis:
bei Starten gab es wieder das Problem mit KWin, aber durch ändern der xorg.conf von:
Section "Extensions"
Option "Composite" "true"

zu "composite "false"

ist das Problem mit KWin beseitigt, aber jetzt läd z.b. in FireFox die Seiten immer von Oben nach Unten, also sehr zerhackt, nicht flüssig.
Und die Programme gehen immer noch nicht. :(

Edit2:

Ich füge mal den Crash Bericht von Kwin bei und meine jetzige xorg.conf

Edit3:

Das Komische Laden scheint ein FireFox Bug zu sein, mit Konqueror habe ich das Problem nicht.
aber gebracht hat das mit dem Treiber auch nichts, funktionieren tuen Spiele und Blender immer noch nicht.

Da es nichts gebracht hat, außer das FireFox jetzt Schwierigkeiten macht, weiß einer wie man das wieder zurück setzt? Also den ATI Treiber weg und wieder Grundeinstellungen?
 

Anhänge

  • kwin-20100221.kcrash.txt
    421 Bytes · Aufrufe: 184
  • xorg.conf.txt
    5,6 KB · Aufrufe: 176
Zuletzt bearbeitet:
Oben