Internetverbindung vom Client

Lollypop

assimiliert
Puuhh, nun muß ich fragen. Also: der Server läuft mit XP und ist der Hauptrechner, der mit t-DSL-Flat im Netz ist. Am Netzwerk (10/100 Mbit Realtec Netzwerkkarten, Hub, DSL-Modem im Uplinkport des Hub)hängen noch 2 Rechner. Nu wollte ich mal Probehalber mit dem 2. Rechner (auch XP) in's Internet. Habe im Systray beide Iconen von DFÜ an Internet und Lan-Verbindung. Klicke ich auf "DFÜ-Verbindung an Internet) =der Name vom Server, wird die Verbindung als Aktiv bezeichnet und der Status (Allgemein +Details) wird Angezeigt, auch, wie lange die Verbindung schon besteht. Aber egal welche Addy ich im IE Explorer anwähle, immer kommt "Seite kann nicht Angezeigt werden". Da fehlt doch irgendwo noch ein Haken, oder es ist einer zuviel.
Help the brave Lolly !!!!! :bier
 

Steve Urkel the REAL

Moderator
Teammitglied
Hi Lutscher, ;)

versuche mal auf den Clients im Netzwerk oder im IE die DNS-Server einzutragen (der Client weis doch nicht was www.supernature-forum.de ist, der kennt nur 195.94.80.98)

Eine andere Alternative, ohne die DFÜ-Verbindung, wäre über den Gateway (in Netzwerk des Clients einzutragen, IP des Servers) zu gegen, dann brauchst Du nur den IE öffnen und die Adresse eingeben, die Verbindung wird automatisch aufgebaut.

Steve
 

Lollypop

assimiliert
Hu Steve, war etwas zu hoch Deine Erklärung. So sieht im Server das Netzwerk aus.

Lan.gif


Der erste Client hat 192.168.0.2, der Zweite 192.168.0.3
Das mit dem Gateway scheint einfacher zu sein, als die andere Lösung von Dir mit den DNS-Servern, oder nicht? Also einfach den Browser öffnen und man kann die Links anwählen, scheint mir verlockender als die Lösung mit DNS. Was also kommt im Server und was im Client in den Gateway? Da habe ich bis jetzt noch nie die Finger dran gehabt. Sei ein lieber Mensch :D und mach mich schlau. :trost
 

Steve Urkel the REAL

Moderator
Teammitglied
Einfacher ist das, was weniger arbeit macht, aber an den DNS sachen kommste evtl nicht vorbei.

Also:

1. DNS,
sind ja nur zwei IP-Adressen und zwar die von T-Online (DNS1 = 194.25.2.129, DNS2 = 212.185.249.84). Die einfach im IE oder in den Netzwerkeinstellungen (ist besser) eintragen, auf deinem Bild íst das ja schön abgebildet. Ohne diese Adressen, kann der Client Probleme haben die Adressen umzusetzten, ist mir auch so ergangen.

2. Gateway
Trage die IP-Adresse des Servers unter den Netzwereinstellungen/Gateway (evtl. in TCP/IP Protokoll versteckt) der Clients ein. Es sollte dazu eine Einstellmöglichkeit geben (die DNS Einträge auch eintragen). Jetzt sollte jede in Privaten-Lan nicht bekannte IP über den Gateway (Server) in das INet gelangen.

Steve

PS: Habe gerade gesehen, das Du feste DNS-Einträge angeklickt hast, aber keine eingetragen sind. Stelle mal auf DNS automatisch beziehen ein und schau mal was passiert.
 

Lollypop

assimiliert
Also, wenn ich DNS anhaben will, muß ich zuerst die Serveradresse auf "IP Adresse automatisch beziehen" stellen. Hab ich gemacht. War nix mit in's Internet kommen vom Client. Haste noch ne andere Idee?
 
N

nachtgespenst

Gast
Hi Lolly,

ich will auch mal versuchen Dein Problem zu lösen. Also:

1. brauchst Du einen Router (Hardware oder Software z.B. Ken DSL), damit Dein DSL Modem eine feste IP bekommt (die Ip für das Modem muß zu Deinem Netzwerk passen (z.B. x.x.x.3), jetzt kann das Modem wie ein neuer Rechner im Netz angesprochen werden.

2. die IP des Modems ist dann bei allen Clients der Standardgateway und der bevorzugter DNS-Server.

3. bei den Clients muß im IE > Verbindung> keine Verbindung eingestellt werden (da die Anwahl über das Lan erfolgt).

Jetzt solltest Du von allen Clients eine Verbindung ins Internet erhalten.

Ich hoffe Dein Problem damit gelöst zu haben.

cu ngs
 

Lollypop

assimiliert
Hi nachtgespenst, das löst das Problem nicht, da ich einen Hub habe. Müßte den teuren Hub wegwerfen und 'nen noch teureren Router kaufen. Sollte das die einzige Losung sein, dann reiße ich lieber den Server vom Netz und richte auf den anderen Rechnern auch die DFÜ-Verebindung ein. Trotzdem Danke für den Versuch.
 

SkyMaster

schläft auf dem Boardsofa
OK, dann versuche ich dir das mal mit meinen worten zu erklären :D

(vorausetzung ist das du ein fertiges Netzwerk hast was funzt )

1) auf den hauprechner die DFÜ-Verbindung einrichten
(dabei das DSL-Moden in den Hub im UPLINK stecken)

2) Auf deinen XP-Rechner die INTERNETVERBINDUNGSFREIGABE INSTALIEREN!

3) dein rechner die IP 192.168.0.1 zuweisen mit einer Subnetzmask von : 255.255.255.0

4) Auf ALLEN anderen REchnern die IP-Adresse um jeweils eine Zahl erhöhen erhöhen

5) auf alle Rechner Folgende einstellung in den TCP/IP Protokoll vornehmen :
DNS Host =name des ersten Rechners (bei mir z.B. ANDY)
DNS Nummer = 192.168.0.1 (IP-Adresse des ersten Rechners)
Gadeway = 192.168.0.1 (IP-Adresse des ersten Rechners)


6) Auf ALLEN Clientrechnern in den Internet-Explorer einstellen:
VERBINDUNG = KEINE VERBINDUNG HERSTELLEN


SO, das wars eigenlich schon !
Mit den einstelleung sagts du deinen Clienten das er sich die Daten für das Internet von den Server holen soll (192.168.0.1)
Was sie in der regel dann auch Ohne Problemme machen !
Wenn du möchtest das sich die Clienten auch einwählen können (wenn auf dem Server die verbindung getrennt ist) must du auf dem Server in der Internetverbindungfreigabe diese Option Aktivieren !

Das hat bist jetzt IMMER geklappt (bei ein Netzwerk mit HUB !

Aber Achtung: Die Clienten können nur im I-Net surfen wenn der Server eingeschaltet ist !!!


CU
Sky
 
Zuletzt bearbeitet:

Nipple

assimiliert
Hi Lollypop,

wenn Du mit einem Hub zwei Rechner gleichzeitig ins Netz bringen willst kannst Du aufgeben, das wird nichts, weil jeder Rechner nach aussen(ins Internet) mit der gleichen Ip auftritt und das kriegt der Hub nicht hin, dafür brauchst Du leider zwingend einen Router. Ich habe hier auch noch eine gute Adresse bei Netzwerkproblemen: www.netzadmin.org
 
N

nachtgespenst

Gast
Hi Lolly,

wegschmeißen brauchst Du nichts. Nimm doch einfach einen Software Router. Da ich einen Hardware Router benutze kann ich Dir keine Empfehlung geben, habe aber von AVM Ken DSL bisher nur gutes gehört (Info www.avm.de )

Du kannst aber auch im Forum nach Erfahrungen fragen.

Dies ist die einfachste Lösung

cu ngs
 

SkyMaster

schläft auf dem Boardsofa
Genau so Ist es ..und die von mir Oben beschriebene einstellung ist nix anderes wie ein Softrouter...nur das du keine zusätzliche soft mehr brauchst :)
 

Lollypop

assimiliert
Soooooo, nun fühl ich mich wohl!

Danke Euch, die Ihr Euere paar kostbaren noch funktionierenden Gehirnwindungen :D für mich malträtiert habt. Es klappert! Es waren 2 Fehler drin:
1. hatte Rechner 2 mit der IP 192.168.0.2 auf der Netzwerkkarte die Adresse 3.
2. hatte ich auf Rechner 2 die feste IP Adresse 192.168.0.2 vergeben und nicht "Automatisch beziehen" angehakt. Deßhalb konnte ich keine DNS-Serveradresse eintragen, ist dann Deaktiviert.
So, dafür gebe ich eine große Runde aus. Prost Jungs! :bier :bier :bier :bier :bier :bier :bier
 
Oben