Icon von Netzwerklaufwerken falsch

KaDi

bekommt Übersicht
Hallo zusammen,

beim Start von FC werden bekannte Netzwerklaufwerke auf die bis zu diesem Zeitpunkt noch nicht zugegriffen wurde mit einem roten "x" gekennzeichnet. Das ist soweit auch ok. Wenn man dann jedoch mit FC auf diese Laufwerke zugreift, also wirklich mit ihnen auch arbeitet, verschwindet das rote "x" leider nicht! Es verschwindet erst, wenn man FC schließt und wieder neu startet. Ich weiß, das ist Kosmetik, aber trotzdem leider falsch.

Gruß

KaDi
 
Und wenn du jetzt noch ein Minimum an Informationen über dein System addierst,
kann Marek vielleicht etwas dazu sagen.
OS Version, FC Version (32 oder 64Bit) ?
 
Hallo,

sorry. OS: Win10 H22, FreeCommander XE 2024 Build 906 64-bit donor

BTW, ich hatte den Bug bereits hier am 08.06-2023 gemeldet und auch schon in einer privaten E-Mail an Marek als er mir mit einem anderem Problem bei den Netzwerklaufwerken speziell bei WEBDAV-Laufwerken geholfen hat. Bisher habe ich in der Sache noch kein Reply erhalten.

Gruß

KaDi
 
Scheinbar einfache Sachen sind manchmal schwierig zu ändern.
Ich sollte von Windows eine Nachricht bekommen, dass das Symbol sich geändert hat.
Es scheint, dass in manchen Umgebungen kommt diese Nachricht nicht oder nicht richtig.
Man muss das Programm nicht neu starten, es reicht Ctrl+Shift+R (Refresh all).
 
Einen schönen guten Morgen Marek,

vielen Dank, dass Du Dich der Sache angenommen hast. Ich habe gerade einmal ein paar Tests gemacht:

- den Rechner neu gestartet. Im Explorer erscheint das Laufwerkssymbole mit dem roten "x".
- FC gestartet, auch dort ist wie beschrieben das rote "x" vorhanden. Soweit, so gut.
- Dann mit dem FC das Laufwerk angesprochen. Wie bereits berichtet bleibt das rote "x" erhalten.
- Im Explorer-Fenster bleibt das rote "x" AUCH erhalten! Der Zugriff über einen anderen Prozess führt also zu keinem auslösenden Event, dass sich der Status geändert hat.

Ich gehe also davon aus, dass ein Zugriff auf das Laufwerk nicht zu einem Event dergestalt führt, dass diese Information an alle Prozesse vermittelt wird. Wenn ich im Explorer dann auf das Laufwerk zugreife, dann ändert sich der Status und das rote "x" verschwindet. Der Refresh erfolgt also irgendwo im Hintergrund. Der Zugriff auf das Laufwerk bewirkt dies. So wie ich das sehe, muss FC bei erfolgtem ersten Zugriff auf das Laufwerk im Nachgang den Refresh selbst auslösen, sonst wird sich das rote "x" nie auflösen.

Gruß

Klaus
 
Oben