Ich komme nicht klar :-(

g-star

Erster Beitrag
Hallo zusammen,

Ich bin neu Hier und Verstehe das Programm nicht !

Oder ich mache ein dummen fehler den ich selber nicht finde !

Also ich habe einfach alles Install.

Dann starte ich das Programm, Log mich mit admin account ein und mache eine domain !

wenn ich das alles eingerichtet habe setzte ich freie datei für auym. und fertig oder ?

dann teste ich das intern. geht alles will ich aber von außen zugreifen geht nix warum ?

Es ist ein Win32 Server von 1und1 !

Habe es auch schon an meinem privat pc versucht aber die anderen können auch nicht zugreifen
 

MaXg

assimiliert
Wenn es intern geht und extern nicht, gibt es nur 3 Möglichkeiten.

Dein Win32 System Blockiert externe Zugriffe via Firewall.

Ports werden von der 1&1 Wall gesperrt.

Die Netzwerkkonfiguration bei 1&1 macht es unmöglich (wie ist deine zugewiesene IP?).
 

seker

Herzlich willkommen!
Hallo


Ich bin auch neu hier. Habe die 30 tage Testversion runtergeladen. Und laut den Beschreibungen Domain und einen Testuser angelegt, aber über den Webbrowser kann ich auch nicht zugreifen. Nun ein paar Informationen was für ein Hardware (Router) ich benutze und welche Einstellungen ich gemacht habe.

1. Router

Ich habe einen Linksys WRT54GL mit der neuen DD-WRT Standard v23 Firmware
Hier habe ich TCP Port 21 auf meine eigene IP Adresse weitergeleitet.
Firewall Einstellungen kann ich nicht viel machen

2. Ich besitze einen dyndns.org

3. Habe eine Domain erstellt ohne irgendwelche Einstellungen zu ändern ausser anonymen zugriff nicht zu erlauben

4.habe einen user angelegt ohne Einstellungen zu ändern. Username und Passwort eingegeben und den Ordner auf den er zugreifen darf

5. habe im webbrowser ftp://username: passwort@....dyndns.org eingegeben aber vergeblich. Die Seite wird nicht aufgerufen
Habe es auch mit IP adresse versucht nada

Irgendwelche Ratschläge Hilfestellungen? Braucht ihr mehr Infos?

Danke
 

seker

Herzlich willkommen!
* About to connect() to ----.dyndns.org port 21
* Trying 83.135.---.---... connected
* Connected to ------.dyndns.org (83.135.---.---) port 21
* FTP response reading failed
* Closing connection #0

Die Meldung bekomme ich wenn ich extern testen lasse

Hi habe IP probiert gehabt. Hat leider nicht auch nicht geklappt



- Betriebssystem : WindowsXp Prof +Sp2
- Art des Internetzugangs und Provider: DSL 20000 Versatel
- verwendete Server-Software mit Versionsangabe : Gene6 Ver.3.8.0 Build34
- ausführliche Angaben zur Konfiguration, insbesondere zu den Ports : Benutze den Standard Port21, und wie oben geschrieben ohne bestimmte Einstellungen Domain und User angelegt
- evt. vorhandene Firewall-Software : router Firewall und Router ist vo Linksys WRT54GL
- bei DynDNS: ---.dyndns.org aktualisierung über den Router
- bei vorhandenem Router: Linksys WRT54GL mit DD-WRT Standard v23, Port21 auf meine lokale IP forward gemacht
- Ein Auszug aus dem LOG-File des FTP-Servers und/oder des Clients: Welchen Log?
 

Ruhe

fühlt sich hier wohl
Im FTP Server das bitte checken:

Domain -> Secure -> IP binding

[] Disable PASV mode
Redirect PASV IP: ....dyndns.org
Passive port range: 50000 - 50100 *


* Diese Ports im Router öffnen/weiterleiten
 

seker

Herzlich willkommen!
Hallo Ruhe


Erstmal danke dass du versuchst mir zu helfen. Leider klappt dies auch nicht.
Habe wie du es gesagt hast meine dyndns eingetragen und die Ports im Router weitergeleitet. Bekomme aber beim Online Test die selbe Meldung :(

Brauchst du vielleicht irgendwelche Screenshots?
 

Supernature

Und jetzt?
Teammitglied
Es kommt noch nicht mal zum Login, wie man oben sieht. Es erscheint außerdem auch nicht die Begrüßungsnachricht des G6 - ich vermute mal, er wird gar nicht angesprochen. Hat Dein Router evt. einen eingebauten FTP-Server, der zuerst deaktiviert werden muss?
 

seker

Herzlich willkommen!
Hallo Supernature

Ich war so blöd. Hatte meinen Windows Firewall vergessen gehabt. Wenn ich den ausschalte, dann funktioniert es. Nur würde ich den Firewall trotzdem benutzen. Wie kann ich denn im windows firewall ranges freigeben? Habe irgendwie das Gefühl dass nur einzelne Ports freigegeben werden kann.
 

Supernature

Und jetzt?
Teammitglied
Das Gefühl trügt Dich nicht. Die WindowsXP-Firewall blockt nur eingehenden Traffic, und davor bist Du mit Deinem Router bereits gut geschützt.
Es ist also kein Risiko, die Firewall abzuschalten.
 

seker

Herzlich willkommen!
Mich hatte es bis jetzt nicht gestört gehabt. Werde es jetzt auch ausgeschaltet lassen.

So jetzt da Standardmäßig alles läuft kann ich mich auf die anderen Einstellungen konzentrieren.
 

dogfriend

Herzlich willkommen!
hallo zusammen,

ich habe mir schon alles durchgelesen und komme einfach nicht weiter.
1tes problem: wenn ich im g6 meine domäne (dyndns.org) OHNE zertifikat anlege port 21 nehme und einen user einrichte dann kann man mit dem ftp client darauf zugreifen und das machen was eingerichtet wurde. wenn ich aber den port 999 in meiner fritzbox öffne und man versucht dann das selbe wie vorher, dann werden keine verzeichnisse angezeigt und man wir automatisch vom server getrennt.
2tes problem: wenn ich meine domäne im g6 MIT zertifikat anlege geht gar nichts. weder port 21 noch irgend ein anderer port. :cry:
der ftp server muß aber mindestens implicit ssl haben bevor ich hier 2tb daten mit anderen usern share !!!
würde mich echt über eure hilfe freuen.
danke im voraus.
 

Supernature

Und jetzt?
Teammitglied
LOG-Auszüge von Server und Client wären hilfreich, damit man es besser eingrenzen kann. Bei der Fritz!Box auf jeden Fall nur den Server-Port freigeben.
 

dogfriend

Herzlich willkommen!
Supernature schrieb:
LOG-Auszüge von Server und Client wären hilfreich, damit man es besser eingrenzen kann. Bei der Fritz!Box auf jeden Fall nur den Server-Port freigeben.

so, bin wieder da.....

also ich habe log files von server und client zusammengefügt und angehängt. ich habe auch alle möglichkeiten ausprobiert und benötige nun nur noch die lösung meines problems.
1. wenn ich in der fritzbox unter port freigabe den "ftp server" nehme dann stellt der sich automatisch mit port 21 ein -> ergebnis: alles läuft wunderbar (man kann von außen zugreifen mit ftp protokoll, mit implicit ssl und explicit ssl (auth ssl) - okay ist ganz positiv
2. wenn man in der fritzbox z.b.den port 990 frei gibt -> ergebnis: NICHTS läuft !!! weder normal noch implicit ssl noch explicit ssl - ganz schlecht !!!
3. wenn ich unter port freigabe "exposed host" nehme und am ftp server port 990 für meine domäne einstelle -> ergebnis: alles läuft wieder wunderbar (normal ftp, implicit ssl, explicit ssl) - ABER , heute morgen wollten schon 2 würmer über die offene fritzbox auf den rechner - ultraschlecht !!!

da heißt, ich benötige eine lösung um das szenario 2 zum laufen zu bewegen. die logfiles sind natürlich vom zweiten fall !!!
ich hoffe es kann mir jemand helfen aber wie ich gesehen/gelesen habe hat ja wohl noch jeder hier im Gene6 forum DIE lösung seines problems bekommen.
danke im voraus an alle die mir hier helfen können und wollen.
 

Anhänge

  • 2006-11.txt
    17 KB · Aufrufe: 216
Zuletzt bearbeitet:

Supernature

Und jetzt?
Teammitglied
Das Problem, dass Schädlinge versuchen, über populäre Ports einzudringen, wirst Du nicht lösen können. Bei einem vernünftig abgesicherten System gehen diese Versuche aber ins Leere.
Versuche mal Folgendes:
1.) Server auf Port 990, diesen in der Box freigeben
2.) Im Server unter Passive IP Deinen DynDNS-Namen eintragen und einen Portrange vergeben - diesen Range ebenfalls in der Box freigeben.
 

dogfriend

Herzlich willkommen!
Supernature schrieb:
Das Problem, dass Schädlinge versuchen, über populäre Ports einzudringen, wirst Du nicht lösen können. Bei einem vernünftig abgesicherten System gehen diese Versuche aber ins Leere.
Versuche mal Folgendes:
1.) Server auf Port 990, diesen in der Box freigeben
2.) Im Server unter Passive IP Deinen DynDNS-Namen eintragen und einen Portrange vergeben - diesen Range ebenfalls in der Box freigeben.

ui !!!!
supi klasse, vielen dank. jetzt läuft es tadellos (y), OHNE das die fritzbox mit "exposed host" oder dem vorkonfigurierten standard port 21, läuft.
mich interessiert aber natürlich auch das "warum".
das was du unter 1. geschrieben hast, hatte ich ja schon eingestellt.
wieso muß man also bei der fritzbox (oder bei anderen routern auch ?) noch eine portrange zusätzlich freigeben ? und unter passive ip die eigene dyndns eintragen ?
würde mich auch hier freuen nochmal antworten zu meinen fragen zu bekommen.
 

Supernature

Und jetzt?
Teammitglied
Wenn man Port 21 verwendet, dann "weiß" die Fritz!Box auch, dass für den PASV-Modus weitere Ports benötigt werden, und gibt diese bei Bedarf frei. Darum muss man dann auch im G6 weiter nichts einstellen.
 

seker

Herzlich willkommen!
Hallo


Ich habe es doch nicht lösen können. Bei meinen ganzen Einstellungsversuchen habe ich anscheinend Firewall vom Router ausgeschaltet gehabt. So dass es funktioniert hat. Und wenn ich diese Firewall wieder einschalte habe ich keinen Zugriff. Ich werde jetzt ein paar Screenshots machen. Vielleicht kann man mir ja dann auch besser helfen


Danke

PS: Screenshot

Welche Screenshots braucht Ihr vom Server?



 
Zuletzt bearbeitet:

dogfriend

Herzlich willkommen!
@ Supernature

no a froag: wieviele PASV ports muß man freigeben bzw. wie setzt sich diese anzahl des portrange zusammen wenn man 5 oder 10 user zulassen möchte ???
danke im voraus.
 
Oben