Ubuntu Hilfe beim Einrichten und Aufzeichnen von Ton in (gtk-)recordMyDesktop

Pixel-Toast

schläft auf dem Boardsofa
Guten Abend zusammen :)

Ich versuche schon seit einer Ewigkeit bei recordMyDesktop den Ton mit aufzuzeichnen, was mir bisher nie gelungen ist.

Als Soundtreiber benutze ich PulseAudio, welches ich auch in den Einstellungen, unter Audio so eingestellt hab (PULSE).

Leider bekomme ich weder so, noch über die Konsole mit dem Befehl...
recordmydesktop --device pulse
...den Ton aufgezeichnet.

Da ich noch ein ziemlicher Anfänger bin, was Linux betrifft, hoffe ich einfach mal, dass mir jemand bei meinen Problem helfen kann, wie ich doch noch Ton aufzeichnen könnte.

Habe mir auch mehrere Anleitungen auf YouTube angesehen, doch keine hat bei mir funktioniert :(
 

Bio-logisch

Moderator
Teammitglied
Typischer Weise könnten die Mixer - Einstellungen schuld sein. Hast Du da ein Gerät als Aufnahmequelle ausgewählt?

Kenne leider das Programm nicht selber, daher bitte auch die Anleitungen, die Du schon ausprobiert hast mit benutzen!
 

ZuluDC

assimiliert
Guck doch mal hier oder hier.

PULSE gross geschrieben wäre falsch; es muss klein geschrieben sein. Bei mir ging es nicht ohne neu zu booten.

Ubuntu und Audio ist irgendwie auch so ne Geschichte seit PulseAudio werkelt und dass bei einer Neuinstallation xorg bei mir nur Flimmerwerk bietet, wenn ich nicht händisch ne xorg.conf erstelle, geht mir immer grausam auf den Sack - das war auch schon besser. Und die integration von Kde in Kubuntu halte ich schlicht für ein Verbrechen...
 

Pixel-Toast

schläft auf dem Boardsofa
Typischer Weise könnten die Mixer - Einstellungen schuld sein. Hast Du da ein Gerät als Aufnahmequelle ausgewählt?
Hallo Bio-logisch.

Ich habe im AlsaMixer (via Konsole, da mir die Grafische Oberfläche nicht zusagt) unter Capture die Aufnahme für meine Soundkarte aktiviert und auf 100% gestellt, leider ohne Erfolg :(

Guck doch mal hier oder hier.

PULSE gross geschrieben wäre falsch; es muss klein geschrieben sein. Bei mir ging es nicht ohne neu zu booten.
Hi ZuluDC :)

Nach der Anleitung von UU bin ich schon vorgegangen, daher habe ich es auch mit dem Konsolen-Befehl versucht (sowohl groß, als auch klein geschrieben), leider hat mich dies nicht wirklich weitergebracht.

Dein zweiter Link scheint da schon interessanter, danach habe ich es selbst nochmal mit dem Befehl...
$ recordmydesktop --device hw:NVidia,0
...versucht (im Anschluss erneut mit ,1), leider auch hier wieder ohne Erfolg :(

Später habe ich es auch mit der Grafischen Oberfläche nochmal ausprobiert, doch beide Versuche sind ohne Veränderungen zu vorher fehlgeschlagen.

edit:
Ich bin jetzt nach einer anderen Anleitung im UU-Forum vorgegangen, wozu man zusätzlich noch das Programm pavucontrol installieren muss.

Damit konnte ich jetzt Ton aufnehmen, wenn auch nur sehr leise :)

Falls einer weiß, wie ich den Ton lauter bekomme, bedanke ich mich nochmal, aber immerhin habe ich ja schonmal Ton aufgenommen bekommen :D
 

Anhänge

  • Bildschirmfoto-trigger@ubuntu: -proc-asound-card0.png
    Bildschirmfoto-trigger@ubuntu: -proc-asound-card0.png
    22,4 KB · Aufrufe: 376
Zuletzt bearbeitet:

ZuluDC

assimiliert
Also ich hatte recordMyDesktop zwar installiert, aber noch gar nie mit Ton aufgezeichnet. Erst Deine Bitte um Hilfe hat mit veranlasst bei mir selber zu gucken ; und siehe - Still war's im Walde draussen :)

Nachher habe ich halt im Web nach Lösungen gesucht und zuerst eigentlich erreicht, dass ich generell gar keine Sound mehr im System hatte. Da dachte ich:"Oh Schreck, das hat man davon - jetzt brauche ich Hilfe" :-/

Alles was nach Capture oder so roch habe ich angedreht und aktiviert und ehrlich gesagt hat nie was funktioniert; jegliches Restarten von alsa-utils und pulseaudio in /etc/init.d/ zeigte keine Reaktion. 100%ig kann ich es wirklich nicht mehr sagen, aber mein Gefühl sagt es lag nur am Eintrag pulse in den Optionen von recordMyDesktop und der REBOOT. Da Du auch einen Nvidia-Onboardsound hast (vermute ich mal so), ist es bei Dir wahrscheinlich ähnlich wie bei mir.

Innerhalb des Alsamixers kannst Du Dich mit den Pfeiltasten bewegen, es sind sicherlich noch viel mehr Fader bei Dir vorhanden als im Anhangsbild (sonst würde wahrscheinlich etwas nicht stimmen). Rechte Pfelitaste springt von Fader zu Fader nach rechts - mittels "Pfeil nach oben" reisst Du den Gain resp. das Volume auf. Ich würde jetzt einfach mal ned zimperlich sein und überall den Hahn zu sicher 2/3 öffnen wo es nur geht und dann mal gucken ob es lauter ist.

Mehr kann ich eigentlich ned sagen - Audio ist ein Buch mit sieben Siegeln für mich unter Linux - hauptsache ich bringe es irgendwie immer zum Laufen.
 

Pixel-Toast

schläft auf dem Boardsofa
Das der Ton unter Linux ein Problem ist (von den Einstellungen her) kenne ich wohl, nicht nur bei rmD sondern auch bei Spielen.

Habe alles "auf volle Pulle" stehen, aber der Ton wird dennoch sehr leise aufgezeichnet.

Muss auch darauf achten, dass ich in den Einstellungen den Richtigen Anschluss wähle, sonst schmiert mir PulseAudio ab.

Ich lade gerade ein Video bei YouTube hoch, wenn es oben ist, verlinke ich es mal :)

Link zum Video
 
Zuletzt bearbeitet:
Oben