G6 Passiv Router fragen bzw Probleme.

trecordings

bekommt Übersicht
Hallo Leute.

Ich habe ein merkwürdiges problem mit meinem G6 FTP seit ich einen Router habe.

Ihr ahnt es schon wieder das passiv problem.
Ich habe nun fast alle Threads hier durchgelesen und auch hinbekommen nur warum es nun geht das ist die Frage.

Also von vorne.
Habe im Router Port 20-21 und die passiv Ports 60000-60050 freigegeben.(TCP)
Dasselbe habe ich in G6 gemacht.

Nun hatte ich das problem das ich beim Test immer nach dem List Commando ein Data Connection fehler bekommen habe.

Im grunde genau dasselbe was hier besprochen ist.
https://www.supernature-forum.de/g6...-router.html?highlight=g6+425+data+connection

Nun habe ich zufällig den Portrange in G6 und Router auf 30000-30050 gestellt. Nun sind die fehler weg.

Nun frage ich mich warum gibt es beim Portrange 60000-60050 bei jedem 2 logginversuch diesen fehler beim list und bei den Port Range 30000-30050 nicht?

Irgendwie erscheint mir das nicht logisch.
Auch das ich bei mehrmaligen versuchen ab und zu reingekommen bin verstehe ich nicht so ganz.

Oder kann es sein weil so viele probleme haben das provider bestimmte Ports geblockt haben?

Provider Alice
 

Supernature

Und jetzt?
Teammitglied
Könnte natürlich schon am Provider liegen, eine andere Erklärung fällt mir jedenfalls nicht ein. Die Ports um 60000 sind auch nicht besser oder schlechter als die um 30000 - insofern würde ich sagen: Hauptsache, es funktioniert.
 

MaXg

assimiliert
Kann auch sein das die 60000-60050 schon anderweitig belegt sind.

Ansonsten wie Supi schrieb: hauptsache es geht. :)
 

MaXg

assimiliert
Tip: Mit dem Kommandozeilenbefehl "netstat -a" bekommt man zumindest heraus ob was mit diesen ports arbeitet.
 
B

Brummelchen

Gast
Ich habe dazu auch eine DAU-Frage.

Warum hängt ein FTP-Client am MLSD-Kommando (also LIST), und beendet sich mit
einem GPF, wenn er beim DL durch die Verzeichnisse geht?
(also wenn ich ein Verzeichnis mit Uvz herunterladen, hangelt sich der Client durch
und stürzt dabei ab, auch wenn Daten heruntergeladen werden in dem Moment, der
Absturz aber später erst erfolgt)

G6 läuft auf PASV mit speziellen Ports, im Router sind die aber so nicht eingetragen,
nur der Arbeitsport (21/22, als "special app", wird also dynamisch geöffnet statt statisch).

Zwei Probleme, bitte getrennt behandeln, das Absturz-Problem trifft hier nämlich nicht
zu, dafür das verzögerte Login. Nach dem Login sind nur virtuelle Pfade zu sehen.
Im Client ist schon "Server hinter NAT" aktiviert, macht aber keinen Unterschied.

Was mir am Log im Client auffällt, es werden auch nicht die voreingestellten PASV-Ports
benutzt, sondern höhere.
Der G6-Test von G6 aus sagt auch alles ok, aber auch die höheren Ports eben.
Und ob ich in "Passive-IP" die dyndns eingebe oder nicht, ist auch irgendwie egal!?
 

Supernature

Und jetzt?
Teammitglied
GPF? Uvz? Was das? :crazy

zu den PASV-Ports: Das kommt ganz auf den Router an, viele aktuelle benötigen nur noch die Freigabe auf Port 21, sonst muss man weder am Server noch am Router irgendwas einstellen - bei der Fritz!Box ist das zum Beispiel so.
Wenn Du bei Dir die Logs von Server und Client vergleichst, wirst Du feststellen, dass der Server schon die vorgegebenen Ports nutzt, aber beim Client was anderes ankommt - das macht der Router.
 
B

Brummelchen

Gast
- General Protection Fault
- UnterVerZeichnisse

;)

Also ohne PASV-Ports freizugeben klappt das auch. Nur das eben nicht die
Voreingestellten genommen werden, sondern höher (hochzählend).
Wozu leg ich dass dann fest?

Und warum hängt der Client bei MLSD?
 

Supernature

Und jetzt?
Teammitglied
Zuerst nochmal wegen der PASV-Ports: Schau mal genau, was im Server-LOG bei "Entering passive mode" steht und vergleiche das mit den voreingestellten PASV-Ports - ich bin mir ziemlich sicher, das passt.

Und was die Abstürze des Clients angeht, würde ich auch gerne mal das Server-Log dazu sehen, sonst kann man da nur raten - oder es pauschal auf den Client schieben, der ist im Zweifel immer schuld :p
Es handelt sich nicht zufällig um eine der berühmten Verzeichnisstrukturen mit 346 Unterverzeichnissen, deren Namen jeweils aus 68 Sonderzeichen bestehen? ;) Dann wäre die Ursache auch klar.
 
B

Brummelchen

Gast
Ja klar, meine Verzeichnisse liegen extrem g'schachtelt und sind alle verschlüsselt :ROFLMAO:
Schliesslich könnte man mir ja was klauen.
Nö, zum GPF nix im Log bei mir, aber der Client murmelt immer was von bla und wirft
eine Nummer aus. Müsste ich mir schicken lassen, weil ich es selber nicht habe.
(Selbsttest über Net, nicht LAN, weil "max up"="max down")

Also die PASV-Ports sind auf 50000-50999 festgelegt, aber der Client hat mir ständig
welche über 63000 abgezeigt. Ohne PASV um die 1600-1800. Und das zeigt auch der
G6-Test an.

Ping ;)
 

Supernature

Und jetzt?
Teammitglied
Was der Client sagt ist unwichtig, nur das Server-Log gibt Auskunft darüber, welche PASV-Ports er benutzt.
Wie gesagt, bei mir ist das genau so - der G6 nutzt die vorgegebenen Ports, aber beim Client kommt ein anderer an - das macht die Fritz!Box.
 
B

Brummelchen

Gast
brabbel Logbuch, du stellst Anforderungen :D

>> Entering Passive Mode (,195,89) -> 50009

Ja toll >> Deine IP ist :60290

Bei MLSD kam immer
> 425 Cannot open data connection.
> 550 No port specified.

Hängt das evtl damit zusammen?
> 501 PASV not allowed.

PASV ist ja hier erlaubt, es war ausgeschaltet zu Testzwecken.

In der Hilfe-Datei ;)
http://www.g6ftpserver.de/handbuch/documents.html
wird da auch nicht näher drauf eingegangen
(diese 550 Meldung wird nur bei G6 verwendet ;))

PS warum wird eigentlich eine Kompression benutzt, obwohl ausgeschaltet?
MLSD
>> 226-Compression : 105.36% (216 Bytes/205 Bytes)

Und warum hängt MLSD bei virtuellen Verzeichnissen?
Ohne ratzfatz drin.

(erledigt - der zweite Host ist offline)
 
Zuletzt bearbeitet:
Oben