FTP-Server klappt nicht

MarioKappert

fühlt sich hier wohl
Wie in der ueberschrift beschrieben klappt mein FTP-Server nicht.
Erstmal anfangs daten.:
ich habe einen Sinus 154 dsl basic 3 Router.
Windows XP home SP II aber firewall deinstalliert.
Ich benutze BulletProoft FTP Server und ich habe schon volgendes Tutorial gelesen aber es klappt trotzdem nicht :Klick!

Also bei meinem Router kann man keine von - bis Ports freischalten sonder nur einzelne das ist schonmal sch*** aber nichts destotrotz habe ich Port 20, 21 , 55000 , 55001 , 55002 freigeschalten auf meiner 192.168.2.100 IP.
mehr Ports benötige ich ja nicht , da bei meinem FTP server nicht soviel Verkehr sein wird.
Ich habe bei Bulletproof auch Port-range 55000-55002.
Danach habe ich einen Benutzer+Passwort erstellt udn im Dateien zur verfügung gestellt.
Jetzt bin ich unter "Multi IP Settings" gegangen und habe dort meine ip reigeschrieben(die konnte ich unten schon auswaehlen weil sie dort stand)
Nun bin ich auch "Passiv Mode" gegangen und habe dort "Passive Mode" aktiviert und habe erstmal "FixedIP" genommen und da die ip reingemacht die ich unter :Wieistmeineip nachgelesen habe.(Mit dynamic IP auch getestet(kappert.dyndns.tv))

Ich denke so sollte es ja richtig eingestellt sein.
Ich testete es bei www2ftp und kam auch rein , aber wenn ich meine ftp daten an Freunden schicke kommen sie nicht drauf..habe ich doch was falsch eingestellt?oder hab ich noch ein anderes Problemwegen Router etc.?

Hier noch ein Log von BulletProof vielleicht seht ihr darin schon etwas :
Code:
(000033) 21.12.2006 16:44:45 - (not logged in) (83.135.201.233) > connected to ip : 192.168.2.100
(000033) 21.12.2006 16:44:45 - (not logged in) (83.135.201.233) > sending welcome message.
(000033) 21.12.2006 16:44:45 - (not logged in) (83.135.201.233) > 220 Marios-FTP
(000033) 21.12.2006 16:44:45 - (not logged in) (83.135.201.233) > USER mario
(000033) 21.12.2006 16:44:45 - (not logged in) (83.135.201.233) > 331 Password required for mario.
(000033) 21.12.2006 16:44:45 - (not logged in) (83.135.201.233) > PASS ********
(000033) 21.12.2006 16:44:45 - mario (83.135.201.233) > logged in.
(000033) 21.12.2006 16:44:45 - mario (83.135.201.233) > 230 User mario logged in.
(000033) 21.12.2006 16:44:45 - mario (83.135.201.233) > PWD 
(000033) 21.12.2006 16:44:45 - mario (83.135.201.233) > 257 "/" is current directory.
(000033) 21.12.2006 16:44:45 - mario (83.135.201.233) > EPSV ALL
(000033) 21.12.2006 16:44:45 - mario (83.135.201.233) > 500 Unknown command.
(000033) 21.12.2006 16:44:45 - mario (83.135.201.233) > REST 0
(000033) 21.12.2006 16:44:45 - mario (83.135.201.233) > 350 REST supported. Ready to resume at byte offset 0.
(000033) 21.12.2006 16:44:45 - mario (83.135.201.233) > TYPE I
(000033) 21.12.2006 16:44:45 - mario (83.135.201.233) > 200 Type set to I.
(000033) 21.12.2006 16:44:45 - mario (83.135.201.233) > MODE B
(000033) 21.12.2006 16:44:45 - mario (83.135.201.233) > 504 Command not implemented for that parameter.
(000033) 21.12.2006 16:44:45 - mario (83.135.201.233) > PASV 
(000033) 21.12.2006 16:44:45 - mario (83.135.201.233) > 227 Entering Passive Mode (217,231,113,237,214,216)
(000033) 21.12.2006 16:44:46 - mario (83.135.201.233) > LIST 
(000033) 21.12.2006 16:45:18 - mario (83.135.201.233) > disconnected. (00:00:33)

mfG
Kappert , Mario
 

MarioKappert

fühlt sich hier wohl
Supernature schrieb:
Der Test über www2ftp funktionierte? Dann kannst Du eigentlich davon ausgehen, dass der Server funktioniert und die anderen ein Problem haben.
Mach mal hier noch einen Test und poste die Ausgabe:
Gene6 FTP Server ™ - Online FTP Test

Er funktionierte nicht nur , sonder funktioniert immernoch.
Welche Probleme koennten andere denn habe?(Bis jetzt haben es 4-5 Personen probiert)
Achja ich hatte vor kruzem Cerberus FTP_Server und nur Port 20-21 freigeschalten und 2 Leute konnten auf den Server was runter laden und so aber nachdem ich den Server neugestartet hatte konnte keiner mehr drauf obwohl ich nichts verändert hatte.Ich kam sogar selbst schonmal drauf(ich meine nicht ueber lokal)aber das soltle ja nicht gehen wegen dem "pasv mode".

Hier das Log von G6:
Code:
* About to connect() to 217.231.76.237 port 21
* Trying 217.231.76.237... connected
* Connected to 217.231.76.237 (217.231.76.237) port 21
< 220 Marios-FTP 

> USER mario 
< 331 Password required for mario. 

> PASS *****
< 230 User mario logged in. 

> PWD 
< 257 "/" is current directory. 
* Entry path is '/'

> CLNT Testing from http://www.g6ftpserver.com/ftptest from IP 217.231.76.237 
< 200 "Testing from http://www.g6ftpserver.com/ftptest from IP 217.231.76.237" noted. 

> FEAT 
< 211-Extensions supported: 
< CLNT 
< MDTM 
< PASV 
< REST STREAM 
< SIZE 
< 211 End. 

> PASV 
* Connect data stream passively
< 227 Entering Passive Mode (217,231,76,237,19,138) 
* Trying 217.231.76.237... Timed out
* couldn't connect to host
* Connection #0 to host 217.231.76.237 left intact

* Closing connection #0
 

Supernature

Und jetzt?
Teammitglied
In dem LOG sieht man aber schon das Problem - im PASV-Modus kann nichts gelesen werden. Bei dem Test hat der Server den Port 5002 verwendet - hast Du vielleicht irgendwo einen Tippfehler in der Konfig?
Oben schreibst Du ja was von 55000
 

MarioKappert

fühlt sich hier wohl
Ich habe in Bullet Prooft range 55000-55002 und diese Ports im Router auch freigeschaltet , deshalb verstehe ich nicht warum es nicht klappt :D

Bilder
 
Zuletzt bearbeitet:

Supernature

Und jetzt?
Teammitglied
Nimm mal testweise die PASV-IP raus und auch die Portfreigaben für 55000-2 im Router und versuche es dann nochmal.
 

MarioKappert

fühlt sich hier wohl
Code:
* About to connect() to 217.231.76.237 port 21
* Trying 217.231.76.237... connected
* Connected to 217.231.76.237 (217.231.76.237) port 21
< 220 Marios-FTP 

> USER mario 
< 331 Password required for mario. 

> PASS *****
< 230 User mario logged in. 

> PWD 
< 257 "/" is current directory. 
* Entry path is '/'

> CLNT Testing from http://www.g6ftpserver.com/ftptest from IP 217.231.76.237 
< 200 "Testing from http://www.g6ftpserver.com/ftptest from IP 217.231.76.237" noted. 

> FEAT 
< 211-Extensions supported: 
< CLNT 
< MDTM 
< PASV 
< REST STREAM 
< SIZE 
< 211 End. 

> PASV 
* Connect data stream passively
< 227 Entering Passive Mode (217,231,76,237,19,138) 
* Trying 217.231.76.237... connected
* Connecting to 217.231.76.237 (217.231.76.237) port 5002

> TYPE A 
< 200 Type set to A. 

> LIST 
< 150 Data connection accepted from 87.98.200.117:2849; transfer starting. 
######################################################################## 100,0%< 226 Transfer ok 
######################################################################## 100,0%drwxr-xr-x 1 ftp ftp 0 Dec 09 19:02 AntiVir PersonalEdition Classic

Super es geht es können auch andere drauf :) danke.
aber wieso muss passiv aus? und was istmorgen? da hab ich ja ne andere ip was muss ich dann machen , oder geht das automatisch also neue ip im bulletproof.
Und wieso klappt das?ist doch kein port frei

Eine Erklärung wäre nett,danke
 

MaXg

assimiliert
Im ersten post schreibst du das du fixed IP ip markiert und was eingetragen hast.
Diese IP MUSS IMMER deiner tatsächlichen Öffentlichen IP entsprechen.
217.231.76.237 muss in deinem Fall mit der hier identisch sein ->
only-ip

Wenn du einen Provider mit Dynamischer IPvergabe hast, solltest du dir einen dyndns Account anlegen.
 

MarioKappert

fühlt sich hier wohl
ja also ich habe einen account bei dyndns aber der ist komischerweise nicht immer erreichbar deshalb will/wollte ich lieber fixedip nehmen und da meine tägliche IP reichmachen.Da muss doch die ip von Wie ist meine IP-Adresse?
rein oder?
Ich habe ja im moment PASV-MODE aus geschaltet welcher mode ist jetzt drin? und um dynamic dns zu machen muss ich ja wieder PASV anschalten und dann klappt es ja nicht

EDIT:Ich kann bei mir im Router "Dynamische DNS" einschalten, da steht auch schon "dyndns" oder so anderer anbieter was bringt das?
und ist der Domänename bei mir jetzt kappert.dnsalias.net ?

Hab ja jetzt meine dyndns daten im Router und nun kann ich bzw andere auf meinem Server aber ich habe PASV mode deaktiviert im Router wieder Port 55000-55002 freigegeben.
 
Zuletzt bearbeitet:
Z

ZickZack

Gast
MarioKappert schrieb:
ja also ich habe einen account bei dyndns aber der ist komischerweise nicht immer erreichbar
Du musst auch dafür sorgen, dass die IP-Adresse dem Dyndns-Service bekannt wird, wenn sie sich ändert. Dazu kannst Du entweder den DynDns-Updater verwenden oder im Router die entsprechende Update-Routine freischalten. Wie
Dein Domainname lautet, kannst nur Du wissen. ;) Dazu musst Du im Router den Dienstnamen (z. B. dyndns.org), den Benutzernamen und das dazugehörige Passwort eintragen.
 

MarioKappert

fühlt sich hier wohl
ja ich benutze den dyndns updater aber trotzdem sind die adressen manchmal nicht erreichbar keine ahnung warum...

Gut hab ich es im Router richtig eingestellt : D

Aber ich gehje doch jetzt trozdem ueber den PASV MODE rein oder?
Meine Frage : Warum muss PASV bei Bulletproof aus?Aber man ist trotzdem im PASV? :)
 

Supernature

Und jetzt?
Teammitglied
Von der Geschwindigkeit her macht das keinen Unterschied.
Dein erfolgreicher Test war aber MIT PASV. Du hast das auch nicht ausgeschaltet, sondern nur die Einstellungen geändert. Dein Router regelt die Freigabe der PASV-Ports selbständig, das tun inzwischen sehr viele.

Was DynDNS angeht, ich nutze das seit 5 Jahren und hatte noch nicht einen einzigen Ausfall. Wenn Du da Probleme hast, kann es eigentlich nur am verwendeten Updater oder dessen Einstellungen liegen.
 

MarioKappert

fühlt sich hier wohl
Achso also d.h ich brauch keine Ports etc. freischalten , denn es geht alle automatisch bei meinem Router?

Also danke für deine/eure Hilfe aber noch eine Frage.
Wie macht man Port mode und kannst du ein besseres Programm als Bulletprooft empfehle , weil ich finde die uebersicht der download sehr mangelhaft da man nicht sehr gut erkennt was der user grade treibt...
und G6 finde ich nicht gut,weil es schwer verständlich ist.
Ich habe Serv-U auch getestet ist auch nciht schlecht aber gibt es da sonst noch was zu empfehlen

Zu dynnds:
Wenn ich versuche mein accoutn bei mir also kappert.dyndns.tv anzupingen steht da "Kein Zielnetz erreichbar"

mfg

Mario
 
Zuletzt bearbeitet:

Supernature

Und jetzt?
Teammitglied
Bei mir wird die dyndns-Adresse zu einer IP aufgelöst, Antwort auf Ping kommt aber auch nicht.

Was alternative Server angeht - es gibt so viele, probier einfach noch ein paar aus.
 
Zuletzt bearbeitet:

andy68

kennt sich schon aus
ftp server funzt nicht

hallo

hab versucht mitQuick`n Easy FTP Server 3.1 Lite einen Server einzurichten was nicht klappt.
Mein System ist win xp media center, router von d-link di 524 mit neuestem treiber.
im router sind die ports 20 und 21 auf meinen pc freigegeben.
am router hängen mehrere clients.
der server ist im lan zu erreichen aber nicht über internet.
im serverprog wir folgendes im log angezeigt:

21:50:23.046 [4008] FTP Server started on port 21.
21:53:49.828 [1288] Client connected from 87.98.200.117.
21:53:49.828 [1288] 220 Welcome to Quick 'n Easy FTP Server
21:53:49.843 [1288] USER anonymous
21:53:49.843 [1288] 331 Password required for anonymous
21:53:49.875 [1288] PASS *************
21:53:49.875 [1288] 230 User successfully logged in.
21:53:49.890 [1288] PWD
21:53:49.890 [1288] 257 "/" is current directory.
21:53:49.906 [1288] CLNT Testing from Gene6 FTP Server ™ - Online FTP Test from IP 84.56.208.132
21:53:49.906 [1288] 502 Command not implemented - Try HELP.
21:53:49.921 [1288] Client disconnected from 87.98.200.117.

ich habe auch schon den thread ftp server probleme oben gelesen und alles probiert was da steht.
hoffentlich kann mir jemand helfen DANKE
 

Bio-logisch

Moderator
Teammitglied
Herzlich willkommen auf dem Wohlfühlboard!
Das sieht eigentlich sehr gut aus:
Login und Passwortabfrage funktionieren ja.
 
Oben