Frage zum Thema Routing

F2B

kennt sich schon aus
Hallo Leute,

also folgende Konfiguration:
- T-DSL Modem (Teldedat 300 LAN)
- IPCOP als Proxy und Firewall (Rot / Grün)
- Netgear Router FR114P
- drei Clients im Netzwerk (Arbeitsgruppe)
- DHCP wird nicht genutzt

Ich möchte, daß die drei Clients über den Router und dann über IPCOP ins Internet gehen. Also Client --> Router --> IPCOP --> Internet

Wie stell ich das an ???? Irgendwie bin ich zu blöd dafür
Wenn ich auf dem Client den Gatway + DNS-Server auf IPCOP einstelle funzt alles prima, nur wenn ich den Gatway + DNS-Server auf den Router einstelle geht nichts mehr.

Ich vermute, das es an dem liegt, daß ich an dem Router eingestellt habe, das er die IP und die DNS automatisch vom ISP bekommt. Ich kann doch keine statische IP und DNS zuweisen. Also was wie wo muß ich einstellen?
Ich hoffe, ich hab mich klar genug ausgedrückt und Ihr könnt mir helfen......

Cu F2B
 

Supernature

Und jetzt?
Teammitglied
Ich weiß nicht, ob das so überhaupt funktionieren kann. Wenn der Router hinter IPCOP hängt, dann hat er ja keine direkte Verbindung mehr zum Modem, also kann er auch keine DSL-Verbindung aufbauen, das müsste dann IPCOP erledigen (wenn es das kann, ich kenne das Programm nicht).
 

F2B

kennt sich schon aus
Halo Supernature,
yepp IPCOP baut die DSL-Verbindung auf. Ich müsste, meiner Meinung nach dem Router nur beibringen, das es die DSL-Verbindung vom IPCOP nutzen soll...... Oder?

Cu F2B
 

Supernature

Und jetzt?
Teammitglied
Genau - also in meinem Router-Setup gibt es die Möglichkeit, keine PPPoE-Verbindung zu konfigurieren, sondern dem Router einfach einen statische IP-Adresse zu vergeben - somit wird er zu einem "normalen" Netzwerk-Client. So müsstest Du das machen, und IPCOP müsste dann so konfiguriert werden, dass es Deinen Router auch als Client erkennt.
 

primatenmann

nicht mehr wegzudenken
DHCP?

Hallo

Willst Du denn die Ip's per DHCP vergeben oder lieber manuell? Der Fehler könnte auch in einer falschen Subnetmaske sitzen.

gruss primatenmann
 
Oben