[Frage] Upstream Traffic bricht immer ein

SoGX

bekommt Übersicht
Upstream Traffic bricht immer ein

Hallo,
hab seit dem Upgrade vom BPFTP auf den neuen G6 FTP Server Probleme mit meinem upstream Traffic, dieser bricht kontinuierlich ein und geht dabei bis auf 0/kb's zurück und ich hab keine Ahnung wieso.
Im BPFTP konnt ich das bisher noch nicht beobachten.
Hänge an einer ADSL2+ Leirung mit nem upstream von einem MBit.

Hab mal ein Pic angehängt, wie sowas in der Praxis aussieht.



MfG
 

Anhänge

  • traffic.jpg
    traffic.jpg
    120,1 KB · Aufrufe: 107

Supernature

Und jetzt?
Teammitglied
Hm, doofe Sache - würde der Transfer ganz abbrechen, könnte man wenigstens was aus dem Log lesen.
Läuft nebenher noch eine andere Anwendung, die Upload benötigt?
Dann könnte es evt. was bringen, wenn man die Priorität des Server-Dienstes erhöht (Unter FTP-Server - Eigenschaften).
 

SoGX

bekommt Übersicht
Das war ja ne Blitzantwort ;)
Nebenher läuft noch Utorrent, hab da aber den upstream auf 50 kb/s gedrosselt.

Dein Tip mit der Priorität hat auch nichts gebracht.

Geschwindigkeit schwankt immernoch zwischen 0-50 kb/s :(
 

KOENICH

der Monarch
Versuch es mal ohne utorrent oder maximale Verbindungen auf einen sehr niedrigen Wert zu stellen - ich meine mich zu erinnern, dass ich auch mal ziemlich Probleme hatte im Zusammenspiel von G6 und Torrents hatte, da letztere sehr viele Verbindungen aufbauen und der FTP dadurch benachteiligt wird.
 

SoGX

bekommt Übersicht
so, hab's jetzt nochmal komplett ohne utorrent versucht
geschwindigkeit geht zwar nich mehr bis auf 0 zurück, schwankungen sind aber immernoch extrem, meine leirung gibt ca 1000 connects/min her, laut speedmeter.de.
ftp uploads, die von mir ausgehen, zb auf testservern laufen ohne diese einbrüche konstant mit 115 kb/s

hab nochmal n' screenshot angefügt
 

Anhänge

  • traffic.jpg
    traffic.jpg
    92,1 KB · Aufrufe: 102

SoGX

bekommt Übersicht
kann es vllt auch daran liegen, das ein user 2 connects aufbaut und der server versucht, die geschwindigkeit auf beide zu verteilen und der einen erst mehr speed gibt, dann der anderen und das immer im wechsel und das dabei so'ne kurve zustande kommt?
 

koloth

Chef-Hypochonder
Ich tippe auf Folgendes:

Die bis zu 1000 connects kommen daher, dass die vorher verbundenen Torrent-Clients alle noch Deine IP kennen und versuchen, sich wieder zu verbinden.

Die schwankende Kurve könnte auch daher kommen, dass Dein User mehrere kleine Dateien zieht. Die Einbrüche kommen dann durch die ftp-Befehle, die zwischen den einzelnen Downloads liegen. Die Kurve steigt ja immer sehr schnell wieder an.
 

SoGX

bekommt Übersicht
mit den kleinen dateien kann ich ausschließen.

kann es vielleicht sein, daß das abfrageintervall zu niedrig ist, im schnitt über insgesamt 5 min komm ich auf durchschnittlich 115 kb/s von max 128?
also sollte soweit doch alles io sein, oder ist das trozdem nicht normal?
 

Supernature

Und jetzt?
Teammitglied
Mal ganz blöd gefragt: Könnte es vielleicht auch sein, dass einfach nur die grafische Darstellung nicht stimmt? Hast Du mal mit einem der Clients reden können, ob er diese Schwankungen auch wahrnimmt?
 

MaXg

assimiliert
Dieses kleine Tool könnte beim ermitteln der tatsächlichen Geschwindigkeit hilfreich sein.

klick [ddl, 220kb, keine Installation nötig]
 

SoGX

bekommt Übersicht
hab jetzt nochmal n' bischen rumprobiert, hab das tool von maxg getestet, sowie n' traffictool, welches via snmp den traffic direkt am router ausliest.
bei gleicher konfiguration und ohne jegliche bandbreitenbeschränkung hab ich beim alten bpftp server nen mittleren datendurchsatz, der ca 15-20kb/s höher liegt als beim g6 ftp.
in anbetracht der tatsache, das ich einen upstream von netto 115 kb/s habe, wovon schon allein 50kb/s für den torrent weggehen, find ich das schon ne menge.
kann mir das einfach nich erklären.

würde auch beim alten server bleiben, leider sind anscheinend diverse befehle, die neuer clients benutzen nich implementiert. zum beispiel funktioniert das resumen nicht immer, da versucht wird den zeitstempel zu ändern, was nur funktioniert, wenn ich den usern auch löschrechte gebe, was ich nur ungern mache. für lösungsansätze diesbezüglich bin ich natürlich auch offen ;)

mfg
 
Oben