[Frage] Sound abspielen?

ftprobi

Herzlich willkommen!
Sound abspielen?

wie kann man bei connect einen Sound abspielen, bei der alten Version hat das funktioniert, wurde unter events eingebunden

vielleicht weiss hier wer eine Lösung für das Problem

Danke
 

Supernature

Und jetzt?
Teammitglied
Die Option "Play sound" gibt es in der neuen Version nicht mehr.
Wenn man für den Event "OnClientConnected" bei Execute eine Sounddatei vorgibt, wird sie wahrscheinlich mit dem Standardplayer geöffnet, das wäre natürlich nicht das Wahre.

Aber mit einem kleinen DOS-Script, welches den Sound abspielt, könnte es klappen - nur leider weiß ich aus dem Stand nicht, wie der Syntax dafür aussehen müsste. Aber ich gehe mal auf die Suche.
 

ftprobi

Herzlich willkommen!
ja das hab ich mir eigentlich auch gedacht und habe wav file eingebunden, komischer weise funktioniert das aber auch nicht, irgend eine exe Datei eingebunden wird auch nicht gestartet, aber ein bat mit einem net send Befehl die funktioniert eigenartiger weise
werde nicht ganz schlau draus

trozdem mal Danke für die prompte Hilfe
 

Supernature

Und jetzt?
Teammitglied
Das von RekiM empfohlene Programm wurde mir auch schon zugespielt, damit habe ich mal über eine bat eine wav-Datei abgespielt, funktioniert prima. Das einzig Störende ist das aufpoppende DOS-Fenster - ich bin da nicht so bewandert, kann man das irgendwie unterdrücken? Dann hätten wir nämlich den perfekten Ersatz.
 

RekiM

kennt sich schon aus
Evtl. mal mit START /MIN CMD... probieren.

Größerer Testreport mit Bugmeldung und Feature-Request folgt in Kürze.

edit: START /INV ... soll angeblich die Session auch verstecken.
 

ftprobi

Herzlich willkommen!
mit dem Tool funktioniert das wave abspielen über eine batch datei bei mir auch, aber wenn ich den batch einbinde in den Evenst funktionierts nicht mehr.
 

Supernature

Und jetzt?
Teammitglied
Also bei mir funktioniert es, und sogar im "silent" Mode, also ohne aufpoppendes DOS-Fenster.
Welchen Event hast Du verwendet? Ich habe es mit "OnClientLoggedIn" und "OnClientConnected" ausprobiert, funktionierte in beiden Fällen.
 

Supernature

Und jetzt?
Teammitglied
Na den Event ausgewählt, den Pfad zur Bat-Datei unter Execute eingegeben und auf OK geklickt - und dann ging es :)
 

ftprobi

Herzlich willkommen!
habe ich genau so gemacht funktioniert bei mir nicht mit Events, wenn ich den batch starte gehts aber

Batch datei inhalt
C:\Programme\bat\wav.exe mwlaser.wav
 

ftprobi

Herzlich willkommen!
so habe den Fehler gefunden, hinter dem Wav file muss man nochmals den Pfad angeben dann funkt.. Hurra
 

speedynews

Herzlich willkommen!
Hallo,

kann mir einer einen Aktuellen Link zu dem Patcher geben ?

Der obrige funzt nicht mehr.

mfg Speedynews
 

Supernature

Und jetzt?
Teammitglied
Ich muss mal sehen, evt. habe ich es noch irgendwo zu Hause auf der Platte liegen.

Edit: Versuch mal eines der beiden Tools im Anhang.
 

Anhänge

  • PlaySound.zip
    1,8 KB · Aufrufe: 394
  • Speak.zip
    9 KB · Aufrufe: 263
B

Brummelchen

Gast
MP/WMP
"C:\Programme\Windows Media Player\mplayer2.exe" /Play /Close "%1"
Mit einer modifizierten Verknüpfung geht das auch fast ohne Fenster (minimiert)
Nachteil, dazu müsste man die LNK per START... aufrufen, was wiederum ein
DOS-Fenster zur Folge hat.

Schön wäre es natürlich, wenn das ohne jegliches Fenster spielen täte.
Welches SpeechSDK brauch denn SPEAK? Es gibt ja zwei (v4/v5),
die nicht kompatibel sind. Ah ja, Playsound spielt ohne Fenster.
Da ich für "Programm schliessen" allerdings bereits einen Klang habe,
wird der auch abgespielt. Schade, dass diese Option entfernt wurde.
 
Zuletzt bearbeitet:
Oben