[Frage] Bei Verbindungsversuch: 421 Not logged in, access denied

sylenza

nicht mehr wegzudenken
Bei Verbindungsversuch: 421 Not logged in, access denied

Hallo :)

ich habe, nach einigem hin- und her, es immerhin geschafft, einen lokalen Zugriff auf den ftp zu bekommen. Sowohl die telnet- als auch die Browserverbindung funktioniert soweit. Allerdings bekomme ich per Browser nur als "anonymous" eine Verbindung. Mein eingerichteter Test-User (mit dem sinnigen Passwort "test") bekommt keinen connect. Aber das Problem gehe ich später an.

Problematischer ist der Zugriff von außerhalb. Wenn ich den ftp-Test(Gene6 FTP Server - Online FTP Test) starte, bekomme ich folgende Antwort:


* About to connect() to d3testdyn.dynalias.net port 21
* Trying 213.49.191.88... connected
* Connected to d3testdyn.dynalias.net (213.49.191.88) port 21
< 421 Not logged in, access denied.
* This doesn't seem like a nice ftp-server response
* Closing connection #0


Das Server-Protokoll sieht dabei so aus:

06/09/13 05:22:53, starting ...
06/09/13 05:22:53, listens on 192.168.72.99:21
06/09/13 05:22:53, listens on 127.0.0.1:21
06/09/13 05:22:54, listens on 192.168.73.1:21
06/09/13 05:22:54, listens on 192.168.17.1:21
06/09/13 05:23:16, 0, 87.98.200.117, , new connection from 87.98.200.117 on 192.168.72.99:21
06/09/13 05:23:16, 0, 87.98.200.117, , hostname resolved : ns0.gene6.net
06/09/13 05:23:19, 0, 87.98.200.117, , 421 Not logged in, access denied.
06/09/13 05:23:19, 0, 87.98.200.117, , will be disconnected : IP is banned.


Zur restlichen Konfiguration wäre noch zu sagen:

Router (Netgear FWG114P): Die Ports 20,21 sowie 30000 bis 30030 sind geforwardet auf die lokale IP (192.168.72.99);
jeweils in- und outbound.


Im Moment bin ich an einem Punkt des wilden - also planlosen Herumprobierens angekommen, so daß ich mir hier den einen oder anderen Tip erhoffe.

Ich frage mich auch, warum der Server die IPs 192.168.73.1 und 192.168.17.1 (siehe Server-Protokoll) "abhört", aber dafür gibt es sicherlich eine Erklärung für jemanden wie mich, der sich noch nie mit ftp-Servern auseinandergesetzt hat ;)

Gruß, sylenza
 

Supernature

Und jetzt?
Teammitglied
Hallo sylenza :)
Laut Server-Log ist diese IP-Adresse gesperrt (IP is banned)
Möglicherweise bzw. sehr wahrscheinlich hast Du in den Einstellungen für den IP-Zugriff (IP Access in der englischen Version) irgendwas eingestellt, das ist aber im Normalfall gar nicht nötig.

Gibt es die IP-Adressen 192.168.73.1 und 192.168.17.1? Hast Du eventuell mehr als eine Netzwerkverbindung? Standardmäßig lauscht der Server an allen lokalen IPs, die er findet.
 

sylenza

nicht mehr wegzudenken
Hallo Supernature!

Zuerst zu den IP-Adressen 192.168.73.1 und 192.168.17.1: die stammen von den VMs von VMWare - ich hatte die total vergessen aber ich denke, die stören auch nicht.

Unter "IP-Zugriff" (in den Domain-Einstellungen) sind zwei Einträge:
192.168.*
127.0.0.1


sylenza
 

Supernature

Und jetzt?
Teammitglied
Die Einträge hast Du aber selber gemacht, oder? Defaultmäßig steht da nichts drin. Sobald nämlich da ein Eintrag drin steht, wird allen IP's der Zugriff verweigert, die nicht explizit genannt sind - daher ist auch kein externer Zugriff möglich.
 

sylenza

nicht mehr wegzudenken
Ich habe nun die beiden Einträge entfernt, den Server neu gestartet und bekomme immer noch dieselben Meldungen:

ftpTest-Server:

< 421 Not logged in, access denied.
* This doesn't seem like a nice ftp-server response
* Closing connection #0


und (Server-Protokoll):

06/09/13 13:16:01, 3, 87.98.200.117, , new connection from 87.98.200.117 on 192.168.72.99:21
06/09/13 13:16:01, 3, 87.98.200.117, , hostname resolved : ns0.gene6.net
06/09/13 13:16:04, 3, 87.98.200.117, , 421 Not logged in, access denied.
06/09/13 13:16:04, 3, 87.98.200.117, , will be disconnected : IP is banned.


edit:An der XP-Firewall kann es auch nicht liegen, denn ein Deaktivieren führt zum gleichen Ergebnis.
 
Zuletzt bearbeitet:

Supernature

Und jetzt?
Teammitglied
Es liegt ganz sicher am Server, denn er sagt ja selbst "IP is banned"
Diese IP-Zugriffe kann man an verschiedenen Stellen setzen, unter FTP-Server, Domain sowie auch bei den Benutzern und Gruppen.
Geh nochmal alles durch, irgendwo muss noch ein Eintrag drin sein.
 

sylenza

nicht mehr wegzudenken
Supernature schrieb:
Es liegt ganz sicher am Server, denn er sagt ja selbst "IP is banned"
Diese IP-Zugriffe kann man an verschiedenen Stellen setzen, unter FTP-Server, Domain sowie auch bei den Benutzern und Gruppen.
Geh nochmal alles durch, irgendwo muss noch ein Eintrag drin sein.

Beim FTP-Server hatte ich - warum bloß - die gleichen Einträge wie oben beim "IP-Zugriff". Nun sind sie weg und ich bin zumindest ein wenig weiter :)


> USER test
< 331 Password required for test.

> PASS *****
< 230 User test logged in.

> PWD
< 257 "/" is current directory.
* Entry path is '/'

> CLNT Testing from Gene6 FTP Server - Online FTP Test from IP 213.39.193.101
< 200 Noted.

> FEAT
< 211-Extensions supported:
< AUTH TLS
< CCC
< CLNT
< CPSV
< EPRT
< EPSV
< MDTM
< MFCT
< MFMT
< MLST type*;size*;create;modify*;
< MODE Z
< PASV
< PBSZ
< PROT
< REST STREAM
< SIZE
< SSCN
< TVFS
< UTF8
< XCRC "filename" SP EP
< XMD5 "filename" SP EP
< XSHA1 "filename" SP EP
< 211 End.

> PASV
* Connect data stream passively
< 227 Entering Passive Mode (213,39,193,101,117,64).
* Trying 213.39.193.101... Timed out
* couldn't connect to host
* Connection #0 to host d3testdyn.dynalias.net left intact

* Closing connection #0


Hier das "Gegenstück" aus dem Server-Protokoll:
--snip--
06/09/13 15:48:23, 1, 87.98.200.117, test, PASV
06/09/13 15:48:23, 1, 87.98.200.117, test, 227 Entering Passive Mode (192,168,72,99,117,51)
06/09/13 15:53:24, 1, 87.98.200.117, test, disconnected. (00d00:05:01)


Im Server wird mein Test-User auch angezeigt, aber ganz koscher ist es noch nicht. Ich forsche gleich mal im Board weiter nach "timed out" - Fehlern.

//edit: Noch eine Frage (wo ich gerade dabei bin):Sind die Einstellungen im angehängten Screenshot so richtig?
 

Anhänge

  • screen1.jpg
    screen1.jpg
    44,6 KB · Aufrufe: 161

Supernature

Und jetzt?
Teammitglied
Nimm mal die passive IP raus - wie es aussieht, übersetzt Dein Router automatisch richtig.
Wenn das nicht hilft, trag dort mal d3testdyn.dynalias.net ein.
 

sylenza

nicht mehr wegzudenken
Ergebnisse:

Ohne passive IP:

Das gleiche Ergenbis wie mit der lokalen IP:

> PASV
* Connect data stream passively
< 227 Entering Passive Mode (213,39,193,101,117,52).
* Trying 213.39.193.101... Timed out
* couldn't connect to host
* Connection #0 to host d3testdyn.dynalias.net left intact

* Closing connection #0


Mit "d3testdyn.dynalias.net" als passive IP:

anonymous-Login kommt nur bis (Server-Protokoll):
06/09/13 16:21:25, 0, 87.98.200.117, anonymous, 227 Entering Passive Mode (213,39,193,101,117,74)

Der Gene6 FTP Server - Test "hängt sich auf" und zeigt kein Ergebnis.

//und noch ein edit: Es funktioniert (y)

Ich dachte, die XP-Firewall wäre fertig konfiguriert; aber ich habe dort offensichtlich etwas übersehen. Mit dem Deaktivieren der XP-Firewall funktioniert der Test sowohl ohne als auch mit lokaler passiver IP (jedenfalls werden die gleichen Meldungen angezeigt).


Herzlichen Dank an Supernature für die großartige Unterstützung :)
 
Zuletzt bearbeitet:

sylenza

nicht mehr wegzudenken
So, noch ein kleiner Nachtrag: soeben habe ich den Server mal "im richtigen Leben" getestet: alles klappt wunderbar! So macht es richtig Spaß; nochmals "Danke" für den Support!

Gruß, sylenza
 
Oben