[Festplatte] Primary slave drive fails

Blackthorne

assimiliert
Primary slave drive fails

Hallo,

beim Konfigurieren eines Altrechners habe ich 2 IDE-Festplatten eingebaut, die auch beide vom BIOS erkannt werden.

Beim booten bekomme ich allerdings die Meldung "primary slave drive fails". Wenn ich dann F1 drücke, wrid normal gebootet.

Woran könnte das liegen?

:)
 

koloth

Chef-Hypochonder
Andere Frage:
Wie hängen die beiden Platten denn dran?
Primary Master und Primary Slave oder evt. Primary Master und Secondary Master?
Je nachdem, was in der Kiste verbaut ist (falls die Platten alleine als Master an einem Strang sitzen), musst Du sie auf "Master only" setzen. Das könnte die Meldung "slave fails" evt. auch erklären. Schliesslich hängt da dann wirklich nichts dran und die Meldung ist korrekt so. Dann solltest Du dem Controller mit der Jumperung "Master only" mitteilen, dass da wirklich nichts dran hängt.
 

Blackthorne

assimiliert
Das BIOS erkennt beide Platten, Ubuntu als Betriebssystem bis jetzt nur den Master.

Die beiden festplatten hängen am Primary-Strang (als master und Slave), am Secondary hängt ein DVD-Laufwerk.

:)
 

koloth

Chef-Hypochonder
Dann war es das mit "Master only" also nicht.
Wie ist das Bios bzgl. der IDE-Kanäle eingestellt? Auto oder explizit der passende Typ?
 

Blackthorne

assimiliert
Auto.

Wenn ich Auto anklicke, erscheint allerdings der jeweilige Typ - dabei werden beide Platten korrekt angezeigt.

:)
 

koloth

Chef-Hypochonder
Lässt sich dann nicht gleich der korrekte Typ eintragen? Bei Auto wird sonst jedesmal wieder neu "gesucht". Probier doch mal, evt. ist dann auch der Fehler beim ersten Bootversuch weg.

CD-DVD-Laufwerke kann man (wenn man nicht von booten muss) auch auf none statt auto stellen. So lässt sich die Such- und damit Bootdauer ein klein wenig verkürzen.
 

Blackthorne

assimiliert
Ich glaube, es liegt am Jumper bei der Slave-Platte.

Während des Bootvorgangs wird sie korrekt mit Seagate ST380011A angezeigt, im BIOS selbst steht jedoch nur Auto und auch, wenn ich Auto anklicke, wird der korrekte Name nicht wiedergegeben (meine Info von vorhin war insoweit nicht korrekt).

Die Beschreibung auf der Platte, welcher Jumper beim Betrieb als Slave zu setzen ist, ist sehr vage, im Moment habe ich keinen Jumper gesetzt, weil ich dachte, dass das richtig sei).

Kennt jemand die korrekte Stellung der Jumper?

:)
 

Blackthorne

assimiliert
Zunächst einmal danke für den Tipp, aber viel schlauer macht mich das nicht. Die Passage zu den Jumpern wird bei mir wie folgt dargestellt:

ST-380011A (Barracuda 7200.7 80, Ultra ATA/100)

ÉÍÍÍÍÍÍÍÍÍÍÍ»
º REAR VIEW º
ÈÍÍÍÍÍÍÍÍÍÍͼ
J2 40 pin I/O Cable Connection
³ pin-20 removed
³
³ ÚÄÄ [spare jumper on pins 5-7]
³ ³
ÕÍÍÍÍÍÍÍÍÍ ³ÍÍÍÍÍÍÍÍÍÑÍͳÍÍÍÍ1Í/ÄÄÄÄÄÄÄÄÄ\ TOP (HDA)
͵::::::::::ú::::::::1³ :Á: : : ³ 0 0 0 0 ³ÍÍ
ÔÍÍÍÍÍÍÍÍÍÍÍÍÍÍÍÍÍÍÍÍÏ8³Í³Í³Í³ÍÀÄ5ÄGÄGÄ12Ù BOTTOM
³ ³ ³ ³
³ ³ ³ ÀÄÄ Limit Capacity (see below)
³ ³ ÀÄÄÄÄ Reserved
O=OFF, X=ON -->> X-OÄÄÄÄÄÄ Master ON
O-OÄÄÄÄÄÄ Slave OFF

X-XÄÄÄÄÄÄ Slave Present (when pins 7-8 ON
used on Master drive)
O-XÄÄÄÄÄÄ Cable Select (when pins 7-8 OFF)

On drives greater than 33.8GB, Limit Capacity jumper changes total
available sectors as reported via Identify Drive data words 60-61 to
33.8GB to solve issues with certain BIOS during power on. The ATA
Read Native Max command will report true full capacity. The ATA
Set Max command will restore true full capacity to the operating
system drivers. Third party partitioning software may be needed to
achieve full capacity when using this option jumper.


Die Festplatte hat 4*2 pins, auf die man einen Jumper stecken könnte. Welche Kombination ist denn für "slave" die richtige?
 

little tyrolean

Elder Statesman
Slave braucht keinen Jumper, schau mal hier nach...

p.s.
Cable Select funktioniert nur mit 80-poligen ATA-Kabeln,
die Stecker sind gekennzeichnet, was wo hingehört.
 

Blackthorne

assimiliert
Dann habe ich das Ganze doch richtig interpretiert. Ich habe nämlich keinen Jumper gesetzt.

Leider bedeutet das, dass das Problem dann ein Anderes ist.

Wenn noch jemand einen Tipp hat, wäre ich sehr dankbar.

:)
 

klasch

chronische Wohlfühlitis
Versuch doch mal die zweite Platte am 2. IDE ob sie als Slave hinter dem CD/DVD funktioniert.

Es gibt Platten die absolut nicht zusammen arbeiten wollen.
 

Blackthorne

assimiliert
klasch schrieb:
Versuch doch mal die zweite Platte am 2. IDE ob sie als Slave hinter dem CD/DVD funktioniert.


Das hatte ich vor, als nächstes zu versuchen. Ich komme jedoch vor Mittwoch nicht dazu. Über das Ergebnis werde ich berichten.

:)
 

Blackthorne

assimiliert
Computer sind zwar dumm, dafür aber auch nicht immer logisch.

Ich habe als erstes das IDE-Kabel getauscht, was aber keine Verbesserung gebracht hat.

Dann habe ich die 2. Festplatte, die als slave nicht erkannt wurde, ebenfalls als slave (die Jumper waren also richtig gesteckt bzw. nicht gesteckt) hinter das DVD-Laufwerk gehängt und siehe da, alles wurde erkannt und funktioniert jetzt.

Das verstehe wer will!

:)
 
Oben