[Festplatte] PIO-DMA-Frage [sagen mein Win2k/XP]

Winny

treuer Stammgast
PIO-DMA-Frage [sagen mein Win2k/XP]

Was ich schon immer fragen wollte:
Beim Durcharbeiten der Windows-Tipps finde ich "DMA-Modus für CD-ROM aktivieren". Sowohl unter Win2k als auch unter XP stehen bei mir im Geräte-Manager folgende Erweiterte Einstellungen:
---------------------------------
PRIMÄRER IDE-Kanal
Gerät 0 Gerätetyp: angegraut
Übertragungsmodus: DMA, wenn verfügbar (akt. Übertragungsmodus: Ultra-DMA-Modus 2)

Gerät 1 Gerätetyp: angegraut
Übertragungsmodus: Nur PIO (akt. Übertragungsmodus: PIO-Modus)
--------------------------------------
SEKUNDÄRER IDE-Kanal
Gerät 0 Gerätetyp: angegraut
Übertragungsmodus: DMA, wenn verfügbar (akt. Übertragungsmodus: Multiword-DMA-Modus 2)

Gerät 1 Gerätetyp: Automatische Erkennung
Übertragungsmodus: DMA, wenn verfügbar (akt. Übertragungsmodus: Nicht anwendbar)
--------------------------------------
VOR den beiden IDE-Kanälen gibt es noch einen
Intel(r) 82371AB/EB PCI-Bus-Master-IDE-Controller OHNE Erweiterte Einstellungen sowie mit folgenden Treibern:
atapi.sys - intelide.sys - pciidex.sys
---------------------------------------
Ich habe keine Probleme mit dem Laufzeitverhalten meiner Laufwerke. Folgende IDE-Geräte sind installiert:
1. IDE-Festplatte 15GB
2. CD-ROM
3. (seit 08/2001) ein CD-Brenner.

Sagen diese Einstellungen irgendwem etwas? Kann das so bleiben oder muss etwas umgestellt werden? An welchem IDE-Kanal und Gerät hängen denn nun welche Laufwerke?

Mit Dank im voraus Winny
 

zyconore

kennt sich schon aus
scheint, als ob am
PRIMÄREN IDE-Kanal (MASTER) Deine "etwas ältere" [ weil: läuft nur im UDMA-Modus 2 (UDMA33), aktuell ist 4 (UDMA66/ATA4) oder 5 (UDMA100/ATA5) ] Festplatte hängt (als MASTER) und
da ja zwei Geräte pro Kanal genutzt werden können, befindet sich Dein CD-ROM als SLAVE mit (üblichem) PIO-MODE 4 (Übertragungsrate ist vergleichbar mit UDMA 33, namlich 33 MB /sek) an diesem Kanal.

Am SEKUNDÄREN IDE-KANAL befindet sich als MASTER Dein Brenner mit den üblichen MW-DMA 2-Modus. Manche Brenner haben auch UDMA2 als Modus, das macht aber im Wesentlichen kein Unterschied.
Der SLAVE Port ist frei (deshalb ist unter XP die automatische Erkennung noch aktiviert und bei den anderen angegraut, da dort ja schon Geräte installiert sind).

Die Einstellungen unter Windows sind OK. Eventl. kannst Du unter GeräteManager/Systemkomponenten/DMA Manager oder so ähnlich 64kbyte exklusiven Speicher reservieren lassen, um sicherzugehen daß der DMA Kanal immer seine Speicherressourcen zur Verfügung hat und Windows nich erst diesen, eigentlich vom DMA-Kanal genutzten Speicherbereich, "clearen" muss.

Ansonsten ist zu beachten, daß Du die richtigen Einstellugen im BIOS machst und dort die auf Deine HD/CD-ROM/Brenner zutreffenden Einstellungen machst. (Les auf der Website der Hersteller nach, welches die Höchstwerte für die DMA-Modi dr Geräte ist).

Wenn jedoch alles, wie Du sagstest, funktioniert, lass die Einstellungen einfach so.

bis dann
 

Winny

treuer Stammgast
Na da bin ich ja hochzufrieden. Herzlichen Dank, zyconore, für die ausführliche und kompetente Antwort.
Gruß Winny
 
Oben