[Festplatte] HD wird falsch erkannt!

Predator33

Herzlich willkommen!
HD wird falsch erkannt!

Hi Leute!

Hab ein Problem! Meine neue 250GB große Festplatte wird nicht richtig erkannt. Partition Magic zeigt sie mit nur 131GB an. Beim Installieren von Win2K wurde sie auch mit 1321B angezeigt. Im Bios allerdings wird sie richtig erkannt.
Diesen Regedt32.exe Eintrag, dass größere Platten erkannt werden können hab ich gemacht, bringt aber nix. Keine Ahnung, was ich jetzt machen soll!?

Könnt ihr mir Helfen???

Mein PC:

Win2K SP4
HD: Hitachi Deskstar t7k500 mit 250GB
Mainboard: Asus P4S533

Hab noch ne kleine 60GB Platte als Slave dranhängen, aber die funktioniert einwandfrei...

Wäre echt Klasse wenn ihr mir'n Tipp geben könntet!!!!

Ach genau: ich hab auf der Platte jetzt mal 6 GB für Win2K mit NTFS partitioniert und der Rest liegt noch brach so zu sagen.
 
Z

ZickZack

Gast
Wenn die 250er Platte im Bios wirklich mit voller Größe erkannt wird, geh in die Datenträgerverwaltung von W2K und partitioniere den Rest. Partition Magic brauchst du dazu nicht.
 

Predator33

Herzlich willkommen!
Hmm.. da wird sie auch falsch angezeigt...

Am Jumper oder kabel kann's ja nicht liegen, oder? - im Bios wird sie ja richtig angezeigt...

Ist übrigens nicht über s-ata angeschlossen sondern normal Ide
 
Z

ZickZack

Gast
Hast du sie mit Partition Magic eingerichtet? Wenn ja, mit welcher Version?
 

Predator33

Herzlich willkommen!
Hab's mit Partition Magic 7 gemacht - allerdings mit der Demo Version

Das mit dem Bios hab ich mir auch überlegt, aber sie wird dort wirklich richtig angezeigt.
 
Z

ZickZack

Gast
Starte das Setup von der W2K-CD, lösche alle Partitionen, starte den Rechner danach neu und wieder das Setup. ;) Dann installierst Du W2k auf einer ca. 10 GB großen Partition neu , installierst das SP4, das Rollup-Pack, erstellst den Registry-Eintrag und nach einem erneuten Neustart solltest Du in der Datenträgerverwaltung die restliche Kapazität als nicht zugeordneten Speicherplatz erkennen und einrichten können.

PM7 konnte gerade mal mit 80 GB-Platten umgehen, ob die Demo große Platten richtig erkennt und einrichtet, weiß ich nicht genau. PM8 hat da keine Probleme mehr. Allerdings braucht man zur Ersteinrichtung einer Festplatte keinen Partitionsmanager, das kann Windows ganz ohne fremde Hilfe. ;)
 

Predator33

Herzlich willkommen!
@koloth:

Hab dir einen kleinen Auszug gemacht

Gehen Sie folgendermaßen vor, um 48-Bit-LBA-Unterstützung für große Festplatten in der Registrierung zu aktivieren:
1. Starten Sie den Registrierungseditor (Regedt32.exe).
2. Klicken Sie auf den folgenden Registrierungsschlüssel:
HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\Atapi\Parameters
3. Klicken Sie im Menü Bearbeiten auf Wert hinzufügen und fügen Sie den folgenden Registrierungswert hinzu:
Name: EnableBigLba
Typ: REG_DWORD
Wert: 0x1

der komplette Artikel: 48-Bit-LBA-Unterstützung für ATAPI-Laufwerke in Windows 2000


@ZickZack: Erstmal Danke, für die Unterstützung! werd's wohl so machen (müssen) . Aber noch eine kleine Frage: Warum soll ich die Partition für Windows so groß machen?
 
Z

ZickZack

Gast
Du kannst sie auch kleiner machen, aber mit 10 GB hast Du ausreichend Reserve z. B. für Ruhemodus, Updates und Auslagerungsdatei.
Bei der Plattengröße musst Du doch nicht knausern.
 
Z

ZickZack

Gast
little tyrolean schrieb:
Der Eintrag ist case-sensitive - es muß also EnableBigLBA heißen.

Microsoft schrieb:
Normalerweise unterscheiden Einträge in der Registrierung nicht zwischen Groß- und Kleinschreibung.
Wenn ein Schlüssel oder Wert casesensitiv ist, steht das überlicherweise in den entsprechenden KB-Artikeln vermerkt. Das ist aber hier nicht der Fall.
 

little tyrolean

Elder Statesman
Inwieweit man sich da auf Microsoft verlassen kann, will ich lieber gar nicht wissen... :D
Tatsache ist aber, daß mehr als einige Einträge nutzlos werden, wenn sie nicht case-richtig geschrieben sind.
 
Oben