[Debian] WLAN - Aktivierung beim Start & feste IP!?

Oli

dem Board verfallen
WLAN - Aktivierung beim Start & feste IP!?

So, ich hab nun seit einer Weile mit Debian rumgebastelt. Bisher lief es alles über Kabel nun geht auch der WLAN Stick. Dummerweise muss ich anscheined, wenn das Debian gestartet ist (KDE Oberfläche) - das WLAN "richtig" starten. Das sieht so aus, das ich die Gnome Tools nehme (Netzwerk) dort zwischen DHCP auf Feste IP, wieder zurück auf DHCP stelle. Alles bestätige und dann kommt der kurze Ladebalken "wlan0" wird aktiviert. Die Konfigurationen scheinen aber soweit geblieben zu sein. Wo es nur komsichweise beimStart probleme gibt, er kann "/etc/interfaces" nicht lesen!?

Weiß da jemand Rat? Ob ich das noch irgendwie ordentlich anpassen kann.
Und gibt es ein Programm, welches Netzwerk und WLAN vernüftig miteinander kombiniert. Ist ja schrecklich. Hab duzende Tools drauf, sowohl von Gnome und KDE. Das Gome Netzwerktool ist auch sehr gut, nur scheint darüber nicht alles zu klappen.
Der KWiFi Manager funktioniert auch irgendwie. Dort wiederum kann man nur keine IPs einstellen.

Hab ich dann noch IPs im GnomeNetzwerktool eingestellt funktioniert das Netz dann wieder nicht. Hat da auch jemand eine Ahnung warum!?
 

Oli

dem Board verfallen
Mhhh... erstmal danke. Ich hab das auch schon andereswo so gesehen, solche Einstellungen. Hab das auch mal ausprobiert, jedoch klappt das nicht. Ob es nun am Fehler liegt, dass er die Interfaces nicht lesen kann - ich weiß es nicht!?

Achso, ob das war nur ein Schreibfehler. Sie ist schon da wo sie sein sollte.

Steht die Konfiguration eigentlich noch wo anderes? Denn sonst würde ich sagen, er ließt es schon nur nicht richtig oder er wird irgendwo aufgehalten. Denn ansich sind alle Konfigurationen, dann beim Start vorhanden. Ich muss nur mit dem KWiFiManager das Profil aktivieren und im GnomeNetzwerk-Tool die Verbindung irgendwie aktivieren.
 

Franz

assimiliert
Immer diese bunten Zusatzprogramme - wo bleibt den Unix? :D

Der WiFiManager muß beim Starten wissen, welche WLAN- Karte angesprochen werden soll.
Alle Karten stehen im Verzeichnis /proc/net/dev.
Die Liste arbeitet er ab, bis er einen Treffer hat.
Im Manager muß dafür die "Konfiguration beim KDE-Start aktivieren" gesetzt sein,
und bei "Zu ladendes Profil" die anzusprechende Karte ausgewählt werden.

Sollte deine Karte nicht in der Liste sein, kannst du sie manuell (im Verzeichnis) eintragen.

Wahrscheinlich kann deswegen Debian beim Start das Verzeichnis
./interfaces nicht lesen, weil die Karte gar nicht eingetragen ist.

Nach obg. Konfiguration kannst du dann auch von DHCP auf feste IPs umstellen.
Wozu das Netzwerktool von Gnome?
Poste doch mal deine ./interfaces, den Inhalt des Verzeichnisses
/proc/network/dev und die WLAN Karte, die angesprochen werden soll.

Und warum hast du deine Pudelmütze noch auf?
 

Oli

dem Board verfallen
Das GNOME-Tool brauch ich um dann eine Verbindung hinzukriegen...
Also ich würde es gerne weglassen. Ging nur leider noch nicht. :(

Es ist so, dass, wenn ich das WLAN Profil im KWiFi Manager geladen hab, sich das WLAN Feld "aufbaut" und dich zum richtigen Accesspiont verbindet. Tja, aber erst anchdem ich im GNOME-Netzwerkrumgespielt hab, funktioniert das Internet!?

Zumdem kann man bei KWiFi keine IPs eingeben. Wobei ich die ja nun manuell eintragen kann.

In dieser /proc/net/dev steht überhaupt nichts. In den gesamten Dateien dort in dem Ordner scheint überhaupt keine Datei beschreiben zu sein. (In die Ordner hab ich nicht geguckt, sind ein wenig viele... :D). Was soll da rein?

Die interfaces sieht so aus (Statische IP ist grad mal wieder nicht drin.):

Code:
# This file describes the network interfaces available on your system
# and how to activate them. For more information, see interfaces(5).

# The loopback network interface
auto lo
iface lo inet loopback
address 127.0.0.1
netmask 255.0.0.0

# The primary network interface
auto eth1
allow-hotplug eth1
address 127.0.0.1
netmask 255.0.0.0
broadcast 127.255.255.255
network 127.0.0.0
iface eth1 inet dhcp
name Ethernet LAN-Karte

#Dell WLAN [aus]
#auto eth0
#iface eth0 inet dhcp
#wireless-essid GamingLAN
#name Ethernet LAN-Karte

##Fritz USB WLAN Stick
#Starten beim booten
auto wlan0

#Hotplug-Konfiguration
mapping hotplug
	script grep
	map wlan0

#Statische IP-Adresse 
iface wlan0 inet dhcp
	wireless-mode Managed
	wireless-essid GamingLAN
	wireless-key s:[Schlüssel]
	name Drahlose LAN-Karte
	broadcast 192.168.178.255

#Anschluss Modem
iface eth2 inet dhcp
name Ethernet LAN-Karte
 

Franz

assimiliert
Ist das der ganze Inhalt??

Hmm,

ich kann mich des Eindrucks nicht erwehren, daß die LAN - Karte auf sich selbst referenziert:
1. der Loopback ist nat. richtig,
2. würde ich die eth0 etwa wie folgt konfigurieren:
-------------
auto eth0
iface eth0 inet static
address 192.168.0.2
netmask 255.255.255.0
network 192.168.0.0
broadcast 192.168.0.255
gateway 192.168.0.1
--------------
3. dann vermisse ich den Eintrag von ifup eth0

2. Offenbar muß das Modem mit 2 Netzen hantieren.
Sind beide Netze und/oder Ip-Nummern in der FritzBox - Konfig eingetragen?

Die WLAN Karte ist m.E., auch noch nicht optimal konfigiriert.

Würde es dir etwas ausmachen deine Netzwerkarten zu posten?

Die Einträge/Startscripts findest du unter /etc/init.d/network.
Soweit ich weiß, unterscheidet sich das Verzeichnis bei Debian nicht von anderen Distris.
 

Oli

dem Board verfallen
eth0 ist doch eh auskommentiert gewesen. Ist auch aus. Seit gestern hab ich auch keine Probleme mit der Interfaces. Es ist alles rausgeflogen was nicht benötigt wird. Das Modem, das intigrierte WLAN (eth0) und noch irgendwas.

Jedenfalls gibt es keinen Fehler mehr. Feste IP geht nun auch. Aber ich muss mich eben immer noch selber anmelden.

Das muss doch irgendwie zu automatisieren sein!?

Achso, ich hab letztes Mal die eine Frage vergessen. Ich finde mein altes Benutzerbild nicht mehr... Daher hab ich noch die Mütze... :cry:
Dann eben ganzen Jahr Weihnachten. Ich muss mur mal ein neues Bild machen.

Edit: Es gibt eine networking Datei in diesen Ordnern. Ich denke mal das wird die von Debian sein!? Sieht aber auch nach sehr viel Neuland aus, wenn ich da was einrichten soll. :D Zumal es doch doof ist, wenn es Hakenkästchen in den Programmen gibt die sich da nennen: "Beim Systemstart mitstarten" und dann geht es nicht. Kann aber immer noch auf ein anderes Problem hindeuten, das die Treiber nicht richtig geladen werden und erst nach Hardware deaktivieren/ aktivieren richtig erkannt werden bzw. den richtigen Pfad oder sonstwas finden.

Edit2: Ich bin nun so nebenbei wieder auf GNOME umgestiegen. KDE scheint mir doch zu sehr Ressourcen bzw. RAM zu fressen.
 

Oli

dem Board verfallen
Hab heute noch mal rumgefrimmelt an meinem kleinen Problem. Ich hab nun den ganzen KDE Qutsch runter genommen, auch das KWiFinetwork Tool. Nun läuft alles über GNOME mit dem netapplet, welches im Tray ist. Zwar hab ich beim Start noch immer kein WLAN sofort, jedoch brauch ich nur noch über das Netapplet Tool im Systemtray zwei einfache Klicks machen. Das ist schon wesentlich komfortabler und so weit völlig akzeptabel.
 

schachwolf

Herzlich willkommen!
hallo,

ich hab eine WLAN-Karte in meinem Notebook unter Debian 3.1 (Sarge) installiert
und zusätzlich eine on-Board - Netzwerkkarte. Beide Karten schienen nach dem Start
des Rechners normal zu laufen. Trotzdem funktionierte die WLAN-verbindung nicht.
Ich habe daher einfach die on-Board - Karte mittels "ifdown eth0" deaktiviert und
schon funktionierte mein WLAN. Da ich mit dem Notebook vorwiegend WLAN nutzen
möchte und die on-Board - Karte nicht brauche , habe ich einfach in der Datei
"/etc/network/interfaces" die Zeile "auto eth0" auskommentiert, um zu verhindern,
dass diese beim Booten mitläuft. Vielleicht hat jemand eine Idee, wie man trotzdem
beide Karten gleichzeiig nutzen kann.
 

Franz

assimiliert
Hallo und herzlich willkommen :)

wenn du die Karten in 2 verschiedene Subnetze legst, sollte es klappen.
D.h., du müsstest beiden eine feste IP zuweisen und, falls aktiv,
DHCP deaktivieren oder den DHCP Pool (IP-Adreßbereich) entsprechend anpassen.
Kannst du deine ifconfig posten?

Einrichten kannst du das entweder mit dem Netzwerkmanager oder manuell in der /etc/network/interfaces
(Hier lohnt es sich den Befehl ifup zu benutzen.)
 

schachwolf

Herzlich willkommen!
wlan und on-board-Karte unter debian gleichzeitig nutzen

Hallo arcanoa,

da ich in meinem Heimnetz weitere Rechner ansprechen will (z. B. 2 VDRs), weiss ich nicht, ob die Unterteilung in 2 Subnetze an dieser Stelle sinnvoll ist, da ich davon ausgehen muss, dass diese Unterteilung dann nicht mehr zum Rest des Netzwerks passt. Ich muss allerdings zugeben, dass die Idee nicht uninteressant ist, habe mich aber bisher noch nicht mit einer solchen Unterteilung beschäftigt. Für weitere Ideen bin ich natürlich sehr dankbar.
Hier meine "/etc/network/interfaces" mit deaktivierten eth0


auto lo
iface lo inet loopback
# auto eth0
iface eth0 inet static
address 192.168.1.4
netmask 255.255.255.0
network 192.168.1.0
broadcast 192.168.1.255
# dns-* options are implemented by the resolvconf package, if installed
dns-nameservers 192.168.1.10
dns-search team1
name Ethernet LAN-Karte
gateway 192.168.1.10
#Hotplug-Konfiguration
mapping hotplug
script grep
map ath0

#Statische IP-Adresse usw.
iface ath0 inet static
wireless-mode Ad-Hoc
wireless-essid team1
wireless-key off
address 192.168.1.5
network 192.168.1.0
netmask 255.255.255.0
broadcast 192.168.1.255
gateway 192.168.1.10

Viele Grüsse

schachwolf
 

Franz

assimiliert
Wenn du keine 2 Netze haben möchtest erschließt sich mir der Sinn von 2 NICs nicht, ehrlich gesagt.
Das macht doch nur Sinn, wenn kein Routing vorhanden ist, man sich aber tropsdem in 2 Netzen bewegen möchte.
 

tlx

treuer Stammgast
Unter Debian gibt es mittlerweile ein Tool namens "network-manager-gnome". Das ermöglicht ein problemloses Umschalten zwischen LAN und WLAN, es unterstützt WEP und WPA, und - aus meiner Sicht am wichtigsten - funktioniert mit allen derzeit verfügbaren WLAN-Interfaces (= für die man z.B. ein Kernel-Modul laden kann).

Das Ding muss nur in die Sitzungsoptionen unter Startprogramme eingetragen werden: "nm-applet --sm-disable".

Ein weiteres Debian-Paket ist "libpam-keyring", das es ermöglicht, den Gnome-Keyring (darin werden die Passwörter fürs WLAN gespeichert) automatisch mit der Benutzeranmeldung freizuschalten. Somit ist es nicht mehr nötig, sich zuerst unter GNOME anzumelden und dann nochmals den Keyring mittels Master-Passwort feizugeben.

Diese beiden "Schmuckstücke" kombiniert, und du hast ein komfortables Netzwerk-Management, das LAN bevorzugt, sofern es angesteckt ist, ansonsten das stäkste WLAN zuerst, un das vollautomatisch.
 
Oben