[Debian] Ubuntu - Bildschirmauflösung

Bluescreen

schläft auf dem Boardsofa
Ubuntu - Bildschirmauflösung

Hallo,

ich habe Ubuntu 5.10 frisch auf meinem PC als 2. Betriebssystem neben XP Pro installiert.

Es gelingt mir nicht, die Bildschirmauflösung auf > 1024 * 768 bei 60 Hz zu stellen. Die Grafikkarte und der Monitor machen auch 1280 * 1024 bei 75 Hz mit, da das bei Windows einwandfrei funktioniert.

Wo ist die Schraube, an der ich hier drehen kann?

:)
 

ZuluDC

assimiliert
SubSection "Display"
Depth 24
Modes "1024x768" "800x600" "640x480"
EndSubSection
EndSection

SubSection "Display"
Depth 24
Modes "1280x1024" "1024x768" "800x600" "640x480"
EndSubSection
EndSection

Es sollte so funktionieren, aber es ist manchmal gar nicht schlecht die horizontale und vertikale Frequenz zu überprüfen, denn wenn die Angaben zu tief sind und der Monitor mehr kann, kann es sein, dass die höhere Auflösung nicht geladen werden kann.

Section "Monitor"
Identifier "Standardbildschirm"
Option "DPMS"
HorizSync 28-51
VertRefresh 43-60
EndSection
 

Bluescreen

schläft auf dem Boardsofa
Hallo ZuluDC,

ich werde, da ich unterwegs bin, vermutlich erst am Montag wieder an dem Rechner etwas machen können.

Nur zur Klarstellung: Meinst du damit, dass ich lediglich in der xorg.conf diese Passage ändern muss?

:)
 

ZuluDC

assimiliert
Ja eigentlich müsste es gehen, wenn Du aber nachher immer noch nur 1024x768 an Auflösung hast stimmen deine horizontale und vertikale Frequenzwerte nicht.
Wie ich sehe hast Du auch die 3D-Beschleunigung drin - also den proprietären Nvidiatreiber geladen.
 

ZuluDC

assimiliert
Wenn es nicht klappt ändere einfach
Section "Monitor"
Identifier "Standardbildschirm"
Option "DPMS"
HorizSync 28-51
VertRefresh 43-60
EndSection

zu

Section "Monitor"
Identifier "Standardbildschirm"
Option "DPMS"
HorizSync 30-80
VertRefresh 50-80
EndSection

Solltest Du aber wirklich einen alten oder echt schlechten Monitor haben, ist es ein bisschen 'heiss' einfach irgendwelche Werte anzugeben, die ein besserer Monitor kann. Aber ein Monitor, der nicht älter ist als vielleicht 4 Jahre sollte diese Werte im Grunde schon umsetzen können.
 

Bluescreen

schläft auf dem Boardsofa
Ich habe nun nach bestem Wissen die Werte der xorg.conf geändert mit dem Erfolg, dass nichts mehr ging (Anfängerfehler, aus denen man hoffentlich lernt).

Dananch habe ich zwangsläufig Ubuntu neu installiert und siehe da, die Auflösung 1280 x 1024 ist mit einem Mal vorhanden. Sage noch einer, Computer seien logisch und hätten keine Gefühle.

Meine xorg.conf sieht jetzt wie folgt aus:
 

Anhänge

  • Xorg_2.txt
    3,1 KB · Aufrufe: 688
Zuletzt bearbeitet von einem Moderator:

Bio-logisch

Moderator
Teammitglied
Interessante Effekte :D
Deswegen halte ich es immer so, dass ich vorher mit cp ein Backup der Datei erstelle, die ich als nächstes bearbeiten will:
Dann kann man immer noch mit einer Knoppix - CD booten und die alte Fassung wieder herstellen.

Aber Hauptsache, es läuft ;)
(PS: Habe mir erlaubt, die Beiträge etwas zu kürzen, in dem ich die Dateien in den Anhang verlegt habe. Nich über den Zeilenumbruch wundern, es war ein Windows-Editor ;))
 

ZuluDC

assimiliert
Genau - Bio-logisch trifft es auf den Punkt. Man sichert vorher mit 'cp xorg.conf xorg_backup.conf' oder ähnlich. Dann kann man wursteln wie man will. Wenn man gar nix mehr schnallt, weil man völlig ab der Rolle ist und auf der konsole auch versagt, weil man nicht mal mehr auf 2 zählen kann, darf man ja immer noch mittels Knoppix grafisch booten und dann die xorg.conf zurückschreiben.

Die Datei xorg.conf ist halt schon sehr zentral und verzeiht kaum Fehler. Anführungszeichen vergessen oder Schreibfehler - schon ist es fertig mit dem X-Server. Dass Dir das passiert ist tut mir echt leid Bluescreen, und ich hab beim besten Willen nie gewollt, dass Dir sowas zustösst. Wirklich ärgerlich sowas, aber ich kenn das und bin schlicht auch nicht davor geimpft.

Was ich direkt sehe ist, ist, dass der verwendete Treiber nun der Standard-Nvidiatreiber ist ohne 3D-Beschleunigung. Wenn Du überhaupt nicht gamen tust unter dem Pingu ist es eh Pappe - ansonsten muss der proprietäre Treiber her. Ich hab den noch gar nicht soviel installiert, war aber überrascht wie einfach es eigentlich ging mit der .bin-Datei von Nvidia. Aber das muss nicht überall direkt so gut funzen wie hier - zudem muss man nach jedem neu gebackenen Kernel den Treiber nochmals installieren (aber VMWare ist da ja auch so).

Also - schade das Du gleich nochmal neu aufsetzen musstest - handumkehrt schleckt keine Geiss weg, dass man durch jeden Bock den man schiesst immer wieder lernt - mag es manchmal noch so unangenehm sein.
 

Hans- Peter

dem Board verfallen
Naja, bei manchen Distris braucht man schon eine 3D Beschleunigung, sonst kann man nicht mal Filme ruckelfrei abspielen...
 

ZuluDC

assimiliert
Da hast Du mit hoher Wahrscheinlichkeit recht.
Ich mag mich noch schwach erinnern, dass die GraKa (GeForce4 Ti 4400) dieses PIV 3GHzer im AthlonXP2000-Rechner daneben steckte und es da eher ruckelte als jetzt unter dem Pingu...damals hatte ich ganz sicher den generischen Nvidia-Treiber drauf.
 

tlx

treuer Stammgast
Für die Zukunft:

mv xorg.conf xorg.conf.`date`

dann einfach ein:

sudo dpkg-reconfigure xserver-xorg

Egal ob Debian, Ubuntu, Kubuntu, *buntu, Knoppix ... dpkg ist immer die Grundlage. Wenn man das weiß, dann kann man sich ein "neu Installieren" sparen. :angel
 
Oben