[Debian] CUPS Druckerserver

prossler

bekommt Übersicht
CUPS Druckerserver

Hallo,
Bin am verzweifeln. Bekomme keinen Druckerserver eingerichtet. Cupsd.conf lässt sich nicht öffnen.
Folgende Fehlermeldung erscheint:
root@........
bash: /etc/cups/cupsd.conf:keine berechtigung

Kann mir jemand helfen?
Vielen Dank im voraus!
 

Bio-logisch

Moderator
Teammitglied
Herzlich willkomen auf dem Wohlfühlboard!
Du musst die Datei mit einem Texteditor öffnen, also z. B.

vi /etc/cups/cupsd.conf

wenn Du vi verwendest.
 

prossler

bekommt Übersicht
Vielen Dank

Vielen Dank, hatt geklappt. Weitere Fragen kommen sicher noch. Bin ganz neu auf diesem Gebiet.( Absolut keine Ahnung) :) .
 

Buccaneer

chronische Wohlfühlitis
Wenn Du eine Datei mit Vi öffnest, ist sie erst einmal nur im sog. "Befehlsmodus".
Um sie zu ändern, solltest Du dich erst mal mit Vi auseinandersetzen, da es dort
eine Menge Shortcuts gibt (z.B. Taste "x" im Befehlsmodus löscht ein Zeichen, Taste "i" wechselt in den Editiermodus, etc...)

Da Vi ein ziemlich mächtiger Editor ist, schau einfach mal hier, da findest Du eine kurze Einleitung.
 

prossler

bekommt Übersicht
Nächstes Problem

Vielen Dank. Vi funktionniert. Editieren kann ich jetzt. Mein nächstes Problem ist der Kartenleser. Mit dmesg wird der Kartenleser angezeigt. Ich weis jedoch nicht wie ich jetzt Zugriff auf die Karten bekomme.
 

prossler

bekommt Übersicht
Kartenleser

Kopie von dmesg,

usb 1-8: new low speed USB device using ohci_hcd and address 8
input: USB HID v1.11 Mouse [Logitech USB RECEIVER] on usb-0000:00:02.0-8
pci_hotplug: PCI Hot Plug PCI Core version: 0.5
shpchp: Address64 -------- Resource unparsed
shpchp: Address64 -------- Resource unparsed
shpchp: Address64 -------- Resource unparsed
shpchp: Standard Hot Plug PCI Controller Driver version: 0.4
Vendor: Generic Model: USB SD Reader Rev: 1.00
Type: Direct-Access ANSI SCSI revision: 00
Attached scsi removable disk sda at scsi5, channel 0, id 0, lun 0
Vendor: Generic Model: USB CF Reader Rev: 1.01
Type: Direct-Access ANSI SCSI revision: 00
Attached scsi removable disk sdb at scsi5, channel 0, id 0, lun 1
Vendor: Generic Model: USB SM Reader Rev: 1.02
Type: Direct-Access ANSI SCSI revision: 00
Attached scsi removable disk sdc at scsi5, channel 0, id 0, lun 2
Vendor: Generic Model: USB MS Reader Rev: 1.03
Type: Direct-Access ANSI SCSI revision: 00
Attached scsi removable disk sdd at scsi5, channel 0, id 0, lun 3
usb-storage: device scan complete
ttyS0 at I/O 0x3f8 (irq = 4) is a 16550A
lp0: using parport0 (interrupt-driven).
lp0: console ready
apm: BIOS version 1.2 Flags 0x07 (Driver version 1.16ac)
apm: overridden by ACPI.
NET: Registered protocol family 10
Disabled Privacy Extensions on device c0381d00(lo)
IPv6 over IPv4 tunneling driver
eth0: no IPv6 routers present
 

prossler

bekommt Übersicht
Kartenleser

Hier meine fstab. Es funkt trotzdem noch nicht.

# /etc/fstab: filesystem table.
#
# filesystem mountpoint type options dump pass
/dev/hda1 / reiserfs defaults 0 1

proc /proc proc defaults 0 0
/dev/fd0 /floppy vfat defaults,user,noauto,showexec,umask=022 0 0
usbfs /proc/bus/usb usbfs devmode=0666 0 0
sysfs /sys sysfs defaults 0 0
tmpfs /dev/shm tmpfs defaults 0 0
/dev/cdrom /cdrom iso9660 defaults,ro,users,noexec,noauto 0 0
/dev/cdrom1 /cdrom1 iso9660 defaults,ro,users,noexec,noauto 0 0
/dev/dvd /dvd iso9660 defaults,ro,users,noexec,noauto 0 0
/dev/sda1 /mnt/sda1 auto noauto,user,sync 0 0
/dev/sdb1 /mnt/sda1 auto noauto,user,sync 0 0
/dev/sdc1 /mnt/sda1 auto noauto,user,sync 0 0
/dev/sdd1 /mnt/sda1 auto noauto,user,sync 0 0

~
~
 

prossler

bekommt Übersicht
Fehlermeldung

Hallo
Hätte ich vielleicht jedesmahl den gleichen Gerätenamen angeben müssen bei mnt
sda1. (1 Gerät mnt sda1, 2. Gerät mnt sdb1 usw. ?
Fehlermeldung Konqueror:
Laufwerk konnte nicht eingebunden werden.
Die Fehlermeldung war:
mount: Einhängepunkt /mnt/sda1 existiert nicht
 

Bio-logisch

Moderator
Teammitglied
Die Fehlermeldung deutet darauf hin, dass Du die Verzeichnissen nicht angelegt hast:

Als root:
cd /mnt
mkdir sda1 sdb1 sdc1 sdd1
 
Oben