[Anleitung] So bekomme ich ein Saitek R4 Force Feedback Lenkrad unter W2K/XP zum laufen!

Bio-logisch

Moderator
Teammitglied
AW: [Anleitung] So bekomme ich ein Saitek R4 Force Feedback Lenkrad unter W2K/XP zum laufen!

Erst mal herzlich willkommen auf dem Wohlfühlboard!
An Deiner Stelle würde ich mir einen Adapterstecker besorgen, ist weniger Aufwändig und mit deutlich weniger Risiko gehaftet.

MfG, Bio
 

sammy322

Herzlich willkommen!
AW: [Anleitung] So bekomme ich ein Saitek R4 Force Feedback Lenkrad unter W2K/XP zum laufen!

Original geschrieben von Bio-logisch
Erst mal herzlich willkommen auf dem Wohlfühlboard!
An Deiner Stelle würde ich mir einen Adapterstecker besorgen, ist weniger Aufwändig und mit deutlich weniger Risiko gehaftet.

MfG, Bio

Aufwand scheue ich nicht unbedingt. Ich glaube mal gelesen zu haben das es dass R4 auch mit USB gab. Sollte dann doch gehen, oder? Wenn das natürlich ein dramatischer Umbau wäre, dann laß ich es sein. Wenn ich aber nur ein USB-Kabel Anlöten müsste, würd ichs machen. Ich weiß ja nicht ob die Platine für USB vorbereitet ist. Vieleicht weiß da jemand mehr drüber?

mfg Sammy
 

sirnoname

Herzlich willkommen!
AW: [Anleitung] So bekomme ich ein Saitek R4 Force Feedback Lenkrad unter W2K/XP zum laufen!

Hi,
welche Midi Port Nummer habt ihr für den Sidewinder eingestellt ?
330, 300 ??

Ansonsten: Danke für die Infos !!

Wer gerne FF von Spielen auslesen will sollte sich mal hier umschauen:
http://www.usbpage.de/yoda
 

sirnoname

Herzlich willkommen!
AW: [Anleitung] So bekomme ich ein Saitek R4 Force Feedback Lenkrad unter W2K/XP zum laufen!

OK !!

Es funzt unter XP mit dem Sidewinder Gameport Edition.
Also was abslut wichtig ist: Keine AC97 onboard Soundkarte.
Ich benutze ne SBlive, da gehts unter XP mit dem selbstsuchen.
Den Midiport im Bios der AC97 einzuschalten bringt nix.
Auch ist mommentan bei meiner SBlive im Gerätemanager
kein Midiport installiert.
Forcefeedback ging bei mir erst mit der Creative Karte.
Die Treiber/Software 4.0 zum einstellen brauch ich nicht, macht mein Game.
Hoch lebe Microsoft, die das Installations Spiel immer wieder spannend machen ;)

Never give up !!
sirnoname
 

Argus

Erster Beitrag
Keine Bremse mehr ?

Hallo, ich habe mein R4FF umgebaut - alles OK.
Allerdings hat das Bremspedal als einzige "Taste" keine Funktion mehr.
Vielleicht kann ja jemand helfen.

Gruß Argus
 

UPS1135

Erster Beitrag
AW: [Anleitung] So bekomme ich ein Saitek R4 Force Feedback Lenkrad unter W2K/XP zum laufen!

Hi,
Klasse, endlich kan ich Win XP benutzen.

aber leider habe ich auch probleme mit der Bremse. Mein Wheel wird als "Microsoft Sidewinder Force Feedback Wheel" angezeigt. wird auch als OK gezeigt. aber wenn ich z.B. 18Wheels of Steel PttM Spiele, dann Bremst meine Bremse immer so ein bischen. da hilft auch keine "DeadZone" im Spiel auf sehr hoch zu stellen. dan hab ich mir die Kalibrierung vom Wheel angeschaut und gesehen, das Die Bremse die ganze zeit etwas auf der bremse steht, das geht erstz weg, wenn ich die Bremse mit meiner Hand Feste zurückziehe. Kalibrieren hat auch nix geholfen, ausserdem störts mich, das Gas und Bremse auf verschieden axen sind. manche Spiele wir FS2004 unzterstützen sowas nich, da Bremst die Bremse auf vollepulle.
hoffe irgendjemand shcuat wieder hier im forum vorbei,
ciao
Mag

 

Klippenkotzer

Erster Beitrag
AW: [Anleitung] So bekomme ich ein Saitek R4 Force Feedback Lenkrad unter W2K/XP zum laufen!

So jetzt habe ich es auch geschafft das Dingen in Gang zu bekommen Nur geht bei mir das FF auch nicht. Wie was das mit dem MIDI? Hat das noch jemand hinbekommen ausser jlorenzo? Ich habe eine SB Audigy2. Mir ist aufgefallen das nach dem Umbau sich das Lenkrad nicht mehr von alleine in die mitte dreht, bei eingeschalteten FF. Ist das bei euch auch so?

Gruß Klippe
 

holger77

Erster Beitrag
AW: [Anleitung] So bekomme ich ein Saitek R4 Force Feedback Lenkrad unter W2K/XP zum laufen!

mahlzeit...
hab auch das leider veraltete aber noch immer spassbringende r4 von saitek mit force feedback. hab mit hilfe des bildes auch die brücke bei j3 entfernt. allerdings hab ich einen adapter von gameport auf usb. wenn ich lenkrad und adapter/pc zusammenstöpsl erkennt er zwar die neue hardware und sagt mir ich kann sie benutzen, aber in der gamecontroller-einstellung sehe ich anfangs nur den usb adapter als OK. sobald ich dann sidewinder (automatische erkennung) einstelle bekomme ich ein 'nicht verbunden'. kann also keine settings machen keine achsen kalibrieren usw. hab auch onboard sound ac97 und hab mit den irq und anderen ports wenig am hut. werd hier grad komplett verrückt mit dem teil hier.
 

Santa111

Erster Beitrag
R4 wheel benutzen oder tonne ?

jo hi leute.. hab auch ein normales R4 ohne FF ! hab es aufgeschraubt und auch eine j3 brücke gefunden aber logischerweise(oder auch nicht)auch andere platine.. weiss irgendwer von euch ob das die selbe brücke ist wie beim R4 mit FF ??? konnte auch keine brücke mit saitek mode finden wie irgendwer vorher beschrieben.. kann mir da jemand von euch helfen???

btw nettes forum gg.. :) würd auch gern mal mit wheel daddeln hab bis jetzt immer nur mit tastatur und das ist nur bedingt spassig .. :( :smokin thx im voraus schonmal.. :smokin
 

Tunerboy

Herzlich willkommen!
AW: [Anleitung] So bekomme ich ein Saitek R4 Force Feedback Lenkrad unter W2K/XP zum laufen!

Ich hab ne frage ich hab dat r4 mit forcefeedback vom nachbarn geliehen und der hat kein netzteil mehr!
kann ich auch ohne netzteil spieln?
 

JensusUT

Senior Member
AW: [Anleitung] So bekomme ich ein Saitek R4 Force Feedback Lenkrad unter W2K/XP zum laufen!

Hallo Tunerboy,
Probier es aus. Aber ich schätze, es wird mehr als 500 mA brauchen, den nohne Grund wird das Netzteil ja nicht dabei gewesen sein ;)
Kaputtmachen kannst du jedenfalls nichts...

Gruß
Jensus
 

Tunerboy

Herzlich willkommen!
AW: [Anleitung] So bekomme ich ein Saitek R4 Force Feedback Lenkrad unter W2K/XP zum laufen!

ich müsste es eh erst noch umbauen!
von daher guck ich das ich das netzteil krieg!
wer eins überhat bitte melden!!
 

sleepwalker

Erster Beitrag
AW: [Anleitung] So bekomme ich ein Saitek R4 Force Feedback Lenkrad unter W2K/XP zum laufen!

Hallo zusammen,

durch Zufall habe ich den Thread hier geschickt bekommen.
Sofort mein viele Jahre altes Saitek R4 FF aus dem Schrank geholt und die Verbindung auf J3 entfernt.

Ich habe es an den onboard Gameport angeschlossen.
Unter Gamecontroller habe ich Microsoft SideWinder eingestellt.
Mir wird jetzt ein "Microsoft SideWinder 3D Pro" und Status "nicht verbunden" angezeigt. Das Lenkrad bewegt sich immer hin und her, aber es tut sich nichts.

Wie kann ich dieses Problem beheben damit ich endlich mal wieder spielen kann?

Grüße
Daniel
 

MatHora

Erster Beitrag
Gameport to USB-Adapter

hallo zusammen,
also ich hab jetzt auch gerade die überbrückung abgelötet, sieht auch ganz gut aus.

ich hab aber immernoch ein problem: ich habe so einen billigen Gameport to USB Adapter (Sitecom), da ich keinen Gameport habe.

wenn ich jetzt bei den Gamecontrollern Microsoft Sidewinder (oder auch irgendeinen anderen) auswähle, sagt er mir, dass der gameport oder die gameporttreiber nicht richtig konfiguriert seien, und ich im gerätemanager schauen soll.

hatte schon jemand dieses problem? hat jemand einen lösungsvorschlag?
 

bergischland

Erster Beitrag
AW: [Anleitung] So bekomme ich ein Saitek R4 Force Feedback Lenkrad unter W2K/XP zum laufen!

Hallo und vielen Dank für diese Infos.

Etwa ein Jahr hat das R4 ungenutzt im Schrank gelegen und jetzt bin ich über diesen Thread gestolpert. So wird mein Sohn das R4 vielleicht wirklich nochmal nutzen können. Es macht einen viel besseren Eindruck als das Nachfolgemodell R440 (?).

Wie schon himoz in #23 schrieb und auch maciek123 in #35, gibt es wohl mindestens noch eine andere Elektronik. Die habe auch ich.

Ich denke, die ist älter, weil die Bauelemente noch größer sind als bei dem Layout vom Anfangsposting. Allerdings gibt es dort eine konkrete Bezeichnung für den Kontakt nämlich 'saitek mode' anstatt einfach J3. Die Position ist aber genau wie bei der anderen Platine unterhalb von J1 und J2.

Ich habe unten mal Bilder angehängt, die diese zweite Variante des R4 zeigen. Es ist nur erforderlich den oberen Deckel abznehmen. Die Platine kann drin bleiben. Bei mir sind auch einige Kabelstränge mit Heißkleber fixiert worden und ich habe mir beim Demontieren auch prompt ein kurzes Kabel abgerissen.

Insgesamt musste ich etwas frickeln, weil es nicht sofort klappte. Ich habe nacheinander (mit zwischenzeitlichem Probieren) zwei Leiterbahnen mit einen kleinen scharfkantigen Schraubendreher durch gescheuert (rot gestrichelte Linien im blauen Kasten). Das sieht auf den Fotos brutal aus. Ich weiß jetzt auch garnicht, ob die eine oder die andere Trennung gereicht hätte. WICHTIG war allerdings, dass das R4 zunächst nicht erkannt wurde. Erst als neben den Pedalen auch noch das Netzteil angesteckt war und damit die Stromversorgung klappte, wurde es sofort als Sidewinder ForceFeedback erkannt und funktionierte bei der Kalibrierung (bis auf die beiden fehlenden Knöpfe) sofort anstandslos unter XP am Gameport.

Weder an XP noch an Vista klappte aber der Anschluss mittels Gameport-an-USB-Adapter. Es wurde rein garnichts erkannt und auch die manuelle Konfiguration des MS-Joysticks brachte keine Besserung. - Weiß da jemand Rat?

Möglicheise bringt der Einbau eines Gameports (z.B. auf einer Soundkarte) etwas. Werde ich mal ausprobieren, ob eine alte vorhandene dafür geht.

Ich hoffe, die hochgeladenen Bilder sind nun auch hier zu sehen...

attachment.php


So sieht die Platine eingebaut von oben aus. Sie muss NICHT ausgebaut werden!
attachment.php


Das ist die Platine von unten (wie Ihr sie Euch garnicht ansehen müsst). Man erkennt die neun im Quadrat angeordneten Löcher in der Platine von J1, J2 und 'Saitek mode', sowie den daneben liegenden Widerständen
attachment.php


Hier ist der Originalzustand zu erkennen
attachment.php


Und hier seht Ihr die Spuren meiner zaghaften Vergewaltigung. Rechts im blauen Quadrat sind die Lötpunkte der Widerstände (seitenverkehrt gegenüber der Unterseite).
attachment.php



Grüße

Frank
 

Anhänge

  • modell.jpg
    modell.jpg
    295,8 KB · Aufrufe: 3.642
  • platine_oben.jpg
    platine_oben.jpg
    267,6 KB · Aufrufe: 3.763
  • platine_unten.jpg
    platine_unten.jpg
    186,1 KB · Aufrufe: 3.617
  • platine_original.jpg
    platine_original.jpg
    218,6 KB · Aufrufe: 3.590
  • platine_fertig.jpg
    platine_fertig.jpg
    212,1 KB · Aufrufe: 3.841

JensusUT

Senior Member
AW: [Anleitung] So bekomme ich ein Saitek R4 Force Feedback Lenkrad unter W2K/XP zum laufen!

Sauber, Frank... das nenne ich doch mal eine positive Resonanz auf den Thread! Nach der Lesezahl zu urteilen werden sicher ein paar Leute von deiner Beschreibung profitieren. Danke nochmal!

Gruß
Jensus
 

QuHno

Außer Betrieb
AW: [Anleitung] So bekomme ich ein Saitek R4 Force Feedback Lenkrad unter W2K/XP zum laufen!

@MatHora: Erst einmal Herzlich Wilkommen!

Bin zufällig darüber gestolpert, vielleicht hilft das (ohne Garantie, ich hab kein solches Teil):
SideWinder-USB-Portcontroller meldet Status "Nicht verbunden"

Original, Englisch:
SideWinder USB Port Controller Reports "Not Connected" Status

Und eventuell braucht's auch einen passenden Treiber, vielleicht mal hier nachlesen (aber schön wiederkommen, gelle ;))
TechnikTeam Software-Dantenbank - Dateilansicht: Sidewinder Software 4.0

edit: Ich lese grad in einem MSKB Artikel, dass man für die Force Feedback Teile wohl eher einen 3.02er Treiber braucht... leider habe ich für den keine DL Adresse gefunden, evtl hat den aber noch wer, mit ein wenig Glück sollten die W2K Treiber unter XP funktionieren, siehe:
Flight Simulator 2000: Troubleshooting Joystick Problems (Part 1) Englisch, da die maschienenübersetzte deutsche Version für's Hinterteil ist....
 
Zuletzt bearbeitet:

david12784

Erster Beitrag
AW: [Anleitung] So bekomme ich ein Saitek R4 Force Feedback Lenkrad unter W2K/XP zum laufen!

hallo kann mir einer helfen?

UND ZWAR HABE ICH EIN Saitek R440 Force Feedback GEKAUFT UND INSTALLIERT GEHT AUCH ALLES AUSER MEIN FEEDBACK NICHT BEI ALLEN SPIELEN!!!WER KANN MIR HELFEN
 
Zuletzt bearbeitet von einem Moderator:

oxfort

Geht bald.
AW: [Anleitung] So bekomme ich ein Saitek R4 Force Feedback Lenkrad unter W2K/XP zum laufen!

Wenn Du Dich nicht näher äußerst, kann Dir keiner helfen!

Hier wirst Du keinen finden, der Dein Zimmer aufräumt.:megagrin

Ach ja, herzlich willkommen!:)
 
Oben