Ergebnis 1 bis 5 von 5

Thema: .NET Framework doppelt?

  1. #1
    gehört zum Inventar Avatar von Holl
    Registriert seit
    13.10.07
    Ort
    Schwäbischer Wald
    Beiträge
    512

    .NET Framework doppelt?

    Hallo und guten Abend allerseits

    Habe heute mal meine Software-Liste durchgeschaut, und habe entdeckt, dass ich sowohl "Microsoft .NET Framwork 2.0" als auch "Microsoft .NET Framwork 2.0 - Language Pack-DEU" und ebenfalls beides als 3.0 Versionen.
    Nun meine Frage(n):
    1. Was ist .NET Framework überhaupt und wozu benötige ich es? Ich kenn das nur vom MSN Messenger, ich meine, da sei mir das Stichwort mal über den Weg gelaufen.
    2. Kann ich 2.0 deinstallieren, wenn ich 3.0 auf dem Rechner habe? Ich habe vor kurzem ein Windows Update gemacht, da kam eben, dass jene besagte 2.0 auf 3.0 geupdatet wird. Wird 3.0 einfach ins Betriebssystem gesetzt und die alte (2.0) Version gammelt vor sich hin?

    Wäre dankbar, wenn mir jemand Hilfe leisten könnte, bin etwas verunsichert, was dieses .NET Framework angeht. Und wenns bereits ein Thema dazu gibt, entschuldige ich mich, hab in der Suche nichts gefunden.

    Gruß Holl

  2.   Anzeige

     
  3. #2
    schläft auf dem Boardsofa Avatar von OSI-L8
    Registriert seit
    10.05.07
    Beiträge
    1.036

    AW: .NET Framework doppelt?

    Es gibt Programme die dieses Framework erfordern. Ob du sie benötigst hängt davon ab, ob du solche Programme verwendest.

    .Net3.0 ist abwärtskompatibel zu 2.0, es reicht für gewöhnlich 3.0 zu haben. Ob Windows es allerdings zu genau nimmt bei einer Deinstallation von 2.0 weis ich nicht. Kommt auf einen Versuch an.

    2.0 ist jedoch nicht abwärtskompatibel zu 1.1 von daher kann es dir passieren, dass eine Anwendung 1.1 fordert auch wenn du 2.0 (oder 3.0) installiert hast. Ob 3.0 das ausführen von 1.1 ermöglicht vermag ich nicht zu sagen.

  4. #3
    gehört zum Inventar Avatar von robbsta
    Registriert seit
    03.07.04
    Ort
    Hannover
    Beiträge
    693

    AW: .NET Framework doppelt?

    Zitat Zitat von OSI-L8 Beitrag anzeigen
    Ob 3.0 das ausführen von 1.1 ermöglicht vermag ich nicht zu sagen.
    Manchmal ja, manchmal nein. Das Problem dabei liegt an der Programmierung. Wenn in die Software eine Überprüfung eingebaut ist, ob das 1.1 Framework installiert ist, dann verweigert es die Installation. Ist die Überprüfung nicht vorhanden, lässt sich das Programm problemlos installieren und meistens auch ausführen. Manchmal kann es jedoch vorkommen, dass das Programm den Dienst verweigert und zwar dann, wenn Klassen verwendet werden die in den Frameworks unterschiedlich sind.
    Für den Programmierer sollte es aber ein leichtes sein, sein Programm mindestens auf Framework 2.0 anzupassen, meistens reicht schon der Konvertierungsassistent von Visual Studio 2005.

  5. #4
    schläft auf dem Boardsofa Avatar von OSI-L8
    Registriert seit
    10.05.07
    Beiträge
    1.036

    AW: .NET Framework doppelt?

    gut somit besteht keine Kompatibilität zwischen 1.1 und 3.0 danke für die Info

  6. #5
    gehört zum Inventar Avatar von Chom
    Registriert seit
    07.11.07
    Ort
    Bergisches Land
    Beiträge
    726

    AW: .NET Framework doppelt?

    Hallo,
    ich habe auch mal dazu eine Frage ich habe .net farmework 2.0 und 3.0 installier aber als ich versucht habe 2.0 zu deinsterlieren hat mir windows angezeigt dass es nich gelöscht werden kann da ander systeme es benötigen.
    aber ich habe hier gelesen das 3.0 kompatibel zu den programmen von 2.0 ist, und da wollte ich mal fragen ob einer weiss wie ich 2.0 löschen kann.

Ähnliche Themen

  1. Microsoft.NET Framework 2.0
    Von schlanke_1988 im Forum Allgemeine Computerfragen
    Antworten: 8
    Letzter Beitrag: 14.11.06, 18:48
  2. Microsoft .NET Framework 3.0 erschienen
    Von Wolfi im Forum Alles rund um Windows
    Antworten: 0
    Letzter Beitrag: 10.11.06, 19:36
  3. Antworten: 9
    Letzter Beitrag: 24.03.06, 15:27
  4. [Gelöst] net framework 1.1 << was ist das ?!
    Von Dready im Forum Alles rund um Windows
    Antworten: 16
    Letzter Beitrag: 26.02.04, 10:57

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •