Ergebnis 1 bis 6 von 6

Thema: [Ubuntu] Netzwerkproblem mit Nautilus

  1. #1
    assimiliert Avatar von Timelord
    Registriert seit
    06.04.07
    Ort
    Hessen
    Beiträge
    3.739

    Verärgert Netzwerkproblem mit Nautilus

    Hi,

    ich hätt da mal a Problem ...

    OK, ab hier wird es ernst:
    System: Ubuntu 6.06 (Dapper Drake)
    LAN-Chip: Realtek RTL8169 (192.168.69.24, name=ForgottenGod)
    Router: 192.168.69.67 (nicht betroffen)
    Betroffen: Zugriff auf Synology RS406 (NAS, 192.168.69.101, name=data)

    Als relativem Poweruser und Umsteiger von Windows mit veralteten Linux-Kenntnissen (es ist jetzt 2 Jahre her und damals waren es reine Server ohne grafische Oberfläche) hab ich ein derbes Zugriffsproblem.
    Jedesmal wenn ich mit dem Dateimanager durch Verzeichnisse des NAS browse und parallel Daten kopiere, hängt sich der Transfer und der Zugriff auf das NAS komplett auf. Internet (via Router) und Drucken via Netzwerk geht weiterhin.
    Ich habe schon alles mögliche versucht - die NAS-Freigaben per fstab oder per Hand gemappt, die komplette Netzwerkkonfiguration neu erstellt, die MTU angepasst, das NAS in der 'hosts' eingetragen, eine andere Switch verwendet, den GNOME-Commander, ...

    So langsam bin ich am Ende. Google kennt zu diesem Problem noch nicht mal eine eBay-Seite.

    Habe jetzt noch ein wenig herumprobiert und konnte das Problem genauer festlegen (oder anders gesagt: ich kann es jetzt unter allen möglichen Bedingungen "provozieren"): Es scheint so, als ob mehrfacher gleichzeitiger Zugriff das Problem verursacht. Am NAS kann es aber nicht liegen - im Härtetest bekomme ich mit 4 Windows-Rechnern gleichzeitig eine perfekte Performance.
    Kann mir jemand einen Tipp geben, was ich noch an meiner Netzwerkkonfiguration umstellen kann?

    Hier ein paar Dateiauszüge:

    resolv.conf
    nameserver 192.168.69.67
    hosts
    [...]
    192.168.69.101 data
    [...]
    (Testweise eingetragen, restliche Daten unverändert, daher nicht aufgeführt.)

    fstab
    # /etc/fstab: static file system information.
    #
    # <file system> <mount point> <type> <options> <dump> <pass>
    proc /proc proc defaults 0 0
    /dev/sda1 / ext3 defaults,errors=remount-ro 0 1
    /dev/sda5 none swap sw 0 0
    /dev/scd1 /media/cdrom0 udf,iso9660 user,noauto 0 0

    //192.168.69.101/share /home/timelord/mnt/share smbfs credentials=/home/timelord/.smbcredentials,uid=1000,gid=1000 0 0
    # //data/share /home/timelord/mnt/share smbfs credentials=/home/timelord/.smbcredentials,uid=1000,gid=1000 0 0
    (Egal ob mit IP oder Servername, es geht nicht. Versuche ich es mit 'cifs' geht gar nichts.)
    (Auch von Hand => sudo mount -t -o username=timelord //data/share /home/timelord/mnt/share <= dasselbe.)

    .smbcredentials
    username=timelord
    password=[...]
    interfaces
    auto lo
    iface lo inet loopback

    auto eth0
    iface eth0 inet static
    address 192.168.69.24
    netmask 255.255.255.0
    gateway 192.168.69.67
    [...]
    Ist in den Dateien soweit alles OK? Habe ich eine wichtige vergessen?

  2.   Anzeige

     
  3. #2
    assimiliert Avatar von Timelord
    Registriert seit
    06.04.07
    Ort
    Hessen
    Beiträge
    3.739

    AW: [Ubuntu] Netzwerkproblem mit Nautilus

    So, habe das ganze Problem jetzt ein bischen einkreisen können und mit einem anderen PC versucht nachzustellen - oh weh, oh Schreck - das ist beständig

    Betriebssystem weiterhin Ubuntu 6.06 (Dapper Drake).
    NAS: Synology RS406

    Problem:
    Mehrfache Zugriffe auf derselben Freigabe frieren den Zugriff des PCs auf die Freigabe ein (z. B. kopieren von der Freigabe auf die lokale Platte und gleichzeitiges Verzeichnisbrowsen auf der Freigabe). Nach einer Ewigkeit fängt sich der PC dann wieder und macht weiter.

    Fragen:
    Kann ich mir die Freigaben noch anders als im 1. Beitrag angegeben mounten?
    Muss ich irgendetwas am Ubuntu konfigurieren, damit der mehrfache Zugriff funktioniert?

  4. #3
    schläft auf dem Boardsofa Avatar von Las_Bushus
    Registriert seit
    18.03.05
    Ort
    DD
    Beiträge
    1.077

    AW: [Ubuntu] Netzwerkproblem mit Nautilus

    hmm und unter win ging das mehrfach browsen ohne probs?
    Variante 1. dein NAS ist schuld
    Variante 2. der Nautilus kriegts nicht gebacken, an der Stelle würde ich mal den Konqueror nutzen, der gehört zwar an sich nicht zu gnome sondern zu kde, funktioniert aber auch unter gnome (soweit ich das getestet habe)
    wenn es mit dem Konqueror geht (den ich richtig cool finde) könntest du ja den nutzen.
    evtl. ist es auch einfach eine veraltete version des Nautilus (mal aktuallisieren, wenn das geht)
    3. vielleicht mal die firmware/software des nas aktuallisieren? wenn es da eine neuere version gibt.

  5. #4
    assimiliert Avatar von Timelord
    Registriert seit
    06.04.07
    Ort
    Hessen
    Beiträge
    3.739

    AW: [Ubuntu] Netzwerkproblem mit Nautilus

    Danke für die Tipps, nachdem ich es mit einem weiteren Rechner probiert hab hat sich leider Variante 1 als Schuldiger enttarnt
    Nach mehrstündigem Suchen im Supportforum von Synology habe ich einen (in Worten: 1) Beitrag dort gefunden, wo bestätigt wird, dass der eingesetzte Sambaserver wohl ein ziemliches Problem mit Linux-Clients hat.

    Es gibt zwar einen Workaround, aber dafür müsste ich in die Firmware des NAS eingreifen - und damit meine Garantie verspielen, was bei dem Anschaffungspreis nicht in die Tüte kommt.

    Bleibt mir nur die Hoffnung, dass sich bald eine neue Firmware mit verbessertem Samba einfindet.

    Ich bin leider von dem NAS abhängig, daher werd ich das schöne Ubuntu erstmal einmotten müssen :'(

  6. #5
    schläft auf dem Boardsofa Avatar von Las_Bushus
    Registriert seit
    18.03.05
    Ort
    DD
    Beiträge
    1.077

    AW: [Ubuntu] Netzwerkproblem mit Nautilus

    klingt ja traurig
    alles nur wegen einem doofen nas
    umtausch willst du nicht? gegen ein anderes gerät?

  7. #6
    assimiliert Avatar von Timelord
    Registriert seit
    06.04.07
    Ort
    Hessen
    Beiträge
    3.739

    AW: [Ubuntu] Netzwerkproblem mit Nautilus

    Das NAS tauschen geht nicht ... dafür ist es einfach zu gut (gnadenlos hohe Geschwindigkeit, gute Zusatzfunktionen und viel viel Speicherplatz). Für meine Anforderungen einfach perfekt (abgesehen nun von der Linux-Unterstützung).

    Update 15.01.2009: Nach eineinhalb Jahren wurde die NFS-Unterstützung in die Firmware eingebaut. Ubuntu installiert und ein paar kleine Tests bestätigen: Es geht.
    Geändert von Timelord (15.01.09 um 23:16 Uhr)

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •