Ergebnis 1 bis 9 von 9
Thema: Apache 2 Problem-Bitte um Hilfe Hallo, ich habe mir den Apache 2.0.47 installiert mit allen Modulen und neuesten MySQL usw. Hatte schon ein bestehendes System ...
  1. #1
    Herzlich willkommen!
    Registriert seit
    19.07.03
    Beiträge
    7

    Apache 2 Problem-Bitte um Hilfe

    Hallo,

    ich habe mir den Apache 2.0.47 installiert mit allen Modulen und neuesten MySQL usw.
    Hatte schon ein bestehendes System mit Apache 1.3.27 auf dem alles super gelaufen ist.

    Wenn ich jetzt bei Apache 2 einen neuen Virtual Host anlegen möchte, bekomme ich beim Start folgenden fehler:

    Fehler beim Starten von Apache :
    Starting Apache with SSL...
    [error] VirtualHost 217.xx.xxx.xx:80 -- mixing * ports and non-* ports with a NameVirtualHost address is not supported, proceeding with undefined results
    (98)Address already in use: make_sock: could not bind to address [::]:80
    no listening sockets available, shutting down
    Unable to open logs

    Error 1! Couln't start Apache!

    Ich hab doch nur normal einen Virtuellen Server angelegt:

    Behandelt den Namen-basierten Server server1.de an Adresse 217.xx.xxx.xx.
    Adresse 217.xx.xxx.xx
    Anschluss 80 Server-Name server1.de
    Dokumenten-Root /home/www/html

    Ich versteh den Apache 2 nicht.

    Wie kann ich jetzt meine ganzen IP's und Virtual Hosts in den Apache 2 einbinden?

    Gruss

  2.   Anzeige

     
  3. #2
    B.Ohlsen der alte Schwede Avatar von SoKoBaN
    Registriert seit
    17.06.03
    Ort
    Soliraffenland
    Beiträge
    4.606

    AW: Apache 2 Problem-Bitte um Hilfe

    Poste doch bitte mal einen kompletten angelegten Vhost.
    Scheint aber probleme mit dem Port 80 zu geben. Bist sicher, das da nix drauf läuft?
    Evtl. der 1er Apahe noch als Systemservice...

  4. #3
    Herzlich willkommen!
    Registriert seit
    19.07.03
    Beiträge
    7

    AW: Apache 2 Problem-Bitte um Hilfe

    Evtl. der 1er Apahe noch als Systemservice...
    Äh, ich dachte, wenn ich ihn stoppe ist es aus mit ihm.
    Wusste nicht, dass das System das nicht weiss, dass ich ihn ersetzt habe mit Apache 2.
    Wie sage ich es dem System, dass ich jetzt den Apache 2 haben möchte.

    Hier ein angelegter VHost.

    NameVirtualHost 217.xx.xxx.xx

    <Directory "/home/www">
    <Files ~ "^\.ht">
    deny from all
    </Files>
    AllowOverride None
    AllowOverride Indexes AuthConfig Limit FileInfo
    Options -FollowSymLinks -SymLinksIfOwnerMatch Includes
    </Directory>
    <Directory "/home/www/user1/html">
    DirectoryIndex index.html index.htm index.php index.php3 index.php4 index.shtml index.shtm index.sht
    Options +ExecCGI +Includes
    </Directory>

    <Directory "/home/www/user1/logs">
    AllowOverride all
    DirectoryIndex index.html index.htm
    AuthType Basic
    AuthName "Logdateien"
    AuthUserFile /etc/userlist.conf
    require user user1
    </Directory>

    <VirtualHost 217.xx.xxx.xx>
    ServerName user1.server.de
    DocumentRoot /home/www/user1/html
    User user1
    Group ftponly
    php_admin_value open_basedir /home/www/user1
    php_admin_value upload_tmp_dir /home/www/user1/phptmp
    CustomLog /home/www/user1/logs/access_log common
    CustomLog /var/log/httpd/access_log common
    CustomLog /var/log/httpd/http_traffic_log traffic
    ServerAlias domain.de
    ServerAlias www.domain.de
    </VirtualHost>

    <VirtualHost 217.xx.xxx.xx>
    ServerName log.user1.server.de
    DocumentRoot /home/www/user1/logs
    User user1
    Group ftponly
    </VirtualHost>

    Gruss und Danke für Deine Hilfe.

  5. #4
    B.Ohlsen der alte Schwede Avatar von SoKoBaN
    Registriert seit
    17.06.03
    Ort
    Soliraffenland
    Beiträge
    4.606

    AW: Apache 2 Problem-Bitte um Hilfe

    Ich glaube, ich bin fälschlicherweise davon ausgegangen, das es sich um ein Windowssystem handelt.
    Sieht aber eher nach Linux aus.
    Nun die Frage...hast das als rpm Installiert oder oder selber compiliert?

  6. #5
    Herzlich willkommen!
    Registriert seit
    19.07.03
    Beiträge
    7

    AW: Apache 2 Problem-Bitte um Hilfe

    RPM von apachefriens.org und es ist Linux.
    Dieses rpm ist das Beste, was ich je gesehen abe. So läuft es ja wunderbar, bis auf das, dass ich halt keine Virt Hosts anlegen kann. Das rpm hat von Grund auf einen Standart Server und der Läuft.

    Gruss

  7. #6
    B.Ohlsen der alte Schwede Avatar von SoKoBaN
    Registriert seit
    17.06.03
    Ort
    Soliraffenland
    Beiträge
    4.606

    AW: Apache 2 Problem-Bitte um Hilfe

    Der Standartserver läuft....das versteh ich u nich ganz...
    der muss doch auch irgendwo seine Vhosts definiert haben.
    Den 1er Apache hast aber nicht zufällig deinstalliert?

  8. #7
    Herzlich willkommen!
    Registriert seit
    19.07.03
    Beiträge
    7

    AW: Apache 2 Problem-Bitte um Hilfe

    Nein den 1er Apache habe ich nicht deinstalliert, war mir zu unsicher, falls der Apache 2 nicht läuft, und siehe da, es war richtig.
    Ist wirklich schade darum, dass der 2er nicht läuft bzw ich keine VHosts anlegen kann.

  9. #8
    B.Ohlsen der alte Schwede Avatar von SoKoBaN
    Registriert seit
    17.06.03
    Ort
    Soliraffenland
    Beiträge
    4.606

    AW: Apache 2 Problem-Bitte um Hilfe

    Also eines ist doch unklar...
    Ich starte apache mit apache start
    Und das mach ich egal, ob 1 oder 2...
    Wenn du nun beide drauf hast, woher willst du wissen, welcher gestartet wurde?
    Die Symlinks müssten doch dann verwurschtelt sein...

  10. #9
    Herzlich willkommen!
    Registriert seit
    19.07.03
    Beiträge
    7

    AW: Apache 2 Problem-Bitte um Hilfe

    Es läuft def. der 2er und ich kann auch mit eingabe einer von meinen Domains die Welcomeseite des LAMPP aufrufen. Ich kann ode schaffe es nur nicht, dem Apachen zu sagen, dass er meine IP's und Domains bzw VHosts einbinden soll.

Ähnliche Themen

  1. [WinXP] Habe ein S-ATA Problem, bitte um Hilfe!
    Von delphi01 im Forum Alles rund um Windows
    Antworten: 4
    Letzter Beitrag: 02.06.05, 05:43
  2. Großes Problem, bitte um hilfe :-(
    Von Killer im Forum Hardware-Forum
    Antworten: 3
    Letzter Beitrag: 08.03.04, 17:46
  3. Router Problem!! Brauche DRINGEND Hilfe!
    Von InternetFreak im Forum Netzwerke & Server
    Antworten: 6
    Letzter Beitrag: 27.02.04, 07:32
  4. Problem: Apache und mod_gzip
    Von MaXg im Forum Netzwerke & Server
    Antworten: 4
    Letzter Beitrag: 04.02.04, 18:53
  5. Apache baut Marktanteil bei Web-Servern aus
    Von RollerChris im Forum WWW News und Gerüchteküche
    Antworten: 0
    Letzter Beitrag: 20.08.02, 17:55

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •  

Search Engine Friendly URLs by vBSEO ©2011, Crawlability, Inc.

1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 37 38 39 40 41 42 43 44 45 46 47 48 49 50 51 52 53 54 55