PDA

Archiv verlassen und diese Seite im Standarddesign anzeigen : [Webdesign] Flash: load movie?



PaffDaddy
02.01.02, 23:28
Hi,
ich möchte aus einer "Filmsequenz"heraus einen neuen Film laden:


on (release) {
gotoAndStop (1);
}
on (press) {
_level0.gotoAndStop(35);
loadMovieNum ("baume.swf", 1);
play ();
}

So funktioniert es leider nicht.Der Film auf Level 0 wird zwar zum richtigen Bild geführt,doch der neue wird nicht geladen.
Der zu ladende Film liegt im selben Verzeichnis!
In der Ausgabe erhalte ich auch keine Fehlermeldung!
Wo liegt denn mein Fehler??

MfG Paffy
:angel

Astrominus
02.01.02, 23:47
Mmmmh..... Also wenn ich das richtig sehe, soll die Filmsequenz "_level0" zu Bild 35 springen und dann ein neuer Film gestartet werden.
Setze doch einmal den "LoadMovie"-Befehl eben in dieses Bild 35.

Oder habe ich etwas falsch verstanden ?

Wenn ich das richtig sehe, springt er BEVOR er den "LoadMovie" befehl ausführen kann dorthin und kann dadurch eben den restlichen Code nicht mehr ausführen (Weil er sich ja in sequenz "level0" auf Bild 35 befindet.

PaffDaddy
03.01.02, 08:07
Hi Astrominus,

ich möchte meinen Film auf Bild 35 parken.
Da ich aber mehrere Buttons in meinem Film auf Level 0 habe,kann ich natürlich nicht bei Bild 35 den Befehl "load movie" eingeben.
Ich werde es aber mal so versuchen,und dann evtl. noch 3 zusätzliche Schlüsselbilder erstellen.
Zur Zeit verweise ich noch auf weitere URL`s,aber mit Flash muß das ja nicht unbedingt sein.

MfG paffy:angel

PaffDaddy
03.01.02, 08:29
Danke, das wars!!!!

Ich werde noch zwei leere Schlüsselbilder erstellen dann gehts.

MfG Paffy:angel

Astrominus
03.01.02, 11:38
Das mit den Buttons wusste ich natürlich nicht.

Freut mich aber das ich trotzdem etwas helfen konnte.