PDA

Archiv verlassen und diese Seite im Standarddesign anzeigen : UT99 läuft zu schnell



Seiten : [1] 2

Cesar
11.03.05, 18:19
Hi,
Leider ist mein PC abgestürzt. Ich musste ihn dann einfach ausschalten. Das Problem ist, er geht nicht mehran. :confused

Jetztmuss ich mit meinem leertaste kaputt seienden Laptop vorlieb nehmen :motz .
Und zwar hier das Problem.
UT läuft zu schnell. Im Vorspann, labert diegute Frau janormal, aber das Bildrast.
Beim Spiel, laufe ich ziehmlich schnell und zitternd umher. Ich Multiplayerspiel, laufen aufalle anderen so komisch. Aufjeden Fall, kann man so nicht spielen.
Nun hab ich mir den neuen OpenGl Treiber runtergeladen, und den alten überschrieben. Ich hab auf openGl umgestellt, undeslief alles normal.

Nach einem Neustart des Spiels, ging es dann wieder nicht :chainsaw: . Ich musste dann erst auf Direct3d umstellen, und vom spiel auswieder auf OpenGl. Dann geht es richtig, biszum nächsten neustart.

Wie kommtdas?
Hat jemand ne Idee :confused
ps. sorry wenn mal ein Leerzeichen fehlt, die Taste klemmt leider

Bio-logisch
11.03.05, 18:25
Das Problem hatte ich auch, schau mal hier:

http://www.utworld.de/faq/ut_bugs.php#speed
Da es ein Laptop ist, musst Du dem Spiel die tatsächliche cpu-Geschwindigkeit per Parameter übergeben.


2. Prozessor mit variabler Taktfrequenz

Mit obigen Tips kriegt man gelegentliche Speedattacken in den Griff - aber was ist los, wenn das Spiel generell zu schnell läuft? Dies tritt häufig bei Notebooks auf, bzw. bei allen Computern mit Prozessoren, die erst unter Last auf volle Geschwindigkeit hochfahren. Folgendes passiert:

1) UT startet und ermittelt den Prozessortakt. Nach diesem Wert wird die generelle Geschwindigkeit des Games eingestellt.
2) Der Rechner stellt fest "Hups, es wird Prozessorpower gebraucht" und dreht die CPU auf - z.B. von 1200 auf 2000 MHz.
3) Wenn UT läuft, basiert seine interne Geschwindigkeit auf dem alten Wert, in Wirklichkeit rennt der Rechner jetzt aber mit wesentlich mehr MHz - Ergebnis: Das Spiel läuft nonstop zu schnell.

Wie soll man das jetzt hinkriegen? Zum Glück kann man UT den MHz-Wert, nach dem es die interne Geschwindigkeit regelt, manuell übergeben! Dazu muß man die Verknüpfung zum Spiel anpassen. (Wenn keine da ist: Bauen. ;) ). Dies geht wie folgt: Man macht man einen Rechtsklick auf die Verknüpfung, wählt "Eigenschaften" und schreibt die Zeile "Ziel" wie folgt um:

Aus
C:\Games\UT\System\UnrealTournament.exe
wird
C:\Games\UT\System\UnrealTournament.exe -CPUSPEED=1600

bei einem Prozessor mit 1600 MHz bzw. 1.6 GHz. Es müssen übrigens die "echten" Megaherzen des Prozessors angegeben werden! Bei CPUs, die statt Taktfrequenz ein "Pentium-Rating" verwenden (z.B. AMD AtlonXP), kann der angegebene Wert von der echten Frequenz abweichen - hier im Zweifelsfall also erst Erkundigungen anstellen.

(Special Thx @ EraseR für den CPUspeed-Tip.)

Cesar
11.03.05, 19:18
Jo, danke hat hingehauen :funny

Schönen Gruss
Cesar :smokin

chmul
11.03.05, 19:46
Wow, was man bei uns alles erfahren kann.... :respekt

Cesar
11.03.05, 20:03
:D Das sach ich dir :D Nicht schlecht

Bio-logisch
11.03.05, 20:15
Unter Linux gibt es das Problem übrigens auch, da kann man es lösen, in dem man die Takt vorher hochschraubt, mit einem kleinen Script:


matthias@linux:~> cat Documents/startut.sh
#!/bin/sh
xgamma -gamma 1.7
su -c "echo 1400000 > /sys/devices/system/cpu/cpu0/cpufreq/scaling_min_freq"
cd /usr/local/games/ut/
./ut
su -c "echo 600000 > /sys/devices/system/cpu/cpu0/cpufreq/scaling_min_freq"
xgamma -gamma 1.0
matthias@linux:~>

Das xgamma -gamma 1.7 sorgt dafür, dass das Bild heller wird, die nächste Zeile schaltet die Minimale cpufrequenz auf 1400000 kHz hoch (also der maximale Wert meines Laptops), danach wechselt das Script ins ut-Verzeichnis und startet das Programm.
Wird das Programm beendet, werden die Einstellungen zurückgestellt.

Die Werte für die cpu bekommt man mit

matthias@linux:~> cat /proc/cpufreq
minimum CPU frequency - maximum CPU frequency - policy
CPU 0 600000 kHz ( 42 %) - 1400000 kHz (100 %) - userspace

Unregistriert
03.08.06, 02:24
hi hi leutz habe genau das gleiche proplem aber bei mir hat das nicht geklappt was Bio-logisch gepostet hat habt ihr vieleicht für mich eine andere idee thx jetzt shcon mal

chmul
03.08.06, 07:23
Du hast auch das Problem, dass UT auf Deinem Laptop zu schnell läuft? Welches Betriebssystem? War das vorher anders oder immer schon so?

Cesar
07.10.06, 16:52
Hiho, nu ich wieder :D

Bio hat oben in dem Zitat das hier zu stehen:
...Mit obigen Tips kriegt man gelegentliche Speedattacken in den Griff - aber was ist los, wenn ..........

Leider ist die Seite Down. Nur noch das Forum gibt es, und da finde ich keine Suche :(
Also ich habe jetzt mit meinem super schnellen Rechner :D diese beschriebenen Speedattaken :(
Hat sich einer aufgeschrieben wie man dieses beheben kann?`
Bio??? :D

AlterKnacker
07.10.06, 17:16
Im Google-Archiv findet sich doch fast alles ;):



11. - UT läuft zu schnell!
Die guten alten Zeiten - die Hardware war zu langsam, und es wurde an allen Ecken getuned, um noch ein paar FPS rauszuholen. Auf aktueller Hardware (Prozessor mit mehrereren GHz, dicke Radeon/GeForce-Karte) muß man sich dagegen nun mit dem gegenteiligen Problem herumschlagen: Das Spiel wird zu schnell. Offline ist das schon häßlich genug, online muß man außerdem noch mit extremen Lags kämpfen, da der Server die hohe Geschwindigkeit nicht mitmacht und einen ständig einen Meter zurücksetzt.

Es gibt zwei unabhängige Gründe, aus denen UT zu schnell wird. Der erste wirkt sich durch gelegentliche Speed-Attacken aus, wenn auf dem Schirm nix los ist (z.B. ein leerer, enger Gang), bei der zweiten Variante läft das Spiel generell mit doppelter Geschwindigkeit.

1. Das FPS-Syndrom

Bei der Programmierung wurde anscheinend von den Codern nicht eingeplant, daß ihr Spiel mal auf entsprechender Hardware mit über 200 FPS laufen würde. Ab dieser Grenze etwa beschleunigt das Game selbst! Dieser Effekt tritt also besonders dann auf, wenn gerade nix los ist (besagter leerer, enger Gang: Die CPU langweilt sich), sobald etwas Action aufkommt, ist alles wieder normal. Mit der eingebauten FPS-Anzeige (Tools -> Timedemo Statistics) kann man das sehr gut nachvollziehen.
Lösung für das Problem: Die maximalen FPS müssen abgeriegelt werden! Dazu gibt es wiederum drei verscheidene Ansätze.

a) Im Online-Modus hängen die maximalen FPS vom sogenannten Netspeed ab. Dieser wird über die Internet-Verbindungseinstellung (Modem&ISDN/DSL/LAN) geregelt und liegt je nach Einstellung bei 5000, 10000 oder 20000 (Byte pro Sekunde). Abfragen kann man den Wert im Spiel per F6-Taste, manuell per netspeed xyz-Kommando setzen - netspeed 12000 legt den Wert auf 12000 fest. Viel höher sollte man nicht gehen, falls Lags wegen zu vielen FPS auftreten.

b) Wenn ihr D3D verwendet, müßt ihr die vertikale Snychronisation (VSync) einschalten. Dies begrenzt die FPS auf die Bildwiederholrate des Monitors. (Röhrenmonitor: Meist 75-100, LCD: 60 :/ ). Den VSync kann man einerseits in den Optionen des Grafikkarten-Treibers unter "D3D" einschalten, andererseits auch in der UnrealTournament.ini aktivieren:

[D3DDrv.D3DRenderDevice]
...
UseVSync=False

Zur Abwechslung steht "False" hier für "VSync aktiviert" - die Programmierer haben hier die Werte vertauscht. Im Zweifelsfall überprüft per FPS-Anzeige, ob das Abriegeln klappt.

c) Die dritte (und imho beste) Möglichkeit bietet OpenGL. Genauer gesagt eine inoffizielle OpenGL.dll namens UTGLR. Die gibt es entweder bei unserern Downloads (http://www.utworld.de/downloads_ut/patches.php) oder direkt von der Quelle (http://cwdohnal.home.mindspring.com/utglr/). Zur Installation muß die DLL ins Systemverzeichnis von UT entpackt und die alte damit überschrieben werden. Danach muß das Game im Safe-Mode gestartet und das Render-Device auf OpenGL umgestellt werden. (OGL wird übrigens erst angezeigt, nachdem man "Show all devices" angetippt hat!)
Startet man das Spiel und wechselt in die Advanced Options (http://www.utworld.de/faq-alt/ut_grundlagen.php#ao), so finden sich hier unter Rendering->OpenGL Support die neuen Settings. (Ändert man hier eine der Einstellungen, schreibt die DLL ihre Einstellungen auch in die UnrealTournament.ini.) Unter den vielen neuen Settings befindet sich eine, um die FPS direkt abzuschotten. Die Zeile für die FPS-Begrenzung lautet:

[OpenGLDrv.OpenGLRenderDevice]
...
FrameRateLimit=99

Dies riegelt die maximalen Frames pro Sekunde bei 99 ab.
Wer unter OpenGL lieber per VSync den Maximalwert setzen will, kann das mit folgender Zeile erreichen:

[OpenGLDrv.OpenGLRenderDevice]
...
SwapInterval=1

Mittels a), b) oder c) (Dolly anyone? ;) ) sollten plötzliche Speedattacken der Vergangenheit angehöhren.

2. Prozessor mit variabler Taktfrequenz

Mit obigen Tips kriegt man gelegentliche Speedattacken in den Griff - aber was ist los, wenn das Spiel generell zu schnell läuft? Dies tritt häufig bei Notebooks auf, bzw. bei allen Computern mit Prozessoren, die erst unter Last auf volle Geschwindigkeit hochfahren (z.B. AMD Athlon64 mit aktivierten Cool'n'Quiet). Folgendes passiert:

1) UT startet und ermittelt den Prozessortakt. Nach diesem Wert wird die generelle Geschwindigkeit des Games eingestellt.
2) Der Rechner stellt fest "Ooops, es wird Prozessorpower gebraucht" und dreht die CPU auf - z.B. von 1200 auf 2000 MHz.
3) Wenn UT läuft, basiert seine interne Geschwindigkeit auf dem alten Wert, in Wirklichkeit rennt der Rechner jetzt aber mit wesentlich mehr MHz - Ergebnis: Das Spiel läuft nonstop zu schnell.

Wie soll man das jetzt hinkriegen? Zum Glück kann man UT den MHz-Wert, nach dem es die interne Geschwindigkeit regelt, manuell übergeben. Dazu muß man die Verknüpfung zum Spiel anpassen. (Wenn keine da ist: Bauen. ;) ). Dies geht wie folgt: Man macht man einen Rechtsklick auf die Verknüpfung, wählt "Eigenschaften" und schreibt die Zeile "Ziel" wie folgt um (Beispiel):

Aus
C:\Games\UT\System\UnrealTournament.exe
wird
C:\Games\UT\System\UnrealTournament.exe -CPUSPEED=1600

bei einem Prozessor mit 1600 MHz bzw. 1.6 GHz. Es müssen übrigens die "echten" Megaherzen des Prozessors angegeben werden! Bei CPUs, die statt Taktfrequenz ein "Pentium-Rating" o.ä. verwenden (z.B. AMD AtlonXP), kann der angegebene Wert von der echten Frequenz abweichen - hier im Zweifelsfall also erst Erkundigungen anstellen.

(Special Thx @ EraseR für den CPUspeed-Tip.)

Update

Anscheinend sind sehr neue Prozessoren (Athlon64 3500+ und aufwärts sowie die entsprechend dicken Intel-Gegenstücke) mit UTclassic nicht wirklich ausgelastet. Das führt dazu, daß die CPU mitten im Spiel je nach Gegneraufkommen, Action usw. die MHz-Zahl nach oben oder unten ändert. Damit läuft die Methode, die Frequenz vorzugeben, ins Leere - das Spiel orientiert sich an einem festen Wert, und der ist nicht mehr gegeben. :p

Aus dieser Misere kommt man nur mit einem Trick heraus. Die variable Taktfrequenz ist unter Windows an ein Energieschema gebunden (Systemsteuerung -> Energieoptionen), meist an das Schema "Minimaler Energieverbrauch". Unter einem anderen Schema wie "Desktop" fährt die CPU immer auf Maximalfrequenz. Man kann natürlich das Schema manuell umstellen, UT starten und danach wieder das alte Schema wiederherstellen; das wird aber auf Dauer lästig. Besser: Eine Batch, die diese Schritte automatisiert.

Batch, wassen das? Kenner skippen diesen Abschitt, Noobs lesen weiter. ;)
Eine Batch ist eine Datei, die ein paar Befehlszeilen enthält. Bei Doppelklick drauf werden diese Befehle ausgeführt. Eine Batch erstellt & editiert man so:
1. Unter Extras->Ordneroptionen->Ansicht den Punkt "Erweiterungen bekannter Dateiypen" abschalten
2. Eine Textdatei auf dem Desktop erstellen und die Endung von .txt auf .bat ändern (das Windows-Gemecker kann weggeklickt werden)
3. Rechtsklick draufmachen, "Bearbeiten" wählen und die Befehlszeilen eintragen
4. Speichern, Editor zumachen, Doppelklicksen ;)

In die Batch kommen folgende Zeilen (Beispiel):

powercfg /setactive "desktop"
C:\Games\UT\System\UnrealTournament.exe
powercfg /setactive "minimaler energieverbrauch"

Die Batch ändert das Schema, startet dann UT und hängt dann im Hintergrund. Macht einem entsprechend brülligen Prozi aber nix weiter aus. ;) Beendet man UT, wird die Batch wieder aktiviert und die letzte Zeile ausgeführt. Somit ist die CPU wieder im Stromsparmodus, und alles ist gut. *g*

"Desktop" und "Minimaler Energieverbrauch" sind die Standardnamen für die entsprechenden Energieschemata. Die können aber auch anders heißen - wenn Windows bei einem der Befehle meckert, selbst in der Systemsteuerung nachschauen. ;)


Na denn, viel Spaß :D

hexxxlein
07.10.06, 20:24
Ich hatte da auch so meine Probleme. Trotz Framebegrenzung und der neuen Verknüpfung von UT mit Taktangabe, lief das Game mal schnell dann wieder langsam und sogar im Dauerlauf. :( Hatte das Energieschema immer manuell umgestellt. Mit der Batchdatei läuft das nun super und konstant mit einer Geschwindigkeit. Danke für das Update. :)

Brummelchen
07.10.06, 22:16
Falls jemanden das Batchfenster stört, so ganz ohne sind die Konsolenfenster auch nicht,
hier eine 32-bit Variante.

UT99 Power-Config
==============
(c) 2006 Brummelchen

Das Programm sucht UT99 in der Registry, es sollte also regulär installiert sein oder
zumindestens diese Einträge vorhanden sein:

HKCR "Applications\UnrealTournament.exe\shell\open\command"
HKCR "unreal\Shell\open\command"
HKLM "SOFTWARE\Unreal Technology\Installed Apps\UnrealTournament" "Folder"

Und arbeitet dann folgenden Code ab:

nsExec::Exec '"$POWERCFG" /setactive $\"desktop$\"'
nsExec::Exec '$UTPATH\system\UnrealTournament.exe'
nsExec::Exec '"$POWERCFG" /setactive $\"minimaler energieverbrauch$\"'

Es ruft das entsprechende Programm auf, wartet auf dessen Beendigung und geht dann weiter.
Es werden keine DOS-Boxen angezeigt wie im Batch.

Falls ihr eine Virenwarnung bekommt, ist alles sauber, sind Falschmeldungen.
Das ist normal für NSIS.

Das Programm kann nur für eine Instanz gestartet werden.

- Version 0.1
- Version 0.2: kann auch INI benutzen


[ut99]
path=c:\spiele\Unreal
mode1=desktop
mode2=minimaler energieverbrauch

(Beispieleinträge, \system\unrealtournament.exe wird selbst hinzugefügt)

Die INI, kann, muss aber nicht benutzt werden, ansonsten wird gesucht.
Die Modi werden nicht überprüft, sollten schon die richtigen sein (auch richtig geschrieben)

Infos, Download, Updates
https://www.supernature-forum.de/tipp-and-tricks-and-help/60704-ut-power-config.html

hexxxlein
07.10.06, 23:23
Funktioniert ebenfalls bestens und ohne Probleme. :)

Cesar
08.10.06, 13:41
Oki, ich danke euch wiedermal gaaanz herzlich :)
Werd das sofort mal versuchen.

Cesar
08.10.06, 18:48
So, ich nochmal, und damit ihr nicht aus der Übung kommt, wie immer mit nem Problem :D

Nach ewigem Versuchen, hab ich gar nicht erreicht:heul

Angefangen hab ich damit:

b) Wenn ihr D3D verwendet, müßt ihr die vertikale Snychronisation (VSync) einschalten. Dies begrenzt die FPS auf die Bildwiederholrate des Monitors. (Röhrenmonitor: Meist 75-100, LCD: 60 :/ ). Den VSync kann man einerseits in den Optionen des Grafikkarten-Treibers unter "D3D" einschalten, andererseits auch in der UnrealTournament.ini aktivieren:

[D3DDrv.D3DRenderDevice]
...
UseVSync=False

Zur Abwechslung steht "False" hier für "VSync aktiviert" - die Programmierer haben hier die Werte vertauscht. Im Zweifelsfall überprüft per FPS-Anzeige, ob das Abriegeln klappt.


Ich habe gar nicht die Zeile "UseVSync...."
Hab ich aber einfach mal hingeschrieben.
Bringt nichts :(


Dann das:

c) Die dritte (und imho beste) Möglichkeit bietet OpenGL. Genauer gesagt eine inoffizielle OpenGL.dll namens UTGLR. Die gibt es entweder bei unserern Downloads oder direkt von der Quelle. Zur Installation muß die DLL ins Systemverzeichnis von UT entpackt und die alte damit überschrieben werden. Danach muß das Game im Safe-Mode gestartet und das Render-Device auf OpenGL umgestellt werden. (OGL wird übrigens erst angezeigt, nachdem man "Show all devices" angetippt hat!)
Startet man das Spiel und wechselt in die Advanced Options, so finden sich hier unter Rendering->OpenGL Support die neuen Settings. (Ändert man hier eine der Einstellungen, schreibt die DLL ihre Einstellungen auch in die UnrealTournament.ini.) Unter den vielen neuen Settings befindet sich eine, um die FPS direkt abzuschotten. Die Zeile für die FPS-Begrenzung lautet:

[OpenGLDrv.OpenGLRenderDevice]
...
FrameRateLimit=99

Dies riegelt die maximalen Frames pro Sekunde bei 99 ab.
Wer unter OpenGL lieber per VSync den Maximalwert setzen will, kann das mit folgender Zeile erreichen:

[OpenGLDrv.OpenGLRenderDevice]
...
SwapInterval=1

Mittels a), b) oder c) (Dolly anyone? ) sollten plötzliche Speedattacken der Vergangenheit angehöhren.



Die Zeile "Frame Limit..." und "Swap Interval..."
Habe ich ebenfalls nicht. Auch nach dem erstellen passierte nichts :( Ausser dass das Spiel dann in Zeitlupe lief.

Und zu guter letzt habe ich mir die Batch Datei erstellt. Auch hier läufts dann nur in Zeitlupe.

Die Batch sah bei mir dann so aus:
powercfg /setactive "desktop"
C:\Programme\UnrealTournament\System\UnrealTournament.exe
powercfg /setactive "minimaler energieverbrauch"

UT startete dann auch, aber das wars.

Wie ihr seht, ich hab mal wieder von Tuten und Blasen keine Ahnung, und hoffe auf Hilfe.

Vielen Dank schonmal, und liebe Grüße:hallo

vllt was zu meinem Prozessor??
AMD Athlon 64 X2 Dual Core Prozessor 4600+ :daumen+

Gorkon
08.10.06, 19:15
Zum Initialposting: Wenn Settings nicht gespeichert werden, ist die Ini schreibgeschützt. Haben wir ein CD-Backup eingespielt? :p

OpenGL:
https://www.supernature-forum.de/tipp-and-tricks-and-help/45723-opengl-faq.html
Nach dem Schritt mit den "Preferences" gibt es auch alle Settings.

Der ganze Geschwindigkeits-Krempempel ist nur dann wichtig, wenn dein Rechner Cool&Quiet aktiviert, die entsprechenden Treiber installiert und den Stromsparmodus eingestellt hat. Findet sich unter Systemsteuerung->Energieoptionen. Da kannst du
a) sehen, wie die Energieschemata heißen
b) ob die Befehle in der Batch was bewirken (mal einzeln in eine Eingabeaufforderung tippen)


vllt was zu meinem Prozessor??
Vllt mal was zum Rechner?!? Ein Posting der Marke "Habe Pobleme mit meinem Rechner" ohne genaue Beschreibung desselben ist gelinde gesagt suboptimal...

Brummelchen
08.10.06, 19:42
>> Vllt mal was zum Rechner?
https://www.supernature-forum.de/allgemeine-computerfragen/60531-pc-vergleich.html
:p

>> Haben wir ein CD-Backup eingespielt?

Bei mir wurde das RO immer zurückgesetzt, seit ich XP benutze

>> Nach dem Schritt mit den "Preferences"

UT starten, Konsole auf (ö) "open preferences" (kann auch "show preferences"/"preferences" sein) eingeben.
Dann den richtigen Treiber wählen und einstellen. IdR erstellt jener beim Öffnen
der prefs per Konsole alle seine Einträge, nicht nur die manuell erstellen.
Deswegen kennt Gorkon die ja immer alle :D

Cesar
08.10.06, 21:01
Oki danke euch nochmal. Werd ich morgen dann mal wieder versuchen :)

@Gorkon
AMD Athlon 64 X2 4600+ (Windsor, 2,40 Ghz)
Zwischenspeicher: LEvel-1-/Level-2-Cach: 2x64 Kilobyte /2x512Kilobyte
Arbeitsspeicher: TRS DDR2-667 CL 5 (2 Dual Channel)
Arbeitsspeicher: 1024 - bis 4096 aufrüstbar
Chipsatz/Bios: Nvidia Nforce 550 / Phoenix
GraKa: Nvidia Geforce 7600 GS/256MB
Der isses ;)


Vllt mal was zum Rechner?!? Ein Posting der Marke "Habe Pobleme mit meinem Rechner" ohne genaue Beschreibung desselben ist gelinde gesagt suboptimal.
Dachte halt, nur der Prozi ist dafür verantwortlich, dass das Teil zu schnell läuft...
Am Ram wirds nicht liegen, an der GraKa auch nicht und an der FP erst recht nicht :D Oder?!
Desshalb hab ich nur meinen Prozessor gepostet ;)

Cesar
08.10.06, 22:15
Man das ist ja wieder peinlich:heul :heul :heul :heul

Habs nochmal versucht.
Erst war das Spiel in Zeitlupe, dann rannte es auf einmal.
Hab mit den Frames von 0 - 600 alles versucht. Immer in 10er schritten erhöht:eek
Wie gesgat, entweder es rennt und hat ´hat kurze nochschneller renner, oder es schleicht, und ich mach ein Monsterkill nach dem anderen:lol Fetzt :D

Mein Energischema heisst Desktop, hab aber alles auf "NIE".

Kann nich mal einer von euch per Software auf meinen PC, und das richtig machen:angel
Ich bin zu blöd für sowas:heul

hexxxlein
08.10.06, 22:51
Find ich schon komisch. Wenn ich auf Desktop stelle, dann läuft UT ganz normal und ich brauch die Zusätze (Batch etc. ) nicht. Hab dann eben nur in der UT ini unter den OpenGL Settings folgendes eingetragen:

FrameRateLimit=85
SwapInterval=1

In den Settings der Grafikkarte bei "Vertikale Synchronisation" sollte die Einstellung auch auf Anwendungsgesteuert bzw. auf An gesellt sein. Erst dann zeigt "SwapInterval=1" auch Auswirkungen. Da macht das auch keinen Unterschied ob ich bei FrameRateLimit 0 oder 85 stehen habe. Höher komme ich dann halt nicht.

Ich bekam erst diese Probleme mit UT (ebenso wie du sie beschreibst), als ich den AMD Treiber installiert, im Bios "Cool n Quit" aktiviert und das Energieschema auf "Minimaler Energieverbrauch" umgestellt hatte.

Nichts von all dem soll bei dir helfen? Geh noch einmal langsam deine Settings durch.

Wenn du UT ordnungsgemäß installiert hast, kannst du auch das Zip von Brummlechen runterladen. Entpackst das irgendwo und legst dir eben von der Exe eine Verknüpfung. UT wird damit ebeso gestartet. Dann brauchst du die Batchdatei nicht mehr. :)

Cesar
08.10.06, 23:34
Also in meiner Unreal Tounament.ini, sieht es unter OpenGL so aus:
[OpenGLDrv.OpenGLRenderDevice]
Translucency=True
VolumetricLighting=False
ShinySurfaces=True
Coronas=True
HighDetailActors=True
DetailTextures=True
TruFormMinVertices=0
TruFormTessellation=3
UseTruForm=False
ZRangeHack=False
AAFilterHint=0
NumAASamples=0
UseAA=False
RequestHighResolutionZ=True
MaskedTextureHack=False
SmoothMaskedTextures=False
FrameRateLimit=99
SwapInterval=1
UseVertexProgram=False
UseCVA=False
UseMultiDrawArrays=False
TexDXT1ToDXT3=False
DynamicTexIdRecycleLevel=100
CacheStaticMaps=False
UseTexPool=True
UseTexIdPool=True
UseSSE2=True
UseSSE=True
BufferTileQuads=False
BufferClippedActorTris=True
SinglePassDetail=False
SinglePassFog=False
ColorizeDetailTextures=False
DetailClipping=False
UseDetailAlpha=True
DetailMax=0
RefreshRate=0
MaxTMUnits=0
NoFiltering=False
NoMaskedS3TC=False
MaxAnisotropy=0
UseTNT=False
Use16BitTextures=False
UseS3TC=False
UseAlphaPalette=False
AutoGenerateMipmaps=False
UseTrilinear=False
UsePrecache=False
AlwaysMipmap=False
ShareLists=False
UsePalette=False
UseMultitexture=True
UseBGRATextures=True
UseZTrick=False
MaxLogTextureSize=8
MinLogTextureSize=0
MaxLogVOverU=8
MaxLogUOverV=8
OneXBlending=False
GammaCorrectScreenshots=False
GammaOffsetBlue=0.000000
GammaOffsetGreen=0.000000
GammaOffsetRed=0.000000
GammaOffset=0.000000
LODBias=0.000000
DescFlags=0
Description=
FrameRateLimit=85

Vertikale Sync. ist auf Anwendungsgesteuert!
Energiesch. ist auf Desktop!

Wenn ich das Spiel mit Brummelchens Zip starte, läuft es nicht mehr in ZEitlupe, sondern wieder extrem schnell...

Allerdings finde ich in meiner Registry auch den Eintrag
"HKCR "Applications\UnrealTournament.exe\shell\open\command"" nicht :(
Applications ist da, aber UT.exe nicht.
Die beiden anderen sind aber da!

Werde morgen nochmal neu installieren.

Danke dir aber erstmal ganz herzlich :)

Cesar
09.10.06, 11:50
So hab ich nochmal neu installiert.
Leider mit dem selben "Erfolg" :heul
Glaub ich schmeiss den PC ausm Fenster:lol

Gorkon
09.10.06, 13:52
Du hast FrameRateLimit doppelt drin. Einmal mittendrin =99 und das andere Mal ganz am Ende =85. Ansonsten mußt du halt überprüfen, ob die beiden Bedingungen (abgeriegelte FPS, konstante CPU-Gescheindigkeit) gegeben sind.

1. Im Game findest du unter "Tools" die "Time Demo Statistics". Einschalten, dahinter verbirgt sich die FPS-Anzeige. Dann ein bissi Deddeln und beobachten - wenn sie über den eingestellten Maximalwert geht, ist was falsch eingestellt.
2. Die akteulle Prozi-Geschwindigkeit kannst du dir unter Windoze mit diversen Programmen anzeigen lassen. Gibt da z.B. auf der AMD-Seite (http://www.amd.com/de-de/Processors/TechnicalResources/0,,30_182_871_13118,00.html) was (AMD Clock), vl sogar anderswo bessere Tools. Und denne startest du UT und beobachtest, was die Taktfrequenz so treibt. Sie sollte während des Spielens konstant bei 2400 MHz liegen. Du kannst das Game übrigens jederzeit per Alt-Return in den Fenstermodus schießen, um die Anzeige wieder im Blickfeld zu haben.

Cesar
09.10.06, 14:17
Hi du, und danke nochmal.
Das mit dem Doppeltem FrameRateLimit ist mir gestern noch aufgefallen.
Daran lag es nicht :D

Also "AVG" geht selten über 30.
Die Taktfrequenz liegt bei 2400 - 2450 MHz. Das schwankt ständig.

Gorkon
09.10.06, 14:38
AVG steht für Average (Durchschnitt) und ist völlig egal. Es kommt drauf an, daß die aktuellen FPS (der lustig schwankende Wert über AVG) nicht über den eingestellten Wert (85? 99?) gehen. Sie sollten optimalerweise immer genau drauf oder kurz darunter liegen.

Wobei mir schleierhaft ist, wie man mit einem X2 4600+ einen AVG-Wert von popeligen 30 hinkriegt. Die CPU schafft locker mehr. Es sei denn, du quälst deine Graka mit 1600x1200 in 16fach AntiAliasing. Oder hast die Mainboardtreiber o.ä. vergessen.

Schwankungen zwischen 2400 und 2450 halte ich für Meßungenauigkeiten. Solange es nicht wild zwischen 1000 und 2400 schwankt, können wir den Faktor "variable CPU-Frequenz" schon mal ausschließen.

Cesar
09.10.06, 16:00
Hi du, und vielen Dank nochmals.

Ich hab noch die ganze Zeit versucht, dann lief das Spiel mal schnell, mal zu langsam.
Dann kam Besuch, ich hab den PC ausgeschalten, und nach dem erneuerten Hochfahren, geht es:daumen+
Keine Ahnung wieso auf einmal, habe die Einstellungen ja nicht verändert wärend der PC aus war:lol

Werd mal noch ein wenig versuchen, und rausfinden woran es lag...
Wegen Dem AVG Wert guck ich auch nochmal.
Auflösung im Spiel ist 800X600, AntiAliasing ist auf Anwendungsgesteuert. MB Treiber müssten installiert sein, sonst würde mein Gerätemanager ja was zeigen oder?!

Werd nochmal gucken:hallo

Also AVG liegt jetzt bei 59,63 Schwankt natürlich leicht...
Und Last Sec. hat den selben Wert.
Mehr steht bei mir nich :)

Scheint ja alles zu gehen jetzt.

Werd mir gleich mal den UT Ordner sichern, falls ich mal neu installieren muss:D

Gorkon
09.10.06, 16:22
Last Sec ist der gesuchte Wert. Ok, heißt übersetzt, dein Monitor fährt bei der Auflösung 60Hz, so daß die FPS jetzt wegen VSync bei 60 abgeriegelt werden. Bei einem LCD/TFT ist das normal. Wenn du mehr FPS haben willst, SwapIntervall auf 0.

Bei einem Röhrenmonitor sollte mehr als 60Hz drin sein. Einstellbar ist das in der Ini hier:
RefreshRate=X
0 benutzt Systemeinstellung (die kann durchaus bei 60 liegen), ansonsten kann man da selbst was reinkleben - je nach Monitor und Auflösung z.B. 75, 85 oder 100.

P.S. eine 7600 dürfte mehr als 800x600 schaffen. ;)

Cesar
09.10.06, 17:15
Ich trau mich gar nicht mehr in der .ini was zu machen. Bin sau Froh dass das jetzt läuft.
Aber die Herzzahl kann ich doch auch unter Windows ganz easy ändern, oder reicht das nicht?

800X600 find ich ganz optimal :)
Aber ich werd mal noch ein bissl rumspielen.

Danke dir nochmal.

Gorkon
09.10.06, 17:51
Mussu kucken, ob das so easy in Windoze geht, im Zweifelsfall im Treibermenü. Sonst ein bissi googeln nach RefreshForce.

Cesar
09.10.06, 18:20
Alles Roger, versuch ich dann mal, Thx :)

Cesar
09.10.06, 20:15
Hey, ganz ehrlich ich war es nicht!

Hab eben UT gespielt (offline), alles Supi. Dann hab ich nen Onlinespiel gestartet, um meinen Ping mal zu sehen, alles Supi.
Dann hab ich meinen PC neu gestartet, UT gestartet, nichts Supi:heul
Nu rennt das wieder!

Wie geht denn sowas?
Hab ich ne Maus in der Festplatte, die Daten verschiebt/zerstört oder sonstwas macht?

Einstellung sind alle so wie vorhin auch.

Cesar
09.10.06, 20:28
Hab euch das mal hochgeladen.
ISt nen Video wie das bei mir läuft. Das "Stocken" liegt nicht an einem zu lahmen PC, sondern genau wie es auf dem Video zu sehen ist, läuft das Spiel zZ bei mir wieder :(

Hier ist der Link: UT.rar at uploaded.to - Free File Hosting, Free Image Hosting, Free Music Hosting, Free Video Hosting, ... (http://uploaded.to/?id=9cddbb)
Sind 7MB ca.


Vielleicht kann damit einer mehr anfangen als ich.
Achtet auch auf diese AVG und last Sec. am rechten Rand!

Brummelchen
09.10.06, 22:53
Sorry, das ist zu ruckelig, um was zu erkennen. Oder meinst du genau das?

Cesar
09.10.06, 23:04
Ja genau das geruckel meine ich. so wie es auf dem Video zu sehen ist, so ist das bei mir.
Das Spiel läuft zu schnell und ruckelt dabei auch noch ohne ende.
Sogar die Maus ruckelt im Menü ohne Ende, als wenn mein PC viel zu schwach wäre...

Cesar
09.10.06, 23:56
nur mal so am Rande, jetzt läuft es wieder in ZEitlupe :D
Ich hab nichts verstellt!

ich glaube ich werde mit diesem PC eine genauso Gute Freundschaft wie mit meinem alten schliessen :(

Gorkon
10.10.06, 00:36
Äh...was ist das für ein bekiffter halb Fenster halb Fullscreen Modus? Wundert mich nicht wirklich, daß es dann nur so bescheiden läuft. Wenn du nicht mehr weißt, wie du das geschafft hast, kill im Zweifelsfall die Ini und fang von vorne an. Und nebenbei, falls du es gemacht haben solltest, UT offen haben & gleichzeitig in der Ini popeln ist sinnfrei bis kontraproduktiv.

Wenn es wieder in Zeitlupe läuft, ich habe verdammt nochmal haarklein beschrieben, welche beide Faktoren du untersuchen mußt. Grinsesmileys & Ichhabnixgemacht posten bringen niemanden weiter.

Cesar
10.10.06, 10:48
Keep Cool Baby! :D
Also, gespielt habe ich im normal Full Screen. Aufgenommen wurde es leider nur so !
Und NEIN, ich habe wärend UT offen war, nicht an der ini gespielt!

Und diese Verdammt nochmal haarkleinen Faktoren sind nunmal so wies sein soll!

Es tut mir ja nun mal leit, dass ich nicht so viel davon weiss wie ihr.
Dann stelle ich halt mal eins zwei Fragen mehr, aber ich würde es sonst nicht schaffen!

Ich kann dich/euch ja verstehen, wenn ich euch tierisch auf den Sack gehe mit Doofen Fragen, aber als es gestern auf einmal nicht mehr ging, dann musste ich euch das doch sagen! Und ich hab gesagt wie es war! Ich hab den PC neugestartet.

Hab dann in die .ini gekuckt, ob sich da was verstellt hat (bin eigentlich alle Punkte von euch nochmal abgegangen), und hab dann meinen Hilfe Schrei, und ein ":D" hier losgelassen.

Ich werde jetzt die ini Löschen - das hatte ich noch nicht gemacht (wusste auch nicht dass man das ohne Probs machen kann), und nochmal anfangen.

Bis dann

hexxxlein
10.10.06, 14:19
Alles wichtige wurde bereits gesagt, was mir noch einfällt sind die GK Settings nicht ganz so hoch zu nehmen. Allerdings habe ich auch gesehen, dass einige Punkte davon von UT nicht genutzt werden, da sie per ini nicht gesetzt wurden. Spielst du auf einen TFT oder nutzt du einen Röhrenmonitor?

Ansonsten wie Gorkon schon sagt, ini raus und neu anfangen, Nach und nach die Einstellungen sorgfältig durchgehen.

Wenns dir hilft, kann ich dir auch gerne meine Settings zukommen lassen. Ich spiele mit OpenGL und GK ist 6800GT ebenfalls AMD Prozi. :)

Cesar
10.10.06, 15:45
Hi Hexxxlein,

Habe vorhin die Ini schon neu gemacht. Leider passiert wieder nichts.
Ich habe es jetzt aufgegeben.

Aber wenn du mir mal deine zukommen lassen könntest wäre das richtig klasse.
Vielleicht gehts ja dann...

Aso, ich hab nen Röhrenmonitor.

Gorkon
10.10.06, 17:12
Sorry, wenn ich ein bisserl allergisch reagiert habe. Aber aus Erfahrung kann ich sagen, daß "Ich hab nichts gemacht" Bullshit ist. "Ich weiß nicht mehr, was ich zuletzt geändert habe" trifft meist eher zu. Gerne sowas wie eine Ini, die noch geöffnet ist, beim Schließen wird gefragt "Änderungen speichern?", und du klickst auf "Ja" - ohne daran zu denken, daß du damit möglicherweise irgendwelche Settings überspeichert hast.

Beim Zeitlupen-Effekt ist ziemlich definitiv die variable Taktfrequenz schuld. Möglicherweise gibst du auch eine falsche Frequenz vor (das am besten ganz sein lassen). Irgendwas hast du irgendwie irgendwo umgestellt. Oder du hast mal Brummels EXE laufen lassen, ohne dran zu denken, daß sie das System zum Schluß in den Stromsparmodus schickt und es dort bleibt. Irgendsowas halt. Bevor du mir nicht glaubhaft versicherst, daß du die Energieschemata und die aktuelle Taktfrequenz beim Zocken mehrfach überprüft hast, bleibe ich bei meiner Meinung, daß du schlichtweg was verstellt hast.

Warum es zwischendurch so extrem rumgeruckelt hat, da bin ich jetzt überfragt. Selbst im Softwaremodus sollte es schneller laufen. Du hast nicht zufälligerweise gleichzeitig die Graka mit einem Heißluftfön bearbeitet? ;) btw braucht die eigentlich einen zusätzlichen Stromanschluß?

P.S. bevor jemand meckert "Mach hier nicht den Dicken, hast doch selbst keine Ahnung": Doooooch. :p Habe mir vor 2 Wochen dieselbe CPU eingebaut. Läuft. ;)

Cesar
10.10.06, 17:48
Jo ist OK :)

Aber mal ganz ehrlich, ich habe wirklich nichts gemacht.

Wie gesagt, es ging nicht, und ich habe den PC ausgeschalten. Bein nächsten Start ging es dann.
Beim zweiten Neustart, ging es wieder net. Und so ist es jetzt.
Ich hatte nun erst auf die GraKa getippt, dass die nen Schuss hat oder so...

Also die GraKa hat keinen zusätzlichen Stromanschluss. Wundert mich eigendlich.

Soll ich nochmal so ein schnuckeliges Video drehen, da kannst du dann genau meine Einstellungen sehen, und dann starte ich mal UT.

Dann kannst du dich 100%ig vergwewissern.

Ich bin wie gesagt für jeden Tip dankbar, und versuche ihn auch umzusätzen, aber hier komm ich nicht mehr weiter...

Ich Checke jetzt nocheinmal ALLE Einstellungen, gehe nochma den gesamten Tread durch (wie heute morgen), und finde vielleicht was.^

EDIT:
Eben ging es wieder.
Bis zum nächsten Neustart.

Denke mal da hat der Prozessor, oder die Graka eine wech oder?!
Taktf. ist bei 2400... Konstand.

Gorkon
10.10.06, 18:22
Definiere "geht". Definiere "geht nicht".

Laß es mal im Software-Modus laufen. Dann weißt du definitiv, ob es an der Graka liegt oder nicht.

Cesar
10.10.06, 18:29
Geht heisst, es läuf so wie es ein soll, geht nicht heisst es rennt/stockt ;)

Im Software Modus, rennt es extrem schnell, aber es stockt da nicht.

Hab dir mal nen Video gedreht.
Sind 6 MB ca.
Da bin ich die Einstellungen durchgegangen, und habe dann UT gestartet. Wärend UT lief, das selbe nochmal :)
UT 2te.rar at uploaded.to - Free File Hosting, Free Image Hosting, Free Music Hosting, Free Video Hosting, ... (http://uploaded.to/?id=f4ad33)

hexxxlein
10.10.06, 18:29
Doch, ich kann Gorkon verstehen, und es liest dich druchaus nicht als ob du den dicken Max machst. Hilfestellung ist wohl eher das richtige Wort.

Also Cesär. Wie Gorkon sagt, irgendwas läuft da gewaltig schief.

1. Falls du eine Verknüpfung von UT mit der CPU Taktfrequenz erstellt hast, dann lösch diese.
2. Hast du den AMD Treiber installiert und Cool n Quit im Bioas aktiviert?
3. Wenn ja - wie ist in den Energieoptionen das Schema eingestellt? Desktop oder Minimaler Energieverbrauch?
Rat von mir zum Testen: Im Bios Cool n Quit deaktivieren und das Energieschema auf Desktop stellen.
4. GK Settings prüfen (VSync sollte auf An oder Anwendungsgesteuert stehen)
5. OpenGL Setting in der ini prüfen

Noch eine Frage. Auf welcher Bildschirmaktualisierungsrate ist der Monitor eingestellt? 85 Hertz oder 100?

Ich gebe dir hier meine OpenGL Settings, die in der UT ini eingetragen sind:

[OpenGLDrv.OpenGLRenderDevice]
AAFilterHint=0
AlwaysMipmap=False
AutoGenerateMipmaps=False
BufferClippedActorTris=False
BufferTileQuads=False
CacheStaticMaps=False
ColorizeDetailTextures=False
Coronas=False
DescFlags=0
Description=NVIDIA GeForce 6800 GT
DetailClipping=False
DetailMax=0
DetailTextures=False
DynamicTexIdRecycleLevel=100
FrameRateLimit=85
GammaCorrectScreenshots=True
GammaOffset=0.000000
GammaOffsetBlue=0.000000
GammaOffsetGreen=0.000000
GammaOffsetRed=0.000000
HighDetailActors=True
LODBias=0.000000
MaskedTextureHack=False
MaxAnisotropy=2
MaxLogTextureSize=8
MaxLogUOverV=8
MaxLogVOverU=8
MaxTMUnits=0
MinLogTextureSize=0
NoFiltering=False
NoMaskedS3TC=False
NumAASamples=2
OneXBlending=False
RefreshRate=85
RequestHighResolutionZ=False
ShareLists=False
ShinySurfaces=True
SinglePassDetail=True
SinglePassFog=False
SmoothMaskedTextures=False
SwapInterval=1
TexDXT1ToDXT3=False
Translucency=True
TruFormMinVertices=0
TruFormTessellation=3
Use16BitTextures=False
UseAA=True
UseAlphaPalette=False
UseBGRATextures=True
UseCVA=False
UseDetailAlpha=True
UseMultiDrawArrays=True
UseMultiTexture=True
UsePalette=True
UsePrecache=False
UseS3TC=False
UseSSE=True
UseSSE2=True
UseTNT=False
UseTexIdPool=True
UseTexPool=True
UseTrilinear=False
UseTruForm=False
UseVertexProgram=False
UseZTrick=False
VolumetricLighting=False
ZRangeHack=False

Sollten diese Einstellungen bie dir nicht laufen, dann ändere folgende Punkte:
MaxAnisotropy=2 --> 0
NumAASamples=2 --> 0
UseAA=True --> False
UsePrecache=False --> True

In den Settings der Grafikkarte habe ich folgendes stehen:
Anti-Aliasing Einstellungen = Anwendungsgesteuert
Anisotrope Filterung = Anwendungsgesteuert
Systemleistung = Qualität
Vertikale Synchronisation = Anwendungsgesteuert
Mipmaps erzwingen = Keine
Übereinstimmende TextureClamp = Ein
Erweiterungsbeschränkung = Aus
Hardewarebeschleunigung = Ein Bildschirm
Trilineare Optimierung = Ein
Anisotrope Mip-Filteroptimierung = Aus
Optimierung des anisotropen Musters = Ein
DreifachPuffer = Aus
Negativer LOD-Bias = Erlauben

- sind wohl noch die Grundeinstellungen

So kannst du erst mal testen. Rennt oder schleicht UT dann immernoch, bitte noch einmal melden.

Cesar
10.10.06, 18:35
1. Falls du eine Verknüpfung von UT mit der CPU Taktfrequenz erstellt hast, dann lösch diese.
2. Hast du den AMD Treiber installiert und Cool n Quit im Bioas aktiviert?
3. Wenn ja - wie ist in den Energieoptionen das Schema eingestellt? Desktop oder Minimaler Energieverbrauch?
Rat von mir zum Testen: Im Bios Cool n Quit deaktivieren und das Energieschema auf Desktop stellen.
4. GK Settings prüfen (VSync sollte auf An oder Anwendungsgesteuert stehen)
5. OpenGL Setting in der ini prüfen


Hihi:hallo

1- hab ich nicht
2- AMD treiber sind installiert Cool n Quit hab ich gestern deaktiviert
3-Energieschema - Desktop - alles andere hab ich gelöscht
4- VSync ist auf Anwendungsgesteuert. (siehe neues Video)
5- Ini, hab ich auch schon 100 mal überprüft.

Der Monitor ist auch 60Hz.

So, dann werd ich mal deine Ini vergewaltigen:lol
Danke dafür

hexxxlein
10.10.06, 18:44
Wenn du einen Röhrenmonitor nutzt, dann kannst du diesen auch auf 85Hertz laufen lassen. :) Sorry, dass Video konnte ich erst später sehen, war mit der Erstellungs des Beitrages beschäftigt. :)


Solltest du den Monitor auf 60 Hertz stehen lassen, dann ändere die Werte:
RefreshRate=85 (60)
FrameRateLimit=85 (60)

Kommst dann eh nur auf Max 60 Frames, da VSync an ist. :)

Edit: Darauf achten, dass du in UT als Renderer auch OpenGL angewählt hast, sonst greifen die Einstellungen nicht.

Cesar
10.10.06, 18:48
So oki, doki :)

Nach dem ich meine OpenGL Settings mit deinen erstezt habe, war das gleiche wie vorher.
Dann habe ich die Optionen geändert die du gesagt hast, und dann lief das Spiel wieder in Zweitlupe. Hab ich auch gleich aufgenommen, aber leider war das Fenster "AMD Clock" hinter das UT Fenster gerutscht :(
Bei nächsten Start des Spiels (selbe Einstellungen), hackt es wieder nur noch (So wie mit meinen OpenGL einstellungen)

Monitor ist auf 85Hz jetzt. Hat aber im spiel nichts gebracht.

So des wars erstmal :)

hexxxlein
10.10.06, 18:58
Als einzige Option bleibt nun nur noch Cool n Quit wieder aktivieren, Energieschema auf Minimaler Energieverbrauch stellen.
Damit läuft UT aber noch nicht. Lade die Exe von Brummelchen runter, dann in einen Ordner entpacken und die Exe starten - nur die Exe und nicht UT. Das Spiel sollte nun selber mit umgestellten Energieschema starten. So und nur so läuft UT auch bei mir mit gleicher Geschwindigkeit und Max 85 Frames online sowie offline. :)

Sollte das so auch nicht laufen, dann bin ich mit meinem Latein am Ende. :(

Cesar
10.10.06, 19:18
Oki, da hab ich aber gleich wieder nen neues Prob.

Ich habe alle Energieschemas gelöscht bis auf "Desktop", da sich das ständig alleine umgestellt hat.
Muss ich gleich ma gucken.
Ich begeb mich jetzt erstmal ins Bios. :)

hexxxlein
10.10.06, 19:21
Wenn sich das Energieschema stets und ständig allein umstellt - versteh ich zwar nicht- dann ist da irgendwas faul und du brauchst dich nicht wundern, wenn UT so rumzickt. :grübel Eventuell läuft es ja nun mit nur diesem Energieschema?

Cesar
10.10.06, 19:26
Ne, das lag an Brummelchens .exe glaube ich. Der bleibt doch nach dem Start der .exe automatsich auf "minimaler Energieverbrauch"?!
Das wusste ich aber bis heute nicht, desshalb hab ich alles runtergehauhen.

Nun muss ich das erstmal wieder hinbekommen.

eehm, zu der cool n quit option, ich habe da nur "Disable" und "Auto"
Habe das eben wieder auf "Auto" gestellt :)

Brummelchen
10.10.06, 19:33
>> Der bleibt doch nach dem Start der .exe automatsich auf "minimaler Energieverbrauch"

Ich habe (nur) zwei positive Rückmeldungen erhalten. Da das Tool sogar die powercfg
prüft, liegt es nicht daran.

hexxxlein
10.10.06, 19:34
Ne, das lag an Brummelchens .exe glaube ich. Der bleibt doch nach dem Start der .exe automatsich auf "minimaler Energieverbrauch"?!

Wenn sich das Energieschema nicht umstellt, dann ist UT nicht richtig installiert. Das hat Brummelchen aber dazu geschrieben.
Ich habe eben selber aus Neugier nachgesehen.

Jetziges Energieschema: Minimaler Energieverbrauch
Exe gestartet - UT Fenster verkleinert und ins Schema geschaut.
Es steht auf DESKTOP!
Nach Beenden von UT wechselt das Schema wieder.
Die Exe funktioniert also. Da hast du vorher schon was vergeigt.

Cesar
10.10.06, 19:39
MMh, das ist ja komisch.
UT habe ich bereits zweimal neu installiert. Werde es nochmal ein drittes mal versuchen.

Aber wenn mein Energieschema eh auf Desktop steht, dann müsste ja wenigstens das hinhauen.

Naja, werd das alles nochmal neu installieren, und nochmal testen :)

hexxxlein
10.10.06, 19:47
Jepp, dass meinte ich jetzt. Wenn du nur ein Energieschmema hast, dann brauchst du die Exe auch nicht, da es nichts zum Umstellen gibt. Läuft UT so immer noch zu schnell, kannst du es nur noch mit der Verknüpfung und der Taktangabe versuchen. Schlecht ist es nur, wenn man die Angabe nicht kennt.

Cesar
10.10.06, 20:05
Hiho, habe jetzt neu installiert (keine Patches,Updates,mappacks etc... halt vollkommen Roh)

Selbes Problem.
Also bevor ich die ini bearbeitet hatte, war es in ZEitlupe (hab ich diemal richtig gefilmt), und danach war es genauso wie es eh schon war...

Gorkon
10.10.06, 20:43
Ok. Du hast ein Computer-Problem und hast es in ein Forum gepostet. Mit folgenden kleinen Regeln kannst du den Thread richtig schön in die Länge ziehen und nebenbei deine Mitposter erfreuen.

1. Bei einem technischen Problem poste nie Nie NIE deine Rechnerkonfiguration. Die Forencommunity liebt es rumzuraten, welche der möglichen 26027891344590617 Kombinationen aus Hard- und Software deine darstellt. Wenn du danach gefragt wirst, liefere die Beschreibung häppchenweise.
2. Wenn zum Thema bereits längere Texte gepostet wurde, vermeide diese komplett durchzulesen. Du könntest bestimmte Zusammenhänge verstehen und dein Problem von vornherein vermeiden.
3. Wenn dir die Zusammenhänge trotz Durchlesens nicht klar sind, frage auf keinen Fall nach, was wieso warum passiert. Probiere stattdessen wild drauflos und unterhalte das Forum mit deinen Hilferufen.
4. Gehe auf keinen Fall systematisch an das Problem heran. Probiere stattdessen alles wild durcheinander aus, besonders wenn du nicht weißt, welcher Tip eigentlich was bewirkt. Die daraus resultierenden Ergebnisse sind dann besonders unterhaltsam.
5. Wenn sich das Problem in verschiedene Unterprobleme mit vermutlich ebenso unterschiedlichen Ursachen aufteilt, schmeiße den Leuten aussagekräftige Fehlerbeschreibungen wie "es geht nicht" oder "ist jetzt genauso wie es eh schon war" an den Kopf. Solltest du aber nach dem aktuell auftretenden Problem gefragt werden, zähle einfach alle auf einmal auf. Sollen die sich doch eins aussuchen.
6. Werden dir Methoden genannt, mit denen du dem Fehler auf die Schliche kommen könntest, wende sie auf keinen Fall an! Damit könntest du die Fehlerursache selbst entdecken, das würde diesen unterhaltsamen Thread zu sehr abkürzen.





...





Lesen, durch den Kopf gehen lassen und vl verstehen, warum ich eben meinen Monitor schlagen wollte.



Damit dieses Posting nicht komplett zum Flaming verkommt, nochmal alles zum Mitschreiben:

1. Speedattacken. Werden durch zu hohe FPS ausgelöst (ab ca. >200). Kann man bekämpfen, indem man die FPS auf einen maximalen Wert begrenzt (85, 100 o.ä.). Das geht
1.1 Über die OpenGL- oder D3D8-DLL und den Ini-Wert FrameRateLimit.
1.2 über die vertikale Synchronisation, dann liegt die Grenze bei der Bildwiederholrate des Monitors. Kriegt man entweder über Treibereinstellungen oder über Ini-Settings wie UseVSync oder SwapIntervall. Monitor-Sync liegt bei LCD'S/TFT's immer bei 60, Röhrenmonitore sind da variabel. Dort läßt sie sich bestimmen
1.2.1 Über die Grafiktreiber (suchen).
1.2.2 Über externe Tools wie RefreshForce. Googlen. Nur benutzen, wenn du weißt, was du machst.
1.2.3 Über das Ini-Setting RefreshRate (OpenGL/D3D8).

2. Zeitlupe. Kommt daher, daß der Prozi beim Starten von UT mit hoher Frequenz fährt und sich das Spiel auf diesen Wert synchronisiert, die Megaherzen im Spiel dann aber niedriger liegen. Hängt mit variabler Taktfrequenz zusammen, die meist wiederum an das Energieschema "Minimaler Energieverbrauch" gekoppelt ist. Gegen Zeitlupe hilft demnach
2.1 das Energieschema auf "Desktop" zu stellen und es dort zu lassen, auch wenn die CPU dann mehr verbrät, als sie soll
2.2 das Energieschema ständig von Hand umzustellen
2.3 das Schema automatisch bei Start von UT auf "Desktop" und beim Beenden wieder auf "Minimaler Energieverbrauch" stellen zu lassen. Das geht
2.3.1 über die beschriebene Batch-Variante
2.3.2 über Brummels EXE

3. Extremruckeln. Ursache unbekannt. Müßte systematisch erforscht werden.



P.S. UT neu zu installieren wird null komma gar nichts bringen. Durchs Löschen der Ini's erreichst du denselben Effekt, nur wesentlich schneller.

Sowas kann man übrigens erfragen. Ich habe keine Probleme, Fragen zu beantworten, auch wenn sie auf den ersten Blick noch so blöd sind. (Auf den zweiten Blick sind sie es nämlich selten bis nie.) Was mich völlig aggro macht, ist das anfangs beschriebene Verhalten, deswegen die dezent sarkastische Beschreibung.

P.S.2 laß mich raten, du startest das Game mal mit und mal ohne Brummels Exe, je nach Lust und Laune. Lies dir Punkt 2 mal genau durch.

P.S.3 dein Problem sicherlich lösbar, aber wenn du so weitermachst wie bisher, klinke ich mich aus diesem Thread aus.

Cesar
10.10.06, 20:52
So, ich will das mal eben zusammenfassen, vielleicht fällt uns ja doch noch was zu ein.
ich habe jetzt noch die ganze Zeit versucht...

Also meine Einstellungen:
AMD Treiber ist installiert - Cool n Quit ist aktiviert (war schon deaktiviert)
Energieschema ist Desktop - alles andere gelöscht!
VSync ist auf Anwendungsgesteuert.

So der Monitor läuft jetzt mit 85Hz.
In meiner Ini habe ich die beiden Einträge:
SwapInterval=1 und
FrameRateLimit=85

Prozi bleibt immer auf 2400Mhz.

Jo, hab ich was vergessen? Denké nicht.


Ausserdem habe ich eben versucht die UT.exe in UT.exe -CPUSPEED.... umzubenennen.
Danach lief das Teil wieder nur in Zeitlupe.
Ansonsten ruckelt es nur.

Ich weiss nicht was ich noch machen kann.
Ihr seit glaube auch so langsam am Ende:heul

Will einer meinen PC haben, dann bau ich mir meinen alten wieder zusammen:daumen-


EDIT:

1. Speedattacken. Werden durch zu hohe FPS ausgelöst (ab ca. >200). Kann man bekämpfen, indem man die FPS auf einen maximalen Wert begrenzt (85, 100 o.ä.). Das geht
1.1 Über die OpenGL- oder D3D8-DLL und den Ini-Wert FrameRateLimit.
1.2 über die vertikale Synchronisation, dann liegt die Grenze bei der Bildwiederholrate des Monitors. Kriegt man entweder über Treibereinstellungen oder über Ini-Settings wie UseVSync oder SwapIntervall. Monitor-Sync liegt bei LCD'S/TFT's immer bei 60, Röhrenmonitore sind da variabel. Dort läßt sie sich bestimmen
1.2.1 Über die Grafiktreiber (suchen).
1.2.2 Über externe Tools wie RefreshForce. Googlen. Nur benutzen, wenn du weißt, was du machst.
1.2.3 Über das Ini-Setting RefreshRate (OpenGL/D3D8).


Genau das habe ich alles schon durch!
Wenn es damit geklappt hätte, wäre der Tread 2 Seiten kürzer geblieben. Leider funktioniert das bei mir ja nicht.

Brummels .exe hab ich gestern schonwieder gelöscht.


P.S.3 dein Problem sicherlich lösbar, aber wenn du so weitermachst wie bisher, klinke ich mich aus diesem Thread aus.

Nur was soll ich noch sagen?
Wie gesagt, die tips der Seite hier hab ich alle durch!

Daten meines PCs kannste haben, obwohl ich GLAUBE dass ausser Prozessor und Graka (kennst du ja auch schon),mit dem Problem nicht zu tun haben können...
Aber naja, dann sach ich dir das mal:

AMD Athlon 64 X2 4600+ (Windsor, 2,40 Ghz)
Zwischenspeicher: LEvel-1-/Level-2-Cach: 2x64 Kilobyte /2x512Kilobyte
Arbeitsspeicher: TRS DDR2-667 CL 5 (2 Dual Channel)
Arbeitsspeicher: 1024 - bis 4096 aufrüstbar
Chipsatz/Bios: Nvidia Nforce 550 / Phoenix
GraKa: Nvidia Geforce 7600 GS/256MB
Festplatte: WDC WD3200JS-00PDB0 (298 GB, IDE)

Brummelchen
10.10.06, 21:51
hmm, wenn du Schema "Desktop" nutzt, dann brauchst du nicht "-cpuspeed"

Meine EXE startet UT99 ohne Parameter, warum auch?
Die nächste Version 0.3 zeigt ein nettes Fenster und kann auch andere UT bedienen.
Vllt hilfts ;)

hexxxlein
10.10.06, 23:01
Also meine Einstellungen:
AMD Treiber ist installiert - Cool n Quit ist aktiviert (war schon deaktiviert)
Energieschema ist Desktop - alles andere gelöscht!

Damit ist Cool n Quit eh nicht aktiviert und UT sollte eigentlich laufen, wenn du einen der Punkte, die Gorkon nochmalig augezählt hat, einbeziehst. :)